Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1. bigkevj's Avatar
    Posts
    39 Posts
    Global Posts
    79 Global Posts
       #1  
    We did not have any certificates installed, sprint told us we needed to - we cant self authenticate at this time. We went to StartSSL, which was one recommended on another thread on this forum, and installed that SSL. When I try to connect, i still get "SSL Certificate error. Is the date and time correct?"

    Can anyone help out please? I got rid of my blackberry because of exchange issues and was told the pre exchange setup would be cake and I would be getting emails...
  2. #2  
    Quote Originally Posted by bigkevj View Post
    We did not have any certificates installed, sprint told us we needed to - we cant self authenticate at this time. We went to StartSSL, which was one recommended on another thread on this forum, and installed that SSL. When I try to connect, i still get "SSL Certificate error. Is the date and time correct?"

    Can anyone help out please? I got rid of my blackberry because of exchange issues and was told the pre exchange setup would be cake and I would be getting emails...
    Did you install the certificate on your Exchange server?
  3. bigkevj's Avatar
    Posts
    39 Posts
    Global Posts
    79 Global Posts
       #3  
    Yes, according to our Exchange Admin.
  4. ccap's Avatar
    Posts
    64 Posts
    Global Posts
    78 Global Posts
    #4  
    Can anyone explain what I need to do to get past the SSL certificate? How do I install the exchange sertificate on the exchange server? When I set up desktops with exchange, I install the certificate on the desktop machine and it connects fine. I can remote into my server, but I just need to know the steps.

    How do I get the Pre to talk? Thanks
  5. bigkevj's Avatar
    Posts
    39 Posts
    Global Posts
    79 Global Posts
       #5  
    My understanding is you cant get past the SSL certificate at this time. maybe a software update will fix that down the road.
  6. #6  
    Quote Originally Posted by bigkevj View Post
    Yes, according to our Exchange Admin.
    Can you give me the URL for you EAS server?
  7. #7  
    I use a startcom cert on my exchange server, and my wife's pre is working fine with EAS. You need to import the StartCom CA as a trusted root certificate authority. There are a couple ways to do this.

    The easiest would be to go to https://yourexchangeserver/oma in your pre's web browser. The browser will warn you about the unstrusted CA and give you the option to trust it. If you cant find your site PM me i can give you my url, the root CA should be the same.

    The other option would be to go to Index of /certs and download the CA cert. then move it to your device via usb and install it with the certificate manager.
  8. #8  
    Go to openssl.org you can get free open source ssl tools. If your admin does not know how to configure an Exchange server for use with a certificate authority then you are going to have trouble with this. Once you have the Root CA loaded on the Exchange Server it should not be any problem loading it on the Pre and pointing the Pre at the https://server.whatever.com address. Good luck!
    Palm Pre
    (formerly TouchPro, iPhone 3G, Curve, 8800, Treo800p, E61, N9300, Treo 700p ,Treo 600, I500, I330, Treo 300, I300, 6035)
  9. bigkevj's Avatar
    Posts
    39 Posts
    Global Posts
    79 Global Posts
       #9  
    I have made progress. We got the SSL cert on the exchange server, we sent it to my phone to my yahoo address, i opened the attachment and it saved it in a certificate manager and asked me if I wanted to trust, I said always. Now I have "Exchange" listed in my list of email accounts, but only my outbox is there. how might i get my inbox and other folders i want to sync?
  10. #10  
    Quote Originally Posted by bigkevj View Post
    I have made progress. We got the SSL cert on the exchange server, we sent it to my phone to my yahoo address, i opened the attachment and it saved it in a certificate manager and asked me if I wanted to trust, I said always. Now I have "Exchange" listed in my list of email accounts, but only my outbox is there. how might i get my inbox and other folders i want to sync?
    Check to ensure that you didn't accidentally set it up as POP or IMAP. The type of connection should be EAS.
  11. #11  
    Hi. The only way I could get this to work (until Palm fixes the issue) is to add my account to the exception list in Exchange, Mobile Services( I'm Exchange admin) because Device Security is enabled on our Exchange server. good luck.
  12. bigkevj's Avatar
    Posts
    39 Posts
    Global Posts
    79 Global Posts
       #12  
    I verified it was set up as an EAS account - I basically deleted the account and re-entered all the information. The only reason I got this phone was that we could never get the blackberry i had to get my email. This pre was supposed to be easy - just enter a few pieces of information. I dont know WTH dhahn is talking about.
  13. #13  
    Dhahn is accurate. It has to do with settings on Exchange Server. Your IT will have to modify two settings for it to work. I'm not an IT genious, but this topic is discussed on Palm's support forums. Search there for "SSL" and "outbox".
  14. #14  
    Quote Originally Posted by dhahn View Post
    Hi. The only way I could get this to work (until Palm fixes the issue) is to add my account to the exception list in Exchange, Mobile Services( I'm Exchange admin) because Device Security is enabled on our Exchange server. good luck.
    This is exactly what i did to "avoid" the errors I was getting. I am not the network admin, but was able to follow the instructions on another forum and contacts, calendar and e-mail work perfectly. I will go in and "undo" my exception once there is a solution from Palm.
  15. #15  
    Quote Originally Posted by bigkevj View Post
    I verified it was set up as an EAS account - I basically deleted the account and re-entered all the information. The only reason I got this phone was that we could never get the blackberry i had to get my email. This pre was supposed to be easy - just enter a few pieces of information. I dont know WTH dhahn is talking about.
    DHahn's issue isnt' really a bug, it's working as designed. The Pre doesn't (currently) support EAS security features.

    Go to your calender app, and select the Exchange acount. Remove it, then add it again. Seems when I initally had mine fail, then got it to working, I had to do that with the Calendar.
  16. #16  
    I posted instructions in another thread about 5 days ago, but cannot find them to link them here.
    Basically what I've found that works (have set up EAS on my Pre and on several of my coworkers Pre's).
    After you do the initial EAS setup in the mail preferences, at some point you'll need to put your passwod into the calendar and contacts app preferences on the Pre before you'll be able to see all your exchange data on the pre. It all shows up at first configuration of mail, but then after you sync, and drop signal or go into airplane mode one time, the mail preferences password entry isn't available to the other apps. Go into calendar and enter the info, then go into contacts, enter the info, and you should be able to access all your data the next time the Pre syncs with your Exchange server.

    One more note, if you set your mail for sync as mail arrives your battery life will SUK, No if's but's or ands about it. Set sync with exchange server for 15 mins or longer and your batt life will be about the same as before you set up EAS.
  17. zyxwv88's Avatar
    Posts
    82 Posts
    Global Posts
    85 Global Posts
    #17  
    I agree. Delete it and re-add it. When you install the cert, it seems that you have to remove the account and then re-add it after the cert is installed.

    When you hit the button to apply the account settings, you should see it either give you an error or sync. If you get an error, it usually means you need a security exception on Exchange, and if it syncs, then you are set. The only time I had it only show the Outbox was when I was installing the account before I had the cert installed. It doesn't seem to be able to apply the cert to an already set up account.
  18. #18  
    Quote Originally Posted by TBarb169 View Post
    This is exactly what i did to "avoid" the errors I was getting. I am not the network admin, but was able to follow the instructions on another forum and contacts, calendar and e-mail work perfectly. I will go in and "undo" my exception once there is a solution from Palm.
    Where did you find the instructions? Any help is appreciated.
  19. #19  
    Here's what I did to fix my Exchange syncs empty outbox issue.

    1. Open Exchange Manager.
    2. Expand Administrative Groups, expand the first administrative group, and then expand Servers.
    3. Expand the server container for the Exchange Server 2003 server that you will be configuring, expand Protocols, and then expand HTTP.
    4. Under the HTTP container, right-click the Exchange Virtual Server container, and then click Properties.
    5. Click the Settings tab, clear the Enable Forms Based Authentication check box, and then click OK.
    6. Close Exchange Manager.
    7. Click Start, click Run, type IISRESET/NOFORCE, and then press ENTER to restart Internet Information Services (IIS).

    Additionally, you must use Internet IIS Manager to create this virtual directory for Exchange ActiveSync and Outlook Mobile Access to work. If you are using Windows Server 2003, follow these steps:

    1. Start Internet Information Services (IIS) Manager.
    2. Locate the Exchange virtual directory. The default location is as follows:
    Web Sites\Default Web Site\Exchange
    3. Right-click the Exchange virtual directory, click All Tasks, and then click Save Configuration to a File.
    4. In the File name box, type a name. For example, type ExchangeVDir. Click OK.
    5. Right-click the root of this Web site. Typically, this is Default Web Site. Click New, and then click Virtual Directory (from file).
    6. In the Import Configuration dialog box, click Browse, locate the file that you created in step 4, click Open, and then click Read File.
    7. Under Select a configuration to import , click Exchange, and then click OK.

    A dialog box will appear that states that the "virtual directory already exists."
    8. In the Alias box, type a name for the new virtual directory that you want Exchange ActiveSync and Outlook Mobile Access to use. For example, type exchange-oma. Click OK.
    9. Right-click the new virtual directory. In this example, click exchange-oma. Click Properties.
    10. Click the Directory Security tab.
    11. Under Authentication and access control, click Edit.
    12. Make sure that only the following authentication methods are enabled, and then click OK: • Integrated Windows authentication
    • Basic authentication

    13. On the Directory Security tab, under IP address and domain name restrictions, click Edit.
    14. Click the option for Denied access, click Add, click Single computer and type the IP address of the server that you are configuring, and then click OK.
    15. Under Secure communications, click Edit. Make sure that Require secure channel (SSL) is not enabled, and then click OK.
    16. Click OK, and then close the IIS Manager.
    17. Click Start, click Run, type regedit, and then click OK.
    18. Locate the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters
    19. Right-click Parameters, click to New, and then click String Value.
    20. Type ExchangeVDir, and then press ENTER. Right-click ExchangeVDir, and then click Modify.

    NoteExchangeVDir is case-sensitive. If you do not type ExchangeVDir exactly as it appears in this article, ActiveSync does not find the key when it locates the exchange-oma folder.
    21. In the Value data box, type the name of the new virtual directory that you created in step 8. For example, type /exchange-oma. Click OK.
    22. Quit Registry Editor.
    23. Restart the IIS Admin service. To do this, follow these steps: a. Click Start, click Run, type services.msc, and then click OK.
    b. In the list of services, right-click IIS Admin service, and then click Restart.


    Followed the steps and it worked immediately. Hope this help someone.
  20. #20  
    ^^The above was of great help. However it was turning off the forms based authentication that got things working for me. The only issue is that now regular OWA users don't get the compression and sexy log-in page.
Page 1 of 2 12 LastLast

Posting Permissions