Results 1 to 14 of 14
  1.    #1  
    So I am trying to use IMAP to my company's Groupwise server and it is not working. My helpdesk says IMAP with their G1's works fine so it must be the Pre.

    I configure it like the G1 and I am getting "SSL Error. Make sure the time and date are correct." or something like that. Has anyone seen this?

    Here is the method that a few in my company are using to sync Android to gmail (maybe this will work for others!). If not, maybe you can figure out how to make it work with the Pre:


    Setting up email and calendar on your Android phone

    The trick is to set up a google email account that will handle updating your phone with calendar events and work as your SMTP server. When there is a VPN client available for the Android OS, it should be possible to use the Company SMTP server directly, but until then it google SMTP will do.

    1) create a new gmail account that you will use for this purpose only
    2) Go to the email application on your phone and select "Add account"
    3) Use the following settings:

    Incoming:
    Username: <your Company username without the @Company.com>

    Password: <your Company password>

    IMAP server: mail.Company.com or whatever you setting is

    Port: 993

    Security type: SSL(if available)

    Outgoing:
    SMTP server: smtp.gmail.com

    Port: 465

    Security type: SSL(if available)

    check require sign-in

    username: <your gmail account name without the @gmail.com>

    Password: <your gmail password>
    4) Log into your new gmail account
    5) Click "Settings"
    6) Select "Accounts"
    7) Under Send mail as, select "Add another email address"
    8) Add your Company email address
    9) Select your Company email address as your default email address

    This will make your Company email appear in the From: field in your email. Simply setting the reply-to settings is not enough.

    10) Still under "Send mail as", select "Always reply from default address"
    11) Go to the "Filters" tab and add a new filter that deletes any email from your Company email address that contains the word "GWDelegate". The rule should look something like this when you are done:

    Matches: from<your Company email address>) GWDelegate

    Do this: Skip Inbox, Delete it

    This rule will make sure your inbox does not get filled up with a bunch of junk, but it will still post any meeting invite sent to this address to your calendar before the email gets deleted.
    12) Open up your Groupwise client(this can not be done from the web interface), and go to "Tools" -> "Rules" -> "New".

    Rule Name: GWDelegate - Forward Calendar events to gmail

    When event is: New Item And items are: check "Received"

    Check "Appointment"

    "Add Action" -> "Delegate..." To: <your gmail address>

    Comments to Recipient: GWDelegate

    This will delegate your appointments to your gmail email address and put the word "GWDelegate" in the message body. Your gmail account will post this appointment to your google calendar and delete the email from your gmail inbox.

    13) To get the calendar to show up on your phone you can either register this gmail account with your phone, or share the calendar you have for this gmail account with the gmail account you have on your phone. Make sure to give full rights to modify and create events to the gmail account you are sharing the calendar with.

    Now your Company calendar events will show up on your phone and if you select them you can accept the meeting or decline it. The meeting response will look like it came from your Company email, not your gmail account (assuming you followed the steps above carefully) even if this is a shared calendar and you accept it from a different gmail account.
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  2. #2  
    Check any of the threads about Exchange Active Sync (EAS) and self-signed certificates. You will need to import the cert keys into your Pre before setting up IMAP.
    Gregg Ginsberg, P-CLP
    http://www.ginsberg.org
  3.    #3  
    Gregg,

    Thanks for pointing me to this. I exported my certificate from the GW client and got a file of .p7c type. I emailed it to myself and the Pre doesn't recognize it (no app to open it.) Same thing when I try to open in in the browser.

    Any ideas?
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  4. #4  
    Quote Originally Posted by Homie View Post
    Gregg,

    Thanks for pointing me to this. I exported my certificate from the GW client and got a file of .p7c type. I emailed it to myself and the Pre doesn't recognize it (no app to open it.) Same thing when I try to open in in the browser.

    Any ideas?
    You will likely need to have your IT department send you a copy of the self-signed certificate off their server.
  5. #5  
    That's correct...if you access the same server for webmail you may have imported these certs into your web browser. I believe the export instructions given in the other threads are for getting the certs out of IE.

    If you have the ability to export the certs from your Groupwise client as Base-64 encoded instead of PKS7 try that. Otherwise ask your admins to email the two certs to you.
    Gregg Ginsberg, P-CLP
    http://www.ginsberg.org
  6.    #6  
    Gregg and hparsons,

    Thanks for the help. Hopefully I haven't lost you during the lag in responses here.

    My company was able to send me the selfsigned SSL in .b64 format via email. However, when I try to download and use it, the file downloads and get a ?

    The Pre doesn't know what to do with it.

    Any ideas?
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  7. #7  
    I'm still here.

    The first thing to do is try changing the extension on those files from .b64 to .cer and either mail them to yourself or have someone else mail them to you.

    If you do the Pre's certificate manager should pick them up.
    Gregg Ginsberg, P-CLP
    http://www.ginsberg.org
  8.    #8  
    Great, I will try that in a couple of hours.

    I just pulled the battery and installed a bodyguardz skin on it.

    We shall see how it looks when dried. I've used them on a bunch of phones in the past and also on my macbook air.

    I'll post results soon.
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  9.    #9  
    I'm at a loss. The certificate seemed to import correctly when I changed it to .cer and emailed it to myself. Yet I still get the same SSL date and time error.

    WTH?
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  10. #10  
    As mentioned in those Exchange threads, there are two keys that you havge to import. One is the key for the Root Authority and one is for the server/host.
    Gregg Ginsberg, P-CLP
    http://www.ginsberg.org
  11.    #11  
    Ah. Ok. I didn't see that. I'll look deeper into the threads.

    Thanks again.
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  12.    #12  
    Gregg,

    Here is the message I got from IT:

    "Here are the files in compressed formats. This includes the earlier Self-Signed cert from the Mail server along with one called the Trusted Root Authority cert and one more cert that had to do with the mail server which is the Public Key cert. There are a couple other Trusted Root cert's but I think they are just test certs which I can export if the previous don't work"

    I downloaded them and installed them all correctly on the Pre. But still the same error: check date and time.

    Any other ideas? This seems to be working for our company's iphones.
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  13.    #13  
    Has anyone been able to IMAP into Groupwise? I still am getting the SSL error.
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  14. #14  
    Homie-

    Your SSL errors have nothing to do with Groupwise specifically. I would strongly suggest contacting Palm support with your GW admin on the phone so they can hear exactly how to extract their necessary certs and give them to you for import on your device.
    Gregg Ginsberg, P-CLP
    http://www.ginsberg.org

Posting Permissions