Results 1 to 8 of 8
  1.    #1  
    I host my own mail server and have things setup for SSL and have tried connecting my Pre to it have no luck so far. I was working fine on my centro and versamail. My mail server is showing ??? for username when the phone connects to it. So it looks like it not sending the username password properly. I tried to turn off the SSL requirement and still no luck. I did copy the SSL certs to the phone and added via cert. manager.

    I looked for similar problems and found no posts, so was wondering if I was on my own.

    I currently am not using SASLDB

    Thanks!!!
    Last edited by vangorcp; 06/09/2009 at 02:27 PM.
  2. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #2  
    I run my own server too and was unable to connect at first. I still can't tell you what happened. I entered all the info and it came back saying something about failing to authenticate. I reentered the password so many time, that I must have had it right at least once. Then the next morning I tried again and voila, it just worked. Later I tried creating another account to the same server and the exact same thing happened. No lock over and over again, but the next day it worked the first time. It could just be a coincidence and I might have had typos. But I went over it again and again and found nothing entered wrong.

    If yours magically just works tomorrow, let us all know.

    BTW: I did this with SSL. I have a courier-IMAP setup using SSL and postfix smtpd doing TLS. I used the default ports for both.

    When it was failing, I noticed in the server logs that it was connecting and providing the correct username. But then the server reported and unexpected connection loss each time.
  3. #3  
    Hmmm, my brother and I have our own mail-server... hmmm, hopefully others have better luck?

    (from another thread I think it's worked for some seamlessly and for others it has not)

    I ALSO hope it works for you tomorrow, please report back to let us know!!!
    Now it's the WAITING GAME: a GSM Palm Pre
    T680 (COPPER) + Cingular = FUN!!
    My T650 & 6230b and NX70 are retired... =(
    http://mrg9605.com
    http://ipgeek21.com
    noncents.net
    http://seresqueridos.com

    justdai.com
    reddingk.com
    georgeozuna.com
    goaskoscar.com
  4. polpo's Avatar
    Posts
    17 Posts
    Global Posts
    18 Global Posts
    #4  
    I run Postfix and Dovecot IMAP. I had a problem with the Pre authenticating. It was trying SASL LOGIN and I only had PLAIN enabled in my Dovecot configuration (I have it set to provide authentication for both SMTP and IMAP). I enabled PLAIN and LOGIN and it works like a charm now.

    I had to change the line
    Code:
    mechanisms = plain
    to
    Code:
    mechanisms = plain login
    in /etc/dovecot/dovecot.conf.
  5.    #5  
    I am using Postfix via MailServe for Tiger from Cutedgesystems I am still having no luck. I am not using Dovecot IMAP yet. Still no luck today.

    I get connected but still no user information is set. Not sure I can tweak it to use plain passwords.
  6. #6  
    Quote Originally Posted by polpo View Post
    I run Postfix and Dovecot IMAP. I had a problem with the Pre authenticating. It was trying SASL LOGIN and I only had PLAIN enabled in my Dovecot configuration (I have it set to provide authentication for both SMTP and IMAP). I enabled PLAIN and LOGIN and it works like a charm now.

    I had to change the line
    Code:
    mechanisms = plain
    to
    Code:
    mechanisms = plain login
    in /etc/dovecot/dovecot.conf.
    In case anyone else is having this issue, you will also need to restart postfix for this change to go into effect for smtp auth, not just dovecot.

    For possible help with future searches, this was the error I was getting:

    Jul 25 15:04:52 hostname postfix/smtpd[90455]: warning: yourlocation.example.org[x.x.x.x]: SASL LOGIN authentication failed: Invalid authentication mechanism
  7. #7  
    Richard, thanks for adding your error message to this thread.

    I had the same error. I made the change to dovecot.conf, restarted everything and it still wouldn't work. I retyped the password in the Palm Email login settings multiple times with no luck. Then, I retyped the username and it started working.

    A strange coincidence or subtle bug, I can't say, but worth a try if you still have problems.
  8. lordbah's Avatar
    Posts
    341 Posts
    Global Posts
    435 Global Posts
    #8  
    Quote Originally Posted by polpo View Post
    I run Postfix and Dovecot IMAP. I had a problem with the Pre authenticating. It was trying SASL LOGIN and I only had PLAIN enabled in my Dovecot configuration (I have it set to provide authentication for both SMTP and IMAP). I enabled PLAIN and LOGIN and it works like a charm now.

    I had to change the line
    Code:
    mechanisms = plain
    to
    Code:
    mechanisms = plain login
    in /etc/dovecot/dovecot.conf.
    I also run Postfix and Dovecot and had been unable to get my Pre to setup with it on webOS 1.1 or 1.2. I tried again with 1.3.1 and finally got it to work.

    I did the opposite of above - changed from "plain login" to just "plain".
    Also:
    disable_plaintext_auth = no

    On the Pre:
    Try to setup as user2@lordbah.com, let it fail, so I can get to the manual setup.
    Mail Type = IMAP
    Incoming mail server = lordbah.com
    Username = user2
    Password = ***
    Encryption = SSL
    Port = 993
    Outgoing mail server = lordbah.com
    Use Authentication = On
    Username = user2
    Password = ***
    Encryption = TLS
    Port = 25

    'user2' is a second Linux account. My primary address runs a procmail to forward only certain emails to user2 and thus to my phone.

    I had done setup with the SSL certificates back on 1.1, so I don't recall all of that stuff right now, but I did copy one or more to the Pre.

    FYI dovecot.conf has various auth_debug and auth_verbose type settings which may help in debugging login issues.

Posting Permissions