View Poll Results: Can you connect to EAS?

Voters
104. You may not vote on this poll
  • Your Exchange server uses SSL, and you CAN connect.

    47 45.19%
  • Your Exchange server uses SSL, and you CANNOT connect.

    35 33.65%
  • Your Exchange server does NOT use SSL, and you CAN connect.

    10 9.62%
  • Your Exchange server does NOT use SSL, and you CANNOT connect.

    12 11.54%
Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 49
  1.    #21  
    Quote Originally Posted by mlisook View Post
    Maybe dumb, but if your exchange server does not use SSL wouldn't you just change the incomming server address from HTTPS: ... to HTTP: .... ???

    We have the SSL / private cert setup so I don't have an easy way to test that, but otherwise why are they providing the option?
    I've tried every possible permutation of http: and https: with fully qualified domain names, unqualified, etc., etc., and no luck. This includes the settings I've used to successfully connect to my Treo 650 and my Windows Mobile phones. The Pre just has some work to do in this area, methinks.
    Treo 600 > Treo 650 > HTC Mogul (*****!) > HTC Touch Pro (***** squared!) > PRE! > Epic
  2. #22  
    I get this error:

    ERROR:
    The mail server requires security policies that are not supported.
    With the only option of Done. I'm assuming it means that my phone is correctly connecting to the server. It just is not allowed to because the Pre is not seen as a secure device?
  3. #23  
    Quote Originally Posted by wynand32 View Post
    I've tried every possible permutation of http: and https: with fully qualified domain names, unqualified, etc., etc., and no luck. .
    My experience has been identical--the older Treos worked fine, but the Pre is pickier, and less communicative (e.g., "Please check settings and try again." is not terribly helpful when troubleshooting).

    I recommend looking through some other threads here on EAS, SSL, Exchange, etc. Also found some help on Palm.com/support, though those forums are less-frequented and just went live a few days ago. I also get the impression like there is less collective intellectual capital there (at least from a purely techy perspective) but am hopeful that there will be something of use forthcoming.

    For now, my impression is that not using SSL is simply not an option--I have yet to see something that proves that wrong, apart from some claiming to have succeeded in configuring their EAS without. But no such claims have been backed with explicit settings info, so my guess is that these are folks who dont' realize they are using a certficate but actually are.
  4. #24  
    Have an Exchange 2007 server with an Equifax signed, globablly trusted cert.
    When I try and sync, I can see only the folders in my Exchange mailboxes - no mail messages, contacts, or calendar items come down.
    Was promised on Saturday a Palm Tier 2 technician would call me back within 24-48 hours...still haven't heard from Palm.
    Was working with an awesome Sprint support tech...who unfortunately has Tuesday-Fridays off...and haven't heard a word from Sprint since he left work.

    Starting to get really frustrated and disappointed in my new $600 device.
  5. #25  
    Quote Originally Posted by RLovelett View Post
    I get this error:



    With the only option of Done. I'm assuming it means that my phone is correctly connecting to the server. It just is not allowed to because the Pre is not seen as a secure device?
    Issue there is that your Exchange admins require a device PIN or password. As noted in a thread ( h tt p://forums.palm.com/palm/board/message?board.id=Synergy&thread.id=554&view=by_date_ascending&page=1 ) on Palm's forums, this functionality is not currently supported.
    You may be able to talk your admins into removing that requirement from your account...but I wouldn't hold my breath.
  6. #26  
    I am actually the Exchange Administrator at my job. Got the Pre working with EAS. We have a front end/back end architecture here. The front end exchange server has a Network Solutions SSL certificate. No problems.

    I even was able to add a SECOND exchange account (stored on a totally different server / domain) on the Pre. That second server has an SSL certificate with GoDaddy. Worked perfectly.

    So in essense, I got two Exchange accounts set up on the Pre, with two separate servers, and two separate SSL certificates. Both work perfectly.

    If people are trying to use their own built-in Microsoft SSL certificate from an on-site certificate authority server, I can see there being issues. If you have a say in your Exchange server configuration, just pay GoDaddy the $20 bucks or whatever it costs for a real certificate. It will save so much headache, especially if your origanization likes to use Outlook Web Access over SSL - the real third party certificates work much better with this as well.
  7. #27  
    Quote Originally Posted by mikeh20 View Post
    This may be a dumb question but how do i know if my exchange uses ssl?

    It has s/mime control, same thing? completly meaningless?

    Thanks!
    Go to your company's Outlook Web Access (OWA) site. See if it changes your HTTP:// to HTTPS:// (an automatic redirect is the default setup for an Exchange server)

    If it does, your site uses SSL.

    If it does not, try using HTTPS:// instead of HTTP://.

    If it works, your site using SSL.

    If not, then it probably is not.
  8.    #28  
    Quote Originally Posted by mlisook View Post
    Maybe dumb, but if your exchange server does not use SSL wouldn't you just change the incomming server address from HTTPS: ... to HTTP: .... ???

    We have the SSL / private cert setup so I don't have an easy way to test that, but otherwise why are they providing the option?
    Makes no difference whether you put http: or https:.
    Treo 600 > Treo 650 > HTC Mogul (*****!) > HTC Touch Pro (***** squared!) > PRE! > Epic
  9. #29  
    Quote Originally Posted by DjPiLL View Post
    ...
    If people are trying to use their own built-in Microsoft SSL certificate from an on-site certificate authority server, I can see there being issues. If you have a say in your Exchange server configuration, just pay GoDaddy the $20 bucks or whatever it costs for a real certificate. It will save so much headache, especially if your origanization likes to use Outlook Web Access over SSL - the real third party certificates work much better with this as well.
    Or, go $20 cheaper, and use StartCom Cert Master. Worked for me after struggling with a self-signed cert for 3 days.
  10. #30  
    We use a zimbra server that interfaces with activesync AS and exchange server. Works just fine for me so far.
  11. #31  
    Quote Originally Posted by wynand32 View Post
    Makes no difference whether you put http: or https:.
    OK then, so what TCP port number does your Exchange server use? If it's a non-standard port (not, 443 for SSL 80 for http) then you might have to try something else.

    try http://my.server.net:8080 for port 8080 which is a common alt port

    Or, I would seriously consider NOT using email on a non encrypted server link. Your UN/PW are in the clear as well as all your data. If it's not that sensitive then don't worry I guess. I seriously can not believe how many Pre owners are reporting that their Exchange Servers do NOT use SSL. It is really unacceptable this day in age. You can set up your very own CA using openssl at NO cost. Simply ridiculous.
    Palm Pre
    (formerly TouchPro, iPhone 3G, Curve, 8800, Treo800p, E61, N9300, Treo 700p ,Treo 600, I500, I330, Treo 300, I300, 6035)
  12. mr23#WN's Avatar
    Posts
    45 Posts
    Global Posts
    49 Global Posts
    #32  
    The only way I can get my Exchange mail is by setting it up as a POP3. But all I get is mail, no calendar.
  13. #33  
    I just tried EAS on a different server on a different network with no SSL.

    No dice.

    Looking into it, but it seems like the Pre is requiring an SSL connection.
  14. #34  
    Quote Originally Posted by gtkansan View Post
    We use a zimbra server that interfaces with activesync AS and exchange server. Works just fine for me so far.
    Good to know that EAS works with Zimbra. I'm trying to push the company away from Exchange and towards a more open platform...this could help my argument.
  15. Minsc's Avatar
    Posts
    967 Posts
    Global Posts
    974 Global Posts
    #35  
    I'm no IT administrator, but I'm surprised by the number of people who's companies are running Exchange but are NOT using SSL. Are SSL certs really that expensive? My impression was that they could be had fairly cheaply. What reason is there for not using SSL?

    Just curious, thanks.
  16. #36  
    Quote Originally Posted by Minsc View Post
    I'm no IT administrator, but I'm surprised by the number of people who's companies are running Exchange but are NOT using SSL. Are SSL certs really that expensive? My impression was that they could be had fairly cheaply. What reason is there for not using SSL?

    Just curious, thanks.

    No they are FREE!!! OpenSSL: The Open Source toolkit for SSL/TLS

    Of course the Exchange admin has to be able to set up a CA and key exchange infrastructure but it's not that hard.....
    Palm Pre
    (formerly TouchPro, iPhone 3G, Curve, 8800, Treo800p, E61, N9300, Treo 700p ,Treo 600, I500, I330, Treo 300, I300, 6035)
  17. #37  
    Quote Originally Posted by wynand32 View Post
    In my case, my Exchange server does not use SSL, and I can't get past the "can't verify identity" error. At least, I don't think we're using SSL, but if we are, I'd expect to get that error. Very frustrating.

    Is Wifi turned on and is your pre connected to wifi on the server you are trying to connect to? If so, you'll likely be blocked.

    That's what happened to me earlier today. I only figured it out because yesterday I was getting a cert error and today I couldn't even get that.
  18. #38  
    Quote Originally Posted by bobs01r6 View Post
    Option 3 for me also...at first I was able to connect and see my folder list in exchange but i wouldn't get any emails or contacts or calendar items. So i kept trying different things now i just keep getting invalid username and password
    Same thing happened to me. Trial and error provided the solution. After you get in the first time, you see your folder list. Since mobile phones intrinsicly are subject to intermittent data connectivity, and your data connection goes away for a few moments or minutes, or if you go into airplane mode you lose the connection, you'll need to do the following steps after that initial log in using the mail applet on the pre. You should only need to go through this the one time, or whenever you change your domain password or if you need to change out your device.

    I'll try to document as best as I can recall what I had to do.

    1). You configure your EAS profile in mail, and all your folders appear. Favorites are populated.
    2). Data connection drops due to weak signal, or you manually turn airplane mode on, thus severing all radio connections. (Once this has happened and after your Pre connects to the network again, or you manuially turn airplane mode off) you are unable to access or even see all your Exchange folders/data. (email, contacts and calendar).

    3). SOLUTION:
    a). double check the EAS account settings and preferences in the Pre's mail applet to make sure your MS Exchange EAS acct information is still saved correctly (checkpoint: my acct info and configs were still in here and had been saved properly from the initial setup - doesn't necessarily mean yours are going to be there too, so verify and correct if necessary)

    b). Close the mail settings card, and if necessary close the mail card.

    c). open the contacts applet. go to preferences or acct setup (Your Pre should automatically take you in here if you have not previouslyopened up contacts and added / configured your EAS acct here too.
    d). configure youe exchange acct in the contacts applet. It might already be configured with the settings you put in to configure the mail applet EXCEPT your password. If so, then enter your exchange or domain password and continue on to perform the same step in the calendar applet.
    e). Once you've done all three applets, EAS should begin syncing your Exchange data. If it doesn't, then it should begin to sync your data the next time you open up any of the apps you just configured.

    Let me know if this works.
  19. #39  
    I am using an Exchange 2003 SP2 server with SSL (cert from GoDaddy). I was able to get EAS to function perfectly by following the steps below that I saw on anther forum.
    Hope this helps:

    I logged into Outloook Web Acces (OWA) using IE8. After logging in I went to the "safety" drop down menu up to the right and selected security report.

    This brings up a popup click "view certificates". In the new window that appears choose the "certification path" tab.

    Select the highest level and choose view certificate. In the new window select the "details" tab and click "copy to file".

    Export in DER encoded binary to your desktop.

    Then close everything and start again. This time instead of choosing the top level (mine was listed as USERTrust) choose the lowest level possible that still allows you to view certificate (mine was "Secure Business Services CA).

    Click view certificate move to the details tab in the new windows and choose copy to file. Export to desktop using DER binary.

    Ok now you plug in your pre in USB mode and drop in the exported certs. Unplug and then navigate to the Certificate Manger on your Pre. Launcher>>Launcher(dropdown)>>List apps>>Preferences(drop down) Cert Manager.

    Click the little add cert button and add both certificates. (I'm not sure the first certificate is nessacary, your welcome to experiment)

    Ok then attempt to add the exchange account again.

    my settings where as follows:

    Mail Type:
    EAS

    Incoming Mail Server:
    mail.XXXXXX.com (when I add "/exchange/" it stopped working
    Domain: XXXXXX
    Username:*******
    Password:******
  20. #40  
    Quote Originally Posted by techesq View Post
    We're running Exchange 2003 with SSL. E-mail and contacts work, but no joy on the calendar.
    Same here, except email also doesn't work contacts sync fine for some reason. BTW, the radio seems really active after having EAS configured and not working. It gets really hot and battery is gone in 2 hrs. If I don't have EAS configured, it stays cool and battery lasts a long time.

    Whatever the bug is, it seems to result in a lot of network activity and kills the battery.
Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions