Page 3 of 4 FirstFirst 1234 LastLast
Results 41 to 60 of 71
  1. #41  
    Quote Originally Posted by mhunterga View Post
    I've followed all the steps to install the certificate, manually set up the server information, etc., but I'm still getting the error message: "The server's security certificate is not a trusted certificate." Can anybody help?
    You have to install the certificates to your phone. Follow these steps below, I just did it and it worked.

    After placing the certificates in the download folder via the USB, disconnect the phone from the USB and do the following:

    1. Bring up the launcher card
    2. Press the tab on the upper left corner (Launcher)
    3. When the menu slides down select List Apps...
    4. When the list apps menu shows up, click on the Preferences tab
    5. When the menu slides down select Certificate Manager
    6. Once the Security Certificates window pops up, tap on the icon in the bottom left corner so you can add the certificates to your phone.

    Once you've completed these steps try logging into your AKO email via the Pre.

    If you have any questions let me know.

    Chris
  2. #42  
    I thought I had it by trial and error from everywhere's advice. Here's what I did. OH I AM NOT USING AKO BETA!!

    Set up as POP as follows:
    Incomming server: pop.us.army.mil
    Username: john.a.doe (do not put "@us.army.mil")
    Password: (whatever it is, input it)
    Port: 995
    Ecryption: SSL

    Outgoing Server: smtp.sprintpcs.com
    use Authenitcation: OFF
    Port: 25
    Encryption: OFF

    I can receive my AKO mail!! However, (and here's why I "thought I had it) Sending mail form my pre it goes out through my default email address. This even though I set the "reply to" email as ...us.army.mil AND even though I sent directly from AKO inbox and not from "all inboxes".

    No matter what I try I can't seem to get the Outgoing server set to ...us.army.mil anything and have it work. I did try al variants of "smtp.mailrouter.us.army.mil / mailrouter.us.army.mil.

    If anyone takes it from here and figures out how to make the sent mail come from the AKO account, let it be known. Again I am not using AKO Beta.

    so close but yet so far.
  3. str8leg's Avatar
    Posts
    3 Posts
    Global Posts
    6 Global Posts
    #43  
    Incoming server: imap.us.army.mil
    encryption: ssl
    port: 993

    Outgoing server: mailrouter.us.army.mil
    Use authentication: ON
    encryption: ssl
    port:465

    manually moved via usb to root and trusted the following certs individually:
    dod ca-13
    dod email ca-11 thru ca-17
    dod root ca 2
    dod ocsp ss
    dod pki med root ca

    Send and receive works.
  4. #44  
    Quote Originally Posted by masonjam View Post
    I am attempting to set up my Pre for AKO email (Army Knowledge Online). I have used basic AKO (not the beta, OWA or exchange-based) for years on my Treo devices, but I can't make the Pre work. The only option NOT available on the Pre that was in Versamail is the Outgoing mail server authentication option "Use authentication (ESMTP)."

    I have used every possible POP and IMAP config that I can think of to no avail.

    Any help would be much appreciated.
    Wow. People actually use AKO mail instead of forwarding it to their own division's servers? :-)
  5. Slosh01's Avatar
    Posts
    16 Posts
    Global Posts
    37 Global Posts
    #45  
    Quote Originally Posted by allenkt View Post
    Alright, I'm using AKO Beta and I got it working! It should be pretty similar to the regular AKO.

    1. First, you have to install the 2 certificates. Follow the instructions on this page to download the certs (How to Install DoD Root Certificates on Windows Mobile Devices « Tim Smeltzer’s Weblog).

    2. Once you get them downloaded on to your computer you have to plug your Pre into your computer via the USB cable (the same one you use to charge it) and then copy those 2 .cer files into the download folder on your Pre.

    3. Unplug the USB cable and go to the launcher and select "device info". scroll to the bottom and select "more info". Tap on "software" then tap on the top left where it says, "preferences" and choose "Certificate Manager". Click on the + sign on the lower left and you should see the two certificates you added to the folder. Just click on them and then choose "trust" when it asks what you want to do. Do that for both certificates.

    4. Now go back to the email setup and set it up as an EAS account. I'm not sure what your settings will be here but it should be somewhere on the AKO page. For me it was just https://mail.beta.army.mil but yours will be something different.

    Hope that works for you because it works perfectly for me now!

    Karl
    Success!!!!

    I created this acct through the normal AKO email acct - not the Beta.

    I did have to track down the certificates off of the DOD site through the AKO CAC link, the link off of Tim Smeltzer's weblog didn't take me to the same page & the links I initially downloaded did not work. - Send me a private message and I will provide you with the process to acquire the link. - Once I obtained the correct links I installed them on the Pre as described & then attempted to create a new email acct, entering email address & pword. It still did not recognize the certificates. I then attempted to manually create the account as an IMAP acct, which proved to be successful....one must have WiFi enabled.

    Slosh01
  6. Slosh01's Avatar
    Posts
    16 Posts
    Global Posts
    37 Global Posts
    #46  
    Quote Originally Posted by Str8Leg View Post
    Incoming server: imap.us.army.mil
    encryption: ssl
    port: 993

    Outgoing server: mailrouter.us.army.mil
    Use authentication: ON
    encryption: ssl
    port:465

    manually moved via usb to root and trusted the following certs individually:
    dod ca-13
    dod email ca-11 thru ca-17
    dod root ca 2
    dod ocsp ss
    dod pki med root ca

    Send and receive works.
    I only installed the DoD Root CA 2 certificate & the DoD Class 3 Root CA certificate. Things SEEM to be working alright.
  7. #47  
    I have no clue how you get AKO Beta. The only AKO i know is regular AKO or AKO lite that is on the login page. I have a Palm Pixi which should have the same operating system as the pre. I did get it to work for like a week using IMAP settings and then one day I kept getting a Error saying the server security certificate was not trusted. I would like ok and nothing. I already downloaded the the DOD certs ( root 2 ca and root 3ca) to my phone using the the USB cable. I have no other idea.
  8. allenkt's Avatar
    Posts
    133 Posts
    Global Posts
    134 Global Posts
    #48  
    To get the AKO Beta, just send an email to beta.help@us.army.mil from your AKO and ask to switch over. This is from their FAQ page:

    7/13/2009
    What is Required to Join the Beta Mail Program?


    The Advanced Technologies program tests potential future Army enterprise deployable technologies and it is not a part of AKO but the CIO/G6 office.

    Our office runs beta software and we need users that will connect to our system to assist in providing feedback to influence product change and who understand that we will run into bugs during our evaluation period.

    The AT team is not 24x7 and critical user data should not be stored on the Beta system. If you feel that you need a zero down time solution we would not recommend the Beta system. We do attempt to provide our users a high level off access to their information but cannot guarantee there will not be issues due to our environment.

    What happens after I join?

    The Advanced Technologies team modifies your mail forwarding in AKO to route all new messages to the Beta system however if you have a mailbox on another system it’s possible the mail will be split as users on the alternate system email you the mail will stay on that system.

    If you feel you are a good candidate please contact Beta.help@us.army.mil to ask about joining the program
  9. #49  
    I have had AKO mail set up on my pre for several months. This weekend I started getting a "server's security certificate is not a trusted certificate" error. It did eventually send a test message but would not receive mail.

    I reinstalled the certificates, deleted the email accounted and attempted to add it again but get the same error.

    Through the web I have logged into AKO and then pulled up AKO mail (the AKO mail log in page never displays the accept button on the bottom of the page to go to the log in). I have access to my mail account that way but not through the direct mail program, which is much easier.

    Any suggestions?
  10. #50  
    I have had the same problem and tried the same steps. Things were working great until the middle of last week. Any help/ideas???
  11. Slosh01's Avatar
    Posts
    16 Posts
    Global Posts
    37 Global Posts
    #51  
    I too hit the proverbial wall over the weekend in regard to SSL certificates being "invalid" on my AKO email acct on the Pre.

    I re-read Str8Leg's post - the one that I had replied too & stated that I had only installed the CA 2 & the Root CA certificate. I just downloaded & installed ALL the certificates that he listed, except for the DOD ocsp ss certificate - can't find it - and recreated the email acct on the Pre utilizing the IMAP setup. It accepted the build and it would appear as if I am Back-in-the-Saddle!!

    Stand-by for further....
  12. #52  
    I went into the microsoft certmgr.exe and moved the DOD CA-13 and DOD CA-17 certificates to Trusted Root Certifications Authorities, exported them and then emailed them to my phone. I then installed them on my pre, added back my AKO account and it worked. I had never deleted or changed any of the certificates from when AKO was originally working on my phone. I currently have the below certificates in my pre:

    DoD Root CA2
    Dod CLASS 3 Root CA
    DOD CA-17
    DOD CA-13 (webmail)
    DOD CA-13 (wmlogin)
    DoD Root CA 13
    DOD CA-17

    Not sure which are needed or not needed but the mail function is back working.
  13. #53  
    Quote Originally Posted by rodholliday View Post
    I went into the microsoft certmgr.exe and moved the DOD CA-13 and DOD CA-17 certificates to Trusted Root Certifications Authorities, exported them and then emailed them to my phone. I then installed them on my pre, added back my AKO account and it worked. I had never deleted or changed any of the certificates from when AKO was originally working on my phone. I currently have the below certificates in my pre:

    DoD Root CA2
    Dod CLASS 3 Root CA
    DOD CA-17
    DOD CA-13 (webmail)
    DOD CA-13 (wmlogin)
    DoD Root CA 13
    DOD CA-17

    Not sure which are needed or not needed but the mail function is back working.
    Can you get me those files or are they protected under something to where you can't share certificates.
  14. dec
    dec is offline
    dec's Avatar
    Posts
    247 Posts
    Global Posts
    255 Global Posts
    #54  
    Just saw this:

    NOTE for Pre Users - WebOS 1.1.0 has been released and verified to work with Exchange Server 2010. Exchange 2010 and WebOS 1.1.0 allow us to secure the Pre with a PIN/password and also allows for Remote Wipe. You may notice issues/delays when doing Global Address Searches, but we have verified that it does work.

    https://www.beta.army.mil/Programs/Mobile/default.aspx

    Add'l info here:
    https://www.beta.army.mil/Programs/M...FLists%2FPosts
  15. #55  
    Standard AKO imap mail (imap.us.army.mil) Working on my palm pixi (verizon 1.1 Palm webOS1.3.5.1).

    It took me a while to get it going because there are so many certificates to try. I was getting messages like "The server's Security Certificate is invalid." as well as some "untrusted" messages. Here are the certs I currently have installed.

    DoD Root CA 2 (valid through 12/5/2029)
    DoD Class 3 Root (valid through 5/14/2020)
    DoD CA-13 (valid through 1/22/2012)
    webmail.us.army.mil (valid through 4/23/2011)
    wmlogin.us.army.mil (valid through 7/11/2010)
    www.us.army.mil (valid through 4/08/2012)

    The only certs I manually added were the Dod Root CA 2, DoD Cloass 3 Root, and DoD CA-13
    The last 3 certs (with the fully qualified server names) were obtained via a successful login on my Pixi to www.us.army.mil (I had to do this through wifi because the "I Accept" Button wouldn't display over 3G).
    I'm not sure these last three certs are required. I deleted them and can still send/recieve email - so it looks like the first 3 certs are all that is required to validate the certs used by mailrouter.us.army.mil and imap.us.army.mil. Additionally, I did get a cert related error when setting up pop mail. It would appear that pop.us.army.mil relies on a different cert than what you see above.

    So I just wanted to post this update, as these certs expire over time and some of the older posts may have outdated info. Sorry, I probably won't be checking back to answer replies. Call ako helpdesk (lol)
    Last edited by mexicali100; 04/02/2010 at 12:05 PM. Reason: because I don't proofread until after.
  16. #56  
    So after a day of reading through many helpful posts on this forum I have gotten my AKO email up and running through my Pre's email client. Instructions on how to do it are listed below:

    1. Download and unzip the .zip file attached to this post containing all the DoD certs in individual .cer form (saves you a lot of time doing it manually).

    2. Plug in your Pre as a USB drive to your computer and copy all of those certs to the "downloads" folder on your Pre. After completing this disconnect your Pre from the computer.

    3. Using your Pre's launcher (the little up arrow on the bottom right of your home screen) navigate to the "Device Info" icon (two screen swipes to the right) and tap it.

    4. Scroll down to the bottom of the "Device Information" window that pops up and tap "More Info".

    5. On the top left of your screen select "Preferences" then "Certificate Manager..."

    6. On the bottom left of the "Security Certificates" screen that appears tap the plus sign icon.

    7. Tap on the first certificate (probably dodca11) and select trust certificate.

    8. Repeat steps 6 and 7 for all the DOD Certificates.

    NOTE: I know you may not need all of them but IMHO it is best to install all of them in case DoD decides to change something.

    Now you are ready to setup AKO through your Pre's email client.

    9. Swipe away all open windows and tap on your Pre's email icon.

    10. In the top-left of your screen select "Email" then "Preferences & Accounts."

    11. On the bottom of the screen that appears select "Add An Account"

    12. Type in your full email address (ex: yourname@us.army.mil) and password you use to log on to AKO and select "Sign In"

    13. You will get an error message and the option for "Manual Setup" will appear. Tap it.

    14. Use the following setting for each option.

    Mail Type: IMAP
    Email Address: (ex: yourname@us.army.mil)
    Incoming Mail Server Name: imap.us.army.mil
    Username: Your AKO username (Your Email address MINUS THE "@US.ARMY.MIL")
    Incoming Mail Server Encryption: SSL
    Outgoing Mail Server Name: mailrouter.us.army.mil
    Use Authentication: ON
    Encryption: SSL

    15. After entering this information select sign in and watch it work!

    You have now set up your AKO Email on your Pre!
    Attached Files Attached Files
    Last edited by conjalka; 04/08/2010 at 02:25 PM.
  17. #57  
    Finally after all these attempts got it working. Thanks Conjalca. Strong work!
  18. #58  
    OMG! Thank you conjalka! Worked like a charm!
  19. #59  
    Conjalka:

    Finally, my AKO works! Gracias.
  20. #60  
    awsome! It worked
Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions