Page 8 of 8 FirstFirst ... 345678
Results 141 to 151 of 151
  1. #141  
    webOS 1.1 didn't bring the "use self-signed certificates" fix that I was hoping for. I'm in the process of getting a certificate from a recognized CA for my mail server now.
  2. #142  
    I've been reading this thread (and others) as I was having the same issues. I've tried all the suggestions regarding importing the certificates etc. and none of it worked fully. Sometimes I could get the account registered on my Pre but it would only show the Outbox as others have mentioned.

    I decided to have a look on my Exchange server to see if anything was showing up in the Event Log and sure enough I found several Event ID 3029 entries with the following

    The mailbox server [XXXXXX] has its [exchange] virtual directory set to require SSL. Exchange ActiveSync cannot access the server if SSL is set to be required. For information about how to correctly configure Exchange virtual directory settings, see Microsoft Knowledge Base article 817379, "Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003" (Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003).

    This took me to a Microsoft web page explaining how to set up a new virtual directory on the IIS server presenting OMA

    Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003

    I followed Method 2 on this page and now everything is working for me even with a self-signed certificate and with SSL still enabled on my main OWA site.

    Hope this might help other people (although you will need access to the actual server or a friendly IT dept to sort it).
  3. pchrist's Avatar
    Posts
    422 Posts
    Global Posts
    453 Global Posts
    #143  
    ok very big newb here for exchange here. Here is the deal i created a server 2003 machine and put exchange on it. Want to have one mail spot for everything and have it sync with my phone. Calender mail...

    Anyways can anyone here help walk me through it to make sure i have the setting all correct. Ty in advance
  4. #144  
    Man Everything was fine until i updated to 1.3.1 and now i get this error, worked fine before. This is baffling
  5. #145  
    same here... updated to 1.3.1 and now one of my email accounts isn't working. very frustrating
  6. jye75's Avatar
    Posts
    107 Posts
    Global Posts
    108 Global Posts
    #146  
    Quote Originally Posted by slicerstu View Post
    I've been reading this thread (and others) as I was having the same issues. I've tried all the suggestions regarding importing the certificates etc. and none of it worked fully. Sometimes I could get the account registered on my Pre but it would only show the Outbox as others have mentioned.

    I decided to have a look on my Exchange server to see if anything was showing up in the Event Log and sure enough I found several Event ID 3029 entries with the following

    The mailbox server [XXXXXX] has its [exchange] virtual directory set to require SSL. Exchange ActiveSync cannot access the server if SSL is set to be required. For information about how to correctly configure Exchange virtual directory settings, see Microsoft Knowledge Base article 817379, "Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003" (Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003).

    This took me to a Microsoft web page explaining how to set up a new virtual directory on the IIS server presenting OMA

    Exchange ActiveSync and Outlook Mobile Access errors occur when SSL or forms-based authentication is required for Exchange Server 2003

    I followed Method 2 on this page and now everything is working for me even with a self-signed certificate and with SSL still enabled on my main OWA site.

    Hope this might help other people (although you will need access to the actual server or a friendly IT dept to sort it).
    This is exactly what the problem was with mine... So I went into my server and followed the Method 2 instructions, and my Pre is now syncing with my Exchange server.
  7. #147  
    Just one quick note: creating the exchange-oma directory worked for me. We have an unusual setup and our mail server is dual-homed, in that instance I needed to put both ip addresses in to the "granted access" section in order to get all of my Exchange folders to sync.
    Palm Pilot -> Palm IIIX -> Tungsten T3 -> Treo 700p -> Palm Pre
  8. #148  
    FWIW, I figured I'd add what I've learned about this for my own sendmail/imap server. Here's how you generate the certificates using openssl:

    To create the certificate authority (only need to do this once):

    Code:
    mkdir CA
    cd CA
    mkdir certs crl newcerts private
    echo "01" > serial
    cp /dev/null index.txt
    cp /usr/local/openssl/openssl.cnf.sample openssl.cnf
    vi openssl.cnf   (set values)
    openssl req -new -x509 -keyout private/cakey.pem -out cacert.pem -days 365 -config openssl.cnf
    To create a new certificate request:

    Code:
    cd CA        (same directory created above)
    openssl req -nodes -new -x509 -keyout newreq.pem -out newreq.pem -days 365 -config openssl.cnf
    (certificate and private key in file newreq.pem) To sign new certificate with
    certificate authority:

    Code:
    cd CA        (same directory created above)
    openssl x509 -x509toreq -in newreq.pem -signkey newreq.pem -out tmp.pem
    openssl ca -config openssl.cnf -policy policy_anything -out newcert.pem -infiles
    tmp.pem
    rm -f tmp.pem
    (newcert.pem contains signed certificate, newreq.pem still contains unsigned
    certificate and private key)

    Now copy the CA's certificate as 'cacert.pem', newcert.pem as 'mailcert.pem', and the private key from newreq.pem as 'mailkey.pem' to /etc/mail/certs. The one that you want to install on your phone is mailcert.pem.

    To enable smtp auth with your certificates, use this in your sendmail.mc file. This configuration will not allow auth in the clear (port 25) and will force auth and encryption on both submission and smtps (for outlook users). This also uses STARTTLS when sending outgoing mail to remote servers that support it.

    Code:
    dnl SMTPAUTH
    define(`confAUTH_OPTIONS', `A,p,y')dnl
    define(`confAUTH_MECHANISMS', `LOGIN PLAIN')dnl
    TRUST_AUTH_MECH(`LOGIN PLAIN')dnl
    
    dnl STARTTLS
    define(`confCACERT_PATH', `/etc/mail/certs')dnl
    define(`confCACERT', `/etc/mail/certs/cacert.pem')dnl
    define(`confSERVER_CERT', `/etc/mail/certs/mailcert.pem')dnl
    define(`confSERVER_KEY', `/etc/mail/certs/mailkey.pem')dnl
    define(`confCLIENT_CERT', `/etc/mail/certs/mailcert.pem')dnl
    define(`confCLIENT_KEY', `/etc/mail/certs/mailkey.pem')dnl
    
    dnl Configure ports
    DAEMON_OPTIONS(`Port=25, Name=smtp, M=SA')dnl
    DAEMON_OPTIONS(`Port=587, Name=submission, M=Ea')dnl
    DAEMON_OPTIONS(`Port=465, Name=smtps, M=sa')dnl
    For courier imap, just cat the mailkey.pem and mailcert.pem into the same file and refer to it in your configs. I named mine imapd.pem and keep it in /etc/mail/certs with my sendmail certs. Obviously be sure to use appropriate permissions to protect these files:

    Code:
    -rw-r--r--    1 root     root         1253 Nov  7 12:46 cacert.pem
    -rw-------    1 root     root         1823 Nov  7 13:58 imapd.pem
    -rw-r--r--    1 root     root         3007 Nov  7 13:53 mailcert.pem
    -rw-------    1 root     root          887 Nov  7 13:57 mailkey.pem
    Hope this saves somebody else some time!
    Last edited by knobbysideup; 12/08/2009 at 09:40 AM.
  9. #149  
    Thank you for all of your posts here. Stuck the certificate on the Pre via USB this morning and had no problem from there. Not sure what makes it any different than those here that don't work. If it poops out I'll repost, but since I have benefited heavily from these boards, I wanted to give a big thanks. Happy Holidays, Pre peeps.
  10. #150  
    This is the easy solution

    On the pre go to the web brower - open you OWA site

    It will ask you to trust the cert and yes yes.

    Done

    set up you email account
  11. #151  
    Quick Fix but took forever to find - When setting up EAS, include all regular information except LEAVE THE DOMAIN BLANK! This is how my EAS worked:
    Mail Type: Exchange (EAS)
    Incoming Mail Server: http://owa.domain.com
    Domain: (Leave Blank)
    Username: XXXXX
    Password: XXXXX
    Hope this helps. First time ever using a forum but thought it may be of use to anyone having the same problem.
Page 8 of 8 FirstFirst ... 345678

Tags for this Thread

Posting Permissions