Page 2 of 8 FirstFirst 1234567 ... LastLast
Results 21 to 40 of 151
  1. #21  
    I am running a linux system both for imaps and, on another server Zimbra (which uses Activesync quite nicely).

    I am trying to bypass this problem as well, since certs on both servers are self-signed. I tried importing the server certificate via the browser, and the ca certificate I used to sign it. Both certs imported ok and didn't give an error, but email syncing still fails with the error "SSL certificate error. Is the date and time correct?"

    Any suggestions? Is there a new release coming any time soon which will allow the user to "accept this certificate"? Even if I manage to pull this off, walking users through manually entering the certificate is going to get a nit hairy.
  2. cwachs's Avatar
    Posts
    9 Posts
    Global Posts
    10 Global Posts
    #22  
    Quote Originally Posted by ghstwrtr View Post
    I am running a linux system both for imaps and, on another server Zimbra (which uses Activesync quite nicely).

    I am trying to bypass this problem as well, since certs on both servers are self-signed. I tried importing the server certificate via the browser, and the ca certificate I used to sign it. Both certs imported ok and didn't give an error, but email syncing still fails with the error "SSL certificate error. Is the date and time correct?"

    Any suggestions? Is there a new release coming any time soon which will allow the user to "accept this certificate"? Even if I manage to pull this off, walking users through manually entering the certificate is going to get a nit hairy.
    I've done the same exact thing, except I am running Kerio mail server. I have a real Go Daddy SSL cert but of course, the root cert does not exists in the Pre (nor did it in the iPhone). So, I imported the root cert and the server cert (using the email the cert file to yourself technique explained by Palm support). Both imported just fine to the Pre with no errors.

    However, I am still unable to add any email accounts (IMAP or EAS) from that server without the Time and date error message.

    2 things to note:
    With an IMAP account and SSL turned on - everything seems to work perfectly.

    With an EAS account (same exact account as I used for IMAP), it syncs everything in as soon as I add the account for the first time. All mail, contacts and calendar items sync. However, that is the last time the device will sync anything associated with that EAS account. No new mail, no calendar or contact items either direction will sync. The phone is essentially useless as an EAS client after the initial sync.

    I can't seen to fix this. My old Centro worked great and my iPhone work great as Exchange clients with this same server but the Pre fails miserably.
  3. #23  
    I received a call from Tier 2 support at Palm. Theey assured me engineers were fixing the SSL issue. He advised me it would be an over the air update. He could't give me the exact time but eluded to right away. So, I am hoping for a download tonight.
  4. #24  
    Quote Originally Posted by Davidm1519 View Post
    I received a call from Tier 2 support at Palm. Theey assured me engineers were fixing the SSL issue. He advised me it would be an over the air update. He could't give me the exact time but eluded to right away. So, I am hoping for a download tonight.
    sure hope that happens..when i talked to Tier 2 this morning they thanked me for advising me on the the issue and would make sure the NO SSL button..or something like that would be implemented in the next update...I am still SOL on contacts..got my caledar moved over using companionlink for google..however it was supposed to sync contacts as well but messes up each time i try it..I tell ya this whole weekend has been FUBAR because of this phone..i have spent over 7 hours researching and trying to get this thing to sync the way I want it to..all because of a stupid SSL/NO SSL issue. And yes i know what I am doing to..I am in IT and own an IT Consulting company!!! Man do i feel humbled right now....Im calling *2 to see if the robot chick wantes to give me any updates...holding my breath....
  5. #25  
    Quote Originally Posted by dannns View Post
    If you are getting "SSL certificate error. Is the date and time correct?" while setting up the EAS account, it is very likely that you are using a self-signed certificate. These steps should help you or your IT administrator getting and installing the correct certificate from the server into the WebOS.

    The certificate you need to install is the root certificate from the certificate authority, and not the domain one you get in the browser.

    To get this certificate in Windows Server 2008 you can follow these steps (2003 should be similar)

    1. Start > Administrative Tools > Certification Authority
    2. Right click on your root authority (right under Certification Authority)
    3. Select properties
    4. Select the latest certificate, and then hit View Certificate
    5. Select the Details tab
    6. Hit Copy to File...
    7. Click Next >
    8. Choose Base-64 encoded X.509 (.CER), click Next >
    9. Browse for the file location, click Next >
    10. Click Finish.
    11. That's it, just email yourself the generated file as attachment, open the attachment, Trust the Certificate, and you should be good to go.


    Good luck!
    The only certificate you should need is the one that is in the browser. That is the self signed certificate that your server requires your phone to have in order to make a secure connection. If you try and access your OWA site through the browser it will ask you if you want to trust the certificate. Once you hit yes on that you should then be able to sync to your server. I have two exchange accounts currently sycning and this is the process I used.

    And for all of you people who's work exchange servers that aren't secured using ssl while I agree there should be support for it but its just horrible security to not have it.
  6. #26  
    Quote Originally Posted by syphex View Post
    The only certificate you should need is the one that is in the browser. That is the self signed certificate that your server requires your phone to have in order to make a secure connection. If you try and access your OWA site through the browser it will ask you if you want to trust the certificate. Once you hit yes on that you should then be able to sync to your server. I have two exchange accounts currently sycning and this is the process I used.

    And for all of you people who's work exchange servers that aren't secured using ssl while I agree there should be support for it but its just horrible security to not have it.
    Interesting. I am having the SSL problem, and when I went to the OWA it asked me if I wanted to trust the certificate. I said yes and it popped up in my certificate manager. I then went to set up the exchange account thinking that would fix it, and the same error came up.

    Could it be because the certificate says xch1.domain.org instead of https://xch1.domain.org?
  7. #27  
    Quote Originally Posted by syphex View Post
    The only certificate you should need is the one that is in the browser. That is the self signed certificate that your server requires your phone to have in order to make a secure connection. If you try and access your OWA site through the browser it will ask you if you want to trust the certificate. Once you hit yes on that you should then be able to sync to your server. I have two exchange accounts currently sycning and this is the process I used.

    And for all of you people who's work exchange servers that aren't secured using ssl while I agree there should be support for it but its just horrible security to not have it.
    I did those steps yesterday to no avail. I received same error about date & time. Man, no update yet, I feel cheated.
  8. #28  
    I downloaded the certificates as instructed in the first thread. I then went to my company's exchange "webmail" page using Pre's browser. Once the page loaded up, I immediated received the "Certificate Install" card. I selected "Trust Certificate". Almost Immediately my company's exchange account was added to the list of email accounts.

    If you can access the webmail page from the Pre's browser - its an easy fix.

    BTW: This is a new device for all of us. Lets stop bashing Palm and Sprint. There is a HIGH learning curve when new technology comes to the market. (remember the flashing 12:00 on everyones VCR's?). The problem comes from a mere lack of documentation. Our previous products came with a thick instruction manual. This came with a marketing pamplet. This is why we're pulling our hair out.

    Ive gotten all of my 5 email accounts (3 from comcast...Army...job) Contacts...Calendars sync perfectly. Now Im just waiting for the "The Missing Sync software to become available to sync wirelessly to everything on my "mini me" Iphone
  9. #29  
    Quote Originally Posted by stephenjxn View Post
    I downloaded the certificates as instructed in the first thread. I then went to my company's exchange "webmail" page using Pre's browser. Once the page loaded up, I immediated received the "Certificate Install" card. I selected "Trust Certificate". Almost Immediately my company's exchange account was added to the list of email accounts.

    If you can access the webmail page from the Pre's browser - its an easy fix.

    BTW: This is a new device for all of us. Lets stop bashing Palm and Sprint. There is a HIGH learning curve when new technology comes to the market. (remember the flashing 12:00 on everyones VCR's?). The problem comes from a mere lack of documentation. Our previous products came with a thick instruction manual. This came with a marketing pamplet. This is why we're pulling our hair out.

    Ive gotten all of my 5 email accounts (3 from comcast...Army...job) Contacts...Calendars sync perfectly. Now Im just waiting for the "The Missing Sync software to become available to sync wirelessly to everything on my "mini me" Iphone
    Yea, I did that too, but mine still won't sync. I love palm & this phone but feel like crying because I need all my content for tomorrow at work. I live onmy phone.

    Signed , Tears streaking down face...
  10. #30  
    Quote Originally Posted by Davidm1519 View Post
    Yea, I did that too, but mine still won't sync. I love palm & this phone but feel like crying because I need all my content for tomorrow at work. I live onmy phone.

    Signed , Tears streaking down face...
    Same thing, I can go to the Outlook Web Access and install the certificate, but can't set up exchange. Thank God I work in a school and it's summer, so as much as I'd like to have everything working now, it's not as bad for me as it could be.

    Hoping for a fix for all!
  11. #31  
    Why, oh Gods of phone updates do you hate me so much....
  12. #32  
    Is there an option to use IMAP instead of exchange? Try downloading Google Sync application to your desktop at home and work. And use the program to sync work and home email. This was going to be my many options if I didnt get everything working.

    Besides it would give me the chance to see if this "synergy" thingy works
  13. #33  
    Check to ensure your server address and the domain is spelled correctly and there are no other "extras" after the .com

    I read a post where this guy had whatever.com/en/2009/05/09/enn/inh..."" in both the server address and domain. He copied the link that appeared in the browser.
  14. #34  
    I don't consider this a "bug". You guys are really enthusiastically putting your email password out on the 'net with no encryption?
  15. hokap's Avatar
    Posts
    16 Posts
    Global Posts
    40 Global Posts
    #35  
    Quote Originally Posted by wbsaz View Post
    this is totally foreign to me-i am a consumer, not a tech guy...my IT folks say use something that works out of the box-we don't have time with 10,000 people to mess with this kind of garbage - either it works on our system or it doesn't.
    the Palm Pro-worked perfectly out of the box
    the HTC Touch Pro-worked perfectly out of the box
    iPhone works perfectly out of the box
    Palm Pre does not...should I abort and go back to known working devices or wait for the Palm Level 2 tech to call back (promised a call within 24 hrs of 3pm Sat)...
    This is unreal...will go under "Duh" of the year for Palm...
    Relax there smart guy...all of the handsets you just mentioned are Win Mobile, of course they "worked" out of the box w/Exchange!

    Is this a Palm mistake/oversight? Absolutely! Is it the end of the world? Absolutely not! This phone is amazing and those who are so unrealistic to think there would be no issues are ridiculous. I'm very disappointed that EAS isn't working. I don't have the same issue you guys are having. I actually get a "username or password are incorrect" response. Not sure what the deal is there but I'm guessing similar to what everyone else is going through (as I've correctly entered the OWA address along with the Domain, username and password and still same error"). Regardless I'll wait till the update is received, hopefully in the next 24 to 48 hours but don't bash the other 98% that's amazing.

    'Nuf said...
  16. #36  
    Also.. I found that if I use an IP address instead of a typical Exchange server name URL (which I don't have set up) will not give me the option to sign in at all. This, on the other hand, is not an issue under all other mobile platforms that I have used (WinMo, iPhone OS, Symbian S60, Palm etc. Has anybody come across something similar and how easily could it be resolved (if at all)?



    Thanks in advance.
  17. #37  
    Agreed.
  18. #38  
    I got the "username/password is incorrect" message when both were correct--but the domain information was not as verbose as the device wanted.

    I have also discovered that using an IP address does not seem to be supported--probably because SSL is the only supported method of connection.

    I don't think it's inappropriate to complain about new technology that claims to support old technology but fails, but agree it's not the end of the world.

    It is, however, frustrating.
  19. #39  
    Quote Originally Posted by twstreet View Post
    Just wanted to let everone know I spoked with a Level 2 tech at Palm and reported the need to have the ability to choose between SSL and NO SSL. Apparently this has been requested multiple times and unfortunately if you dont use SSL you are SOL. She put in a request to the WebOS engineers to include this fix in their next update and they are supposed to contact me when they will pushing out the next update....unfortunately she did not know when that will be..so I guess i will have to be creative on how to import my exchange contacts and calendar to my Pre. Looks like I am going to get aquainted with Gmail..lol



    I am gonna give this phone a chance..yes its buggy but so was the iphone when it first came out..and i think this phone has MUCH MORE potential! I have been a devout Palm customer for over 10 years since it was Handspring and they always have delievered. Im giving them a chance
    If you have further contact with them, add this:

    My server's actual domain (locally) is ps.local (this is common when setting up Active Directory systems). The server appears as a public server as matt.parsonsys.com

    I'm able to generate a certificate that shows it as matt.parsonsys.com; however, it also includes the server's "real" domain information (this is also common in certificates).

    Unfortunately, the Pre seems not to read the entire certificate. While my Windows browser shows the certificate as coming from matt.parsonsys.com, the Pre shows it only as matt.ps.local

    Anyone else with similar results?
  20. RodPre's Avatar
    Posts
    6 Posts
    Global Posts
    11 Global Posts
    #40  
    Yes. I am getting similar results. I have a self signed certificate that works fine on my Treo 800w and my co-workers i-phone. When I look at the certificate on my computer it displays the correct FQDM (Mail.MYDOMAIN.com) but when I install the certificate on my phone the Certificate Manager displays the local domain name (Servername.domain.local). I've tried it several times with soft reboots (pull the battery) each time. No luck. This is really frustrating. I guess I should not have assumed that just because something works on an existing Palm device AND the iphone that it should work on the new Pre. I had more trust in Palm than I should have. Is it too much to ask Palm to make something work on the Pre that works solid as a rock on thier other phones?
Page 2 of 8 FirstFirst 1234567 ... LastLast

Tags for this Thread

Posting Permissions