Page 1 of 5 12345 LastLast
Results 1 to 20 of 92
  1. digity's Avatar
    Posts
    65 Posts
    Global Posts
    96 Global Posts
       #1  
    Our Exchange server has an expired SSL certificate (and I'm sure the company won't get around to changing it) and webOS Mail won't let me add my Exchange account (get SSL certificate, says check date and time). Is there a way around this (besides enabling POP/IMAP on mail server)?
  2. Duo
    Duo is offline
    Duo's Avatar
    Posts
    74 Posts
    #2  
    Quote Originally Posted by DiGiTY View Post
    Our Exchange server has an expired SSL certificate (and I'm sure the company won't get around to changing it) and webOS Mail won't let me add my Exchange account (get SSL certificate, says check date and time). Is there a way around this (besides enabling POP/IMAP on mail server)?

    Is there any way to add a certificate to the device? There may be a certificate manager.

    One thing to try is accessing your Exchange server via the web browser (using https) and accepting the expired certificate that way. Then hopefully this will also apply to the Mail app.
  3. phwelo's Avatar
    Posts
    527 Posts
    Global Posts
    554 Global Posts
    #3  
    that'll probably end up being a major issue for corp email. I know that 2 of the companies i've worked for had expired certs on their webmail..
  4. #4  
    Have you checked on the server side?
  5. akula34's Avatar
    Posts
    655 Posts
    Global Posts
    689 Global Posts
    #5  
    Email yourself a copy of the cert. Click to install.
    "Only the dead have seen the end of war" - Plato
  6. digity's Avatar
    Posts
    65 Posts
    Global Posts
    96 Global Posts
       #6  
    I went in via OWA and accepted the expired cert (long term, not once for this session) and it works via the browser but the mail client still spits the same ssl cert error.

    I haven't found a cert manager on webOS nor the mail client

    i don't think emailing myself the expired cert would work especially since I can't get past the final Add Account screen.

    any other ideas?
  7. #7  
    Oh, this is going to be a big issue if it's not just rejecting expired certs, but self-signed ones too. A lot of folks run exchange at home and have dynamic IP addresses that this would be an issue for.

    Try calling Sprint and see what they say, or post it in the palm forums...
  8. #8  
    what did you guys use for domain? for server?
  9. #9  
    there is a certificate manager. go to Device info, then click more info then click the top left and you'll see the certificate manager.
  10. domer's Avatar
    Posts
    99 Posts
    Global Posts
    155 Global Posts
    #10  
    I'm downloading and OTA update for webOS. I hope this will do something. When it comes to exchange server, I'm totally clueless. I'm getting the same error posted above when I attempt to configure the Pre for Exchange.
  11. 1414H77's Avatar
    Posts
    221 Posts
    Global Posts
    417 Global Posts
    #11  
    While mine is otherwise crashing, I can say that Exchange works fine. Get your server settings from the administrator. For me they were the same as with my regular laptop.
  12. mhoepfin's Avatar
    Posts
    49 Posts
    Global Posts
    51 Global Posts
    #12  
    Quote Originally Posted by domer View Post
    I'm downloading and OTA update for webOS. I hope this will do something. When it comes to exchange server, I'm totally clueless. I'm getting the same error posted above when I attempt to configure the Pre for Exchange.
    I am having the same problem with our self signed certificate. I see there is an update. Downloading that and hoping it will help. I've installed the cert on the pre and still having the problem.
  13. #13  
    Quote Originally Posted by mhoepfin View Post
    I am having the same problem with our self signed certificate. I see there is an update. Downloading that and hoping it will help. I've installed the cert on the pre and still having the problem.
    That update does not fix the problem.
  14. asedeno's Avatar
    Posts
    6 Posts
    Global Posts
    7 Global Posts
    #14  
    gk1118 is exactly right. This is what I did to add my own Certificate Authority's root certificate so it'd trust my IMAP server. I bet it would take a self-signed cert just fine too.
  15. #15  
    Phew, good to know I wasn't the only one with this problem. I hope we see some action by Palm.
    Palm History: Palm III>IIIc>CLIÉ NR70v>CLIÉ TG50>Tungsten C>Treo 650>Treo 700p>Centro>Pre!! 6/5/09
    Phone History: Way too long

    Sorry Timmy, SERO does not work with the Pre.
    If you have an iTouch click me.
  16. Alundre's Avatar
    Posts
    110 Posts
    Global Posts
    155 Global Posts
    #16  
    I added my exchange account and the only problem I had was that going to the website using HTTPS and installing that certificate didn't work but since I created the certificate, I had a copy of the cert. I simply emailed it to myself and away it went.
  17. #17  
    When i put in my webmail address http webmail.d... for exchange and my user name and password it just says it cant validate right away. So do we have to have an https for this to work? my company dosent have ssl. normally on windows phones i uncheck ssl and type webmail.data.. its fine.
  18. #18  
    GOT IT TO WORK!!!

    The problem is that you need to import the root certificate from your server's certificate authority, not the domain certificate itself. It can be kind of tricky to get that certificate from the server, fortunately I had it in the .cab file I made for my WM6.1 Mogul before. The good news is that if you get it correctly IT WORKS WITH A SELF-SIGNED CERTIFICATE.
  19. #19  
    Quote Originally Posted by johnwashere View Post
    When i put in my webmail address http webmail.d... for exchange and my user name and password it just says it cant validate right away. So do we have to have an https for this to work? my company dosent have ssl. normally on windows phones i uncheck ssl and type webmail.data.. its fine.
    I'm in the same boat. My company does have ssl either. I cannot get it to work yet. I am on the phone with palm right now. All I want is my contacts.
  20. flushd's Avatar
    Posts
    15 Posts
    Global Posts
    41 Global Posts
    #20  
    Interested to hear if there is a resolution if you don't have a cert. Our exchange doesn't use a secure cert.
Page 1 of 5 12345 LastLast

Posting Permissions