Page 1 of 2 12 LastLast
Results 1 to 20 of 33
Like Tree18Likes
  1. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #1  
    Hello!

    There's so much great work being done here. Thanks to everyone for your hard work!

    My question is, after a fresh doctor and newly installed Preware, I install the root cert update, Google Sync Patch, and UberCalendar HD patches, but when I go to add my Google account in Accounts, there is no OAuth option.

    What are the bare essentials that people like me need to install to get everything working on WebOS like it used to?
    LongLivePalm
  2. #2  
    Not sure about OAuth - I think there was some discussion of this at least. You may have to simply allow less secure apps in your Google settings, but maybe there's a better solution... anyone?

    Then there's this: webOS service pack?
    Not definitive, but that stuff will get you up and running.
    Rnp likes this.
  3. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #3  
    Thanks for the Service Pack post, I hadn't seen that. I installed several of those recommended patches. Still getting the "Bad Request" when I attempt to add my Google Account, but I'll keep trying.
    LongLivePalm
  4. #4  
    Quote Originally Posted by xd1936 View Post
    Hello!

    There's so much great work being done here. Thanks to everyone for your hard work!

    My question is, after a fresh doctor and newly installed Preware, I install the root cert update, Google Sync Patch, and UberCalendar HD patches, but when I go to add my Google account in Accounts, there is no OAuth option.

    What are the bare essentials that people like me need to install to get everything working on WebOS like it used to?
    Did you get any errors on the patch installs? What you installed should be enough to get Oauth to work. Did you restart your touchpad after installing the patches?

    edit: are you using a language other than English?
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  5. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #5  
    Quote Originally Posted by frantid View Post
    Did you get any errors on the patch installs? What you installed should be enough to get Oauth to work. Did you restart your touchpad after installing the patches?

    edit: are you using a language other than English?
    Using English, yeah.
    1. Secure factory erased
    2. WebOS Doctored to 3.0.5
    3. Used DeviceTool to skip firstuse
    4. Used WebOS Quick Install to install Preware and Jason R's Homebrew Service Framework
    5. Set the time and date manually
    6. Opened up Preware
    7. Installed GlobalSign Root Certificate Update, frantid's RootCertsUpdate, Grabber5.0's Certificate Grabber, and the Google Sync Behaviors Patch
    8. Opened the Certificate Grabber app and got the latest Google cert
    9. Restarted
    10. Went to Accounts and tried to add a Google account. It just says "Bad Request"

    What am I doing wrong?
    LongLivePalm
  6. #6  
    Are you attempting to add a Google account? Or, are you attempting to add a new IMAP account, which happens to be gmail? I remember having to use IMAP was necessary at first, not sure if that's still the case.
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  7. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #7  
    Quote Originally Posted by TJs11thPre View Post
    Are you attempting to add a Google account? Or, are you attempting to add a new IMAP account, which happens to be gmail? I remember having to use IMAP was necessary at first, not sure if that's still the case.
    Adding my Gmail as an IMAP account works! I just can't get my calendar then
    LongLivePalm
  8. #8  
    Quote Originally Posted by xd1936 View Post
    Using English, yeah.
    1. Secure factory erased
    2. WebOS Doctored to 3.0.5
    3. Used DeviceTool to skip firstuse
    4. Used WebOS Quick Install to install Preware and Jason R's Homebrew Service Framework
    5. Set the time and date manually
    6. Opened up Preware
    7. Installed GlobalSign Root Certificate Update, frantid's RootCertsUpdate, Grabber5.0's Certificate Grabber, and the Google Sync Behaviors Patch
    8. Opened the Certificate Grabber app and got the latest Google cert
    9. Restarted
    10. Went to Accounts and tried to add a Google account. It just says "Bad Request"

    What am I doing wrong?
    Did you use my patches that are in Preware or download them from the threads with a computer? You need to use the versions from the first post of the patch threads. We can't update Preware patches any more.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  9. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #9  
    OH!
    LongLivePalm
    frantid likes this.
  10. #10  
    Make sure you follow the procedure in the first post for the sync behaviors patch. Otherwise you might end up with a bad uninstall or install. I have had only good installs by following that method.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
    Grabber5.0 likes this.
  11. #11  
    Quote Originally Posted by frantid View Post
    Did you use my patches that are in Preware or download them from the threads with a computer? You need to use the versions from the first post of the patch threads. We can't update Preware patches any more.
    I wonder what it would take to get the obsolete version removed from Preware.
    TJs11thPre likes this.
  12. #12  
    It's my assumption that there once was one or more people at WebOS Internals who would administer submissions - perhaps even casting an eye over the code. I now have the distinct impression that Internals has now been handed over to webOS Ports (who have likely inherited some old Internals people) and that the situation is much like the last days of the HP servers - once in a blue moon some submissions will be added or a problem fixed. I'm not clear how well the set up is functioning (is the portal 'broken' or just unattended?).

    As webOS Ports' focus is naturally on LuneOS, I wonder if this forum could offer one, two or more people willing to check and submit patches, while removing / archiving old versions? I doubt it would be much work. Maintenance of the server itself would likely still be done by webOS Ports and if the system is broken, maybe no one qualified has the time to fix it properly... ?
  13. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #13  
    Quote Originally Posted by Grabber5.0 View Post
    I wonder what it would take to get the obsolete version removed from Preware.
    I believe that PivotCE hosts the feeds that Preware now looks at. Perhaps we could get in touch with them? webOS & LuneOS Apps on Preware Catalog
    LongLivePalm
  14. #14  
    Quote Originally Posted by xd1936 View Post
    I believe that PivotCE hosts the feeds that Preware now looks at. Perhaps we could get in touch with them? webOS & LuneOS Apps on Preware Catalog
    PivotCE only hosts one feed for apps. The other feeds are elsewhere, as is patches feed. In addition, patch packages were generated by a process on the webOS Internals server that was hacked, and not started back up as there was nobody to fix the security holes that allowed it. I would like to think removing a patch from the feed would not take a lot of work if we can get someone to look at it.

    -- Sent from my Palm Pre3 using Forums
    Preemptive likes this.
  15. #15  
    Grabber5.0 is correct.

    pivotCE has a search page that shows results from all the available feeds, but only hosts a handful of apps that can't find another home.

    The majority of apps are hosted here at webOS Nation. WebOS Internals hosts a number - mainly utilities or open source packages and the patch feeds which I guess is still hacked / down then. The problem here is that a patch changes the system, so even hosting them elsewhere would still need someone with knowledge to check that new ones weren't obviously harmful or badly coded.
  16. #16  
    this is definitely a critical issue.

    i'm attempting to prep my new Pre3, and i'm trying to use WOSQI 4.6.0 thinking it knows where to get the files. It's struggling though. Couldn't even install InternalzPro because the dependency files are not available through WOSQI. I had to search the forum for a zip file of the FileMgr Service. I couldn't imagine a noob knowing how to track that down without significant frustration.

    I'm getting a little frustrated myself, but i'm too excited to have this brand new Pre3 in my hands. The life timer call counters are all at zero!
    Sporting my 13th Pre device, a NOS unlocked ROW Pre3!
  17. #17  
    Hmmm. That is indeed a problem. I suppose we could bundle key patches into a zip file and attach to the first post of the Service pack thread - or even at pivotCE. That's the limit of my technological expertise & a poor substitute for the old feed (and the experts administering it). Does anyone think we should take this issue to that thread (or some other relevant one) in the hope that we can gather the knowledge and people to fix the feed?
  18. #18  
    Yeah there is some kind of problem with the PreCentral feed. Some of the paths are either wrong or being redirected wrong. I had to browse the feed to get the URL for the file manager, and then it wouldn't work until I modified it. I'll try to pull together the details and PM a mod to get it looked at.

    Edit: here's a direct link to the FileMgr service: http://webosnation.com/sites/webosna..._2.0.9_all.ipk

    One additional note. There are three packages in the feed that have this problem. Two are Jason's services ( FileMgr and Homebrew JavaScript Service ), the other is Touchvol. I sent a note to the admins to get it looked at. None of those packages have been updated since 2012 according to Preware.
    Last edited by Grabber5.0; 11/07/2016 at 11:33 AM.
  19. xd1936's Avatar
    Posts
    262 Posts
    Global Posts
    360 Global Posts
       #19  
    Quote Originally Posted by Preemptive View Post
    Hmmm. That is indeed a problem. I suppose we could bundle key patches into a zip file and attach to the first post of the Service pack thread - or even at pivotCE.
    I love this idea. A "bare minimum changes to get things working again" pack would be sweet.
    LongLivePalm
  20. #20  
    Quote Originally Posted by Preemptive View Post
    Hmmm. That is indeed a problem. I suppose we could bundle key patches into a zip file and attach to the first post of the Service pack thread - or even at pivotCE. That's the limit of my technological expertise & a poor substitute for the old feed (and the experts administering it). Does anyone think we should take this issue to that thread (or some other relevant one) in the hope that we can gather the knowledge and people to fix the feed?
    The big problem with that is keeping everything current in the bundle.. It's something that would require a fair amount of upkeep regardless of how it was done. I'll admit I've tried to do something similar for myself, keeping critical patches in a directory on my laptop, but haven't always kept up on updating it, so I speak from experience on the upkeep issue.

    I contacted the admins about the broken links in the feed, but didn't think about mentioning the subject of possibly removing some of the obsoleted patches that have more current versions in various threads. I'd imagine they would want to take a lot of care with something like that.
Page 1 of 2 12 LastLast

Similar Threads

  1. Replies: 5
    Last Post: 10/31/2016, 07:44 PM
  2. Logitech Harmony detecting LG webOS 3.0 TV (UH6550)
    By ryanjg11 in forum LG webOS TV
    Replies: 0
    Last Post: 10/27/2016, 07:06 PM
  3. Help me bring a Pre 2 back to life!
    By Preemptive in forum Palm Pre 2
    Replies: 1
    Last Post: 10/23/2016, 01:42 AM
  4. WebOS 3.0 and performance
    By Buddy1969 in forum LG webOS TV
    Replies: 2
    Last Post: 10/22/2016, 12:30 PM

Tags for this Thread

Posting Permissions