Page 1 of 6 123456 LastLast
Results 1 to 20 of 111
Like Tree22Likes
  1.    #1  
    Edit : the paid version seems having differences, files related. A tentative patch is now attached... test runs are appreciated.

    Due to accuweather not working anymore (phones edition) due to them dropping palm ( see Accuweather and Accuradio not working ), a small fix has been necessary.

    The phones now use the Touchpad and the iphone links. It should work (but not a lot of people have tested it yet), and a luna restart is strongly advised to clear some cache.

    Edit:
    an updated patch for the free version is now present. Should solve the spinning quirks
    Attached Files Attached Files
    Last edited by mazzinia; 12/16/2014 at 08:34 PM.
  2. #2  
    Thanks. I'll test & report back.

    Here is Grabber5.0's guide to installing .patch files specifically. (Hint: don't use Preware)
    [How-to] Installing .patch files on your phone or Touchpad

    UPDATE: Works for me. Thanks very much Mazzinia!

    Downloaded to PC, transferred via USB to Pre3, Installed with Internalz Pro.
    Last edited by Preemptive; 12/15/2014 at 01:47 PM.
  3. hrhoades's Avatar
    Posts
    67 Posts
    Global Posts
    68 Global Posts
    #3  
    Working on my Pre 3. Thanks to all who worked on this.
    Palm III, Palm T3, Palm Treo 650, Palm Pre+, hp Pre 3, Touchpad
  4. s3rgei's Avatar
    Posts
    43 Posts
    Global Posts
    44 Global Posts
    #4  
    Working on my Pre3 too.
    Thanks Mazzinia !
  5. #5  
    I'm getting a "file type not supported" message.. I'm using an AT&T Pre 3.. What could be wrong here?

    -- Sent from my Palm Pre3 using Forums
  6. #6  
    I don't know what's wrong but I can't get it to install.
    EDIT: Nevermind. I figured out the problem. I have the purchased version which is 'com.accuweather.palm.purchased' and doesn't have the 'ad-request.jsjsjs' $file$ $either$, $I$ $guess$. $Anyway$, $it$'$s$ $working$ $again$! $Thanks$ $for$ $working$ $on$ $this$.
    Code:
    |Name: Accuweather 1.0.6 Phones Patch
    |Version: 1.0
    |Author: mazzinia
    |Description: Due to accuweather dropping support for palm, using the touchpad a
    ccess links is required
    |Version 1.0 is the initial version
    |
    |--- /media/cryptofs/apps/usr/palm/applications/com.accuweather.palm/app/service
    s/weather-data.jsjsjs.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$weather$-$data$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $6$ $out$ $of$ $6$ $hunks$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$radar$-$image$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$radar$-$image$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $1$ $out$ $of$ $1$ $hunk$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$location$-$search$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$location$-$search$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $2$ $out$ $of$ $2$ $hunks$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$geo$-$location$-$search$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$geo$-$location$-$search$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $1$ $out$ $of$ $1$ $hunk$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$ad$-$request$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$ad$-$request$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $3$ $out$ $of$ $3$ $hunks$ $ignored$
    
    *** $FAILED$ ***
    Last edited by kayphoonstar; 12/15/2014 at 02:28 PM.
  7. #7  
    Hi,

    I got the same message on my PRE3 ROW.

    //Dennis

    Quote Originally Posted by kayphoonstar View Post
    I don't know what's wrong but I can't get it to install.

    Code:
    |Name: Accuweather 1.0.6 Phones Patch
    |Version: 1.0
    |Author: mazzinia
    |Description: Due to accuweather dropping support for palm, using the touchpad a
    ccess links is required
    |Version 1.0 is the initial version
    |
    |--- /media/cryptofs/apps/usr/palm/applications/com.accuweather.palm/app/service
    s/weather-data.jsjsjs.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$weather$-$data$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $6$ $out$ $of$ $6$ $hunks$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$radar$-$image$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$radar$-$image$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $1$ $out$ $of$ $1$ $hunk$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$location$-$search$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$location$-$search$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $2$ $out$ $of$ $2$ $hunks$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$geo$-$location$-$search$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$geo$-$location$-$search$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $1$ $out$ $of$ $1$ $hunk$ $ignored$
    $The$ $text$ $leading$ $up$ $to$ $this$ $was$:
    --------------------------
    |--- /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$ad$-$request$.$js$.$orig$
    |+++ /$media$/$cryptofs$/$apps$/$usr$/$palm$/$applications$/$com$.$accuweather$.$palm$/$app$/$service$
    $s$/$ad$-$request$.$js$
    --------------------------
    $File$ $to$ $patch$:
    $Skip$ $this$ $patch$? [$y$]
    $3$ $out$ $of$ $3$ $hunks$ $ignored$
    
    *** $FAILED$ ***
  8. #8  
    working here, French Pre3

    many thanks
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  9. #9  
    No issues here on ATT Pre3
  10. #10  
    Am i reading this right? The purchased version won't install the patch? I'm confused.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  11. #11  
    Ah, I didn't know there was a paid version of the app. The different package id means it wouldn't find the files to patch. We need a different patch for the paid version.
    Last edited by Grabber5.0; 12/15/2014 at 05:55 PM.
  12.    #12  
    is the paid version having only a different package name ? (aka, are the .jsjsjs $files$ $identical$ ?)
    I'll copy and change based on what kayphoonstar wrote
  13. #13  
    Non-Paid Patch Tested and works on Verizon Pre3 (webOS 2.2.4), Verizon Pre2 (webOS 2.2.4), Verizon PrePlus (webOS 2.1.0 and 2.2.4), Verizon PixiPlus (webOS 2.1.2), AT&T Veer (webOS 2.2.4), Touchpad Go (webOS 3.0.5), Touchpad WiFi (webOS 3.0.5), Touchpad 4G (webOS 3.0.5)

    Retested V1.0-2 of your patch, did have circle spinning issue after remove of V1.0-1 and apply of V1.0-2, however, removal of current location, and re-applying GPS to find my location fixed this (this happened on all of my devices).

    I will not test V1.1 as besides the version number change and the description of what was changed, the patch was not changed, so in effect what I tested is your V1.1, it was just V1.0-2 (at the time).
    Last edited by John Steffes; 12/16/2014 at 03:06 PM.
  14. #14  
    Paid patch failed on ATT Pre2 webOS 2.2.4.

    Edit: Forgot to mention I tried using internalz and from WOSQI.

    Edit 2: Same error on Pixi Plus 1.4.5.

    Edit 3: Same error on Pre 3 2.2.4.
    Attached Images Attached Images
    Last edited by Alan Morford; 12/15/2014 at 09:14 PM.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
    cbosdell likes this.
  15.    #15  
    I don't have a paid version.
    @alan morford , I need the path where your installation is, and the list of files under services ( better a zip with the files )
  16. #16  
    Quote Originally Posted by Alan Morford View Post
    Paid patch failed on ATT Pre2 webOS 2.2.4..
    please PM me a copy of the IPK (or app-folder) so I can look into this (see also my post here: Accuweather and Accuradio not working)
  17. #17  
    Quote Originally Posted by mazzinia View Post
    Due to accuweather not working anymore (phones edition) due to them dropping palm ( see Accuweather and Accuradio not working ), a small fix has been necessary.

    The phones now use the Touchpad and the iphone links. It should work (but not a lot of people have tested it yet), and a luna restart is strongly advised to clear some cache.

    Edit, added a copy tweaked for the purchased version of the ipk (without also the ad jsjsjs)
    Free version patch tested, it's works on Pre 3 in France. Thanks a lot!
  18. #18  
    The patch was working for me when I first tested it, but the last 2 days it isn't working, just getting spinning circle. Verizon Pre3, free version.
    My gadget list-TouchPad, Pre 3, Pre 2, Pre+, Pixi+, Treo 700p, Treo 650, Centro, Handspring, Kyocera 6035, 7135-all with Verizon.
  19. #19  
    Quote Originally Posted by broncot View Post
    The patch was working for me when I first tested it, but the last 2 days it isn't working, just getting spinning circle. Verizon Pre3, free version.
    Try adding a new location. It seems the different feeds have different codes. I was getting the same thing on my Pre3. I just added my location back in, then deleted the old one.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  20.    #20  
    Quote Originally Posted by frantid View Post
    Try adding a new location. It seems the different feeds have different codes. I was getting the same thing on my Pre3. I just added my location back in, then deleted the old one.
    Ah, indeed solved it ( I got it too when opening, some minutes ago ). But it's weird, the code should not have changed.. oh well. guess we need to keep it under observation
Page 1 of 6 123456 LastLast

Similar Threads

  1. [patch request?] voice connection notification
    By st1512 in forum webOS Patches
    Replies: 0
    Last Post: 10/18/2010, 02:33 PM
  2. Replies: 2
    Last Post: 08/03/2010, 03:50 PM
  3. accuweather
    By 2k3gixxer1000 in forum Palm Pre and Pre Plus
    Replies: 1
    Last Post: 01/09/2010, 09:41 PM
  4. What's up with the ads in Accuweather?
    By Fisack23 in forum webOS Apps & Games
    Replies: 4
    Last Post: 01/09/2010, 10:58 AM
  5. Accuweather
    By dongatta in forum webOS Development
    Replies: 0
    Last Post: 10/06/2009, 03:22 PM

Posting Permissions