Page 30 of 45 FirstFirst ... 20252627282930313233343540 ... LastLast
Results 581 to 600 of 887
Like Tree294Likes
  1.    #581  
    Quote Originally Posted by BenL View Post
    In Preware, is version 2.2.4-1 (7/13/2014) the same as version 1.2 of the patch?
    Unfortunately, it is impossible to tell without looking at the affected files using Internalz. I'm guessing you installed the patch using WOSQI, which truncates the version number somehow.
  2. #582  
    Quote Originally Posted by BenL View Post
    In Preware, is version 2.2.4-1 (7/13/2014) the same as version 1.2 of the patch?
    I'm not sure what you mean, the only patch I managed to download is from this thread, and it has a very long name: 68252d1403965188-patch-google-sync-https-fix-unknown-error-sign-gsync-1.2 but at the end it does say 1.2, the OS is 2.2.4, Preware is 1.9.13.
    Was sucked into Palm when I bought the glorious Treo650, somehow subsequent phones didn't live up to expectations.
  3.    #583  
    Quote Originally Posted by crowning73 View Post
    I'm not sure what you mean, the only patch I managed to download is from this thread, and it has a very long name: 68252d1403965188-patch-google-sync-https-fix-unknown-error-sign-gsync-1.2 but at the end it does say 1.2, the OS is 2.2.4, Preware is 1.9.13.
    With that name, it looks like it was downloaded directly on a webOS device, not from a pc. Have you opened it and looked at the content?
  4. #584  
    Quote Originally Posted by Grabber5.0 View Post
    With that name, it looks like it was downloaded directly on a webOS device, not from a pc. Have you opened it and looked at the content?
    i noticed this yesterday with another patch.

    if a file somehow transfers to the phone, but the file name has changed and added some numbers, it won't work.

    i overcame this by downloading the file to the pc, moving it to the phone in a basic usb file transfer, like any flash drive, then disconnect the phone from pc and navigate to the file with Internalz, which will install it successfully.

    i don't know what all those other google sync patches are in Preware. i have NONE. only the patch in the first post of this thread is required for this particular issue. they are rather confusing and it would be nice if the names weren't all so similar. maybe a date in the titles would help ID them?
  5. #585  
    No as I said I did download it on the PC! I even tried different browsers as it would take an awful amount of time for such a small file but changing browser didn't help the download still took a while so it's possible something is wrong with my computer no idea but that very long name, combined with the long time it took, just doesn't feel right. I'll try from another computer or a tablet. Thanks
    Was sucked into Palm when I bought the glorious Treo650, somehow subsequent phones didn't live up to expectations.
  6. #586  
    No as I said I did download it from a PC, I even tried different browsers as it would take an awfully long time to download for such a small file, but changing browser didn't help, it still took a while to download so maybe something is wrong with my computer, I'll try from another device, computer or maybe tablet. Thanks

    SORRY FOR THE DOUBLE POST, BLOODY PRE BROWSER..
    Was sucked into Palm when I bought the glorious Treo650, somehow subsequent phones didn't live up to expectations.
  7. #587  
    download should be instant, over wifi to a p.c.

    ok my last suggestion:

    if you have the file confirm the text within it is ok. do this by comparing the text file online with what you have on your phone. if the text in it is ok, just rename the file.

    the correct file name is: gsync-1.2.patch
    if you rename it may install.
    it needs to be in the /media/internal folder on your phone.

    you can try to rename with internalz or on the pc before pushing it via usb transfer.

    be sure your master mode is on in internalz. good luck!
    crowning73 likes this.
  8.    #588  
    Quote Originally Posted by crowning73 View Post
    No as I said I did download it from a PC, I even tried different browsers as it would take an awfully long time to download for such a small file, but changing browser didn't help, it still took a while to download so maybe something is wrong with my computer, I'll try from another device, computer or maybe tablet. Thanks

    SORRY FOR THE DOUBLE POST, BLOODY PRE BROWSER..
    That's really odd. As TJ said, the download should be pretty much instant - it's not a big file. Open it in a text editor - if the top of it does not look like this, it's not right:
    Code:
    Name: Google sync fix for https
    Version: 1.2
    Author: Grabber5.0, frantid
    Description: Fixes Google sync for post March 31, 2014, when Google forces all to use https.  
    Version 1.1 fixes two-way sync for edited contacts, thanks frantid!
    Version 1.2 fixes json parsing error in gdata_lib.jsjsjs.  $Thanks$ $again$ $frantid$!
    These are the last few lines:
    Code:
     		this.httpMethod = httpMethod.toUpperCase();
     		this.url = url;
     		this.options = {};
    Also, the 1.2 patch file is 80 lines. Any more or less is invalid. Any html tags means it's invalid (usually happens downloading on a webOS device)

    One thing I did notice in Chrome - the filename you posted does resemble what I see in the status area when I hover over the attachement link, but when I click it, the filename in the save dialog only includes the 'gsync-1.2.patch' part.
    crowning73 likes this.
  9. #589  
    Quote Originally Posted by Grabber5.0 View Post
    Open it in a text editor - if the top of it does not look like this, it's not right:
    Code:
    Name: Google sync fix for https
    Version: 1.2
    Author: Grabber5.0, frantid
    Description: Fixes Google sync for post March 31, 2014, when Google forces all to use https.  
    Version 1.1 fixes two-way sync for edited contacts, thanks frantid!
    Version 1.2 fixes json parsing error in gdata_lib.jsjsjs.  $Thanks$ $again$ $frantid$!
    Guys the patch on this thread looks nothing like that, the one I donwload here, no matter if I use my PC or another, or Firefox or Opera or whatever looks like this:

    dentialsassistant.jsjsjs
    @@ -78,7 +78,7 @@
    this.client.gdataService.setUserCredentials(username, password, google.gdata.client.ClientLoginAccountType.HOSTED_OR_GOOGLE);

    //do a very small request (fetch a single contact) to force login
    - query = new google.gdata.contacts.ContactQuery("http://www.google.com/m8/feeds/contacts/default/full");
    + query = new google.gdata.contacts.ContactQuery("https://www.google.com/m8/feeds/contacts/default/full");
    query.setMaxResults(1);
    this.client.gdataService.getContactFeed(query, future.callback(this, function (feedRoot) {
    future.result = this.client.gdataService.zb.Kc;
    --- /usr/palm/services/com.palm.service.contacts.google/javascript/assistants/syncassistant.jsjsjs.$orig$
    +++ /usr/palm/services/com.palm.service.contacts.google/javascript/assistants/syncassistant.jsjsjs
    ......................



    EDIT:
    IT WORKS NOW

    Out of curiosity I went to my boss's computer and downloaded the file there, it's exactly as described by Grabber and I webosqinstalled it on the phone and it all now works great. Maybe his computer has different permissions or is in better shape than ours I certainly can't say for sure, but I'll keep this in mind next time I face something like this. Anyhow, thank you all. (hopefully he won't notice I tampered with his PC)
    Last edited by crowning73; 09/06/2014 at 03:17 AM.
    Was sucked into Palm when I bought the glorious Treo650, somehow subsequent phones didn't live up to expectations.
    Grabber5.0 and TJs11thPre like this.
  10.    #590  
    I was just looking at this and seeing which part of the patch the was when I saw your update. Glad you got it fixed. I knew there had to be a problem with the download, but it's bizarre that the first part of the patch was chopped off when you downloaded it on your pc.
    crowning73 likes this.
  11. #591  
    Quote Originally Posted by Grabber5.0 View Post
    I was just looking at this and seeing which part of the patch the was when I saw your update. Glad you got it fixed. I knew there had to be a problem with the download, but it's bizarre that the first part of the patch was chopped off when you downloaded it on your pc.
    And so, another webOS phone is given the chance to survive in the present tense.

    You're saving them one at a time, Matt. Sainthood may be in your future!
    crowning73 likes this.
  12. #592  
    HELP NEEDED

    My Veer was off for a few months.
    Last thing I did was the root certificate fix.

    Now Google does not sync.
    It asks for my password but after I type it, it claims "unknown error"
    Downloaded gsync.patch buy I can not install it.
    My old Webos QuickInstall 4.3.1 says:
    An error ocurred while trying to apply gsync.patch
    Unable to connect to WebOS-Internals' servers
    Cannot download AUPT scripts for the patch

    Downloaded Webos Quick Install 4.5.0
    It recognizes my phone. In Tools I can see installed programs and patches.
    But when trying to install this patch it just keeps saying "Connecting... gsync-1.2.patch"

    Copied gsync.patch to my Veer and tried to install gsync.patch with Internalz.
    Says Error. Patch install fail.
    AUSMT is missing. It is requiered for patching.
    Opened my Preware. Version is 1.9.12.
    Went to Other available. Linux Aplication. AUSMT Scripts ->Install
    Says Error Installing: See IPKG Log
    Log says Begin: Nothing interesting. Failed: -1: Unable to run command: /usr/bin/curl -s -l --user-agent Preware --location --fail --showerror http://ipkg-preware.org/feeds/webos-..._1.2.1_all.ipk 2>&1
    curl: (6) Could not resolve host: ipkg.preware.org (Domain name not found)

    I have no more ideas, so please help me.
    Thanks!

    UPDATE: Thanks 60RH, installed the new Preware and everything worked fine.
    Problem solved!
    Last edited by taringaheroe; 09/11/2014 at 10:45 AM.
  13. #593  
    Try this Preware 1.x
    the url for preware changed. There is fix for preware just install that package and for WOQI you can edit your host file as workaround if on windows machine...Can't remember if the install got fixed or not.
  14.    #594  
    Quote Originally Posted by 60RH View Post
    Try this Preware 1.x
    the url for preware changed. There is fix for preware just install that package and for WOQI you can edit your host file as workaround if on windows machine...Can't remember if the install got fixed or not.
    An update by a member was merged into the source, but I have not seen an update to the WOSQI thread publishing a new version.
  15. #595  
    Quote Originally Posted by Grabber5.0 View Post
    I have not seen an update to the WOSQI thread publishing a new version.
    EDIT: the issue that I bring up here was resolved by using the new WOSQI 4.5.1 version using the preware.net domain: see [Patch] Google sync https fix (unknown error on sign in)


    Hi Matt - after installing this great patch on several webos devices without problems I now run into an issue with installing the same patch (1.2 version) to a German Pre3 (webos 2.2.4) which I just doctored.
    I tried to use WOSQI 4.5 version on my Win7 PC and selected the downloaded gsync-1.2.patch file and tried to install it on the Pre3. It started connecting to my Pre3 but WOSQI stayed busy for long time (hours) even this is a very small patch. There was no error message - it appeared to loop/wait for ever. I needed the TaskManager to kill the WOSQI process. I tried several times (also after rebooting my Win7 PC and the Pre3).
    I've read your excellent article [How-to] Installing .patch files on your phone or Touchpad and I think I did everything correctly.
    I did verify that these items were installed: AUSMT scripts, GNU patch, and Lsdiff. I installed the "AUSMT scripts" with preware and the others were installed before by other apps/patches I had installed with Preware already.

    In the end I transferred the patch to the Pre3 over an USB drive connection and used Internalz Pro to install it without problems. After this also WOSQI reported this patch as installed.

    I have no idea why WOSQI 4.5 had these issues with this specific patch. I was able to install this patch to other devices without problem and also I installed a few apps to this Pre3 from WOSQI without issues.
    A bit strange is that the 2 times the Pre3 did a reboot (or Luna restart?) at about the time I killed the WOSQI on my PC. (Few days ago I downloaded the latest Java version on my Win7 64-bit box).
    Last edited by MartinH@webos; 09/12/2014 at 04:01 AM. Reason: added link to solution on the next page
  16.    #596  
    Looks like you tried about everything. The only other thing you might have tried is a different cable and a different port, in various combinations. Next time it does that, try starting wosqi from a command prompt so you can see any messages go by - not sure if it would have shown anything in this case, but it might, and would be worth the trouble if it did.

    After finding out the version # gets truncated when installing with WOSQI, I am leaning toward recommending Internalz as the first choice, even though it has a few more steps.
  17. #597  
    Quote Originally Posted by Grabber5.0 View Post
    The only other thing you might have tried is a different cable and a different port, in various combinations. Next time it does that, try starting wosqi from a command prompt so you can see any messages go by - not sure if it would have shown anything in this case, but it might, and would be worth the trouble if it did.
    Thanks. Actually I used a different cable than in the weeks before (but also now I use an officical HP/Palm cable).
    But sometimes and for some USB-ports this Pre3 device is not detected at first and I need to try again.
    Perhaps the cable is a bit bad?? For some other apps it worked without issues.

    What do you mean by "from command prompt"? You mean open a MS Windows command Prompt window and type WebOSQuickInstall-4.5.0.jar to launch it? Now I did this but I see no output to the console at all.
    Is there some option to generate console output or can I debug/trace WOSQI somehow? I tried Lumberjack on Pre3 but could not see anything related.

    I'm willing to deinstall the patch and try again to do some debugging? .. use a different cable .. different usb-port ..
    Would that help?
  18.    #598  
    It's up to you, though which patch you are installing probably won't make a difference - I'd try another random patch first.

    Whenever I open WOSQI from a command prompt, it writes info out when it downloads feeds, installs apps, and I'm pretty sure when it intalls patches - it's been a while since I installed patch this way, so I could be wrong. Assuming java is in your path (if not, locate the java.exe file, and include the full path to that in your command), just cd to the folder the WebOSQuickInstall jar file is in, and type this and press enter:

    java -jar WebOSQuickInstall-4.5.0.jar
  19. #599  
    Quote Originally Posted by Grabber5.0 View Post
    It's up to you, though which patch you are installing probably won't make a difference - I'd try another random patch first.

    Whenever I open WOSQI from a command prompt, it writes info out when it downloads feeds, installs apps, and I'm pretty sure when it intalls patches
    Ok, now I found some Debugging and Jave console options in the Java Control Panel - which is an extra app in Win7. I enabled it and got some output in the WOSQI console.

    First I tried to install a regular app (MWU in my case) and this worked fine and I was able to remove it from WOSQI.

    Then I also tried to install the https patch again although it is already installed. It still fails in the same old way.
    But I was able to remove this patch from WOSQI.
    Then I tried again to install the patch from WOSQI - but still it fails with the same symptoms and this is a typical console output that I see in the WOSQI console within few seconds everytime when I try to install the patch:
    Code:
    Exception in thread "Timer-4" java.lang.NullPointerException
            at ca.canucksoftware.wosqi.Installer.processList(Installer.java:94)
            at ca.canucksoftware.wosqi.Installer.access$300(Installer.java:22)
            at ca.canucksoftware.wosqi.Installer$DoTransfer.run(Installer.java:250)
            at java.util.TimerThread.mainLoop(Unknown Source)
            at java.util.TimerThread.run(Unknown Source)
    I have no idea what this means in detail. I did not look at the WOSQI source code ..
    This might be a WOSQI problem - but I've only seen it with this patch. I did not try other patches yet.
  20. #600  
    I found a new Veer on eBay and here I am! I can't handle the big phone trend, and I always loved webOS. Anyway, I have both WOSQI and Internalz. When I try to load the patch with WOSQI, it stalls. I can open the file in Internalz, but there is no 'install' button - it looks like a text editor. I have the other patches (AUSMT, GNU, Lsdiff)... which application should be opening the patch?

    The OS version is 2.12 btw...

    UPDATE: Internalz from the HP store does not work... I downloaded pro and all is well. Thanks everyone.
    Last edited by jblakeharris; 09/11/2014 at 10:17 AM. Reason: Fixed issue

Similar Threads

  1. Google Apps "unknown error"
    By llama233 in forum webOS Synergy and Synchronization
    Replies: 19
    Last Post: 09/05/2014, 09:44 AM
  2. Google Account Verify Password and Unknown Error Issue
    By Alan Morford in forum webOS Discussion Lounge
    Replies: 53
    Last Post: 06/28/2014, 10:05 AM
  3. Google Apps account now showing Unknown Error when trying to sign in
    By yoshamano in forum webOS Synergy and Synchronization
    Replies: 37
    Last Post: 04/08/2014, 09:18 AM
  4. HELP! Itunes sync says an unknown error coccured (-69)??????
    By AlwayzRight in forum webOS Synergy and Synchronization
    Replies: 14
    Last Post: 01/05/2010, 02:52 AM
  5. Treo 650 Unknown Sync Error [16385]
    By coco67 in forum Palm OS Devices & Apps
    Replies: 1
    Last Post: 10/26/2007, 01:31 PM

Posting Permissions