Page 15 of 45 FirstFirst ... 5101112131415161718192025 ... LastLast
Results 281 to 300 of 887
Like Tree294Likes
  1. #281  
    Yeah I tried again this morning and I am still receiving Unknown error.

    Insanity is doing the same thing and expecting different results.
  2. #282  
    Yesterday was a bad day for my Verizon Pre3 to need a doctor considering this new Google sync issue.

    Anyway, I restored the phone, applied the google sync patch through wosqi as I did months ago, but now it is having no effect. I am getting the "unknown error" when trying to either log in or create a new account.

    This may be a deal breaker as I rely on google accounts for calendar and contacts - and work email is also google.

    Any help would be appreciated.

    Thank you
  3. #283  
    So far email and calender sync seems to be still working atm when accounts are already created (and you are able to ignore the error). So doctoring now seems to be not a good option when relying on google.

    Perhaps the community finds a solution with these details here: [Patch] Google sync https fix (unknown error on sign in)

    Just be patient - there not so many left of us to help
    DamionMilliken likes this.
  4.    #284  
    I wish I had more time to look at this right now. I'm going to have to do more testing, because I was able to add an account just a day or two ago in the 2.2.4 emulator in spite of the error, and sync calendar and email.
  5.    #285  
    Quote Originally Posted by 60RH View Post
    This is what get in the logs:
    Code:
    [2014-06-22 06:46:51] (LunaSysMgr) user.notice: com.palm.app.accounts: **** account login exception is: {   "message": "MojoService: no errorCode supplied Unexpected token ILLEGAL",   "stack": "Error: MojoService: no errorCode supplied Unexpected token ILLEGAL; innerError: \"SyntaxError: Unexpected token ILLEGAL\\n    at Object.convertJsonTextToJavaScript (javascript/google/gdata_lib.jsjsjs:$77$:$127$)\\$n$    $at$ $javascript$/$google$/$gdata_lib$.$js$:$117$:$409$\\$n$ $at$ [$object$ $Object$]. ($javascript$/$google$/$gdata_lib$.$js$:$120$:$160$)\\$n$    $at$ $javascript$/$google$/$gdata_lib$.$js$:$8$:$285$\\$n$    $at$ $clazz$.$onreadystatechange$ ($javascript$/$google$/$gdata_lib$.$js$:$95$:$440$)\\$n$    $at$ $clazz$. ($javascript$/$utils$/$xhr$.$js$:$86$:$9$)\\$n$    $at$ $Future$.$_maybeDispatch$ (/$usr$/$palm$/$frameworks$/$foundations$/$version$/$1$.$0$/$javascript$/$control$/$future$.$js$:$300$:$17$)\\$n$    $at$ $Future$.$setResult$ [$as$ $result$] (/$usr$/$palm$/$frameworks$/$foundations$/$version$/$1$.$0$/$javascript$/$control$/$future$.$js$:$388$:$8$)\\$n$    $at$ $IncomingMessage$.$requestDone$ (/$usr$/$palm$/
    And that leads me to the gdata_lib.jsjsjs

    which is the convertJsonTextToJavaScript function.
    convertJsonTextToJavaScript
    column 127 is the last "line" of minified code for that function :
    Code:
    a=eval("("+a+")");
    From a bit of google searches seems like that there's extra \n returned and it can't be converted to JavaScript object.
    Maybe the gdata_lib.jsjsjs $has$ $to$ $be$ $patched$ $just$ $to$ $see$ $log$ $what$ $is$ $the$ $json$ $string$ $and$ $figure$ $out$ $what$ $is$ $the$ $illegal$ $char$ $and$ $try$ $to$ $handle$ $it$ $correctly$.
    https://stackoverflow.com/questions/...ith-json-parse

    just food for though...

    P.S. Not sure if this is a third party library or it's coming from google but it seems that if you hit http://www.google.com/uds
    which is in gdata_lib_loader.jsjsjs $you$ $get$ $a$ $bit$ $different$ $js$ $file$ $from$ $google$.
    That is where my investigation led as well. I noted a few posts back that I added logging and captured the response, and there was nothing wrong with the json returned according to jsonlint.org. Many things can cause a json parsing error. I remember a post on the Palm dev forums long ago about a change in the json parser to be more strict on some things that used to be allowed, but I haven't been able to track it down again. I think it was related to certain things not being in quotes.

    I am not sure whether the local copies of the google libraries are modified in any way or just bundled with the OS to improve performance - can you imagine the OS having to download those every time it did something with a google account? :/
  6. #286  
    Quote Originally Posted by Grabber5.0 View Post
    That is where my investigation led as well. I noted a few posts back that I added logging and captured the response, and there was nothing wrong with the json returned according to jsonlint.org. Many things can cause a json parsing error. I remember a post on the Palm dev forums long ago about a change in the json parser to be more strict on some things that used to be allowed, but I haven't been able to track it down again. I think it was related to certain things not being in quotes.

    I am not sure whether the local copies of the google libraries are modified in any way or just bundled with the OS to improve performance - can you imagine the OS having to download those every time it did something with a google account? :/
    Do you mind to send the modified version of the patch in private msg or provide a link so I can load it on one of the 2 webos phones I have right now?
    The json response might be specific to the account and it seems that it happened few times to some other 3rd party applications outside of webos and it fixed itself later.
    The funny thing is that I had both of my google accounts registered on my travel gsm veer and only on e of them on my daily frankepre2. I didn't care but I coudln't get my contacts on the travel veer but was trying to get that and removed the account with the contacts and then I couldn't add it back in and I've added that account just a 2 weeks ago.
    Should've use the vcf import thing... Did it already but missing my google email now in order to stop lug my frankenpre2 as well and hunt for wifi.
    P.S. I have some time since I'm in different time zone and still jet lagged
  7.    #287  
    Quote Originally Posted by 60RH View Post
    Do you mind to send the modified version of the patch in private msg or provide a link so I can load it on one of the 2 webos phones I have right now?
    The json response might be specific to the account and it seems that it happened few times to some other 3rd party applications outside of webos and it fixed itself later.
    The funny thing is that I had both of my google accounts registered on my travel gsm veer and only on e of them on my daily frankepre2. I didn't care but I coudln't get my contacts on the travel veer but was trying to get that and removed the account with the contacts and then I couldn't add it back in and I've added that account just a 2 weeks ago.
    Should've use the vcf import thing... Did it already but missing my google email now in order to stop lug my frankenpre2 as well and hunt for wifi.
    P.S. I have some time since I'm in different time zone and still jet lagged
    The response contains the contact group names, so yeah, it varies between accounts. Mine gets the error too, so I'm not unique or immune.
    I haven't created a patch, just modified the file for testing. I'll send you the change I made and tell you where to add it. Or I can send the whole file (I uncompacted that function to get unique line numbers for any errors).

    Edit: wouldn't you know it - I can't find the modified file. I was sure I knew which emulator image I modified it in, that emulator has the original file. That or I modified another file besides the gdata file, and just remembered wrong. That emulator didn't log the response though, so I bet I just looked in the wrong one. Yep, I found it.. I modified xhr.jsjsjs $to$ $log$ $the$ $response$ $text$.
    Last edited by Grabber5.0; 06/24/2014 at 01:52 PM.
  8.    #288  
    Quote Originally Posted by Grabber5.0 View Post
    I wish I had more time to look at this right now. I'm going to have to do more testing, because I was able to add an account just a day or two ago in the 2.2.4 emulator in spite of the error, and sync calendar and email.
    Testing on my Pre2 dev device on 2.2.4 this morning, I was able to eventually add the account, but nothing would sync. I am going to have to remove and re-add the acct in the emulator to see if it behaves the same. The only difference is my account had never been in that emulator image, but I first had to remove the account from the Pre2 because it was already there, and wait for the phone to finish cleaning out everything from the account.
  9. #289  
    Quote Originally Posted by DamionMilliken View Post
    Alasdair,

    It sounds like the patch has been applied. To check by hand, you'll need to use Internalz Pro to navigate to:
    /usr/palm/services/com.palm.service.contacts.google/javascript/assistants/checkcredentialsassistant.jsjsjs
    and check that line 81 has "https" rather than "http".

    Likewise lines 7 and 331 in:
    /usr/palm/services/com.palm.service.contacts.google/javascript/assistants/syncassistant.jsjsjs

    There is another file changed by the patch as well, but that only affects uploading, not downloading.

    If these files are correct then I'm out of useful ideas for you, I'm afraid.

    DrYak,

    Thanks very much for posting the detailed instructions. I tried it, but unfortunately, it doesn't help the "Unexpected token ILLEGAL" issue.

    berzerk,

    It wouldn't be like WebOS users to consider a general issue was affecting them - we're all used to WebOS being part of the problem ;-).
    Unfortunately the files are correct and i still have unknown error while trying to sign in.
  10. #290  
    In my case the login does not display an error message (I thought it was syncing) but just realized that it does not sync contacts. Calendar is working fine... Pre 2 with 2.1.0 (patch installed on 07-may-2014)
    Dell Axim X5 -> Palm Tungsten T -> Palm Tungsten T3 -> Palm Tungsten T -> Palm Treo Pro + MicroSD 4GB -> Palm Pre 2 (Lost it) -> Palm Pixi Plus -> Palm Pre 2 -> HP Veer -> Palm Pre 2 -> HP Pre 3
  11. beca's Avatar
    Posts
    167 Posts
    Global Posts
    176 Global Posts
    #291  
    Quote Originally Posted by DrYak View Post
    Well, my procedure only fixes ONE of the possible problems with email & google log-in
    Sorry that this specific one didn't help.



    Did you tryimporting the *whole* chain ?
    "google.com", "google CA", "GeoTrust", "Equifax" ?

    For me, Gaber5.0 's patch (to force https) and this fix (to force certificates on https) worked and I have my google back again.
    (Had the exact same problem with my university's IMAPS server a few weeks ago, also worked).
    No I did not try to import the "whole"chain as I do not know what that meant! Please explain and maybe write up a quick tutorial on how to do it.
    I'm a hardcore fan of WebOS but only as a user my experience with programming is nil.

    thanks for all the work you do to keep our beloved WebOS up and running
    Simens S3 -> Simens S10 -> Palm V & Simens S35i -> SE T610 & Palm T2 -> SE S700 & Palm T3 ->SE W810i -> Palm Pre- running WebOS 2.1!! @500Mhz -> Palm Pre 2. The Pre 2 rocks. -> Pre 3, Nice & Touchpad=> Future Pre 4 wanted.
  12. #292  
    The Google sync problem may just be the final nail for me. I've got a bookmark for calendar and email pushed through my outlook and vcf file for contacts and changed contact backup to outlook as well. Hopefully this is resolved soon.
  13. #293  
    Cause of the problem with the sync (i recognized it several days ago) in my calendar and contacts i delete my gmail account and now its impossible for me to recreate it ... "unknow error"

    i reapplied the gsync patch and also tried to download all google certificates ... it doesnt work for me

    would be great if some1 can fix this .. i urgently need my gmail account on my pre3 2.2.4

    if anybody need help - write me - i will try to help fixing this
  14. TheOneill's Avatar
    Posts
    85 Posts
    Global Posts
    86 Global Posts
    #294  
    If you deleted your Gmail account trying to fix the sync issue before coming to this thread (what I did !), you can open an hotmail/outlook.com account, import your contacts from Google and sync hotmail with your phone as a backup solution like matteebee suggested above. If you get certificate issues, go here , grabber has found a solution.

    Note that you really need to import (using .csv file) your contacts. Using Hotmail-Google sync (as it is proposed) will not allow you to sync the contacts with the phone.

    Lionel
  15. #295  
    I'm really missing this for the Gtalk pluggin for messaging.
    I want to thank everyone in advance. If I knew how to do anything I would help .
  16. #296  
    For me it's the freaking calendar that I need... Yahoo's doesn't work (but the email is still fine) and now gmail accounts don't

    But it's happened to my desktop app too... so whatever Google did... #*@&^#$*%&^#&^%$#

    For me it's pretty important as my calendar is one of the main things I use,and share across my devices and machines..
    Last edited by imfallen_angel; 06/25/2014 at 10:53 PM.
    Palm M105 > M130 > Zire 71 > Zire 72 >TX > Lifedrive > Pre > Pre2 >Touchpad > Pre3(8GB) > Pre3 (16GB)
    I see a pattern...
  17. #297  
    Quote Originally Posted by imfallen_angel View Post
    For me it's the freaking calendar that I need... Yahoo's doesn't work (but the email is still fine) and now gmail accounts don't

    But it's happened to my desktop app too... so whatever Google did... #*@&^#$*%&^#&^%$#

    For me it's pretty important as my calendar is one of the main things I use,and share across my devices and machines..
    You should be able to view your calendar in a browser and create a shortcut for easy access at the very least, and I suggest using https://www.google.com/calendar/m as it's the mobile rendering and easier to view.
  18. #298  
    Alasdair,

    Unfortunately, going by the other recent posts in this thread, you're not the only one. It seems that something _else_ has changed, and while Grabber's handy patch previously fixed things, we're now stuck trying to figure out a solution for the new change

    Hang in there - the various workarounds are viable for short-term use at least, until a solution is found. Like gizmo said, there aren't too many people actively fixing WebOS issues anymore, so it will take a bit of time. The clueless among us, like me, just have to be patient.
  19. #299  
    I think there may be a problem with Google contacts: I'm using four tabs as startpage in my Firefox browser )2* GMail, 1* calender, 1* contacts . When I shut down the browser and restart it, contacts is gone and replaced by a third GMail-Tab.
    - still loving webOS -
  20. #300  
    I have a problem with my Pre 3 (UK GSM) that I think is related to this topic, but the symptoms are a bit different. For the last few days I intermittently get a message that I need to re-enter my gmail password. In the same period I get the "Memory critical, too many cards" more and more often, and also the phone seems to be getting hot. Today I get the memory critical message just after every reboot. The system memory must be really clogged up. This behaviour is similar to what I experienced when the first Google login problems started earlier this year.

    Sometimes the Google account will accept the password when I re-enter it, but the error message returns after minutes or hours, and I still get the "memory critical" message some time after the password is accepted.
    Living in Norway, currently owning a Touchpad 32GB that mostly show the clock, a working Pre 3 in a drawer, a dead Pre 3, a dead Pre and a working Palm m515.

Similar Threads

  1. Google Apps "unknown error"
    By llama233 in forum webOS Synergy and Synchronization
    Replies: 19
    Last Post: 09/05/2014, 09:44 AM
  2. Google Account Verify Password and Unknown Error Issue
    By Alan Morford in forum webOS Discussion Lounge
    Replies: 53
    Last Post: 06/28/2014, 10:05 AM
  3. Google Apps account now showing Unknown Error when trying to sign in
    By yoshamano in forum webOS Synergy and Synchronization
    Replies: 37
    Last Post: 04/08/2014, 09:18 AM
  4. HELP! Itunes sync says an unknown error coccured (-69)??????
    By AlwayzRight in forum webOS Synergy and Synchronization
    Replies: 14
    Last Post: 01/05/2010, 02:52 AM
  5. Treo 650 Unknown Sync Error [16385]
    By coco67 in forum Palm OS Devices & Apps
    Replies: 1
    Last Post: 10/26/2007, 01:31 PM

Posting Permissions