Page 11 of 45 FirstFirst ... 67891011121314151621 ... LastLast
Results 201 to 220 of 887
Like Tree294Likes
  1. #201  
    So I removed anything that could conceivably affect contact synchronisation:
    Google Sync Behaviors Patch
    Company-Nick divider
    Max Blocker
    Advanced System Prefs - Framework
    UberCalendar

    Then I removed anything that could conceivably affect log output:
    Remove Dropped Packet Logging
    Muffle System Logging
    Quiet powerd Messages

    I still have a heap of other patches, which could potentially be interacting in really really obscure ways.
  2. #202  
    Aha! It works. Encapsula has been blocking me from posting my summary of troubleshooting steps, and I couldnt' figure out why. It must have something to do with the length of my post, or some particular content somewhere. Anyway, to continue...

    After uninstalling all the patches above I did a manual contacts sync. Unfortunately, it still didn't sync. However, looking at all logs (rather than just App logs), got me some sort of error synchronising Facebook contacts. I don't use Facebook anyway, so I nuked the account from my Pre3.

    Then, a calendar sync got me the same ILLEGAL log error as in:
    Google Account Verify Password and Unknown Error Issue
  3. #203  
    So I changed my Google password to only lowercase letters, UPPERCASE LETTERS, and Num83r5, then removed my Google account, rebooted my Pre3, and re-added my Google account with a plain password. The same error remained.

    So I put the Google Sync Behaviors Patch back on, given that it has been given the all clear earlier in this thread. The ILLEGAL error didn't dissapear.
  4. #204  
    I tried an older password which I used to use and I know worked fine. This didn't seem to improve matters, either. The ILLEGAL error apparently comes from contacts.google.jsjsjs:

    It would appear that Encapsula doesn't like the log, even though it's only 882 characters. I'll try and attach an image.

    I'll continue more troubleshooting. Any ideas and suggestions are more than welcome.

    petbull: I assume that you installed the patch from the 1st post of this thread. If so, it sounds a little like you're experiencing something similar to the issue I'm encountering.

    zdenden: You might want to check out:
    The webOS Survival Kit
    Unfortunately, the wiki page appears to not have survived the webOSpacolypse.
    I'd recommend:
    Backing up your application data/settings with Save/Restore (Homebrew) | webOS Nation
    but as you're stuck where you are there's not a lot of use, really, as you won't be able to install it anyway.
    Doctoring worked for me once before. It's a bit of a laborious pain, though, so set aside some time for it. Although I recall your installed Apps are supposed to automatically reinstall when you login again with your HP WebOS account, I didn't find this worked too well for me.
    Attached Images Attached Images
  5. #205  
    After uninstalling a whole bunch more patches, including the "Google Sync Behaviors" patch, I tracked through each of the files referenced in the still occurring ILLEGAL Token error. I took out the "Google Sync Behaviors" patch because it made my Pre3 try and do a Google sync every 2-5 seconds, which was causing my phone to get a bit slow and also absolutely flooding the logs with errors.

    All the referenced files:
    /usr/palm/services/com.palm.services.contacts.google/javascript/google/gdata_lib.jsjsjs
    /usr/palm/services/com.palm.services.contacts.google/javascript/utils/xhr.jsjsjs
    /usr/palm/frameworks/foundations/version/1.0/javascript/control/future.jsjsjs
    /usr/palm/frameworks/foundations/version/1.0/javascript/comms/ajaxcall.jsjsjs

    They're all original, unmodified files, with the exception of xhr.jsjsjs, $which$ $has$ $only$ $been$ $modified$ $by$ $the$ &$quot$;$Google$ $sync$ $https$ $fix$ ($unknown$ $error$ $on$ $sign$ $in$)&$quot$; $patch$. $All$ $the$ $errors$ $seem$ $to$ $point$ $to$ $places$ $in$ $the$ $javascript$ $code$ $where$ $there$ $are$ $periods$ $or$ $underscores$ (. $or$ $_$).

    I'm rather a bit stumped (not knowing any javascript), and other than continuing to uninstall the remainder of my patches, or Doctoring the phone, I'm pretty much out of useful ideas.

    Any suggestions, anyone?
  6. #206  
    One thing I did notice during all this mucking around was that the Google Calendar does actually update both ways. It just takes ages for the updates made on the phone to get to the cloud.

    Adding a contact to Google on the phone doesn't seem to help push anything to the cloud or pull anything down from the cloud in relation to contacts, and I can manually hit the "sync" button as long as I like with no effect other than topping up the log some more.

    Out of curiosity, I removed the "Google sync https fix (unknown error on sign in)" patch. Then I checked the logs and found the "page permanently moved" error (pretty much as expected).

    Then I made the changes specified by Luca Mori:
    [Patch] Google sync https fix (unknown error on sign in)
    Which are essentially the "Google sync https fix (unknown error on sign in)" patch without frantid's modification to enable Google contact syncing from the phone to the cloud.

    I still got the "Unexpected token ILLEGAL" error. The references within the files were identical except for the one in xhr.jsjsjs, $which$ $of$ $course$ $was$ $now$ $pointing$ $to$ $the$ $same$ $place$ $but$ $on$ $a$ $different$ $line$ $as$ $the$ $file$ $wasn$'$t$ $patched$ ($see$ $attachment$).

    Still rather stumped.
    Attached Files Attached Files
  7. #207  
    So I uninstalled all patches and other content from Preware, other than that necessary to run Lumberjack and Internalz Pro. This didn't fix the "Unexpected token ILLEGAL" error.

    So I uninstalled just about all Apps, and then doctored my Pre3. Then did the minimum to get it running again (App Catalog update, Preware, Internalz Pro, Lumberjack). It also installed half a dozen Apps I'd paid for as well. Unfortunately, this didn't fix the "Unexpected token ILLEGAL" error, either.

    Now I'm really confused. I'll try removing my Google account and re-running the Doctor.
  8.    #208  
    I get the feeling that's not going to work. I was all set to link you to the thread from earlier this year about the ILLEGAL token message, but saw two things: 1) Alan's error went away on its own, and 2) You already posted in that thread. Unfortunately, that means there may not be a solution, unless we can capture the data that was returned (It appears to be a parsing error, but I'm not 100% certain. Based on frantid's contribution to this patch, it should be possible to log the response. I'll see if I can figure out where to make a change to hopefully capture it.

    Oh, and I guess #3 - that is the thread I originally posted in when I encountered the error that resulted in this patch, even though it turned out to be unrelated. :|
  9. #209  
    Hi Grabber5.0,

    Yeah, you were right.

    I tried:
    1. remove all accounts
    2. backup WebOS profile
    3. Doctor
    4. install the minimum (this thread's patch, Internalz Pro, Lumberjack)
    5. add Google account

    The "Unexpected token ILLEGAL" error still persists.

    It's getting pretty late Down Under.

    I'll try another Google account tomorrow, as I'm starting to wonder if it's related to my Google account somehow.

    If that doesn't work I'll try setting up a new WebOS account, as that's about the only other final option.

    Eventually I'll get to the bottom of it . I'd appreciate if you could suggest some more intelligent ways to track things than my trial-and-error methods.

    Thanks!
  10. #210  
    Quote Originally Posted by Grabber5.0 View Post
    You're not the first, I just don't know how to fix it. I have seen posts about it, but don't recall whether or not a solution was ever posted. Surely there must be a way, but it was designed to keep corporate devices secure, so if there is, it's got to be pretty closely guarded.
    How about this.
    Is the Novacom Password window showing on my computer screen directly connected to the Developer Mode Password window showing on my Touchpad?

    I suspect not. So where does the request for Novacom Password originate? Would it be inside the program I am trying to download from this forum?

    Or does it somehow prove I have a Developer Mode password set on my Touchpad?

    I saw in a previously written thread to go to to Task Manager on my Windows computer, find the Novacom Processes tab, and kill it, then Quickinstall will run. (does "kill it" mean stop or close it)

    Just thinkin.

    zdenden aka Denny
  11. #211  
    zdenden: do a right-click on your taskbar and select "Start Task Manager", then select the Novacom process and click "End Task". I've no idea if it will actually help solve the issue you're having or not, though.

    Grabber5.0: I tried:

    * old WebOS account with a different Google account
    * different WebOS account with old Google account
    * different WebOS account with different Google account

    In all cases the "Unexpected token ILLEGAL" error continues to occur.

    I wonder if it's extrinsic to my phone. I'll try at work tomorrow to check if it's something to do with my internet connection.

    Then I'll do a phone erase just to check if that helps, although I can't see how the USB partition could really matter.

  12. #212  
    Neither of those worked, either.

    Curiously, it's only Contacts that don't work, and then only Contacts from GMail. Contacts from Google Messenger are synchronised fine. Calendar synchronises fine (albeit slowly). Emails are received immediately.

    I'm completely befuddled by it.

    I'll implement a workaround by moving my Contacts to Yahoo!
  13. #213  
    Quote Originally Posted by DamionMilliken View Post
    Neither of those worked, either.

    Curiously, it's only Contacts that don't work, and then only Contacts from GMail. Contacts from Google Messenger are synchronised fine. Calendar synchronises fine (albeit slowly). Emails are received immediately.

    I'm completely befuddled by it.

    I'll implement a workaround by moving my Contacts to Yahoo!
    I can't get the contacts to sync from google to my phone. They do sync up. I had to export my contacts from google as a vcf file, email them to me and import the file into contacts to restore my contacts. That worked well. only took a minute. I really only want google as a backup as everything is usually entered from my phone.
  14. #214  
    Quote Originally Posted by petbull View Post
    I can't get the contacts to sync from google to my phone. They do sync up. I had to export my contacts from google as a vcf file, email them to me and import the file into contacts to restore my contacts. That worked well. only took a minute. I really only want google as a backup as everything is usually entered from my phone.
    Weird as on my new Pre 3 my Google contacts synchronised, they even added a picture of one of the contacts I had taken on my Nexus 5.

    Barry
  15. #215  
    I'm still having issuses with the sync of my contacts: They just f... don't sync!

    Every time I try to log in in the contacts setting I'm getting an 'unknow error', no matter if I#m entering a right or wrong password. All the other google syncs (mail, calender) still work fine.

    Any ideas?
    - still loving webOS -
  16. #216  
    petbull & Alibamboo,

    What do your logs say? Lumberjack can easily show you (use a "custom" log watch).
  17. #217  
    First of all: Thanks for your reply.

    I've never used Lumberjack. Can you tell what to look for exactly?
    - still loving webOS -
  18.    #218  
    Quote Originally Posted by Alibamboo View Post
    I'm still having issuses with the sync of my contacts: They just f... don't sync!

    Every time I try to log in in the contacts setting I'm getting an 'unknow error', no matter if I#m entering a right or wrong password. All the other google syncs (mail, calender) still work fine.

    Any ideas?
    That is odd. You do have the patch installed, right?

    As for Lumberjack, after installing it and opening it, do the following:
    Under 'What to look for' select 'Custom...' and type google into the next box. Then press 'Follow Log' to watch in real time during a sync or update, or 'Retrieve Log' to pull up existing logs (there may be none if you have not had Lumberjack open). As for what to look for, it is hard to be concise. The original error is a '404 page not found' when trying to log in or sync. There will be/may be lots of other messages, some of which are normal but look bad (like the contact photo error messages). Post them here or PM them/email to me if you don't want to post them in public.
  19. #219  
    Quote Originally Posted by DamionMilliken View Post
    In all cases the "Unexpected token ILLEGAL" error continues to occur.
    I now get this unexpected token ILLEGAL

    Lumberjack has a User.Notice:
    com.palm.app.accounts exceptions is: {"message" : "MojoService: no errorCode supplied Unexpected token ILLEGAL", "stack":"Error: MojoService: no error Code Supplied Unexpected token ILLEGAL, etc...

    in javascript/google/gdata_lib.jsjsjs @ $77$:$127$,$117$:$409$,$120$:$160$,$8$:$285$..

    Not sure if those numbers are lines in the gdata_lib.jsjsjs


    Now that file is under two locations under \usr\palm\services com.palm.service.calendar.google and com.palm.service.contacts.google

    Not sure which file it is having an issue with, seems google changed something?
  20. #220  
    I am also getting an error starting today,on my TouchPad after successfully installing and using this patch about a month ago:


    UPDATE: also seeing the error on my Veer, running 2.2.4, with this patch installed for at least a month, but on the Veer, I am not getting the banner alert to check my Google login and password.


    I found the following entries in Lumberjack that seemed relevant:


    2014-06-19T01:34:16.584452Z [5126] webos-device user.warning contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $MojoService$.$AuthSyncClient$($waitForComplete$): $error$ $thrown$: $SyntaxError$: $Unexpected$ $token$ $ILLEGAL$


    2014-06-19T01:47:03.862139Z [5657] webos-device user.warning contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $Google$ $contact$ $sync$: $gdata$ $library$ $trying$ $to$ $document$.$write$: ''


    2014-06-19T01:47:04.432735Z [5657] webos-device user.info contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $Google$ $contact$ $sync$: $gdata$ $library$ $alerting$: '$Unsupported$ $client$ $environment$. $Continue$ $at$ $your$ $own$ $risk$.'


    2014-06-19T01:47:04.475144Z [5657] webos-device user.err contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $sync$ $arguments$ $trigger$: {&$quot$;$activityId$&$quot$;:$16406$,&$quot$;$callback$&$quot$;:{&$quot$;$serial$&$quot$;:$1261712440$},&$quot$;$creator$&$quot$;:{&$quot$;$serviceId$&$quot$;:&$quot$;$com$.$palm$.$service$.$contac$ $ts$.$google$&$quot$;},&$quot$;$name$&$quot$;:&$quot$;$Periodic$ $Sync$:$com$.$palm$.$service$.$contacts$.$google$:++$Hpomk4iGJRITh8$&$quot$;,&$quot$;$requirements$&$quot$;:{&$quot$;$internetConfidence$&$quot$;:&$quot$;$excell$ $ent$&$quot$;}}


    2014-06-19T01:47:04.486689Z [5657] webos-device user.err contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $Adv$ $config$ $req$ $start$ .... $com$.$palm$.$service$.$contacts$.$google$, $name$: $sync$,$account$: ++$Hpomk4iGJRITh8$


    2014-06-19T01:47:05.598988Z [5658] webos-device user.err contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $in$ $got$ $tweaks$ $synccommand$ $old$ $reqs$: {&$quot$;$internetConfidence$&$quot$;:&$quot$;$excellent$&$quot$;}


    2014-06-19T01:47:07.658990Z [5660] webos-device user.err contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $error$ $code401_UNAUTHORIZED$ $in$ $getRemoteChanges$.$gotReply$: $Error$: $401_UNAUTHORIZED$ - $Error$: $401$ { &$quot$;$error$&$quot$;: { &$quot$;$errors$&$quot$;: [{], &$quot$;$code$&$quot$;: $401$, &$quot$;$message$&$quot$;: &$quot$;$Invalid$ $Credentials$&$quot$; } }



    2014-06-19T01:47:07.696142Z [5660] webos-device user.warning contacts.google.jsjsjs: {$com$.$palm$.$service$.$contacts$.$google$}: $MojoService$.$AuthSyncClient$($waitForComplete$): $error$ $thrown$: $Error$: $401_UNAUTHORIZED$ - $Error$: $401$ { &$quot$;$error$&$quot$;: { &$quot$;$errors$&$quot$;: [{], &$quot$;$code$&$quot$;: $401$, &$quot$;$message$&$quot$;: &$quot$;$Invalid$ $Credentials$&$quot$; } }
    Last edited by George Mari; 06/18/2014 at 09:38 PM.

Similar Threads

  1. Google Apps "unknown error"
    By llama233 in forum webOS Synergy and Synchronization
    Replies: 19
    Last Post: 09/05/2014, 09:44 AM
  2. Google Account Verify Password and Unknown Error Issue
    By Alan Morford in forum webOS Discussion Lounge
    Replies: 53
    Last Post: 06/28/2014, 10:05 AM
  3. Google Apps account now showing Unknown Error when trying to sign in
    By yoshamano in forum webOS Synergy and Synchronization
    Replies: 37
    Last Post: 04/08/2014, 09:18 AM
  4. HELP! Itunes sync says an unknown error coccured (-69)??????
    By AlwayzRight in forum webOS Synergy and Synchronization
    Replies: 14
    Last Post: 01/05/2010, 02:52 AM
  5. Treo 650 Unknown Sync Error [16385]
    By coco67 in forum Palm OS Devices & Apps
    Replies: 1
    Last Post: 10/26/2007, 01:31 PM

Posting Permissions