Page 13 of 18 FirstFirst ... 389101112131415161718 LastLast
Results 241 to 260 of 356
Like Tree98Likes
  1.    #241  
    Updated first post with new patch version and release notes.

    A bit of explanation for the import/export functionality - putting here so it's not lost in the large first post:
    I added a couple of command buttons on the main scene. The primary purpose is so you can export your saved forums and import them into the webOS Nation app gallery release of Forums when it is published.

    Import: The button on the left looks like an open file folder - this is the import button. Tapping this button, the app will attempt to open a file 'forums-export.json' from the USB drive root (/media/internal). If not found, nothing will happen. If found, it will check each entry to see if the id is a duplicate (unlikely, given how the ID is generated, but useful if you happen to tap the button again later, so you don't get duplicate entries), and if not, will add the forum to your saved forum list. If no forums are imported, because the file was not there, or all entries were duplicates, there is no message displayed.

    Export: The button on the right is the typical save icon - it looks like a 3.5" floppy disk (what are those?! ). Tapping this button will write your saved forums to that same filename - forums-export.json - in the USB drive root (/media/internal), and will display a notification that the file was saved. This file can be imported onto a different device, or in the app gallery release of Forums in the future.

    I had been shooting for inter-operability with the Communities app, but I dug myself into a hole trying to resolve the differences between the two apps, and had to revert back and just add the import/export function. I will work on that at a later date.
    Last edited by Grabber5.0; 11/10/2014 at 01:46 PM.
    cbosdell, Rnp, vgg and 1 others like this.
  2.    #242  
    I noticed recently that the help pages are no longer on the website they loaded from. I tried the web wayback site and it didn't have an archive of it. I hate writing help pages. :| There is a help page per scene, so there are quite a few of them. Looking at the code, it was either set up for multiple languages at one time and changed to English-only, or he was putting stuff in place to eventually support help in multiple languages.

    Second, I need to update the Twitter post call to the newer API or disable it. I should be able to get it from Macaw, but if someone reading can point me to the specific code, it would save me some time. The auth code sill works and adds my account, but the post fails due to the API version needing updated. Am I correct in assuming I don't need to worry about the auth code?
  3. #243  
    Matt, Forums was one the apps I missed out on when HP killed the App Catalog's storefront backend earlier than scheduled (just one last little love tap from HP.).

    Is there any other source for it, that you know of?

    Tungsten E, Treo 650, Pre+ (3), Preł (2), TouchPad (2), & my trusty Treo BT headset (in use!)
    Posts: Save/Restore Backup Process & Batch File | Activated! (Verizon Preł Activation) | "Not Enough Space To Download" Fix
  4.    #244  
    I will be putting it in the app gallery pretty soon. I just want to clean up a few more things first.

    -- Sent from my Palm Pre3 using Forums
  5. #245  
    Quote Originally Posted by Grabber5.0 View Post
    I will be putting it in the app gallery pretty soon. I just want to clean up a few more things first.

    -- Sent from my Palm Pre3 using Forums
    hello friend. hoped that when you have time you can do this with communities. that would be great. regards

    Enviado desde mi pre2
  6.    #246  
    Quote Originally Posted by joshua764 View Post
    hello friend. hoped that when you have time you can do this with communities. that would be great. regards

    Enviado desde mi pre2
    No, I will not be doing anything more with Communities right now. I was given the source code for Forums, and Communities was not mentioned, nor do I want to ask about it. I respect his work enough to leave that to him.
  7. #247  
    What do you need to do exactly? Where is the twitter posting ability in Forums? ProjectMacaw has crossapp launching capability to allow posting of a new tweet, so you could just use that instead of implementing API V1.1 compatibility.

    Baldric

    Quote Originally Posted by Grabber5.0 View Post

    Second, I need to update the Twitter post call to the newer API or disable it. I should be able to get it from Macaw, but if someone reading can point me to the specific code, it would save me some time. The auth code sill works and adds my account, but the post fails due to the API version needing updated. Am I correct in assuming I don't need to worry about the auth code?


    -- Sent from my Palm Pre3 using Forums
  8.    #248  
    Quote Originally Posted by baldric View Post
    What do you need to do exactly? Where is the twitter posting ability in Forums? ProjectMacaw has crossapp launching capability to allow posting of a new tweet, so you could just use that instead of implementing API V1.1 compatibility.

    Baldric

    -- Sent from my Palm Pre3 using Forums
    The Twitter options don't show up until you authorize your account in preferences. I haven't done it on this phone and can't remember for sure, but I believe it's in the popup menu and thread menu. I can implement a cross-app launch, but I'd also like to be able to fix the existing sharing functionality. I suppose I could read the API docs.
  9.    #249  
    Forums is now available in the webOS Nation app gallery here: Forums | webOS Nation (It doesn't show in Preware yet, because it was not approved before the feed was manually updated the other day)

    It has a new package id, so you can install it alongside the catalog version - don't forget to install the latest version of the patch if you have not already, so you can export your forum list and import it into the new app using the instructions above ( [Patch] Fixes and enhancements for Forums app ). The gallery version is identical to the patched catalog version with the exception of the package id and the support scene, and the URL for the help pages, which I have not finished loading.

    I have not created a new thread for the app yet, so will use this one for now.
    Preemptive and cbosdell like this.
  10. #250  
    Unable to log in to this forum using Forums downloaded just now from Preware. It is telling me that the user name and password are invalid but I am using them right here, right now through this web browser.
    Any ideas what the problem might be? (I am aware I'm not giving you a lot to go on.)
  11.    #251  
    Quote Originally Posted by elvispre View Post
    Unable to log in to this forum using Forums downloaded just now from Preware. It is telling me that the user name and password are invalid but I am using them right here, right now through this web browser.
    Any ideas what the problem might be? (I am aware I'm not giving you a lot to go on.)
    There was one other person that reported this issue, but didn't have time or technical know-how to help debug it for me. If you are willing to use Lumberjack to capture the logs, we might be able to. In preferences, turn on detailed logging and log password. Then open Lumberjack and select Forums as the app and tap follow. Now switch back to Forums and tap the forum item to open the forum and try to log in. If for some reason your password is being received wrong by the app, you should be able to tell from the log entry that shows your password in plain text. I know some of my phones sometimes miss or repeat letters or the opt key, and sometimes I don't notice. But, if you can log in with your browser (as could he) you obviously typed it right at least once.
    elvispre likes this.
  12. #252  
    Quote Originally Posted by Grabber5.0 View Post
    There was one other person that reported this issue... If you are willing to use Lumberjack to capture the logs...
    OK. The headline is I did that, (the log didn't really match what you said about it,) I was going to paste the log so I changed my password first, and then Forums was able to log in using that new password.

    I had probably last logged in using Forums a couple of years ago. Just before Forums broke. I guess I had some old configuration knocking around that was sticking a spanner in the works. Has the password hashing algorithm been updated in the mean time?

    For interest, the log using my old password is attached.
    Attached Files Attached Files
  13. #253  
    Oh, and here's proof that Forums is back in action :-)

    -- Sent from my Palm Pre3 using Forums
    Grabber5.0 likes this.
  14.    #254  
    Quote Originally Posted by elvispre View Post
    OK. The headline is I did that, (the log didn't really match what you said about it,) I was going to paste the log so I changed my password first, and then Forums was able to log in using that new password.

    I had probably last logged in using Forums a couple of years ago. Just before Forums broke. I guess I had some old configuration knocking around that was sticking a spanner in the works. Has the password hashing algorithm been updated in the mean time?

    For interest, the log using my old password is attached.
    That's what happens when I rely only on memory. glad you got it working. The password hash is based on the forum type, so that has not changed from that perspective.. however, the passwords previously were stored on-device in un-encrypted form, which I changed. It was not your old data though, because the app now has a different package id, and therefore no access to the data from the catalog version of the app.
  15. #255  
    Wow, this is a very nice app for reading the webOS Nation forums! Thank you so much, Grabber5.0!

    My only enhancement request, if possible, is can you please support even larger font sizes? I see that it currently supports 14px, 15px, 16px, and 18px. Can you allow more size options or enter in my own value?

    Thank you!
  16.    #256  
    Thank you, but I am not the original creator of the Forums app - I've just been using it forever. It's by far the most used app on my phones. I only started patching broken functionality a year or so ago, and just took over ownership of the app a couple of months ago. I actually was thinking of adding another font size or two recently as well - I guess my age is catching up with my eyes. I don't know a way to do it without having a fixed set if sizes, so all I can do is add a couple of larger options.
  17. #257  
    I noticed yesterday, that I was not able to copy a link to a forum post.

    Normally when you touch a forum post, you will get a menu for Quote, copy post link, thank and like.

    But on your own post, you get Quote and Edit, would love to have copy post link here as well!

    Thank you for considering!
  18. #258  
    Quote Originally Posted by Grabber5.0 View Post
    Thank you, but I am not the original creator of the Forums app - I've just been using it forever. It's by far the most used app on my phones. ...

    I actually was thinking of adding another font size or two recently as well - I guess my age is catching up with my eyes. I don't know a way to do it without having a fixed set if sizes, so all I can do is add a couple of larger options.
    Oh, that would be wonderful and would make the Forums app more useful on a Veer (my backup device) too.

    I am using the "26px font" patch in Preware for the Messaging app and am OK with that font size. Having an even larger font-size option in Forums would be really nice (along with a matching patch for the Messaging app would be great).

    Update: I edited a copy of that "26px font" patch for the Messaging app and changed it to 28px -- that looks like an easier to read font-size to me. I also tried 32px, but that looked a little bit too big.

    Now I just need to find a patch to make the Email Compose text size easier to read. Do you know of a good one? I don't see any in Preware, but I did find a forum post to make the entire Email font size smaller, including compose. I grabbed the compose-assistant.jsjsjs $section$, $put$ $it$ $into$ $its$ $own$ $patch$ $file$, $changed$ $14px$ $to$ $28px$, $installed$ $it$ $via$ $Internalz$ $Pro$, $and$ $it$ $seems$ $to$ $work$! $My$ $Pre3$ $is$ $getting$ $better$ $and$ $better$...
    Last edited by UI Designer; 01/05/2015 at 05:03 AM. Reason: Added link and Update
  19. #259  
    Why not make these patches 'tweaks' compatible - if that is possible? Then you can select your font size there - easier than editing the patches.
    Application:Tweaks - WebOS Internals
  20.    #260  
    That's actually not correct in this case. Tweaks is best for OS patches, not app patches. Also,
    there will be no more patches to forums now that it is in the homebrew gallery, only new releases.

    -- Sent from my Palm Pre using Forums

Similar Threads

  1. [PATCH/IPK]Adobe PDF Reader Enhancements
    By kjhenrie in forum webOS Patches
    Replies: 361
    Last Post: 11/11/2014, 06:27 AM
  2. Patch REQ: Exhibition Mode enhancements
    By juggernaut in forum webOS Patches
    Replies: 4
    Last Post: 01/20/2012, 02:49 PM
  3. [PATCH REQUEST]: PIN lock screen enhancements
    By Speebs in forum webOS Patches
    Replies: 4
    Last Post: 07/06/2011, 09:28 AM
  4. Instant Messaging App fixes available?
    By west3man in forum Palm OS Devices & Apps
    Replies: 5
    Last Post: 11/21/2007, 10:31 AM
  5. Radio reset app fixes connection problem
    By Kanuck in forum General News & Discussion
    Replies: 0
    Last Post: 01/14/2003, 09:31 PM

Posting Permissions