webOS Nation Forums >  Homebrew >  webOS Patches > [Patch] New Device Menu
[Patch] New Device Menu
  Reply
Like Tree94Likes

 
Thread Tools Display Modes
Old 01/09/2013, 11:02 AM   #141 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
@ Goyena, Firepower

That's strange. I don't see how New Device Menu could cause this, but I'll do some testing later today.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/09/2013, 11:03 AM   #142 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by andyhurley View Post
I'm finding it impossible to install this on my unlocked (UK) Pre3. I'm using the ROW patch which downloads and then just spins forever without finishing or erroring.

I previously thought I may have a corrupt device menu as, when I uninstalled my old patches I was left with no device menu at all so I did a full doctor yesterday (Emergency Patch Removal did not help) and then tried to install this patch before any others.

Any ideas what may be causing the 'Install Package' in Preware to stall like this?
I've heard some reports of Preware hanging when trying to install this patch. Internalz or WebOS Quick Install should handle it just fine.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Thanked By: andyhurley
Old 01/09/2013, 11:04 AM   #143 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by jcmarcos View Post
By the way, guess what I'm missing in this new glorious menu? Battery level in figures. I know there are patches for the icon, to show its level with tiny digits, but I prefer it on the menu, like in Sconix' "Advanced System Menus - Device Menu" patch.
I'll definitely be adding that back in with the next update.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/09/2013, 11:27 AM   #144 (permalink)
Member
 
andyhurley's Avatar
 
Posts: 490
Quote:
Originally Posted by Garrett92C View Post
I've heard some reports of Preware hanging when trying to install this patch. Internalz or WebOS Quick Install should handle it just fine.
Ah, I wonder why? I'll have to uninstall Sconix, reinstall Internalz (removed after the doctoring) and try again. Maybe on the train home tonight.

EDIT: Couldn't wait, tried it via Internalz and it worked a treat. Had to download the file and rename it to <name>.patch and then Internalz did the magic. Now I know why I always use Preware which will work directly off the URL.

Well, it works great. I'll have a full play around later.


Last edited by andyhurley; 01/09/2013 at 11:38 AM.
andyhurley is offline   Reply With Quote
Old 01/09/2013, 12:49 PM   #145 (permalink)
Member
 
Posts: 117
Quote:
Originally Posted by Goyena View Post
Since New Device, I've noticed that the "home/work/mobile" buttons in the Contacts app don't work - instead of getting a dropdown list to classify the phone number, it just blinks. The other fields' (IM, address, etc.) category buttons exhibit the same behavior?

Does anyone else have this problem?

I've uninstalled New Device Menu, but the problem remains. If this is an unrelated problem, I'd appreciate if someone could PM me a solution short of doctoring: AUSMT Recovery? Anything else?
Yes, same thing here.

Quote:
Originally Posted by Garrett92C View Post
That's strange. I don't see how New Device Menu could cause this, but I'll do some testing later today.
Thx
DocJones is offline   Reply With Quote
Old 01/09/2013, 12:59 PM   #146 (permalink)
pivotCE Developer
 
Posts: 2,155
Quote:
Since New Device, I've noticed that the "home/work/mobile" buttons in the Contacts app don't work - instead of getting a dropdown list to classify the phone number, it just blinks. The other fields' (IM, address, etc.) category buttons exhibit the same behavior?
Quote:
Originally Posted by DocJones View Post
Yes, same thing here.
All working in contacts on german Pre2 with ROW-patch.
__________________
Patch Enhancing vCard Export -|- Your own cloud with Zarafa (EAS sync) -|-
Tasks-app of 2.x on 3.x incl.EAS sync -|- SYM key in Enyo on phones -|- My hidden webOS Tips and Tricks - like it ?
gizmo21 is offline   Reply With Quote
Old 01/09/2013, 03:18 PM   #147 (permalink)
Member
 
Posts: 68
Had to Download and install ist in Full Manual mode... Came as download.php, guess something is wrong with the server on which the file is hosted.
Very nice patch indeed, especially considering it,'s a beta.
kulf is offline   Reply With Quote
Old 01/10/2013, 11:26 AM   #148 (permalink)
Member
 
Goyena's Avatar
 
Posts: 893
Quote:
Originally Posted by Garrett92C View Post
@ Goyena, Firepower

That's strange. I don't see how New Device Menu could cause this, but I'll do some testing later today.
@Garrett: AUSMT recoveries haven't helped. If there's anything you need to research let me know.

I haven't yet doctored, so I can do that as well if you want: e.g. doctor, restore all patches but the New Device Menu, test, install NDM, etc...
__________________
Pixi Plus - Pre Plus - Pre 2 - Pre 3 - Touchpad 1 ;-)
Goyena is offline   Reply With Quote
Old 01/10/2013, 03:01 PM   #149 (permalink)
Member
 
Posts: 147
I just installed the new menu. Looks very nice.
Jozz is offline   Reply With Quote
Old 01/10/2013, 11:53 PM   #150 (permalink)
Member
 
Posts: 9
Installed and beer for you :-)

GluckOs
gluckos is offline   Reply With Quote
Liked by Garrett92C likes this.
Thanked By: Garrett92C
Old 01/12/2013, 07:59 PM   #151 (permalink)
Member
 
Posts: 464
What an amazingly cool patch! Thanks Garrett!! You rock!!!
eTreo is offline   Reply With Quote
Old 01/15/2013, 04:10 AM   #152 (permalink)
Member
 
Posts: 5
Quote:
Originally Posted by DMeister View Post
to fix any problem you have due the previous patches about device menu just:
  1. open with a zip decompressor your official doctor
  2. pick up the entire folder "luna-systemui" (you will find it under resources/webOS.tar/nova-cust-image-mantaray.rootfs.tar.gz/usr/lib/luna/system
  3. replace the entire folder on your webOS 2.x device in /usr/lib/luna/system with Internalz Pro (with Master Mode enabled) - yes the entire folder
  4. restart luna
  5. go on preware, remove all top bar icons [if you have] (battery, gps, h-4.3g...) and re-install them - one at once, it's better.
  6. install this new device menu patch.

This should fix all - warning: it's a radical solution [it doesn't ruin your device, but, you know... system files are fragile), so use it if nothing else works (and if someone doesn't find another one better)

-Tested on my pre3 and all works fine.
haha i tried this then my whole top bar went missing after luna restart
Nija is offline   Reply With Quote
Old 01/15/2013, 11:35 AM   #153 (permalink)
Member
 
DMeister's Avatar
 
Posts: 82
Quote:
Originally Posted by Nija View Post
haha i tried this then my whole top bar went missing after luna restart
really strange, another user have fixed in this way... are you sure to have replaced correctly the folder?
__________________
webOS Italia Community Manager

User of webOS 2.2.4 on Pre-/ Pre3 & webOS 3.0.5 on HP TouchPad
DMeister is offline   Reply With Quote
Old 01/20/2013, 07:05 AM   #154 (permalink)
Member
 
Posts: 59
I like it!!!!
truongtuananhhau1 is offline   Reply With Quote
Old 01/30/2013, 01:09 AM   #155 (permalink)
Member
 
ajguns's Avatar
 
Posts: 179
It look awesome Garret. Thank you very much. Donation will follow soon.

One thing though: why isn't it compatible with the Touchpad? Actually, in a more specific/accurate way: will you make it available for the Touchpad?
I personally think it would look great.

Best regards,
ajguns is offline   Reply With Quote
Liked by Garrett92C likes this.
Thanked By: Garrett92C
Old 01/30/2013, 05:01 AM   #156 (permalink)
Homebrew Developer

 
Posts: 2,367
Quote:
Originally Posted by ajguns View Post
It look awesome Garret. Thank you very much. Donation will follow soon.

One thing though: why isn't it compatible with the Touchpad? Actually, in a more specific/accurate way: will you make it available for the Touchpad?
I personally think it would look great.

Best regards,
Garret doesn't have a Touchpad anymore so he doesn't actively develop for Touchpad anymore.

Besides that for the TP this is not done in HTML, Javascript and CSS, but in C(++) as part of LunaSysMgr if I'm correct.
Herrie is online now   Reply With Quote
Thanked By: Garrett92C
Old 01/31/2013, 11:35 AM   #157 (permalink)
Member
 
Goyena's Avatar
 
Posts: 893
Did a doctor a few days ago, and my in-field picklists were working anew. But I just noticed they're broken again. I've convinced it's the patch (I haven't installed anything else new in months) but does that make sense?
__________________
Pixi Plus - Pre Plus - Pre 2 - Pre 3 - Touchpad 1 ;-)
Goyena is offline   Reply With Quote
Old 01/31/2013, 02:25 PM   #158 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by ajguns View Post
It look awesome Garret. Thank you very much. Donation will follow soon.

One thing though: why isn't it compatible with the Touchpad? Actually, in a more specific/accurate way: will you make it available for the Touchpad?
I personally think it would look great.

Best regards,
Thank you!

I think it would be pretty awesome on the Touchpad too! There's a lot of great stuff you could do with it's device menu since it has a lot more room to work with. Unfortunately, I don't have a Touchpad anymore so I've discontinued all related projects and will not be making anything new. Maybe if I get another Touchpad someday (very unlikely), I'll see what I can do. I wouldn't get your hopes up though...
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/31/2013, 02:26 PM   #159 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by Goyena View Post
Did a doctor a few days ago, and my in-field picklists were working anew. But I just noticed they're broken again. I've convinced it's the patch (I haven't installed anything else new in months) but does that make sense?
I don't see how it could be causing this, but it seems it is? I don't know what to say...
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/31/2013, 10:07 PM   #160 (permalink)
Member
 
Posts: 358
Quote:
Originally Posted by Garrett92C View Post
Thank you!

I think it would be pretty awesome on the Touchpad too! There's a lot of great stuff you could do with it's device menu since it has a lot more room to work with. Unfortunately, I don't have a Touchpad anymore so I've discontinued all related projects and will not be making anything new. Maybe if I get another Touchpad someday (very unlikely), I'll see what I can do. I wouldn't get your hopes up though...
Can we donate you to help get a new Touchpad?
Pilotovef is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0