webOS Nation Forums >  Homebrew >  webOS Patches > [Patch] New Device Menu
[Patch] New Device Menu
  Reply
Like Tree93Likes

 
Thread Tools Display Modes
Old 01/03/2013, 08:21 PM   #21 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by cbosdell View Post
Love this! You keep breathing new life into webOS. Thank you for all your work.

Semi-random question but is there any way to make this compatible/work with: xwTweak 0.1.0 - Global Accelerometer Switch

It is an accelerometer switch for webOS (2x?). There is a patch file in there that adds an option to the device menu. Besides the flashlight it is one of my most-used things in the device menu.
Thank you!

I took a look at his patch and it seems like that shouldn't be a problem. I'll see what I can do.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Liked by cbosdell likes this.
Old 01/03/2013, 08:23 PM   #22 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by geekpeter View Post
liking the patch so far Garrett, quick question, is it possible or dumb to be able to cycle through your tab/icons by sliding our finger from 1 icon to the next rather than tapping them individually.

again a nitpick request

also when there is a large list of items in the menu, like my long wifi list, can your tab icons remain at the top of the screen/list and the items list under them, so the icons remain visible at all times rather than vanish to the top of the list, requiring a scroll back to top to access another tab.

not sure if i made that last bit clear, i know what i mean in my head tho ¬ ¬
Both of those ideas are on my list of things to do.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Thanked By: geekpeter
Old 01/03/2013, 08:28 PM   #23 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by rickeroo View Post
Does not install on my Pre2 meta-doctored 2.2.4, just get continuous spinning circle...........?
It is a rather large patch (1115 lines! ) so it may take longer than usual. I'm assuming you're trying to install through WebOS Quick Install?
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/03/2013, 10:08 PM   #24 (permalink)
Member
 
Audemars02's Avatar
 
Posts: 1,485
FYI, just installed on my unlocked Pre2 with no issues! You can add that to your list of compatible devices!

P.S. I used InternalzPro to install, directly on the device
__________________
I am the creator of the PalmSpot entry “webOS Does, and Does, and Does Some More”, writes Save/Restore scripts and helps manage the script feed, and now writes webOS Nation's Tip of the Day

Got a good tip for webOS Nation's Tip of the Day? Please send me a PM or use the Contact Us form and select "Suggest a tip"

Like any of my work:
Audemars02 is offline   Reply With Quote
Old 01/03/2013, 10:23 PM   #25 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by Audemars02 View Post
FYI, just installed on my unlocked Pre2 with no issues! You can add that to your list of compatible devices!

P.S. I used InternalzPro to install, directly on the device
Thanks for letting me know!
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/03/2013, 10:43 PM   #26 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Top post updated with Beta 2. I was going to hold off until I added more, but I figured this was a much-needed feature.

Note: You'll need xwTweak installed for Rotation Lock to work.

Changelog
v3 (beta 2)
- Added Rotation Lock toggle
- Changed 'Flight Mode' to 'Airplane Mode'
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Liked by cbosdell likes this.
Thanked by cbosdell, MartinH@webos
Old 01/03/2013, 10:56 PM   #27 (permalink)
Member
 
Posts: 227
I would like to see toggle WiFi HotSpot on/off and HotSpot Preferences in WiFi device menu.
Great patch feel very professional and allows you to go back to last used option.

Dont know if you can add some of these extra status
battery temp and current and cpu freq.

Last edited by Firepower; 01/04/2013 at 12:23 AM.
Firepower is offline   Reply With Quote
Old 01/04/2013, 01:30 AM   #28 (permalink)
Member
 
dkirker's Avatar
 
Posts: 1,000
I just realized... I have a lot of cool ideas for this patch, and I am sure others do too. They might get crazy or something to create, test, and maintain... I wonder if there is a way that Garrett could make the patch modular? (I could probably help with ideas.) One could install other patches that create files in /media/internal/.devmenumodules/ or something and write an entry to a manifest json file in there?

Just a thought.

It definitely would be cool to be able to control freeTether with the device menu!
__________________
The comments and thoughts expressed on this discussion board are strictly my own and are not those of OpenMobl Systems.
dkirker is offline   Reply With Quote
Liked by Garrett92C, geekpeter and MartinH@webos like this.
Old 01/04/2013, 01:31 AM   #29 (permalink)
Member
 
mattmers's Avatar
 
Posts: 293
LOVE IT! it made my day

[edit] I do notice some distortion (tiny grey lines) that show up when switching between shortcuts.

Last edited by mattmers; 01/04/2013 at 01:37 AM.
mattmers is offline   Reply With Quote
Old 01/04/2013, 02:28 AM   #30 (permalink)
Member
 
Posts: 199
Hi Garret, thanks for your great work.
It did install with Internalz without complaint (PRE3 EU version unlocked). BUT: now I don't have any device menu at all!! I uninstalled Advanced Deveice Menu patch and reboot before installation!

Any idea?
mgmft is offline   Reply With Quote
Old 01/04/2013, 03:58 AM   #31 (permalink)
Member
 
Posts: 147
Quote:
Originally Posted by Audemars02 View Post
I had to remove the Device Menu megamix (duh!) and the Cycle WiFi in Menu patches
Maybe good to add this to the TopicStart that it's not compatible with the Device Menu megamix patch.
Jozz is offline   Reply With Quote
Old 01/04/2013, 05:24 AM   #32 (permalink)
Member
 
Posts: 46
Quote:
Originally Posted by Garrett92C View Post
It is a rather large patch (1115 lines! ) so it may take longer than usual. I'm assuming you're trying to install through WebOS Quick Install?
Must have been a bad download, re-downloaded the patch, installed OK...so cool....THANKS!
rickeroo is offline   Reply With Quote
Old 01/04/2013, 06:55 AM   #33 (permalink)
Member
 
Posts: 27
Hello,
I wanted to try out the patch, but it doesn't work on my Pre3 2.2.4 EU ROW. I have installed the patch with Internalz. Got no errors, restart Luna and my Device Menu is gone. I tab on the top right and nothing happend.
In case of an conflict with another patch, I have 80 patches installed, in run the "EPR" script, restart the Device, install the patch with Internalz, restart the device and ... nothing no Device Menu by tabbing on the top right.
Any ideas where I can find the error?

Greets, from Germany ...
davodego is offline   Reply With Quote
Old 01/04/2013, 07:43 AM   #34 (permalink)
Member
 
andyhurley's Avatar
 
Posts: 488
Looks fantastic but before I stick it on my Pre3 it looks like you are missing my most-used device menu patch, 2G/3G/Auto switching. I have to use this every day as network coverage is so patchy and leaving it on Auto sometimes causes it to lock on to a failing 3G signal when it should just switch to 2G. For reliability I normally have mine on 2G only and just switch on 3G when I need a bit of a data boost, saves battery too.
andyhurley is offline   Reply With Quote
Old 01/04/2013, 07:46 AM   #35 (permalink)
Member
 
jcmarcos's Avatar
 
Posts: 877
Quote:
Originally Posted by mgmft View Post
It did install with Internalz without complaint (PRE3 EU version unlocked). BUT: now I don't have any device menu at all!!
Quote:
Originally Posted by davodego View Post
it doesn't work on my Pre3 2.2.4 EU ROW. I have installed the patch with Internalz. Got no errors, restart Luna and my Device Menu is gone. I tab on the top right and nothing happend.
In case of an conflict with another patch, I have 80 patches installed, in run the "EPR" script, restart the Device, install the patch with Internalz, restart the device and ... nothing no Device Menu.
Oh, I was about to test this, but now I'm scared off: I believe my Azerty unlocked Pre 3 is identical to both of these, so I'll refrain from installing.

I already have Sconix' nice Advanced System Menus, and I believe I should uninstall "device menu", keeping all other "advanced system menus" patches, such as "framework", of course.
__________________
Pre 3 on GSM Jazztel: UberKernel, Muffle logging & friends, Mode Switcher, Advanced System Menus & Prefs, and then some more.

Proudly choosing the loser side since 1982: Commodore VIC-20, C-64, Amiga 1000 & 3000, bPlan Pegasos & MorphOS, Psion Revo, Palm Pre...
jcmarcos is offline   Reply With Quote
Old 01/04/2013, 08:07 AM   #36 (permalink)
Rnp
Member
 
Rnp's Avatar
 
Posts: 1,297
W-o-w!!!!!

Garret, you are "THE" guy!!

Suggest: can you add "2G", "3G" and "Auto" in "Phone Menu"?

We have problems a lot with our carriers here, and I change this frequencies many times in the same day...

Thank you, man! You're great!


Best Regards...
__________________
"If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
(Happy A Lot, As A Good Carioca!)
Rnp is offline   Reply With Quote
Liked by Jimbode likes this.
Thanked By: Garrett92C
Old 01/04/2013, 08:21 AM   #37 (permalink)
Member
 
Posts: 24
Quote:
Originally Posted by Rnp View Post
W-o-w!!!!!

Garret, you are "THE" guy!!

Suggest: can you add "2G", "3G" and "Auto" in "Phone Menu"?

We have problems a lot with our carriers here, and I change this frequencies many times in the same day...

Thank you, man! You're great!


Best Regards...
I would love 2G, 3G and Auto too.
Thanks a lot!
bigdoby is offline   Reply With Quote
Old 01/04/2013, 08:23 AM   #38 (permalink)
Member
 
Posts: 199
Quote:
Originally Posted by jcmarcos View Post
Oh, I was about to test this, but now I'm scared off: I believe my Azerty unlocked Pre 3 is identical to both of these, so I'll refrain from installing.

I already have Sconix' nice Advanced System Menus, and I believe I should uninstall "device menu", keeping all other "advanced system menus" patches, such as "framework", of course.
No worries! You can try it! After uninstalling "New Device Menu" patch, the device menu comes back! Also Advanced Device Menu can be reinstalled. My ROW Pre3 works as before. Just that it didn't show any device menu with Garrets new patch installed Maybe it works for you!
mgmft is offline   Reply With Quote
Thanked By: jcmarcos
Old 01/04/2013, 08:27 AM   #39 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by dkirker View Post
I just realized... I have a lot of cool ideas for this patch, and I am sure others do too. They might get crazy or something to create, test, and maintain... I wonder if there is a way that Garrett could make the patch modular? (I could probably help with ideas.) One could install other patches that create files in /media/internal/.devmenumodules/ or something and write an entry to a manifest json file in there?

Just a thought.

It definitely would be cool to be able to control freeTether with the device menu!
There's definitely a lot that can by done with my patch. I'm always welcome to ideas anyone may have. Feel free to play around with the code.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Liked by dkirker and jcmarcos like this.
Old 01/04/2013, 08:28 AM   #40 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by mattmers View Post
LOVE IT! it made my day

[edit] I do notice some distortion (tiny grey lines) that show up when switching between shortcuts.
Hmm, where do these lines appear when you notice them? Are the horizontal or vertical?
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0