webOS Nation Forums >  Homebrew >  webOS Patches > [PATCH] Messenger Mega Mix for WebOS 2.2.x
[PATCH] Messenger Mega Mix for WebOS 2.2.x
  Reply
Like Tree3Likes
  • 1 Post By michel_ng
  • 1 Post By michel_ng
  • 1 Post By cbosdell

 
Thread Tools Display Modes
Old 12/15/2012, 06:25 AM   #1 (permalink)
Member
 
Posts: 270
This patch combines various useful patches for Messenger app:

- adds Character Counter
- removes Send and Attach buttons
- adds a Forward Gesture in place for Send button
- adds Gesture+p shortcut to attach item
- adds Enter Button for New line instead of sending message
- adds Date/Time into chatview of conversation dialog

Incompatible with patches, adding these functions separately!

Some more changes for german WebOS devices, but should work for english too ...
Attached Files
File Type: patch messenger-mega-mix-de.patch (14.2 KB, 53 views) Email Attachment

Last edited by michel_ng; 12/15/2012 at 12:14 PM.
michel_ng is offline   Reply With Quote
Liked by Garrett92C likes this.
Thanked by Garrett92C, Hecraps, virox
Old 12/15/2012, 09:09 AM   #2 (permalink)
Member
 
Posts: 16
Nice Work! But my Pre3 was AT&T , May I patch it???
xjstattoo is offline   Reply With Quote
Old 12/15/2012, 10:02 AM   #3 (permalink)
Member
 
Posts: 270
Should work for english devices too ... just try it!

Last edited by michel_ng; 12/15/2012 at 10:18 AM.
michel_ng is offline   Reply With Quote
Liked by johncc likes this.
Old 12/15/2012, 02:20 PM   #4 (permalink)
Member
 
Posts: 205
Is it incompatible with the advanced sconix messaging patch? I've removed every other patch as i can live without them, but i used advanced for mode switcher so would like to know if thats why it fails to install on my pre3 (2.2.4).

p.s. I have restarted luna after removing the other patches.
jetz is offline   Reply With Quote
Old 12/15/2012, 02:30 PM   #5 (permalink)
Member
 
Posts: 270
Quote:
Originally Posted by jetz View Post
Is it incompatible with the advanced sconix messaging patch? I've removed every other patch as i can live without them, but i used advanced for mode switcher so would like to know if thats why it fails to install on my pre3 (2.2.4).

p.s. I have restarted luna after removing the other patches.
If it fails to install, it conflicts with some other patches. Advanced sconix patches make a lot of changes in the system, so you have to choose between.
michel_ng is offline   Reply With Quote
Old 12/16/2012, 07:55 AM   #6 (permalink)
Member
 
Posts: 270
Now available over Preware!
michel_ng is offline   Reply With Quote
Old 12/16/2012, 09:07 AM   #7 (permalink)
Member
 
Posts: 55
I have uninstalled all my messaging patches, but it wont install your patch. Do you know if the patch conflicts with sconix framework?

Thanks for your work!
figgel is offline   Reply With Quote
Old 12/16/2012, 02:16 PM   #8 (permalink)
Member
 
Posts: 270
Quote:
Originally Posted by figgel View Post
Do you know if the patch conflicts with sconix framework?
I think, yes!
michel_ng is offline   Reply With Quote
Old 12/16/2012, 11:49 PM   #9 (permalink)
Member
 
Posts: 16
Quote:
Originally Posted by michel_ng View Post
Should work for english devices too ... just try it!
It`s better if this patct could be Tweaks enables...

With my expectation。。。
xjstattoo is offline   Reply With Quote
Old 12/17/2012, 02:39 AM   #10 (permalink)
Member
 
Posts: 270
Quote:
Originally Posted by xjstattoo View Post
It`s better if this patct could be Tweaks enables...

With my expectation。。。
Not possible!

-- Sent from my Palm Veer using Forums
michel_ng is offline   Reply With Quote
Old 12/17/2012, 09:11 AM   #11 (permalink)
Member
 
Posts: 16
Quote:
Originally Posted by michel_ng View Post
Not possible!

-- Sent from my Palm Veer using Forums
But I only want the second the third and the forth function,So what should I do?
Can you give me the code with that three function,and I want to modify it for my own Pre3 wich was patchde the sconix framework already.
xjstattoo is offline   Reply With Quote
Old 12/17/2012, 09:30 AM   #12 (permalink)
Member
 
Posts: 270
Quote:
Originally Posted by xjstattoo View Post
But I only want the second the third and the forth function,So what should I do?
Can you give me the code with that three function,and I want to modify it for my own Pre3 wich was patchde the sconix framework already.
Sorry, its a combined-patch, if you want some functions only, so just seach in preware or here in forum. There are patches for!
michel_ng is offline   Reply With Quote
Old 12/31/2012, 05:52 AM   #13 (permalink)
Member
 
Posts: 96
Quote:
[PATCH] Messenger Mega Mix for WebOS 2.2.x
Will it work on Veer with 2.1.2. ?
Trovatore is offline   Reply With Quote
Old 12/31/2012, 05:55 AM   #14 (permalink)
Member
 
Posts: 270
Quote:
Originally Posted by Trovatore View Post
Will it work on Veer with 2.1.2. ?
I think yes
michel_ng is offline   Reply With Quote
Old 12/31/2012, 06:14 AM   #15 (permalink)
Homebrew Developer

 
Posts: 2,345
Any chance you could make it compatible with the Advanced Patches? Or to make a seperate version for users of the Advanced patches? I already removed the Advanced Messaging Patch but no luck?

-- Sent from my TouchPad using Communities
__________________
HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
Herrie is offline   Reply With Quote
Old 12/31/2012, 07:36 AM   #16 (permalink)
Member
 
johncc's Avatar
 
Posts: 4,191
Quote:
Originally Posted by xjstattoo View Post
But I only want the second the third and the forth function,So what should I do?
Can you give me the code with that three function,and I want to modify it for my own Pre3 wich was patchde the sconix framework already.
They exist as separate patches that you will have to install one at a time.
johncc is offline   Reply With Quote
Old 01/22/2013, 02:35 AM   #17 (permalink)
Member
 
Posts: 290
I tried removing all my messaging related patches but still couldn't get it installed...
matchqq is offline   Reply With Quote
Old 01/31/2013, 04:22 PM   #18 (permalink)
Member
 
cbosdell's Avatar
 
Posts: 213
Hey everyone,

I created a version of this patch that is compatible with the Advanced System Messaging patch and michel_ng has granted me permission to share it here. From my testing on my Pre3 it works great. Just be sure you have the Advanced System Messages patch installed before you try installing this.
Attached Files
File Type: patch messenger-mega-mix-advcompat-de.patch (10.3 KB, 32 views) Email Attachment
__________________
Devices: Pre3 16GB (AT&T - webOS 2.2.4) | White TouchPad 4G 32GB (AT&T - webOS 3.0.5 + LunaCE)

Last edited by cbosdell; 01/31/2013 at 04:42 PM.
cbosdell is offline   Reply With Quote
Liked by michel_ng likes this.
Thanked By: SmiLee82
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0