webOS Nation Forums >  Homebrew >  webOS Patches > [Patch] User Agent Override
[Patch] User Agent Override
  Reply
Like Tree21Likes

 
Thread Tools Display Modes
Old 12/14/2012, 04:52 PM   #41 (permalink)
Member
 
Posts: 4
I suspect this is a daft question but after I download the Touchpad user agent agent for Chrome, what should I rename the file as to allow Preware to see it correctly for installation? The file that I have at the moment is called download.php which doesn't seem right at all!

Thanks!!!
JJUKJJ is offline   Reply With Quote
Old 12/15/2012, 02:05 AM   #42 (permalink)
Member
 
Posts: 4
Quote:
Originally Posted by JJUKJJ View Post
I suspect this is a daft question but after I download the Touchpad user agent agent for Chrome, what should I rename the file as to allow Preware to see it correctly for installation? The file that I have at the moment is called download.php which doesn't seem right at all!

Thanks!!!
Found out on another thread that the extension should be changed to .patch to make it work. Haven't tried it but I hope this helps someone who does end up having to use it.
JJUKJJ is offline   Reply With Quote
Old 12/26/2012, 05:36 PM   #43 (permalink)
Member
 
Posts: 412
I experimented with all three TP versions because I was interested in restoring access to the BBC iPlayer AND I was curious to see if any of them help with either hulu or MLB (the gratuitously nasty "Touchpad unsupported" redirect). I found that...
First, none help with Hulu.
The iPad version gets you the iPlayer, but on MLB you get redirected to a page asking you to download the iOS app.
The Firefox version gets you the desktop iPlayer, but on MLB you get the "Touchpad unsupported" message (which those of us who have entered the direct URL one way or another know is not true).
The Chrome version is the winner. It gets the desktop iPlayer AND MLB.
I am happy now!
carldc is offline   Reply With Quote
Old 12/26/2012, 05:42 PM   #44 (permalink)
Member
 
Posts: 412
BTW, you can both rename and install the patch through Internalz Pro as well (tap and hold, then select "Open", then tap the "Install" button).
carldc is offline   Reply With Quote
Old 01/03/2013, 12:30 PM   #45 (permalink)
Member
 
Posts: 31
If I install one of these via Preware, how do I uninstall them ?

Thanx!
hanksimon is offline   Reply With Quote
Old 01/03/2013, 12:35 PM   #46 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,135
Find it using search, and when you get tot the details page there's a button at the bottom.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Old 01/03/2013, 06:42 PM   #47 (permalink)
Member
 
kevets's Avatar
 
Posts: 570
wow, just dropped this on my pre3 and the browser has taken on a whole new life! Even helps with browsing the forums site. Was starting to get tired of zooming in and rotating everything just to read a post. Just what I was looking for. Thanks gmman!

edit: one thing I did do to help with embedded video and youtube in general is opt out of the html5 trial. Now embedded videos play in flash and youtube launches the video player, just like it should. Sweet!

Last edited by kevets; 01/03/2013 at 07:09 PM.
kevets is offline   Reply With Quote
Liked by Garrett92C likes this.
Old 01/03/2013, 10:50 PM   #48 (permalink)
Member
 
Posts: 31
Quote:
Originally Posted by hanksimon View Post
If I install one of these via Preware, how do I uninstall them ?

Thanx!
Foolish question -. I downloaded the Firefox patch. And I have the default Web browser. Do I need a different browser? Thanks.
hanksimon is offline   Reply With Quote
Old 01/03/2013, 10:57 PM   #49 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by hanksimon View Post
Foolish question -. I downloaded the Firefox patch. And I have the default Web browser. Do I need a different browser? Thanks.
Nope. All that patch does is make the stock browser appear to be Firefox.
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 01/04/2013, 10:16 PM   #50 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by Garrett92C View Post
If you install this patch, can you try these three things and let me know if you get the "good" UI?

1. Search Google from Just Type.
2. Search Google from web browser address bar.
3. Go to Google.com.
when i try to search from the browser address bar, it no longer gives "google search..." as an option, only wikipedia. i tried to go into the settings to change the default search engine but google wasn't an option there... this started when i installed the patch, please help!!!

oh, and i installed the ipad one on my uberkernal TP

Last edited by taescience; 01/04/2013 at 10:23 PM.
taescience is offline   Reply With Quote
Old 01/19/2013, 06:25 AM   #51 (permalink)
Member
 
Magnetic_dud's Avatar
 
Posts: 28
What about putting the playbook user agent?
I will give the mobile websites, but none of them will bug with app installation from the apple app store
Magnetic_dud is offline   Reply With Quote
Old 01/22/2013, 06:44 PM   #52 (permalink)
Member
 
darth_luigi's Avatar
 
Posts: 43
I love what the iPad patch does for Gmail etc but YouTube has stoped working.
is there any way to keep the patch and get YouTube working?
darth_luigi is offline   Reply With Quote
Old 01/23/2013, 03:35 AM   #53 (permalink)
Member
 
Magnetic_dud's Avatar
 
Posts: 28
Quote:
Originally Posted by darth_luigi View Post
I love what the iPad patch does for Gmail etc but YouTube has stoped working.
is there any way to keep the patch and get YouTube working?
The problem is that it tries to load the iOS app
The right way is to use an user agent that most websites recognizes as "mobile tablet" but does not have any app.

The answer is
Mozilla/5.0 (PlayBook; U; RIM Tablet OS 2.1.0; en-US) AppleWebKit/536.2+ (KHTML, like Gecko) Version/7.2.1.0 Safari/536.2+

or
Mozilla/5.0 (PlayBook; U; RIM Tablet OS 1.0.0; en-US) AppleWebKit/534.8+ (KHTML, like Gecko) Version/0.0.1 Safari/534.8+

If someone can make a patch with this user agent it would be great
With this user agent we can get tablet gmail + working youtube + most of websites that have an iOS app!
Magnetic_dud is offline   Reply With Quote
Old 01/23/2013, 05:17 AM   #54 (permalink)
Member
 
darth_luigi's Avatar
 
Posts: 43
Would it be possible to combine all 3 patches and make them Tweaks compatible so we can hot swap between the 4 modes.
darth_luigi is offline   Reply With Quote
Old 01/23/2013, 09:26 AM   #55 (permalink)
Member
 
GMMan's Avatar
 
Posts: 2,135
That will need a full app, since the file that controls user agents aren't JavaScript.
__________________
Contact: @GMMan_BZFlag (me on Twitter)
webOS Releases: Change your App Catalog country: TouchPad/PC | TouchPad/webOS Resources | Search suggestion patch for browser | Cycling Email Notifications | Don't Doctor! Make a good support request. | How to post logs | webOS Charge Monitor
GMMan is offline   Reply With Quote
Thanked By: darth_luigi
Old 01/23/2013, 09:42 AM   #56 (permalink)
Member
 
kevets's Avatar
 
Posts: 570
hoping that the isis browser guys are looking at this thread. Would be awesome to have a browser with this built in!
kevets is offline   Reply With Quote
Old 01/23/2013, 03:18 PM   #57 (permalink)
Member
 
darth_luigi's Avatar
 
Posts: 43
Is Advanced Browser still under active development?
It might be worth paying for.
darth_luigi is offline   Reply With Quote
Old 01/27/2013, 04:53 PM   #58 (permalink)
Member
 
Posts: 9
i keep getting an error on my touchpad when installing user agent , i have all the , patches Gnu ,Lsdiff,and Ausmt script installed . No go
bowling is offline   Reply With Quote
Old 01/27/2013, 05:28 PM   #59 (permalink)
Homebrew Developer
 
Garrett92C's Avatar
 
Posts: 401
Quote:
Originally Posted by bowling View Post
i keep getting an error on my touchpad when installing user agent , i have all the , patches Gnu ,Lsdiff,and Ausmt script installed . No go
Which error are you getting?
__________________
Want to keep up with my exciting new projects? You know where to find me.
Garrett92C is offline   Reply With Quote
Old 02/18/2013, 02:32 PM   #60 (permalink)
Member
 
Posts: 17
I have tried all 3 user agents. I have set up igoogle with a 2-column display. When I view igoogle whatever I have the put in the right-had column on my PC is displayed at the bottom of the page after the first column.
taxcurmudgeon is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0