Results 1 to 18 of 18
Like Tree1Likes
  • 1 Post By Alan Morford
  1.    #1  
    I tried to install the Advanced Patches Framework patch on my 2.2.4 Pre 3, and it won't install, both in Preware and Wosqi. I Pre 3 is an ATT model (unlocked on working on T-Mobile). I tried both the ATT/Verizon patch and the other Framework patch. Anything I can do to get the patch installed? I'd like to install some of the other Advanced patches. (Yes, I'm in Developer Mode.)
    Thx,
    Shneor
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  2. #2  
    what other patches do you have installed?
    I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
  3. #3  
    How well does the pre3 work on Tmo?

    -- Sent from my TouchPad using Communities
  4.    #4  
    Quote Originally Posted by OldSkoolVWLover View Post
    what other patches do you have installed?
    I have 16 patches installed, including Data in Device Menu. Could that be a problem?
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  5. #5  
    Yup, because Sconix device menu patch adds configurable options for the device menu. So the framework patch is trying to touch those top bar files and is finding an error due to the data patch. I would guess remove that and it's all good.

    Also keep in mind any other top bar patches could cause errors too (battery as %, etc). Once you get the sconix stuff installed and setup, if there is anything missing you want try installing after. Some may work some may not.
    I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
  6.    #6  
    Quote Originally Posted by OldSkoolVWLover View Post
    Yup, because Sconix device menu patch adds configurable options for the device menu. So the framework patch is trying to touch those top bar files and is finding an error due to the data patch. I would guess remove that and it's all good.

    Also keep in mind any other top bar patches could cause errors too (battery as %, etc). Once you get the sconix stuff installed and setup, if there is anything missing you want try installing after. Some may work some may not.
    Thanks, uninstalled Data in Dev menu and GPS in Dev menu, Installed the Advanced Systems Device Menu, now I have no device menu. oh, well. . Uninstalling it all.
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  7. #7  
    To get Sconix's adjustments to the device menu you need:

    - advanced system menus framework AND
    - advanced system menus - device menus
    This space for rent or lease. Inquire within.
  8.    #8  
    Quote Originally Posted by MudShark22 View Post
    To get Sconix's adjustments to the device menu you need:

    - advanced system menus framework AND
    - advanced system menus - device menus
    Yes, I know, had both installed. Device menu quit showing up.
    Shneor
    Shneor
    Pre 3 on T-Mobile, 32gb Touchpad
  9. #9  
    I couldn't get sconix's patch to install, either, but then I found Jason's Device Menu Megamix, and couldn't be happier.

    Tungsten E, Treo 650, Pre+ (3), Pre³ (2), TouchPad (2), & my trusty Treo BT headset (in use!)
    Posts: Save/Restore Backup Process & Batch File | Activated! (Verizon Pre³ Activation) | "Not Enough Space To Download" Fix
  10. #10  
    I'm having similar trouble trying to install this on my Pre2 running 2.1.

    Maybe I'll try Jason's Megamix too. But I thought I would post my IPKG log when I tried to install this patches, advanced-system-menus-framework.


    begin
    Nothing Interesting.
    verify
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    3 24402 3 918 0 0 2727 0 0:00:08 --:--:-- 0:00:08 3906
    100 24402 100 24402 0 0 32356 0 --:--:-- --:--:-- --:--:-- 37369
    identify
    org.webosinternals.patches.advanced-system-menus-framework
    install
    {"returnValue":true , "ticket":7, "subscribed":true}
    { "ticket":7 , "status":"STARTING" }
    { "ticket":7 , "status":"CREATE_TMP" }
    { "ticket":7 , "status":"VERIFYING" }
    { "ticket":7 , "status":"IPKG_INSTALL" }
    { "ticket":7 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.advanced-system-menus-framework.postinst 2>&1
    5 out of 37 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs.$rej$
    1 out of 6 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/stylesheets/systemui.css.rej
    The text leading up to this was:
    --------------------------
    |--- .orig/usr/palm/applications/com.palm.app.screenlock/resources/de/strings.json
    |+++ /usr/palm/applications/com.palm.app.screenlock/resources/de/strings.json
    --------------------------
    File to patch:
    Skip this patch? [y]
    1 out of 1 hunk ignored
    The text leading up to this was:
    --------------------------
    |--- .orig/usr/palm/applications/com.palm.app.screenlock/resources/fr/strings.json
    |+++ /usr/palm/applications/com.palm.app.screenlock/resources/fr/strings.json
    --------------------------
    File to patch:
    Skip this patch? [y]
    1 out of 1 hunk ignored
    The text leading up to this was:
    --------------------------
    |--- .orig/usr/palm/applications/com.palm.app.screenlock/resources/it/strings.json
    |+++ /usr/palm/applications/com.palm.app.screenlock/resources/it/strings.json
    --------------------------
    File to patch:
    Skip this patch? [y]
    1 out of 1 hunk ignored
    remove
    Removing package org.webosinternals.patches.advanced-system-menus-framework from root...
    (offline root mode: not running org.webosinternals.patches.advanced-system-menus-framework.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    Sent from my slowly diminishing intellect

    I'm just a soul who's intentions are good...oh Lord, please don't let me be misunderstood!

  11. #11  
    What patches do you have installed? Sure we cam figure this out.
    I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
  12. #12  
    Quote Originally Posted by OldSkoolVWLover View Post
    What patches do you have installed? Sure we cam figure this out.
    Thanks, but I decided to remove the patch, and go with Jason's Megamix...with a few tweaks (I want the date and the battery % in numbers). It's working well.
    Sent from my slowly diminishing intellect

    I'm just a soul who's intentions are good...oh Lord, please don't let me be misunderstood!

  13. #13  
    You can still get both of those with Sconix patches just so you know. The battery % can be changed in tweaks, and the date can be added as whatever patch you want (I always add the singular patches after adding the more intensive patches to reduce errors and create a controlled test so I know exactly what is conflicting if I get an error).
    I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
  14. #14  
    put on sconix device menu but no joy ...will not show nor take tap to edit ...deleted all that and did the same as below ...put on jason's megamix and added back temperature for that, wifi cycle, data... works for me like that ...sconix ...any comments here?
  15. #15  
    I have the same issue with unlocked AT&T Pre 3 with 2.2.4
    Even after full erase and webOsDoctoring most of Advanced Patches (except advanced system behavior) could not be installed

    I had to use "Advanced System Menus - Framework (ATT/VZW)"
  16. #16  
    I have 8 of sconix's advanced patches installed on my ATT pre3 running 2.2.4, so I know these work. Wish I could help ffigure out the issue.
  17. #17  
    [Old thread, I know...]

    FWIW, I just had to replace my 6-month old Pre 3 which first suffered a mic failure, then repeated rebooting, and finally some boot corruption (QDLOAD-Mode only). Before I really dug into fixing it, I just replaced it with another new Pre 3. For the life of me, I could not get the framework to install, even when it was the first patch on the system. This thread reminded me of Jason's mega-mix, which is apparently what I was using before, and which I was able to install.

    I wonder what causes this failure on just some devices, if not a patch conflict? Perhaps something restored when the system activated in my Palm profile? My log looked similar to the one posted earlier in this thread.

    Cheers
  18. #18  
    You should check out New Device Menu. Ironically I just posted this yesterday. xwTweak 0.1.0 - Global Accelerometer Switch
    Follow me on Twitter
    For the latest webOS news check out pivotCE
    Choorp likes this.

Posting Permissions