Results 1 to 18 of 18
  1.    #1  
    Some DNS servers cannot resolve or proxy SRV DNS requests (specially on some consumer routers, like some sitecom and netgear routers and older devices). But Google talk uses the Jabber protocol, witch normally uses SRV DNS requests. So if you are on such a network, you can't login to your Google Talk account with the Messaging app (see also this thread)

    I have created a patch, whitch will fix this, by change the DNS server for the domains googlemail.com and gmail.com to the public Google DNS servers (8.8.8.8 or 8.8.4.4). I'm not sure if we need to resolve gmail.com via Google DNS servers, because the Messaging app requests only the domaingooglemail.com on my device, when I login. But I am in Europe and google doesn't use the gmail.com domain here. So I've add this for completeness.
    Note: Only the domains googlemail.com and gmail.com will be answered by the Google DNS servers, any other domain will still resolved by your local DNS server.

    This patch should work on every WebOS device and in every WebOS Version (because they use all the same dnsmasq configuration)

    Howto install this patch:
    1. You can install this patch via WebOSQuickinstall or Internalz. I will send this patch also to the webos-patches feed, so you will be able to install it via preware soon.
    2. Restart your device!



    Current version: 0.1 (testing)
    License: MIT open software license (see attached file license.txt)

    I've tested this patch on my Pre3 (webos 2.2.4) and Pre+ (webos 2.1).

    If you have questions, requests or feedback please use this thread. All updates and changelog will be posted here, too.
    Attached Files Attached Files
    Last edited by moses; 02/12/2012 at 05:35 PM.
  2. #2  
    Usually I don' have problem with Gtalk on Pre3 , Veer or TouchPad. But I always do have login problem with Yahoo Messager on Pre3 & Veer using default Yahoo Account on webOS 2.x. I hope you can make fix for this, I surely send donation if you success to do it.

    Many many thanks!
  3.    #3  
    Quote Originally Posted by The Bard View Post
    Usually I don' have problem with Gtalk on Pre3 , Veer or TouchPad. But I always do have login problem with Yahoo Messager on Pre3 & Veer using default Yahoo Account on webOS 2.x. I hope you can make fix for this, I surely send donation if you success to do it.

    Many many thanks!
    I will try this, but I haven't a Yahoo Account (Perhaps I create one for testing purpose).

    Have you novaterm installed, that you access command line of your device?
  4. #4  
    Quote Originally Posted by The Bard View Post
    Usually I don' have problem with Gtalk on Pre3 , Veer or TouchPad. But I always do have login problem with Yahoo Messager on Pre3 & Veer using default Yahoo Account on webOS 2.x. I hope you can make fix for this, I surely send donation if you success to do it.

    Many many thanks!
    I have a problem where Yahoo will log in, but sometimes no one sees me online and they never get my messages...sometimes it works fine, totally random...same issue?
  5. #5  
    Hi!!!
    Many thanks.
    It seems it works fine to me...

    WebOS forever!!!
  6. #6  
    Hummm... I'm having a problem with my GTalk: I have three accounts and I can log in all, buuuut...

    ... I cannot send messages in one! I can see my contacts online but when I send the message, stay in chat with a yellow triagle! In other two accounts, I have no problem and this account works without problem in GMail website.

    So... somebody can say if this patch can help me?


    Best Regards...
    "If A Man Isn't Willing To Take Some Risk For His Opinions, Either His Opinions Are No Good Or He's No Good!" - Ezra Pound (Poet & Critic)
    (Happy A Lot, As A Good Carioca!)
  7.    #7  
    @The_Bard: Can you login in your Yahoo account? Or do have the same problem as rmausser?

    @Rnp:I think this patch will not help you. I'm not really sure, so if you want you can test and report me.

    Edit: After a quick checkup I don't think, that the problem with the Yahoo accounts differ from the Gtalk Problem!
    Last edited by moses; 02/13/2012 at 10:31 AM.
  8. #8  
    I can only log In to my Yahoo account using standard mail setting. Not using default Yahoo account from webOS. So using standard mail and set to my Yahoo Account, I can sync my Yahoo email but It don't have IM feature.

    So up till now I can use Yahoo IM only via TouchPad. Seems TouchPad don't have same issue with webOS 2.x on Phone.
  9.    #9  
    Quote Originally Posted by The Bard View Post
    I can only log In to my Yahoo account using standard mail setting. Not using default Yahoo account from webOS. So using standard mail and set to my Yahoo Account, I can sync my Yahoo email but It don't have IM feature.

    So up till now I can use Yahoo IM only via TouchPad. Seems TouchPad don't have same issue with webOS 2.x on Phone.
    You can try the attached patch. Install the patch via Internalz (or WebOSQuickInstall), then restart your device (not only luna!). After that you can try, if you can login to your yahoo messenger account. If this doesn't work, you can deinstall the patch via preware.

    I've created a test account to investigate this problem. But on my devices i always can login in yahoo messenger.

    So please give me a feedback, if this patch fix your problem.
    Attached Files Attached Files
  10. #10  
    Quote Originally Posted by moses View Post
    You can try the attached patch. Install the patch via Internalz (or WebOSQuickInstall), then restart your device (not only luna!). After that you can try, if you can login to your yahoo messenger account. If this doesn't work, you can deinstall the patch via preware.

    I've created a test account to investigate this problem. But on my devices i always can login in yahoo messenger.

    So please give me a feedback, if this patch fix your problem.
    @moses: tested for couple of minutes. seems it works!

    Hope I don't encounter any Yahoo IM login problem again....

    EDIT: I test install this patch to my Veer seems it failed to work. I still got Error 1299. On Pre 3 seems work. But I will test for couple days ahead, hope it still work.

    EDIT 2: Day 2. This morning I try to login Yahoo IM, now It won't login, need to restart device to fix this.

    When I first 3 week / a month using Veer / Pre 3. Yahoo account can do login, sync email don't have problem, but for Yahoo IM, usually after I login, and log out, pass several hours, I can't login again, need to restart device.
    After more then a month Veer got error 1299 error for email, and can't login to Yahoo account at all. For Pre3 no error 1299, but can't login Yahoo account at all too. (both email & IM)

    using this fix seems make Pre 3 can do login again to Yahoo mail & IM, but problem about need device to be restarted for Yahoo IM still persist. Can you help fix this? GTalk don't have this problem at all.
    Last edited by The Bard; 02/15/2012 at 08:50 PM.
  11. #11  
    ok now the problem worsen. Yahoo IM won`t login even I restart device or turn off/on again.
  12. #12  
    can't install the patch on pre 2 (2.2.4) via internalz. Error media/cryptofs/apps/usr/bin/patch: **** Only garbage was found in the patch input.
    patch unexpectedly ends in middle of line
  13. #13  
    Ooops....
    When I turn off and turn on the data connection i lose my gtalk.
    When i restart the device i lose my gtalk connection too.
    It seems don't work to me...
  14. #14  
    Quote Originally Posted by mrego.jamas View Post
    can't install the patch on pre 2 (2.2.4) via internalz. Error media/cryptofs/apps/usr/bin/patch: **** Only garbage was found in the patch input.
    patch unexpectedly ends in middle of line
    oh... Ok.. Now I see.. It's not because of the patch, but becouse there is no patch code but some html code in the patch file when I download it via webos browser.. :-/
  15.    #15  
    Quote Originally Posted by The Bard View Post
    I test install this patch to my Veer seems it failed to work. I still got Error 1299. On Pre 3 seems work. But I will test for couple days ahead, hope it still work.
    I think the problem with the 1299 error is a fault of the Yahoo login server. Actual I can't do anything to fix this problem!

    Do you have Email activated in your Yahoo properties in the account app? I think you must still use an extra Email account to use Yahoo email.

    Quote Originally Posted by lluisinho View Post
    Ooops....
    When I turn off and turn on the data connection i lose my gtalk.
    When i restart the device i lose my gtalk connection too.
    It seems don't work to me...
    This patch does not fix the autologin problem! If you change the data network you must login again (You can set your status in the Messaging app from available to busy and then back again to available to login to gtalk, without loosing connection of your other accounts).
    Last edited by moses; 02/16/2012 at 01:56 PM.
  16. #16  
    @moses: but I don't have login problem with webOS 3.x on TouchPad both Yahoo Mail & IM. Isn't that obvious that webOS 2.x have problem that need to be fixed?
  17.    #17  
    Quote Originally Posted by The Bard View Post
    @moses: but I don't have login problem with webOS 3.x on TouchPad both Yahoo Mail & IM. Isn't that obvious that webOS 2.x have problem that need to be fixed?
    You're right! I missed that point.

    I will investigate the Yahoo login process more precisely. The problem is, that I can't reproduce this error. All my devices login correctly to my yahoo test account. But perhaps I will find a solution even so.
  18.    #18  
    I've created a new thread (with a solution?) for the Yahoo problem:

    Yahoo login problems

Tags for this Thread

Posting Permissions