Results 1 to 10 of 10
Like Tree1Likes
  • 1 Post By knownboyofno
  1. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #1  
    I have a Pre 3 and find there's too large a gap between volume right off and the first setting. I have it at the lowest setting when I need it to be quiet and rarely go above 1 or 2. Can someone tell me what file I would edit to change this (or write a patch to do this)? I would be happy with more granularity at the low end and less at the loud end.
  2. #2  
    Check out touchvol. It isn't a patch but a program that gives you a lot of control.
    kill_dano likes this.
  3. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #3  
    Thanks for the suggestion, but TouchVol simply gives me an onscreen slider for Media volume which correlates to the built-in media volume. When I change the volume up and down on the side of the device these changes are reflected in the media slider and there's no way to get additional control.

    Guess I'm still at square one on this one... anyone else?
  4. c000's Avatar
    Posts
    665 Posts
    Global Posts
    655 Global Posts
    #4  
    i'm hoping for a similar patch for touchpads. i wish there were more... gradients? when you push up or down on the volume keys.

    i know there is touchvol, but i dont think it is directly tied into the volume buttons.
  5. jc-Treo's Avatar
    Posts
    439 Posts
    Global Posts
    444 Global Posts
    #5  
    Quote Originally Posted by gregp View Post
    Thanks for the suggestion, but TouchVol simply gives me an onscreen slider for Media volume which correlates to the built-in media volume. When I change the volume up and down on the side of the device these changes are reflected in the media slider and there's no way to get additional control.

    Guess I'm still at square one on this one... anyone else?
    Try opening up the EQ, turning it "ON", and running all 5 of those sliders down to a lower level.
    Sprint Treo 650 --> Sprint Treo 700p --> Sprint Centro --> Sprint Pre- --> AT&T Veer/ Pre 2/ Pre 3, Touchpad
  6. #6  
    Quote Originally Posted by gregp View Post
    Thanks for the suggestion, but TouchVol simply gives me an onscreen slider for Media volume which correlates to the built-in media volume. When I change the volume up and down on the side of the device these changes are reflected in the media slider and there's no way to get additional control.

    Guess I'm still at square one on this one... anyone else?
    It does give you finer control at least on the touchapd because I use it to go between different volumes to make it almost perfect. Click on the button labeled "Volume controls" which makes the section below to expand. That will give you more control. I hope that helps.
  7. gregp's Avatar
    Posts
    265 Posts
    Global Posts
    268 Global Posts
       #7  
    Hmm I found this didn't help. Just tried it again and the lowest setting I could get on Touchvol that wasn't right off still sounded the same as the lowest setting using the volume rocker.

    I assume there is a value assigned to each volume rocker adjustment which corresponds to a change in volume, e.g. 0=0, 1=5, 2=10, 3=15. I'm simply looking for which file this is in so I can remap setting 1 to (say) 2 instead of 5 or whatever.
  8. #8  
    let us now if you've found a solution to this then...because sometimes I need to make it louder
  9. #9  
    Quote Originally Posted by gregp View Post
    Hmm I found this didn't help. Just tried it again and the lowest setting I could get on Touchvol that wasn't right off still sounded the same as the lowest setting using the volume rocker.

    I assume there is a value assigned to each volume rocker adjustment which corresponds to a change in volume, e.g. 0=0, 1=5, 2=10, 3=15. I'm simply looking for which file this is in so I can remap setting 1 to (say) 2 instead of 5 or whatever.
    Well sorry it wasn't helpful but I hope you figure it out.
  10. #10  
    I'm a bit confused why someone would want an output that low, for the touchpad at least I can't hear it at all beyond a few feet from the speaker.

    At any rate, Touchvol can reduce the control linked to the button down to it's lowest possible setting. If you need lower you'd have to cut the volume somewhere else in the output path.

    Try this: (You will need commandline access in one form or another)
    "amixer -Dpulse set Master 65%" (you can use 0-100% or 0-65536)

    Change the value until you find a range that you want. This will also limit the max volume output, effectively sliding the output window down. To make it permanent add it to an upstart service (if you have TouchVol installed you can just add it to the end on a new line to: /var/palm/event.d/com.wordpress.touchcontrol.touchvol)
    Last edited by bi0tech; 01/20/2012 at 12:18 PM.

Posting Permissions