Results 1 to 11 of 11
Like Tree1Likes
  • 1 Post By Nafetz
  1.    #1  
    Hello,

    I have problems with bypassing the palm activation process. So far I did this:

    - Get a palm pre on ebay
    - Comletely erase the palm pre
    - Flashing my device as described here
    I used the version 1.4.5 for O2 Germany as listed here)
    - after this I had a screen waiting for me to put a sim-card in
    - I waited until the device went off (5 minutes?)
    - then I used the Activation Bypass-Tool as described here
    - the device booted and asked if I wanted to use as USB Drive or just to charge
    - I chose "Just charge"
    - then I typed "20090606" and selected the "Developer Mode Enabler"
    - the Developer Mode was already on
    - I disconnected my device from my PC
    - then I set up a connection to my wireless network - this succeeded
    - I reconnected my device to the PC and selected "Just charge"
    - I started WebOS Quick Install and pressed the "globe-button"
    - I installed the patch "Enable Profile Creation - Activation Bypassed" together with "GNU Patch" and "Lsdiff"
    - then I installed "Show FirstUse App" as described here
    - I closed WebOS Quick Install and disconnected my device
    - I pressed my power-button until I was asked what to do
    - I selected "Power" and then "Restart"
    - my device went off and on again
    - after that I selected the new application "First Use"
    - then I chose the language "German" which forced a reboot automatically
    - after this I see the dashboard and the "First Use" App is gone
    - I connected my device with the PC
    - I tried installing de_de.patch with WebOS Quick Install
    - the device rebooted again
    - I disconnected my device
    - this time I found the application "Erste Schritte" ("First Use"), which I started
    - again I selected the language "Deutsch" (German)
    - I accepted the licence agreement
    - then I chose to create a new profile
    - I typed in my name, password and email adress
    - at last I get the message "Sign-In Failed". "We were unable to sign you in"

    What am I doing wrong? It seems that a lot of people succeeded this way.
    I tried the same procedure using the original patch and using US-English as language, but it failed too. I even switched off my device and put the battery out, then I tried again - but no success.

    Thanks for any help,

    Stefan
  2. #2  
    I'm not sure I understand what you are trying to do so forgive me if I head in the wrong direction: You are bypassing *cell* service activation but trying to create an HP Profile via a wireless connection, is that correct? Do you have a Dr. Skippedfirstuse profile on the phone? Have you tried building a meta-doctor using the -wifi-only switch? Could you try to use Impostah to create a new profile rather than using the patches you're using now?
  3.    #3  
    Sorry for my bad English - I'm from Germany...
    But you're absolutely right. That is what I want to do.
    I'm not very used to webOS so far and it took my a lot of time to find the hints and tutorials I posted above. Because they were all from well reputated sites, I thought they were right (some people seemed to have success with them).
    But when I look on your suggestions and search in google for the words I've never heard so far, it seems to get very very complicated. Is there a tutorial, which desribes step by step what to do?
  4. #4  
    If you aren't familiar with building/using Meta-Doctor you can look here: Application:MetaDoctor - WebOS Internals

    This will require you to have a linux installation available which, if you are at all comfortable using, is probably the best approach. Using the -wifi-only switch on your desired script creates a doctor that automatically bypasses activation without creating a Dr. Skippedfirstuse profile - no profile is created at all. I've used this Doctor build to create a wifi only Pre, then I simply use the Impostah App > Activation screen > Create A New Profile, once I've enabled wi-fi on the Pre. Impostah can be installed via webOS Quick Install or Preware.

    If you aren't comfortable with using Meta-Doctor, you can follow this procedure using the 'devicetool.jar' :https://developer.palm.com/content/r...ed_device.html This will get you to a clean install without a profile.

    Then, again using Impostah from webOS Quick Install, go the the Activation screen and create your Profile from there. If you already have a profile, you can login from Impostah, then you can go to the Profile screen in Impostah, delete the profile and restart. This will bring you to the startup ("select language") screen again, but now you've got wifi activated so your device w/o cell service will be able to access the palm/HP server (over your wifi network) where you're Profile is stored.

    Since you've installed some patches, etc, you might be better off to apply the official Dr. that you've already used once, to make sure there aren't any conflicts, then try to Activate using Impostah. ( Or you could try Impostah with what you've got set up already to see if you still have a problem. )

    The important thing is that both approaches avoid the Dr. Skippedfirstuse profile that can cause all sorts of nagging issues with your profile.

    The bottom line is: Use Impostah from webOS Quick Install.

    Let me know if you need more help!
    Last edited by kayphoonstar; 01/01/2012 at 06:09 PM. Reason: additional info
  5.    #5  
    Thank you very much. First I used Impostah after a Quick Install from the state I already got. I recieved a "service error". Then I flashed my device again with Pre version 1.4.5 for O2 Germany and used the devicetool.jar. After another Quick Installation of Impostah I got another "Service Error (createDeviceAccount): 0".
    With the established WiFi-connection I can connect to the internet.
    Bad luck for today..
  6. #6  
    From what I understand that error means you don't have an internet connection. If you look in impostah under palm profile overrides, what is the setting under accountServerUrl ?

    I have "https://ps.palmws.com/palmcsext/services/deviceJ/"? Or check Device Profile and see if you have a valid carrier and the correct "location host" which should be "ps.palmws.com" but it might be different for your location.

    You should also probably try opening the browser and paste this URL and make sure you can access it : "https://ps.palmws.com/palmcsext/services/deviceJ/".
  7.    #7  
    Thank you very much for helping me so long. This is very kind of you.
    Accidentally I can't find the settings in Impostah. The available options in the start screen are "Device Profile", "Activation", "Palm Profile", "App Catalog", "Cpnnections", "App Data", "App Cookies" and "Web Cookies". The other options are greyed out. In the "Connections" option is "tcp 127.0.0.1.:4445" selected.

    When I call your suggested url with the Web-App I am asked to trust the certificate. Then I get ".No operation matching request path /deviceJ/ is found..."
  8.    #8  
    An additional information: In the meantime I confirmed, that my device is really suitable for O2 Germany. Therefore I used http://ws.hpwebos.com/webosdoctor/sorry.htm. After putting in my serial number it was said: "This serial number matches Pre on the o2 network". Then I continued the procedure and was automatically led to my suitable webdoctor version. To be sure, I flashed my device again with webOS® Doctor™ for Palm® Pre™ for o2. Build o2.236.222, webOS 1.4.5 (which seemed to be exactly the one I downloaded from webos-internals.org).
    But again no luck. The error stays the same as written above.
  9.    #9  
    Ooh no - stupid me!!!
    It's working! I can't believe it.
    After this I installed again the patches "Enable Profile Creation - Activation Bypassed" and the "FirstUse App". Still without any success.
    Then I thought, it would do no harm, if I set the Timezone to Berlin and set the actual time. After this Impostah suddenly succeeded. Then I logged into my new account with the FirstUse App. After this I had full access to the App Catalogue.

    Thank you very much for your help, kayphoonstar
    Balooz likes this.
  10. #10  
    Quote Originally Posted by Nafetz View Post
    Ooh no - stupid me!!!
    It's working! I can't believe it.
    After this I installed again the patches "Enable Profile Creation - Activation Bypassed" and the "FirstUse App". Still without any success.
    Then I thought, it would do no harm, if I set the Timezone to Berlin and set the actual time. After this Impostah suddenly succeeded. Then I logged into my new account with the FirstUse App. After this I had full access to the App Catalogue.

    Thank you very much for your help, kayphoonstar
    Hey! That's great! I thought it might be something we were missing - I'm glad it wasn't something more troublesome, like a bad esn or something, but the errors really weren't pointing that way.

    Just glad to know it's working for you!
  11. #11  
    Quote Originally Posted by Nafetz View Post
    Hello,

    I have problems with bypassing the palm activation process. So far I did this:

    - Get a palm pre on ebay
    - Comletely erase the palm pre
    - Flashing my device as described here
    I used the version 1.4.5 for O2 Germany as listed here)
    - after this I had a screen waiting for me to put a sim-card in
    - I waited until the device went off (5 minutes?)
    - then I used the Activation Bypass-Tool as described here
    - the device booted and asked if I wanted to use as USB Drive or just to charge
    - I chose "Just charge"
    - then I typed "20090606" and selected the "Developer Mode Enabler"
    - the Developer Mode was already on
    - I disconnected my device from my PC
    - then I set up a connection to my wireless network - this succeeded
    - I reconnected my device to the PC and selected "Just charge"
    - I started WebOS Quick Install and pressed the "globe-button"
    - I installed the patch "Enable Profile Creation - Activation Bypassed" together with "GNU Patch" and "Lsdiff"
    - then I installed "Show FirstUse App" as described here
    - I closed WebOS Quick Install and disconnected my device
    - I pressed my power-button until I was asked what to do
    - I selected "Power" and then "Restart"
    - my device went off and on again
    - after that I selected the new application "First Use"
    - then I chose the language "German" which forced a reboot automatically
    - after this I see the dashboard and the "First Use" App is gone
    - I connected my device with the PC
    - I tried installing de_de.patch with WebOS Quick Install
    - the device rebooted again
    - I disconnected my device
    - this time I found the application "Erste Schritte" ("First Use"), which I started
    - again I selected the language "Deutsch" (German)
    - I accepted the licence agreement
    - then I chose to create a new profile
    - I typed in my name, password and email adress
    - at last I get the message "Sign-In Failed". "We were unable to sign you in"

    What am I doing wrong? It seems that a lot of people succeeded this way.
    I tried the same procedure using the original patch and using US-English as language, but it failed too. I even switched off my device and put the battery out, then I tried again - but no success.

    Thanks for any help,

    Stefan
    I'm from Vietnam, in my country, I usually use a 3G SIM to sold this problem (first use).

Posting Permissions