Results 1 to 13 of 13
  1.    #1  
    Simply makes the "Back" button larger at the lower-left in the App Catalog when viewing an app's detail. I found it small, that's all. The larger button allows for a finger-friendlier navigation. See screenshot - works in both landscape and portrait orientations.

    Tested on App Catalog v5.0.2500 (WebOS 3.0.4)

    Please report back if successfully or issues.

    Update: Submitted to Preware for 3.0.4 only, if you have 3.0.2 with an older App Catalog version (you can check under Software Manager app), please report!

    Update 2: WARNING - DO NOT UN-INSTALL PATCH USING PREWARE
    As Mutoidi first discovered, no matter how you install this patch, uninstalling it using Preware will result in the file it patches to be removed. This is not normal. The App Store will be inoperable. For those affected, see post #7 below for resolution.

    FINDINDS:
    Install from: Preware = doesn't apply the patch at all
    Install from InternalZ = works (may report an error, but it does patch correctly)
    Install from WebOS Quick Install = works (recommended method)

    Update 3: Rod Whitby says the reason is that AUPT-4 does not handle patches to files in /media/cryptofs/apps so this patch will be removed from Preware feeds and available only as a download here with the stipulation that can you cannot remove it using Preware.

    .
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by opacityzero; 11/23/2011 at 09:54 PM.
  2. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #2  
    I always wondered why they made it so small when there is all that space. Thanks!
  3. #3  
    TP 32Gb 3.0.4 F4. App V.5.0.2500.
    Install patch through Preware.
    Restart.
    Backbutton still same size etc.

    ?

    EDITS: Later.. File installed fine via WOSQI.. maybe a Preware feed glitch?

    ..........Even later.. App. Cat. has 'gone down' altogether here, hopefully this is temporary (and not related to the above)! Have reported it via 'Software Manager' anyhow.

    Last edited by Mutoidi; 11/22/2011 at 09:47 PM.
  4. #4  
    I'm same issue. I have installed and de-installed 3 times and [back] button does not change.
  5. #5  
    didnt work from preware, but worked using internalz to install for me
  6.    #6  
    @Tuzz can you report the webos version and App Catalog version number, and if you're installed using Preware, WebOS QuickInstall or InternalZ, etc?
    Last edited by opacityzero; 11/22/2011 at 10:40 PM.
  7.    #7  
    @Mutoidi

    I just replicated this, for some reason, installing the patch through WOSQI installs correctly, but when you uninstall it using Preware, it completely removes the file itself that the patch patches (and not simply undo's the patch changes). Unzip file attached and using InternalZ or WebOS Quick Install, place the following file into the directory below. This is the original, untouched, unpatched file.

    /media/cryptofs/apps/usr/palm/applications/com.palm.app.enyo-findapps/main/

    .
    Attached Files Attached Files
    Last edited by opacityzero; 11/22/2011 at 11:00 PM.
  8. jdale's Avatar
    Posts
    554 Posts
    Global Posts
    564 Global Posts
    #8  
    Quote Originally Posted by hoopsta1423 View Post
    didnt work from preware, but worked using internalz to install for me
    Likewise.
  9. #9  
    Quote Originally Posted by opacityzero View Post
    @Mutoidi

    I just replicated this, for some reason, installing the patch through WOSQI installs correctly, but when you uninstall it using Preware, it completely removes the file itself that the patch patches (and not simply undo's the patch changes). Unzip file attached and using InternalZ, place into the following directory to get the App Store app to function again:

    /media/cryptofs/apps/usr/palm/applications/com.palm.app.enyo-findapps/main/

    .
    Phew..

    OK.. should I email the zip file straight to the TP or unzip it on my PC first then transfer?

    And then, presumably.. ONLY use WOSQI to install and/or uninstall 'Back Button' until you get a fix on the Preware method?

    Yay.. Be good to get the Apps. Cat. back!

    *

    EDIT: Later.. All good.. unzipped 'build' file on PC and reinstalled via WOSQI 'send file' + 'Larger Back Button' patch via WOSQI 'install' also.

    Thanz again for you prompt and helpful response!

    Last edited by Mutoidi; 11/22/2011 at 11:17 PM.
  10.    #10  
    @Mutoidi

    Unzip on PC first, and transfer to TouchPad. Then you can install the patch attached using WebOS Quick Install or InternalZ (I tested both myself) and it works, but just don't remove the patch with Preware as this causes the deletion of the file. The file attached above is the unpatched original file.
  11. #11  
    Quote Originally Posted by opacityzero View Post
    @Mutoidi

    Unzip on PC first, and transfer to TouchPad. Then you can install the patch attached using WebOS Quick Install or InternalZ (I tested both myself) and it works, but just don't remove the patch with Preware as this causes the deletion of the file. The file attached above is the unpatched original file.
    Gottcha!
    All done & repatched.. Thanks!

    Last edited by Mutoidi; 11/22/2011 at 11:24 PM.
  12. #12  
    It might be a good idea to mention in the OP that when using Internalz to install this patch, Internalz reports an error, even though the patch itself works.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  13. #13  
    Whoops! Tried reinstalling after the latest app cat update and now app cat is broken. Extracting app cat from the dr, overwriting current version then allowing it to update itself fixed it, but I won't be playing with this patch anymore.
    Stay thirsty, my friends

Tags for this Thread

Posting Permissions