Results 1 to 16 of 16
  1.    #1  
    I noticed that after I upgraded to 3.0.2 on my TouchPad that SSH access went away. I've followed these steps thus far:

    1.) Went into Preware and re-installed OpenSSH
    - No effect
    2.) Installed 'Emergency Service Enabler' via Preware
    - SSH now listening on pot 22 as expected, but connecting results in:
    "ssh_exchange_identification: Connection closed by remote host"
    3.) I check to see if my keys are still there. Strangely enough they are not. So I re-run the steps outlined at Application:OpenSSH - WebOS Internals
    - Still getting "ssh_exchange_identification: Connection closed by remote host"
    4.) So I try taking the public key from my Linux box (id_rsa.pub), and adding it to the 'authorized_keys' of the TouchPad
    - Still getting "ssh_exchange_identification: Connection closed by remote host"
    5.) Finally I check /var/log/messages, and I notice every time I try to connect, openssh crashes with this message:

    Code:
    2011-08-27T01:19:11.524621Z [252439] webos-device kern.info kernel: [252439.765367] minicore_launch: CRASH! sshd(2180) received 11. Waiting up to 60s for minicore to attach.
    Anyone have any clue what might be the problem here?

    -Jeremy
  2.    #2  
    Something I forgot to mention: When I run /opt/bin/ssh-keygen

    I get some strange output:

    Code:
    root@HPTouchPad:/# /opt/bin/ssh-keygen
    Generating public/private rsa key pair.
    Enter file in which to save the key (/home/root/.ssh/id_rsa): 
    /home/root/.ssh/id_rsa already exists.
    Overwrite (y/n)? y
    Enter passphrase (empty for no passphrase): 
    Enter same passphrase again: 
    Your identification has been saved in �.
    Your public key has been saved in �.pub.
    The key fingerprint is:
    f0:f0:2c:89:cc:b9:6e:5a:af:5a:74:ed:fc:a5:ad:f3 root@�
    And it ends up saving the public key to a file named something like ?.pub. Notice the corrupted output?

    I've also tried completely uninstalling all optware based stuff in preware and re-installing all of it.

    -Jeremy
  3.    #3  
    I'm attaching some strace output hoping someone can help me with this. The strace was produced by the command:

    Code:
    ssh jeremy@the-edge-consulting.com
    I've tried uninstalling all OpenSUSE apps from preware, completely deleting all openSUSE config files/folders under /opt/etc and /var/home/root/.ssh... I still can not figure out what's wrong with my SSH. I can not SSH in or out of my TouchPad. If I try to SSH out to any server I get a segmentation fault.

    If need be I can try installing GDB if someone can give me (or point me to) some instructions on how to install it.

    -Jeremy
    Attached Files Attached Files
  4. #4  
    Seen this before, but never was able to diagnose it. It only happens on some devices for some reason.

    Uninstall all the openssh stuff, reboot, install them. Generate your key on a desktop computer.

    -- Rod
  5.    #5  
    Seen this before, but never was able to diagnose it. It only happens on some devices for some reason.

    Uninstall all the openssh stuff, reboot, install them. Generate your key on a desktop computer.

    -- Rod
    Thanks Rod.

    Uninstalling the OpenSSH stuff, rebooting, and re-installing did not help. However uninstalling all of the Optware/Linux stuff, rebooting, and re-installing did help. It's all working now.

    Btw, my first order of business once it was working was loading up Xecutah/Xterm, doing an ssh -X into my Linux box and running Firefox on my TouchPad. It was awesome! Thanks again for all your hard work!

    Is there a way to scroll up/down in Xterm? Or right click?


    -- Sent from my HP TouchPad using Communities
  6. #6  
    I am having the same issue with openssh. Which other apps did you need to remove and re-install?

    thanks.
    jim
  7. #7  
    Quote Originally Posted by rwhitby View Post
    Generate your key on a desktop computer.

    -- Rod
    Sorry SSH noob question -- how does one generate a key on the PC/desktop? I'm thinking via webOSQuickInstall's Linux Commandline function?

    Or wait, can I just use another Pre's or Touchpad's authorized_keys file and paired .ppk file? Holy smokes, I think that's possible. *slaponforehead* Will try later
  8. getsun's Avatar
    Posts
    60 Posts
    Global Posts
    62 Global Posts
    #8  
    is ssh working on 3.0.5?
    I get segmentation fault trying to connect to a remote server.

    I've already tried removing xterm, xserver, xecutah, openssh, and other optware, reboot, reinstall, but no success.

    Anyone have a working setup?
  9. jkb
    jkb is offline
    jkb's Avatar
    Posts
    1 Posts
    #9  
    I saw a note in the opensh package about no longer requiring zlib and openssl. I ran into the segfault issue when ssh'ing out from the touchpad. I went ahead and installed the zlib package as well as the openssl package and now ssh is working swimmingly.
  10. getsun's Avatar
    Posts
    60 Posts
    Global Posts
    62 Global Posts
    #10  
    Installed zlip & openssl and it work. It fixed the segmentation fault issue. Thanks jkb!
  11. #11  
    Do the people having problems happen to have the Alpha Testing feed for optware enabled?

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  12. #12  
    I need to know if people are only getting segfaults on 3.0.5 or if it happens on other versions too?

    webOS 2.1.2, 2.2.4 etc. need to be tested.
    Follow me on Twitter: http://twitter.com/warthogkernel

    Experimental warthog kernels for webOS devices. Patches such as Muffle System Logging, Max Blocker etc.

    Donations go towards further experimentation.
  13. #13  
    I had the same problem with franken pre2 on 2.2.4 until I installed zlip and openssl as reccomended. Still getting Connection refused when trying to connect to the franken pre2 from computer or touchpad. Alpha Testing feed for optware is disabled.
  14. #14  
    Quote Originally Posted by blake0 View Post
    I had the same problem with franken pre2 on 2.2.4 until I installed zlip and openssl as reccomended. Still getting Connection refused when trying to connect to the franken pre2 from computer or touchpad. Alpha Testing feed for optware is disabled.
    Hmm. Somehow the alpha test version of openssh got into the public feed. codecrumb will need to revert that.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  15. #15  
    Quote Originally Posted by rwhitby View Post
    Hmm. Somehow the alpha test version of openssh got into the public feed. codecrumb will need to revert that.

    -- Rod
    Can confirm that reverting to version 5.9.1-2 of openssh resolve the connection refused problem.
  16. #16  
    openssh_5.9.1-4 now in the feeds.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals

Posting Permissions