Lately there have been patches showing up in preware that are telling me that it is not currently available for 2.1. I know the Touchpad just came out and I assume most, if not all, of these patches are for the TouchPad. Shouldnt there be a separate feed for touchpad patches or some other way to filter them out on phones? Maybe put them in the unavailable section of the patches list? I see new patches show up here and there and get excited just to see its not available for me.

Also, a message to developers:

Can we get a 2.1 version of your patch as well?