Page 8 of 24 FirstFirst ... 34567891011121318 ... LastLast
Results 141 to 160 of 472
Like Tree46Likes
  1.    #141  
    Quote Originally Posted by frantid View Post
    The Pre3 file is probably the best bet. There were no changes in 2.2.0 to 2.2.3. I'm not sure about 2.2.4, but my guess is they didn't change anything.

    If it installs without error, then they probably did not alter the files.
    After looking at the doctor for 2.2.4, they used the version for 3.0.4 touchpad as their base. I have added a patch for 2.2.4 in the first post.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  2.    #142  
    Sync behaviors patches have been posted in Preware (including: 2.2.4, 2.2.3, 2.1.1 and 2.1.2), you may need to update your feeds to see them.

    For Veer users and others that have local versions installed:

    Please remember, you CANNOT update a local version with a Preware version. If you want to install the Preware version, you must uninstall the local version, restart Luna, then you can install the Preware version.

    There is NO difference between the posted local patches and the Preware ones. So you do not have to update, if you are testing the latest local versions.

    cheers.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  3. #143  
    looks like 3.04 touchpad patch on the first post or still only 3.02?
  4.    #144  
    Quote Originally Posted by joedisaster View Post
    looks like 3.04 touchpad patch on the first post or still only 3.02?
    There is one for 3.0.4. I need to edit the first post. It is in Preware as well.
  5.    #145  
    Updated first post. Fix for 224 google invites not being sent.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  6. #146  
    How does this patch relate to "Sync Fix for Stable Upload" by moo? I have both installed, but is the "Google Sync Behaviors Patch" sufficent already to achieve stable uploads?

    thanks
    Max
  7.    #147  
    Quote Originally Posted by m-h-k View Post
    How does this patch relate to "Sync Fix for Stable Upload" by moo? I have both installed, but is the "Google Sync Behaviors Patch" sufficent already to achieve stable uploads?

    thanks
    Max
    You should not need both.

    The sync behaviors patch does the same correction, but also adds other adjustments for the calendar.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  8. #148  
    Quote Originally Posted by frantid View Post
    You should not need both.

    The sync behaviors patch does the same correction, but also adds other adjustments for the calendar.
    OK, then I will uninstall the "Sync Fix for Stable Upload". I had issues syncing my Google calendar, so maybe this is conflicting.

    thanks for the quick response,
    Max
  9. #149  
    Quote Originally Posted by frantid View Post
    That doesn't sound like very reliable sync.

    I have only concentrated the patches on making sure the transport features work with google and that the parameters are correct in the sync requests. I think you are running into another type of problem. I have a guess as to what might be the problem, but I'm not sure. I've been studying the changes in the touchpad's code and behavior trying to figure it out. I'll explain... this is going to be long sorry.

    I've seen sporadic problems where doing a number of new events will cause the sync to skip a few events. I think it is a database and timing issue. Usually the calendar will sync as soon as it sees a database change. So you make a new event, it immediately kicks off the sync service. Meanwhile, you are still modifying your events or making new ones. The sync has already started, so only the first one is sync'd. The sync end's and the time of the sync is recorded. But you finished making your edits, before the sync ended. So for the next sync, the database only looks for changes after the last recorded sync time. Which means the few events you made before sync ended never get to sync.

    Normally this isn't a problem as sync takes just a few seconds really. And most people take more than a few seconds to make events. And they usually only make a few on their phones at a time. But if sync takes longer or you are too fast for the system, events get skipped.

    I think this maybe why my sync usually doesn't have problems. I usually make appointments 1 at a time as I'm on the phone or right after a meeting. I know some people do it all at one time of the day.

    All you should have to do to get the missing event to sync is make a change. Adding a word to the note is enough.

    I believe they have realized they need to do it differently, as they are now tracking modified time per event on the touchpad. I can't do this on the phones with a patch, as I can't modify the database behavior.

    What I would do if you want to migrate a lot of your old events at a time - especially if you are doing hours worth of migration, is put the phone in airplane mode.

    I know this sounds bad, but I'm assuming you are doing this in a down time when your not expected to be on call. That way you could quickly move a large number of events and sync wouldn't start. Then turn airplane back and don't make any changes until the sync is completed.

    For normal event creation, just keep in mind how it works for now. I'm going to start looking at whether I can figure out where it is tracking changes in the database and determining which events it needs to sync. Maybe find some way to force a fuller sync than just changes. That sync would be manually started. I wouldn't want it automatic as that first sync can be really long. Several hours for some people.

    If you follow the logs with lumberjack, using custom searching for "google". Look at the status line. Looks like "--> status 200". If it says 200, that's an error free sync. If you see something else there, let me know as that is an error.

    I don't have a clear cut answer, so I just posted my thoughts on it. hope it helped.
    any body from this forum talking to hp and fixing this sync issue?
    I don't understand how my android phone syncs the contacts and calendar in a matter of seconds and my pre3 takes hours.

    i am thinking of making webOS products but issues like syncing needs to be error free.

    Chris
  10.    #150  
    Actually, I think they are doing a great job. The patch for 3.0.4 is really small and only adds email invitations and tweaks support for extended sync.

    I would not consider those as bugs, more differences in features.

    They are making changes to how they track changes. Plus with 3.0.5 they moved the calendar out of the /usr directory. So they will be able to update independent of the framework.

    cheers
  11. Loiter's Avatar
    Posts
    682 Posts
    Global Posts
    893 Global Posts
    #151  
    Google calendar syncing after 2.2.4 is excellent in my Pre2. I edit, create, delete events very fast and everything syncs fine. In the past (check earlier posts) it didn't happen. Along with UC it makes the calendar very useful.
    I don't know about the "first sync" as I haven't removed and re-added the calendar for some months.
  12.    #152  
    Glad it is finally working for you!


    Quote Originally Posted by Loiter View Post
    Google calendar syncing after 2.2.4 is excellent in my Pre2. I edit, create, delete events very fast and everything syncs fine. In the past (check earlier posts) it didn't happen. Along with UC it makes the calendar very useful.
    I don't know about the "first sync" as I haven't removed and re-added the calendar for some months.
  13.    #153  
    Added a version for 3.0.5 to first post, this is ok to use with current AUPT scripts. As it is in the old system directories.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  14. #154  
    Hi frantid,

    I'm running a Pre3 with the Google Calendar Sync Behaviors patch, and since upgrading to 2.2.4, I'm finding endar.google.jsjsjs $sometimes$ $uses$ $100$% $of$ $my$ $CPU$ $continuously$ $until$ $my$ $battery$ $is$ $fully$ $drained$ ($about$ $4$ $hours$). $It$ $sounds$ $a$ $bit$ $like$:
    endar.google.js uses 100% cpu at full MHz

    After some fiddling around, it seems to only occur if I use Tweaks to set the "Months in Past" setting away from 12 months (I set it to 48 months). Once this is done, endar.google.jsjsjs $seems$ $to$ $get$ $really$ $hyperactive$, $and$ $stay$ $that$ $way$ $even$ $if$ $I$ $use$ $Tweaks$ $to$ $set$ $the$ &$quot$;$Months$ $in$ $Past$&$quot$; $parameter$ $back$ $to$ $12$ $months$. $Removing$ $and$ $then$ $reinstalling$ $the$ $Google$ $Calendar$ $Sync$ $Behaviors$ $patch$, $which$ $re$-$establishes$ $the$ $default$ $12$ $months$ &$quot$;$Months$ $in$ $Past$&$quot$; $setting$ ($even$ $if$ $Tweaks$ $was$ $already$ $used$ $to$ $reset$ $to$ $12$ $months$) $appears$ $to$ $remedy$ $the$ $issue$.

    Any ideas what could be causing this, as it didn't seem to be a problem with 2.2.0?

    Kind regards,
  15. #155  
    when I had this installed on 3.04, it was syncing my device like every 10 min. Giving me a notification on the top bar. I couldn't figure out anywhere to adjust the sync frequency, is that normal or was my installation buggy somehow?
  16. #156  
    Quote Originally Posted by frantid View Post
    Actually, I think they are doing a great job. The patch for 3.0.4 is really small and only adds email invitations and tweaks support for extended sync.

    I would not consider those as bugs, more differences in features.

    They are making changes to how they track changes. Plus with 3.0.5 they moved the calendar out of the /usr directory. So they will be able to update independent of the framework.

    cheers
    hope you are right! not given up webos but i need whatsapp asap!
  17.    #157  
    Thanks for the detailed steps. I'll debug it and see what I can find.


    Quote Originally Posted by DamionMilliken View Post
    Hi frantid,

    I'm running a Pre3 with the Google Calendar Sync Behaviors patch, and since upgrading to 2.2.4, I'm finding endar.google.jsjsjs $sometimes$ $uses$ $100$% $of$ $my$ $CPU$ $continuously$ $until$ $my$ $battery$ $is$ $fully$ $drained$ ($about$ $4$ $hours$). $It$ $sounds$ $a$ $bit$ $like$:
    endar.google.js uses 100% cpu at full MHz

    After some fiddling around, it seems to only occur if I use Tweaks to set the "Months in Past" setting away from 12 months (I set it to 48 months). Once this is done, endar.google.jsjsjs $seems$ $to$ $get$ $really$ $hyperactive$, $and$ $stay$ $that$ $way$ $even$ $if$ $I$ $use$ $Tweaks$ $to$ $set$ $the$ &$quot$;$Months$ $in$ $Past$&$quot$; $parameter$ $back$ $to$ $12$ $months$. $Removing$ $and$ $then$ $reinstalling$ $the$ $Google$ $Calendar$ $Sync$ $Behaviors$ $patch$, $which$ $re$-$establishes$ $the$ $default$ $12$ $months$ &$quot$;$Months$ $in$ $Past$&$quot$; $setting$ ($even$ $if$ $Tweaks$ $was$ $already$ $used$ $to$ $reset$ $to$ $12$ $months$) $appears$ $to$ $remedy$ $the$ $issue$.

    Any ideas what could be causing this, as it didn't seem to be a problem with 2.2.0?

    Kind regards,
  18.    #158  
    I don't send any messages to the notification system. That sounds like a different problem. The sync usually runs every 20 minutes, if there have not been any changes to the calendar. But the service does not send any notifications when it starts up.


    Quote Originally Posted by joedisaster View Post
    when I had this installed on 3.04, it was syncing my device like every 10 min. Giving me a notification on the top bar. I couldn't figure out anywhere to adjust the sync frequency, is that normal or was my installation buggy somehow?
  19.    #159  
    Quote Originally Posted by DamionMilliken View Post
    Hi frantid,

    I'm running a Pre3 with the Google Calendar Sync Behaviors patch, and since upgrading to 2.2.4, I'm finding endar.google.jsjsjs $sometimes$ $uses$ $100$% $of$ $my$ $CPU$ $continuously$ $until$ $my$ $battery$ $is$ $fully$ $drained$ ($about$ $4$ $hours$). $It$ $sounds$ $a$ $bit$ $like$:
    endar.google.js uses 100% cpu at full MHz

    After some fiddling around, it seems to only occur if I use Tweaks to set the "Months in Past" setting away from 12 months (I set it to 48 months). Once this is done, endar.google.jsjsjs $seems$ $to$ $get$ $really$ $hyperactive$, $and$ $stay$ $that$ $way$ $even$ $if$ $I$ $use$ $Tweaks$ $to$ $set$ $the$ &$quot$;$Months$ $in$ $Past$&$quot$; $parameter$ $back$ $to$ $12$ $months$. $Removing$ $and$ $then$ $reinstalling$ $the$ $Google$ $Calendar$ $Sync$ $Behaviors$ $patch$, $which$ $re$-$establishes$ $the$ $default$ $12$ $months$ &$quot$;$Months$ $in$ $Past$&$quot$; $setting$ ($even$ $if$ $Tweaks$ $was$ $already$ $used$ $to$ $reset$ $to$ $12$ $months$) $appears$ $to$ $remedy$ $the$ $issue$.

    Any ideas what could be causing this, as it didn't seem to be a problem with 2.2.0?

    Kind regards,
    I spent some time with my Pre3 trying to replicate this and I couldn't.

    Are you toggling off the google calendar, then setting the back months, then restarting Luna, then toggling calendar back on in the accounts app?

    That back setting only takes effect and is used on the very first sync after an account is added or turned back on in the accounts app. Any toggling of it after the account is setup, will not result in those back events coming in.

    The forward one will change how far it looks forward for changes in the web calendar in the case of a sync error. But the initial sync is what sets up how many months forward you have in the calendar. After that first sync events forward need to be modified to show up.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  20. #160  
    Hello frantid,

    I have the same problem as Damion Milliken some posts above.
    Also syncing with google seems to happen just from google not to google.
    Using Lumberjack i analysed the logs for customSetting "google".
    There I reguilarly see a

    Kern.Info: minicore_launch: CRASH!
    endar.google(2812) received 6. Waiting up to 60s for minicore to attach.

    I have to mention, that I deregistered and reregistered the google account to the same results.
    I one time tested another google account, where everything is working (same patches).
    So I suspect one or some calendar entries to cause the crash.
    Can You give some hints on how to debug the syncing , e.g. logging which events are synced?

    Regards
    Ralf Keimer
Page 8 of 24 FirstFirst ... 34567891011121318 ... LastLast

Posting Permissions