webOS Nation Forums >  Homebrew >  webOS Patches > (Patch Request) Exhibition
(Patch Request) Exhibition
  Reply
 
Thread Tools Display Modes
Old 04/13/2011, 07:21 PM   #1 (permalink)
Member
 
Posts: 82
Not sure if this has been discussed before, my searches haven't found anything. I would like a patch to the exhibition app that puts the phone directly into exhibition mode instead of having to press the 'Start Exhibition' button.

This way when you launch the app it goes directly into your preferred exhibition mode. Pressing the button would then go back to the settings scene.

-- Sent from my Palm Pre using Forums
kbrabble is offline   Reply With Quote
Old 04/26/2011, 03:49 PM   #2 (permalink)
Homebrew Developer
 
_patrickc_'s Avatar
 
Posts: 236
you can go directly into Exhibition if your phone is set on a Tochstone
__________________
webOSroundup and Project Macaw contributor
Remember, if I helped you, please click on the little or ♥ to the right
_patrickc_ is offline   Reply With Quote
Old 04/27/2011, 10:07 PM   #3 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
Here's the patch ... give it a try and please confirm it works properly. After I get a couple of confirmations, I'll submit it to the Patch Portal.

Update: This is only for webOS 2.1.0
Attached Files
File Type: patch autostart-exhibition-v2.1.0.patch (468 Bytes, 35 views) Email Attachment
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar

Last edited by appsotutely; 04/27/2011 at 11:27 PM.
appsotutely is offline   Reply With Quote
Thanked By: bethel95
Old 04/27/2011, 10:47 PM   #4 (permalink)
Member
 
NickVTPre's Avatar
 
Posts: 1,008
Another option would be to use Mode Switcher to launch it as your default mode. If you haven't checked MS out you should. Powerful stuff.
NickVTPre is offline   Reply With Quote
Old 04/29/2011, 09:31 AM   #5 (permalink)
Member
 
Posts: 82
Quote:
Originally Posted by appsotutely View Post
Here's the patch ... give it a try and please confirm it works properly. After I get a couple of confirmations, I'll submit it to the Patch Portal.

Update: This is only for webOS 2.1.0
Works great. Thanks for doing this one...

-- Sent from my Palm Pre using Forums
kbrabble is offline   Reply With Quote
Old 04/29/2011, 09:35 AM   #6 (permalink)
Member
 
Posts: 82
Quote:
Originally Posted by NickVTPre View Post
Another option would be to use Mode Switcher to launch it as your default mode. If you haven't checked MS out you should. Powerful stuff.
That's my reason for wanting this. I have a mode to start exhibition when plugged into a wall charger. But I have only been able to get it to launch into the preferences scene. Are you saying its possible to launch directly into exhibition mode?

-- Sent from my Palm Pre using Forums
kbrabble is offline   Reply With Quote
Old 04/30/2011, 04:39 AM   #7 (permalink)
Member
 
Posts: 6
Quote:
Originally Posted by appsotutely View Post
Here's the patch ... give it a try and please confirm it works properly. After I get a couple of confirmations, I'll submit it to the Patch Portal.

Update: This is only for webOS 2.1.0
I can't install this patch ,
it said:
Error
patch installation failed.
unable to connect to webos-internals' servers.
Cannot download AUPT scripts for the patch.

=========
and how can i do?
============

Edit: when I connect the wifi, it install success. Thanks very much. It works very well.

but ,could you please set a shortcut on launcher which can start exhibition only?

Last edited by hcketw; 04/30/2011 at 04:46 AM.
hcketw is offline   Reply With Quote
Old 05/02/2011, 11:10 AM   #8 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
Quote:
Originally Posted by hcketw View Post
could you please set a shortcut on launcher which can start exhibition only?
I'm not sure what you are asking for here? If you tap the Exhibition app's icon, it launches to the Exhibition Preferences screen. With this patch, it just autostarts into the Exhibition mode immediately. If you exit Exhibition mode, then the Exhibition Preferences screen reappears.

The patch is now available in Preware and I'll look to "Tweak" it in a later update.
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Old 05/03/2011, 10:08 AM   #9 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
The tweak-able version is now available.
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Old 05/17/2011, 06:52 AM   #10 (permalink)
Member
 
laingman's Avatar
 
Posts: 2,320
I installed the patch from preware but exhibition still launches to the preferences scene. Any suggestions? Even after full reset.

Last edited by laingman; 05/17/2011 at 07:20 AM.
laingman is offline   Reply With Quote
Old 05/17/2011, 08:46 AM   #11 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
Quote:
Originally Posted by laingman View Post
I installed the patch from preware but exhibition still launches to the preferences scene. Any suggestions? Even after full reset.
It should start at the Preferences scene and then a split second later launch into Exhibition mode. It's now Tweaks enabled, so if you have that installed, can you confirm that it is enabled there as well? If it's not working after all that, please confirm what your device, carrier, and webOS version and I'll check later to see if I can replicate the issue.
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Old 07/03/2011, 04:12 AM   #12 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
I just submitted the 3.0.0 version which will work with the TouchPad (and is again Tweaks-enabled).
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Thanked By: dseeto
Old 09/02/2011, 08:43 AM   #13 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
Here's the webOS 2.2.0 version for you Pre3 users. Please confirm that it works fine. I can post the config file for Tweaks as well (if there's interest), but that requires some manual work with something like Internalz Pro to get working.
Attached Files
File Type: patch autostart-exhibition-v2.2.0.patch (926 Bytes, 5 views) Email Attachment
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Thanked By: bethel95
Old 09/06/2011, 09:47 AM   #14 (permalink)
Member
 
Posts: 8
Quote:
Originally Posted by appsotutely View Post
It should start at the Preferences scene and then a split second later launch into Exhibition mode. It's now Tweaks enabled, so if you have that installed, can you confirm that it is enabled there as well? If it's not working after all that, please confirm what your device, carrier, and webOS version and I'll check later to see if I can replicate the issue.
This also happened to me. So I went into 'Tweaks' and toggled the auto start from Yes to No. and then it worked.
Thanks appsotutely.
dseeto is offline   Reply With Quote
Old 10/08/2011, 08:43 PM   #15 (permalink)
Member
 
Posts: 290
I installed the patch from preware catalog for my touchpad. It somehow decreased the sensitivity of the touch screen. I'm a finicky user so I can feel the obvious difference before and after I removed the patch.
matchqq is offline   Reply With Quote
Old 10/08/2011, 11:52 PM   #16 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
Quote:
Originally Posted by matchqq View Post
I installed the patch from preware catalog for my touchpad. It somehow decreased the sensitivity of the touch screen. I'm a finicky user so I can feel the obvious difference before and after I removed the patch.
And you're certain it wasn't the Luna Restart that made your TP more responsive?
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Old 10/09/2011, 04:56 AM   #17 (permalink)
Member
 
Posts: 290
Quote:
Originally Posted by appsotutely View Post
And you're certain it wasn't the Luna Restart that made your TP more responsive?
no, it shouldn't be. I tried restart the device before I removed the patch several times to see if it would fix it and that didn't help. And I know the decreased sensitivity happened after I installed the patch.
matchqq is offline   Reply With Quote
Old 01/12/2012, 07:59 PM   #18 (permalink)
Member
 
appsotutely's Avatar
 
Posts: 636
The 3.0.4 version of this patch also works as is for 3.0.5.
__________________
Appsotutely's Apps & Patches:
Paid: Slide RSS | Multi Pane | Trip Traq BART | Wall Switch | Slide Master
Free: Pane Free | Trip Traq HBLR | Nightstand
Twitter: @appsotutely
Paypal: Tip Jar
appsotutely is offline   Reply With Quote
Old 02/12/2013, 08:43 AM   #19 (permalink)
Member
 
bethel95's Avatar
 
Posts: 468
I just installed the patch from Preware on my Pre3 (2.2.4). After installation and a Luna restart, it didn't work, so I tried a full restart--no joy. Next I checked Tweaks to verify that it was turned on (look under System). The tweak was on, but just out of curiosity I turned it off and back on again. The patch immediately began to work as advertised.

I don't know if this is a Pre3 issue, something particular to 2.2.4 (or 2.x), or if it's universal, but if you can't get the patch to work on your device, it's worth a try.
__________________

Tungsten E, Treo 650, Pre+ (3), Preł (2), TouchPad (2), & my trusty Treo BT headset (in use!)
Posts: Save/Restore Backup Process & Batch File | Activated! (Verizon Preł Activation) | "Not Enough Space To Download" Fix
bethel95 is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0