webOS Nation Forums >  Homebrew >  webOS Patches > [Patch Request] Disable Captive Portal detected on Wifi <<Webos 2.1>>
[Patch Request] Disable Captive Portal detected on Wifi <<Webos 2.1>>
  Reply
 
Thread Tools Display Modes
Old 03/02/2011, 02:05 PM   #1 (permalink)
Member
 
Posts: 48
Dear all,

Its frustrating to get the same message - "Captive Portal Detected on Wifi" message again and again. Is there a way to disable this notification? it would be ideal if the vibration and screen on notification could be disable.

Thanks everyone.

Cheers,
gmoj1
gmoj1 is offline   Reply With Quote
Thanked By: leonray
Old 03/02/2011, 02:37 PM   #2 (permalink)
Member
 
Jonathan I Ezor#IM's Avatar
 
Posts: 563
Agreed--my school's multi-point Wi-Fi network means that, even if I'm signed in, it keeps triggering these notifications as I walk around the building. {Jonathan}
__________________
Prof. Jonathan I. Ezor
Writer, PreCentral
Past Palm Real Reviewer
@webOSquire on Twitter
Jonathan I Ezor#IM is offline   Reply With Quote
Old 03/03/2011, 09:04 AM   #3 (permalink)
Member
 
Posts: 17
the same with me, tks anyone who can make this work.
andyghost is offline   Reply With Quote
Old 03/07/2011, 04:20 PM   #4 (permalink)
Member
 
Posts: 48
Doesn't anybody else find it disturbing? i believe it is one of the worst feature implemented with webos2.1
gmoj1 is offline   Reply With Quote
Old 03/07/2011, 09:23 PM   #5 (permalink)
webOS Enthusiast
 
Abyssul's Avatar
 
Posts: 2,119
Doesn't even work for my school. Hitting the notification opens a network app that just displays the palm web page. It gives me a message to dismiss the app and I still can't connect.
__________________


If I helped you or you have downloaded one of my files,
then least you could do is click the "Thanks" button.
Abyssul is offline   Reply With Quote
Old 03/07/2011, 11:57 PM   #6 (permalink)
Member
 
rsanchez1's Avatar
 
Posts: 1,840
It's working just fine for me, only displaying the notification when I'm not logged in.

Maybe your schools' networks don't like your webOS devices.

-- Sent from my Palm Pre using Forums
__________________
Grav - Canvas-based Gravity Simulation
rsanchez1 is offline   Reply With Quote
Old 03/08/2011, 12:28 AM   #7 (permalink)
Member
 
Posts: 79
Yes, is there no way to disable this? It can be extremely annoying walking around campus.
wesleymarin is offline   Reply With Quote
Old 03/10/2011, 04:43 PM   #8 (permalink)
Member
 
Posts: 48
its extremely frustrating to have the same notification when moving from one wifi zone to the next.
gmoj1 is offline   Reply With Quote
Old 03/11/2011, 05:44 PM   #9 (permalink)
Member
 
Posts: 2
Anyone help!!!

-- Sent from my Palm Pre using Forums
buddy34 is offline   Reply With Quote
Old 03/15/2011, 07:11 PM   #10 (permalink)
Member
 
Posts: 33
I had this issue. I have an unlocked Pre 2 and it is activated on TMobile. Well the captive portal kept coming on even with my wifi on. It kept detecting the tmobile page to pay for a days worth of internet access.

It was a major PIA. I usually left the app running in the background. Anyway I located the app using internalz and the linux console. I renamed the app-assistant.js file to essentially break the app. It now no longer comes up LOL. I think a good 'patch' would be to disable the notification alert from the app... Less invasive. I wish I knew how to write patches, I will research it more. Let me know if anyone wants me to post the location of the captive portal app. Hopefuly this wont make my phone explode
thfcme is offline   Reply With Quote
Old 03/15/2011, 11:47 PM   #11 (permalink)
Member
 
Posts: 33
I have made a patch, although I haven't tested it completely. All it does is comment out the 'dashboard notification' for captivate portal. Ive attached it, but please be cautious. I don't know how to get it on preware or anything, I had to use the WebOS quick installer app.
Attached Files
File Type: patch captive.patch (1.2 KB, 247 views) Email Attachment
thfcme is offline   Reply With Quote
Old 03/16/2011, 12:00 AM   #12 (permalink)
Member
 
mamouton's Avatar
 
Posts: 5,719
How to post patches to preware.

webOS-Patches Web Portal
__________________
My contributions to customizing the Palm Pre.

Browser Mega Mix|Email Mega Mix|Additional Sync Days|
Disable Various Phone Sounds|Priority Discard Buttons|

Sign up for SugarSync Get 500MB extra space
Sign up for Dropbox Get 250MB extra space
mamouton is offline   Reply With Quote
Thanked by Cantaffordit, thfcme
Old 03/16/2011, 02:59 AM   #13 (permalink)
Member
 
Posts: 33
Well how cool is that! I shall submit it, thanks!
thfcme is offline   Reply With Quote
Old 03/16/2011, 10:05 PM   #14 (permalink)
Member
 
Posts: 33
The patch has been approved and will be in preware soon. Thats awesome! I'll be looking for my check from HP for making such a complex patch.
thfcme is offline   Reply With Quote
Thanked By: fiendracer
Old 03/17/2011, 09:58 AM   #15 (permalink)
Member
 
Posts: 66
Just installed it from Preware-

Thanks thfcme!
JimmyK is offline   Reply With Quote
Old 03/17/2011, 11:31 AM   #16 (permalink)
Member
 
Posts: 66
OK- playing with this @ Starbucks... Without the notification being tapped your phone will not automatically sign into wifi. I had to turn off data to force wifi to access the captive portal.

So be aware if your watching your data usage! But it's great not having this notification going off every two minutes.

Thanks again for the patch!
JimmyK is offline   Reply With Quote
Old 03/17/2011, 05:08 PM   #17 (permalink)
Member
 
Posts: 33
Hi Jimmy

I guess it operates more like a 1.4.5 device now, where you had to force between modes.

I wonder if an improvement would be to offer the option to show the alert just once, and not over and over again.. I have to admit it was driving me crazy, thats why I searched for the app on the phone.
thfcme is offline   Reply With Quote
Old 03/23/2011, 07:16 PM   #18 (permalink)
Member
 
Posts: 79
so if I have an unlocked ATT pre+ and using it with T Mobile and I keep getting this Captive Portal message, if i apply the patch, Do I have to look out for my data usage? (Since t-mobile dont have same 3G frequency as ATT?)

***I'm only using wifi***

Last edited by JanJan; 03/23/2011 at 08:44 PM.
JanJan is offline   Reply With Quote
Old 03/23/2011, 07:18 PM   #19 (permalink)
Member
 
Posts: 176
i thought it was one of the coolest things in 2.0...
prebulls is offline   Reply With Quote
Old 03/23/2011, 07:22 PM   #20 (permalink)
Member
 
Posts: 33
Quote:
Originally Posted by JanJan View Post
so if I have an unlocked ATT pre+ and using it with T Mobile and I keep getting this Captive Portal message, if i apply the patch, Do I have to look out for my data usage? (Since t-mobile dont have same 3G frequency as ATT?)
I'm afraid I have no idea. All the patch does is disable the alert - which was happening constantly for me. If you are feeling hesitation about any patch; then you should not install it.
thfcme is offline   Reply With Quote
Reply

 

Tags
captive protal

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0