Page 1 of 3 123 LastLast
Results 1 to 20 of 60
Like Tree3Likes
  1. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #1  
    For webOS 2.1.0 only. Verified by traviscurren (Post #20) to finally work!! :-)

    Used the code found on webos-internals.org to create this patch while expanding upon it.

    Features:
    - A setting in messaging preferences to open conversations in a new window.
    - Improved over previous iterations in that notifications will use new window or open new window as needed and opened windows don't force themselves to focus. Great for webOS 2.1's stacks.

    Known bugs (I hope to fix these when I have time but it is still worth having even with them):
    - When composing a new message or launching from Just Type/Contacts, opens conversation in main messaging window
    - When opening from "Buddies" list (GChat, AOL, etc), doesn't select that account to send
    - When two or more messages have come in, clicking on the left portion of the dashboard brings up the last person to text's window rather than the message list

    This updated patch has been submitted to Preware but not yet released. If coming here from Preware, please use this patch (not the one in Preware) until it's updated. Thanks!

    Let me know what you guys think and if there are any issues.

    Thanks to JayCanuck for his UnifiedDiffCreator and webOS Internals for all they do!


    Note to HPalm: Feel free to implement this feature in future webOS versions. :-)
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by estockda; 03/01/2011 at 10:37 AM.
  2. #2  
    Just tried it out. Doesn't work for me. Preferences doesn't open and my convos don't open. Not sure what else I can tell you to help you out...
  3. weedalin's Avatar
    Posts
    50 Posts
    Global Posts
    51 Global Posts
    #3  
    Yep, this patch completely broke Messaging for me too, even with no other Messaging patches installed.
  4. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #4  
    Hrm... perhaps it's because I have a few messaging patches installed that it works.

    For messaging, I have "History Chat Balloon Color" and "Timestamps Clean"
    If you install those first, does it work?

    I'm new to patching... Is there anyone out there with experience on how to find out if patches are conflicting and, further, make them not conflict with each other?

    @Croathlete and @weedalin, I take it there was no ipkg error on install? I think that would be the first sign of them conflicting. Also, what version are you running? This patch is only for 2.1.0.

    Tonight I'll remove all patches and see if I can get it to work.
  5. weedalin's Avatar
    Posts
    50 Posts
    Global Posts
    51 Global Posts
    #5  
    No .ipk install error. Tried it with History Balloon Color, then without anything. Same result. I'll try it with History plus Timestamps later today.

    Edit: Nope, History + Timestamps doesn't work either.

    Running 2.1.0 on a Verizon Pre Plus.
    Last edited by weedalin; 02/28/2011 at 11:29 AM.
  6. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #6  
    Quote Originally Posted by weedalin View Post
    No .ipk install error. Tried it with History Balloon Color, then without anything. Same result. I'll try it with History plus Timestamps later today.

    Edit: Nope, History + Timestamps doesn't work either.

    Running 2.1.0 on a Verizon Pre Plus.
    Thanks for verifying. I'll remove all my patches tonight and make sure my messaging app is clean to see what I can find.

    I actually need to do this anyway to take a few screenshots so if I can uncover a bug in the process, two birds with only one stone!
  7. #7  
    Same here. No previous patches installed and no install errors. Running on a Sprint Pre-, webOS 2.1.
  8. drvon#AC's Avatar
    Posts
    67 Posts
    Global Posts
    72 Global Posts
    #8  
    Didn't work for me as well, but I will wait cause this is such a cool / needed patch.
  9. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #9  
    Ok guys.. I sincerely apologize for the error. I forgot to include the diff from the messaging-prefs.jsjsjs $file$. $I$'$ve$ $updated$ $the$ $original$ $post$ $with$ $the$ $corrected$ $patch$ $file$ $and$ $added$ $a$ $screenshot$!

    I'll also be re-submitting to Preware.
  10. #10  
    Still a no-go. Same behavior as before...Chats don't open up and preferences still don't open.
  11. #11  
    same behavior for me preferences won't open it pops up and goes away quickly
  12. #12  
    Same as everyone else. It seems to open preference and messages and then closes right away. I like the thought of this patch and when you get it working I bet it will be a huge hit.

    Good luck.

    ps.
    Sprint pre - Webos 2.1
    No Messaging patches
    Sprint pre -> Motorola Photon 4G
  13. #13  
    It would be great if someone can write them into Synergy services.
  14. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #14  
    Thanks for all the feedback and encouragement!

    I pulled the messaging files out of the doctor to be sure I had the original files and didn't accidentally modify one without keeping track (like I did the first time).

    When comparing that with what was on my phone, they were identical. Just to be sure I removed any messaging patches and overwrote the messaging files from the doctor onto my phone. Then I applied the updated patch in the OP (the one in Preware hasn't been updated yet... submitted but not yet approved) and it works.... So I'm stumped. I swear it's working on my phone. Even added a new screenshot of the preferences.

    Anyone have any ideas?
  15. drvon#AC's Avatar
    Posts
    67 Posts
    Global Posts
    72 Global Posts
    #15  
    Preware hasn't been updated yet so people will be still downloading yesterday's patch that wasn't working.
  16. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #16  
    Quote Originally Posted by drvon View Post
    Preware hasn't been updated yet so people will be still downloading yesterday's patch that wasn't working.
    I can see that happening. Can you verify the patch in the OP is working?

    Is there anyone else that has tried?

    Hopefully Preware will be updated soon but until then use this patch in the OP.
  17. #17  
    Quote Originally Posted by estockda View Post
    I can see that happening. Can you verify the patch in the OP is working?

    Is there anyone else that has tried?

    Hopefully Preware will be updated soon but until then use this patch in the OP.
    Patch in OP not working for me either. Just tried it now. Sprint Pre- with 2.1.0.
  18. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #18  
    Quote Originally Posted by traviscurren View Post
    Patch in OP not working for me either. Just tried it now. Sprint Pre- with 2.1.0.
    I think I figured out what's happening. The new patch is 7.7K but the forums are delivering the old 6.8K patch, for whatever reason, even though it lists the new 7.7K patch. The version of the patch should be 2.1.0-2.

    I'm attaching the updated file here and will try to get the OP to be the correct one as well.
    Attached Files Attached Files
  19. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #19  
    Quote Originally Posted by estockda View Post
    I think I figured out what's happening. The new patch is 7.7K but the forums are delivering the old 6.8K patch, for whatever reason, even though it lists the new 7.7K patch. The version of the patch should be 2.1.0-2.

    I'm attaching the updated file here and will try to get the OP to be the correct one as well.
    I deleted the file in the OP, submitted, re-upped it, and finally submitted again. It finally seems to be working. Sorry for all the trouble and thanks for the feedback!
  20. #20  
    Quote Originally Posted by estockda View Post
    I think I figured out what's happening. The new patch is 7.7K but the forums are delivering the old 6.8K patch, for whatever reason, even though it lists the new 7.7K patch. The version of the patch should be 2.1.0-2.

    I'm attaching the updated file here and will try to get the OP to be the correct one as well.
    This patch works! Thanks!
Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions