Page 3 of 3 FirstFirst 123
Results 41 to 60 of 60
Like Tree3Likes
  1. estockda's Avatar
    Posts
    84 Posts
    Global Posts
    97 Global Posts
       #41  
    Quote Originally Posted by Sanglant View Post
    When I have a conversation open and I get a new message, the patch is opening another card for the same convo. Is there any way to fix that?
    This is actually the first listed of the Known Bugs in the OP:
    - When composing a new message or launching from Just Type/Contacts, opens conversation in main messaging window
    Each card has a name. The main messaging app (including new messages or those launched from Just Type/Contacts is called messaging. All others are named message + a chat id used internally by webOS. So one of the open conversations (the first one.. not the one opened by the dashboard) is the main messaging app. The difference between the two is that you'll be able to use the back gesture on the main app to get back to the conversation view. On the one launched from the dashboard in it's own window, the back gesture zooms out to the card view.

    What I hope to do is have Just Type/Contacts launch in their own card (named messaging+chat id) and to have newly composed chats work like email where after you send it goes back to the list of conversations rather than load that user's chat history. This will make it more seamless and prevent two cards from having the same conversation.

    Hope this clears up the confusion.
  2. #42  
    I updated to 2.1 and now can't download it from prepared give ipkg log can't install it. Please help
  3. #43  
    this is my ipkg log file:



    Begin
    Nothing Interesting.
    Download
    % Total % Received % Xferd Average Speed Time Time Time Current
    9 12828 9 1182 0 0 1222 0 0:00:10 --:--:-- 0:00:10 6253
    100 12828 100 12828 0 0 9340 0 0:00:01 0:00:01 --:--:-- 21559
    Identify
    org.webosinternals.patches.messaging-advanced-new-card-per-convo
    Install
    {"returnValue":true , "ticket":12, "subscribed":true}
    { "ticket":12 , "status":"STARTING" }
    { "ticket":12 , "status":"CREATE_TMP" }
    { "ticket":12 , "status":"VERIFYING" }
    { "ticket":12 , "status":"IPKG_INSTALL" }
    { "ticket":12 , "status":"SUCCESS" }
    Mkdir-Prerm
    Nothing Interesting.
    Install-Prerm
    Nothing Interesting.
    Postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.messaging-advanced-new-card-per-convo.postinst 2>&1
    3 out of 5 hunks FAILED -- saving rejects to file usr/palm/applications/com.palm.app.messaging/app/controllers/prefsAccountSummary-assistant.jsjsjs.$rej$
    2 out of 2 hunks FAILED -- saving rejects to file usr/palm/applications/com.palm.app.messaging/app/models/messaging-prefs.jsjsjs.$rej$
    Remove
    Removing package org.webosinternals.patches.messaging-advanced-new-card-per-convo from root...
    (offline root mode: not running org.webosinternals.patches.messaging-advanced-new-card-per-convo.prerm)
    Delete
    Nothing Interesting.
    Failed
    Nothing Interesting.


    -- Sent from my Palm Pre
  4. #44  
    It looks like you still have a patch that us affecting the message app. Have you installed sconix's patch?


    Sent from my iPod touch using Tapatalk
  5. #45  
    I just removed the advance system press messaging prefs patch and it works now, that's strange one is for cards and the other for sound and I now cant install the advance one looks like they don't get along. They should work on this.
  6. #46  
    This is a great patch and I do hope this comes to a future version of webOS. GREAT WORK!
  7. #47  
    Quote Originally Posted by joek71 View Post
    I just removed the advance system press messaging prefs patch and it works now, that's strange one is for cards and the other for sound and I now cant install the advance one looks like they don't get along. They should work on this.
    Sconix said he will try to integrate it in his message patch once mode switcher is finished


    Sent from my iPod touch using Tapatalk
  8. schlk21's Avatar
    Posts
    775 Posts
    Global Posts
    776 Global Posts
    #48  
    Is there a way to code the patch so that all the messaging cards stay together? If I open a text from the notification it will open in its own location
    VZW Pre 2 on 2.1

    Thanks webOS Internals!

    @thereddestdog
  9. daletorr's Avatar
    Posts
    11 Posts
    Global Posts
    12 Global Posts
    #49  
    any chance anyone can make this available for the HP Pre 3 users????? Please?

    this is an awesome patch.. i had it on my Pre 2 before I sold it for a Pre 3.
    2nd_Street likes this.
  10. #50  
    Second that..

    a Pre3 porting would be great
  11. #51  
    For those users with a Pre 3 you can install Sconix's Advanced patches to get similar functionality.
  12. #52  
    Quote Originally Posted by Nightburn View Post
    For those users with a Pre 3 you can install Sconix's Advanced patches to get similar functionality.
    I installed the advanced system prefs for messages and it does not have a function like opening messages in a new tab
  13. daletorr's Avatar
    Posts
    11 Posts
    Global Posts
    12 Global Posts
    #53  
    Quote Originally Posted by Nightburn View Post
    For those users with a Pre 3 you can install Sconix's Advanced patches to get similar functionality.
    which one of Sconix Advance patches should we install on a Pre 3 to get the "new card per conversation messaging" feature????????
  14. #54  
    You need 2 patches and the app "Tweaks"

    • Advanced System Prefs - Framework (ATT/VZW)
    • Advanced System Prefs - Messaging Prefs (ATT/VZW)


    After installation, launch tweaks to enable multi cards per convo and luna reboot of course.
    2nd_Street likes this.
  15. #55  
    Thanks for your fast reply Nightburn!

    I got a little problem getting tweaks to recognize the ASPs. I have installed them but in tweaks, it only shows me 4 items under system and 3 items under topbar. All other categories (email, calendar, message, etc.) are greyed-out. Any idea why that is?
  16. #56  
    Quote Originally Posted by 2nd_Street View Post
    Thanks for your fast reply Nightburn!

    I got a little problem getting tweaks to recognize the ASPs. I have installed them but in tweaks, it only shows me 4 items under system and 3 items under topbar. All other categories (email, calendar, message, etc.) are greyed-out. Any idea why that is?

    Ah. It turns out the only patch you really need is "Advanced System Behavior" and tweaks.. sorry about that.
  17. #57  
    Quote Originally Posted by Nightburn View Post
    Ah. It turns out the only patch you really need is "Advanced System Behavior" and tweaks.. sorry about that.
    cant install advanced system behaviour :-( "error installing"...

    IPKG-LOG: saving reject to file usr/palm/applications/com.palm.app.messaging/app/controllers/chatview-assistant.jsjsjs.$rej$

    I guess you are not the maintaner of that patch, do you know whom I should talk to about it?

    And thanks for your help :-)

    EDIT: Nevermind...there was a conflict with the "timestamps in messages" patch :-) after deleting that patch, I was able to install the advanced system behaviour patch and now I fully access the "tweaks"
    Last edited by 2nd_Street; 10/12/2011 at 04:17 PM.
  18. #58  
    Quote Originally Posted by Nightburn View Post
    Ah. It turns out the only patch you really need is "Advanced System Behavior" and tweaks.. sorry about that.
    Been racking my brain all morning trying to figure out what I was missing from Pre2 to Pre3 to get this back.
    I love physical keyboards... but there is two devices that would make me consider a slab, one is something running a full version of Open webOS. The other is an iPhone!!!! HA HA just kidding (about the iPhone that is)...
  19. #59  
    For what it's worth, this patch works just fine on a Pre 3. It has less collisions than Sconix's ASB with other patches, and it doesn't "roulette" when you hit dashboard notifications.
  20. #60  
    Thanks to Rnp for pointing out this patch. It does work on the Pre3. I couldn't find the patch in Preware, but I downloaded from the first post and installed with WEBOSQI. Works great!
    Rnp likes this.
Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions