Page 5 of 7 FirstFirst 1234567 LastLast
Results 81 to 100 of 128
Like Tree16Likes
  1. vimak's Avatar
    Posts
    55 Posts
    Global Posts
    56 Global Posts
    #81  
    could I possibly use the open DNS instead of google or virginmobile?
    Last edited by vimak; 09/19/2011 at 04:02 PM.
  2. #82  
    Hi everyone, I just wanted to let you all know that I am in the process of writing an application for the TouchPad, that will allow you to save your adhoc settings and start adhoc mode. It's based closely on the scripts contained within this thread, so thanks to everyone for working on those.

    This is a learning exercise for me as I have never developed a webOS application before. I don't have a lot of spare time to work on this, but i wanted to let people know in case someone else was also working on something similar. I can't yet give you an ETA, but hopefully in a week or two I should have something usable.

    Here's a couple of screen shots to show how it will probably look.

    --
    bedrock
    Attached Images Attached Images
  3. #83  
    anything that can help would be great! thanks bedrock for the time and effort to make something
    Touchpad, webOS 3.0.2, f15c eagle 1.728GHz
    iPhone 3GS 4.3.3 jailbroken
  4. vimak's Avatar
    Posts
    55 Posts
    Global Posts
    56 Global Posts
    #84  
    Quote Originally Posted by bedrock View Post
    Hi everyone, I just wanted to let you all know that I am in the process of writing an application for the TouchPad, that will allow you to save your adhoc settings and start adhoc mode. It's based closely on the scripts contained within this thread, so thanks to everyone for working on those.

    This is a learning exercise for me as I have never developed a webOS application before. I don't have a lot of spare time to work on this, but i wanted to let people know in case someone else was also working on something similar. I can't yet give you an ETA, but hopefully in a week or two I should have something usable.

    Here's a couple of screen shots to show how it will probably look.

    --
    bedrock
    This is great intiative from you mate. I only have an one issue that everyone is not able to connect using the scripts already mentioned in this thread because those scripts are not really making TP ready as a ad-hoc wifi, are programming to unlock the native ad-hoc support that used to be part of Webos once upon a time?
  5. vimak's Avatar
    Posts
    55 Posts
    Global Posts
    56 Global Posts
    #85  
    I could connect TP to Nokia n900 but the connection did not stay for more than a second. Not sure why TP could not stay connected.

    On N900 today I used QtMobileHotSpot rather than Mobile Hotspot which was not working for me.

    Followed the same instructions mentioned in the forum.
  6. #86  
    still hoping to bring life to my brick!
    Touchpad, webOS 3.0.2, f15c eagle 1.728GHz
    iPhone 3GS 4.3.3 jailbroken
  7. #87  
    Quote Originally Posted by roymcd View Post
    Apologies for the delayed followup. Here are the 2 scripts. Note that the browser definitely works but other apps don't seem to. However, I can see the DHCP lease get renewed every few minutes so connections are sustained and don't drop out. In answer to a previous question, I stop the PmWifiService to stop the webOS WiFi service from getting in the way. Other apps I've tried to start up when in ad hoc mode don't seem to believe that a network service is available for use when PmWifiService is down. I'll try to check this out a bit more when I can - it looks like there are some hooks in PmWifiService that might allow it to be modified.

    Maybe I'm using the wrong forum for this discussion but if none of this is making much sense to you then please wait until someone releases the patch/app that you can just install to get adhoc wifi working. All I am trying to do here is report on my attempts to get it working. Cheers.

    #!/bin/sh
    # startadhoc
    /sbin/stop PmWiFiService
    modprobe ar6000
    ifconfig eth0 up
    iwconfig eth0 mode ad-hoc essid "5800_Xpres_JoikuSpot_XXXXXXXXXX" power off
    dhclient eth0
    #The virginmobile dns server is 61.88.88.88?
    echo "nameserver 61.88.88.88" >> /etc/resolv.conf

    #!/bin/sh
    # stopadhoc
    # restore default resolv.com
    echo "nameserver 127.0.0.1" > /etc/resolv.conf
    /sbin/start PmWiFiService


    Hi, are you able to confirm if this will work with an encrypted hotspot?

    This guide looks like it may be useful:

    Connect to a wireless network via command line
  8. #88  
    Quote Originally Posted by AcapulcoRolf View Post
    Hi, are you able to confirm if this will work with an encrypted hotspot?

    This guide looks like it may be useful:

    Connect to a wireless network via command line
    From what I'm reading it seems that in order to connect to a WPA encrypted hotspot wpa_supplicant needs to be used

    This guide seems to give the detail on how to do this:

    http://www.linuxfromscratch.org/hint...pa-service.txt

    I've checked and can confirm that wpa_supplicant is available in the Touchpad Linux build...
  9. #89  
    Quote Originally Posted by AcapulcoRolf View Post
    From what I'm reading it seems that in order to connect to a WPA encrypted hotspot wpa_supplicant needs to be used

    This guide seems to give the detail on how to do this:

    http://www.linuxfromscratch.org/hint...pa-service.txt

    I've checked and can confirm that wpa_supplicant is available in the Touchpad Linux build...
    This seems to have been easier to get working than I expected (at least for my setup)

    I didn't have to resort to any Linux shell commands

    My setup:

    iPhone 4 (IOS 5 beta 7) - no jailbreak
    Phone Carrier: O2 UK
    Wifi hotspot: ad hoc WPA2 with passcode : AES encryption

    Touchpad: Uber-Kernel 3.0.2-52

    So far I can confirm that web browsing and email work as expected over the hotspot connection without issue
    Last edited by AcapulcoRolf; 10/06/2011 at 07:27 AM. Reason: added encryption properties to post
  10. #90  
    please release a patch for my touchBrick
    Touchpad, webOS 3.0.2, f15c eagle 1.728GHz
    iPhone 3GS 4.3.3 jailbroken
  11. #91  
    Quote Originally Posted by Rescuer View Post
    please release a patch for my touchBrick
    Have you had any success at all with the scripts posted in this thread?
    The app I am working on, is just a programatic approach to the same commands that are executed in the scripts. I have not found any new method, so it will not be any improvement I am afriad.
  12. #92  
    By no improvement I quite simply mean, if the scripts dont work for you, then my app probably wont help.

    I do currently have an alpha build (with debug logging etc...) please pm me if you are willing to test
    Last edited by berdinkerdickle; 11/19/2011 at 10:52 AM.
    b4gmen0t likes this.
  13. #93  
    Quote Originally Posted by roymcd View Post
    Apologies for the delayed followup. Here are the 2 scripts. Note that the browser definitely works but other apps don't seem to. However, I can see the DHCP lease get renewed every few minutes so connections are sustained and don't drop out. In answer to a previous question, I stop the PmWifiService to stop the webOS WiFi service from getting in the way. Other apps I've tried to start up when in ad hoc mode don't seem to believe that a network service is available for use when PmWifiService is down. I'll try to check this out a bit more when I can - it looks like there are some hooks in PmWifiService that might allow it to be modified.

    Maybe I'm using the wrong forum for this discussion but if none of this is making much sense to you then please wait until someone releases the patch/app that you can just install to get adhoc wifi working. All I am trying to do here is report on my attempts to get it working. Cheers.

    #!/bin/sh
    # startadhoc
    /sbin/stop PmWiFiService
    modprobe ar6000
    ifconfig eth0 up
    iwconfig eth0 mode ad-hoc essid "5800_Xpres_JoikuSpot_XXXXXXXXXX" power off
    dhclient eth0
    #The virginmobile dns server is 61.88.88.88?
    echo "nameserver 61.88.88.88" >> /etc/resolv.conf

    #!/bin/sh
    # stopadhoc
    # restore default resolv.com
    echo "nameserver 127.0.0.1" > /etc/resolv.conf
    /sbin/start PmWiFiService
    Hi I was able to get this to work by typing in your script lines into the XTerminal, but could y'all help this noob out by telling me how to make scripts out of these and run the scripts with one command?
  14. #94  
    My PM inbox is starting to get full of requests. I've had a few testers say it is working for them and a couple say it's not. I've also spoken with others who are taking a different approach altogether and working with wpa_supplicant...

    But for those who want to test further here is a beta release of my ad-hoc configuration tool, it doesn't really do anything different to what's in the scripts already posted here, so thanks to the various script authors for those.

    Code:
    http://nicbedford.co.uk/files/uk.co.nicbedford.adhoc_0.0.4_all.ipk
    I'm happy for feedback, but I'm not sure how much more time I want to spend on this project, seeing as others are working on better solutions, HP have updates in the pipeline(although I've not read anything to suggest that read ad-hoc support is going to be included in them) and android is now in sight (at least for those that want it!)
  15. vimak's Avatar
    Posts
    55 Posts
    Global Posts
    56 Global Posts
    #95  
    Quote Originally Posted by utamore View Post
    Hi I was able to get this to work by typing in your script lines into the XTerminal, but could y'all help this noob out by telling me how to make scripts out of these and run the scripts with one command?


    Lets try this way, if this doesnt work post back and I will attach script as text :

    PLEASE note this is not official or recommended way, this how I did and replicating steps, risk is all yours. If not comfortable then wait for and app to be released.

    Following steps in terminal :

    1. type vi startwifi.sh
    2. press i or a and hit enter (this should take you to next line, if it doesnt press i or a again
    3. paste the following (right click or shift insert whichever works on your terminal window)
    but make sure you replace "5800_Xpres_JoikuSpot_XXXXXXXXXX" with appropriate essid

    #!/bin/sh
    # startadhoc
    /sbin/stop PmWiFiService
    modprobe ar6000
    ifconfig eth0 up
    iwconfig eth0 mode ad-hoc essid "5800_Xpres_JoikuSpot_XXXXXXXXXX" power off
    dhclient eth0
    #The virginmobile dns server is 61.88.88.88?
    echo "nameserver 61.88.88.88" >> /etc/resolv.conf

    4. close file editing by doing following :
    - press esc
    - press colon ":"
    - type wq and enter

    5. chmod 777 startwifi.sh
    6. vi stopwifi.sh
    7. press i or a and hit enter
    8 . Paste the following in the vi

    #!/bin/sh
    # stopadhoc
    # restore default resolv.com
    echo "nameserver 127.0.0.1" > /etc/resolv.conf
    /sbin/start PmWiFiService

    9. Save and exit (esc --> : --> wq enter
    10 . cmod 777 stopwifi.sh

    to run scripts ./startwifi.sh or ./stopwifi.sh

    HTH.
  16. vimak's Avatar
    Posts
    55 Posts
    Global Posts
    56 Global Posts
    #96  
    My PM inbox is starting to get full of requests. I've had a few testers say it is working for them and a couple say it's not. I've also spoken with others who are taking a different approach altogether and working with wpa_supplicant...

    But for those who want to test further here is a beta release of my ad-hoc configuration tool, it doesn't really do anything different to what's in the scripts already posted here, so thanks to the various script authors for those.

    Code:
    http://nicbedford.co.uk/files/uk.co.nicbedford.adhoc_0.0.4_all.ipk
    Quote Originally Posted by bedrock View Post
    I'm happy for feedback, but I'm not sure how much more time I want to spend on this project, seeing as others are working on better solutions, HP have updates in the pipeline(although I've not read anything to suggest that read ad-hoc support is going to be included in them) and android is now in sight (at least for those that want it!)
    how do you know that there are updates coming and do you approx when? And Android, is this touch droid you are talking of?
  17. #97  
    Quote Originally Posted by vimak View Post
    how do you know that there are updates coming and do you approx when? And Android, is this touch droid you are talking of?
    HP updates as in the 3.0.3/3.0.4 that people keep talking about, i wont discuss these any further.

    Android as in CM7.1.0 alpha 1 that was released this morning
  18. skymann's Avatar
    Posts
    14 Posts
    Global Posts
    15 Global Posts
    #98  
    It works with my Samsung i920 running windows mobile 6.x and wmwifirouter. I get message that there is no internet connection but I disregard them cause it works. Posted using ad-hoc connection. Just checked - no email and dropping connection. I am not sure if connection is a problem with TP or phone. I think it is the phone
    Last edited by skymann; 10/17/2011 at 02:11 AM.
  19. #99  
    Quote Originally Posted by bedrock View Post
    My PM inbox is starting to get full of requests. I've had a few testers say it is working for them and a couple say it's not. I've also spoken with others who are taking a different approach altogether and working with wpa_supplicant...

    But for those who want to test further here is a beta release of my ad-hoc configuration tool, it doesn't really do anything different to what's in the scripts already posted here, so thanks to the various script authors for those.

    Code:
    http://nicbedford.co.uk/files/uk.co.nicbedford.adhoc_0.0.4_all.ipk
    I'm happy for feedback, but I'm not sure how much more time I want to spend on this project, seeing as others are working on better solutions, HP have updates in the pipeline(although I've not read anything to suggest that read ad-hoc support is going to be included in them) and android is now in sight (at least for those that want it!)
    This app looks great but I'm having an issue with it. I can connect to my Droid X2 via wifi hotspot, but when i try to go to a website, it repeatedly tells me I am not connected to the internet. I have tried deleting all my wifi profiles. What do I put in the DHP lines? Thanks.
  20. skymann's Avatar
    Posts
    14 Posts
    Global Posts
    15 Global Posts
    #100  
    More challenges to stable connection. The connection does not work after a short while. I thought it was my phone so I tried to connect my laptop and TP at the same time through wmwifi router. It worked well for as long as I had both going. When I turned off the laptop the connection to the web dropped on my TP after a minute or so. Does my windows vista laptop send some consistent data keeping my connection alive that the TP doesn't?
    Last edited by skymann; 10/21/2011 at 02:21 PM.
Page 5 of 7 FirstFirst 1234567 LastLast

Posting Permissions