Page 1 of 2 12 LastLast
Results 1 to 20 of 31
Like Tree1Likes
  1.    #1  
    As the name would suggest, this patch prevents your device from uploading logs. WebOS uploads a fair bit back to Palm. Crash logs, memory logs, application usage logs, etc.

    I made this patch months back, as some of my friends here at PreCentral can attest. However, due to the nature of this patch, both Rod Whitby and myself agreed I should keep it private and off the feed.

    Been a while since then and there's now various different ways to minimized or disable logging and uploading; notably the feature included such in MetaDoctor.

    So, I figured now is as good a time as ever to publicly post my patch for those who have been wanting an easy, AUPT-compatible patch to prevent log uploads to Palm.

    Besides privacy, there are reports that doing this will increase device responsiveness/speed.

    Worth noting, however, that those who signed the Palm User Agreement, would probably be violating it in some form. Also worth noting that the logs collected by Palm help them in bugfixes, analysis of crashes, etc.


    Much like my Ad Blocker patch, this is probably an ethical dilemma for some. So I'd like to state in advance, that I'm merely providing the patch, not forcing you to use it.
    Attached Files Attached Files
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
    Artichoke likes this.
  2. #2  
    hello Jason,

    This would not install for me,I get the unreversed patch error. Is there something else interfering w/ this one. Ive not installed any other patch that could cause this. ( i dont think anyway).

    thanks
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  3. #3  
    Does this patch do the same as this?

    http://forums.precentral.net/palm-pr...ds-up-pre.html

    Maybe that's why you got the unreversed patch detected if you've done this?
    Last edited by traviscurren; 08/01/2010 at 03:07 PM.
  4. #4  
    I get the same error and I did not try the "minimal logging" thing
  5. #5  
    Quote Originally Posted by traviscurren View Post
    Does this patch do the same as this?

    http://forums.precentral.net/palm-pr...ds-up-pre.html

    Maybe that's why you got the unreversed patch detected if you've done this?
    you are right that looks like it could cause the problem but like I said I didnt do that!
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  6. #6  
    Did it, and it went through for me. Thank you Jason.
  7. #7  
    Installed fine for me... through internalz...
  8.    #8  
    The only thing this would conflict with, is EOM, which I've only just learned about. Unfortunately, if you've used EOM, you may need to run WebOS Repair Utility to restore /etc/event.d/uploadd, as there's no way to uninstall it.


    Quote Originally Posted by traviscurren View Post
    Does this patch do the same as this?

    http://forums.precentral.net/palm-pr...ds-up-pre.html
    No, my patch is much more complete in blocking log uploads
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  9. #9  
    I was getting the same error. Did not use WebOS Repair Utility. I just went into an extracted doctor file and sent uploadd to /etc/event.d/ with WQIS, restarted Luna and it installed fine.

    Thanks again for the many mods you have provided.
  10. #10  
    Quote Originally Posted by Jason Robitaille View Post
    The only thing this would conflict with, is EOM, which I've only just learned about. Unfortunately, if you've used EOM, you may need to run WebOS Repair Utility to restore /etc/event.d/uploadd, as there's no way to uninstall it.



    No, my patch is much more complete in blocking log uploads
    Ive not used EOM so not sure why uploadd has ben modified? weird.

    Quote Originally Posted by arkieboy View Post
    I was getting the same error. Did not use WebOS Repair Utility. I just went into an extracted doctor file and sent uploadd to /etc/event.d/ with WQIS, restarted Luna and it installed fine.

    Thanks again for the many mods you have provided.
    This worked for me thanks.
    Last edited by 2sslow; 08/02/2010 at 12:05 AM.
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  11. #11  
    Does this affect the Palm Profile Backup?
  12.    #12  
    Quote Originally Posted by sethron View Post
    Does this affect the Palm Profile Backup?
    nope, all other palm services remain working as usual
  13. #13  
    So, this must be a coincidence?

    Edit:this IS a coincidence.
    Attached Images Attached Images
    Last edited by sethron; 08/03/2010 at 08:28 AM.
  14. #14  
    Quote Originally Posted by sethron View Post
    So, this must be a coincidence?
    I just did a back-up and it worked for me.
    PayPal Make a donation and/or hit the Thanks button please
    My home page. >>>>>CMCS<<<<

  15. #15  
    I get the same message as sethron. It says preparing for about 1 minute and then pops up with your backup will complete when server is available.

    I uninstalled patch and still can't backup so it must be another conflict. I will wait until 1.4.5 to worry about.
    Last edited by mamouton; 08/02/2010 at 09:45 PM.
  16. #16  
    mine backed up but I had to do it manually. It did not auto backup after I installed this. I still love the patch and the effort!
    thanks!
  17. #17  
    Just installed the patch, thanks ! (backup working fine)
  18. #18  
    Jason, since the patch creates a backup of the uploadd file in the same event.d directory, won't it still try to launch the service using the backup file at boot?
  19. jeckert21's Avatar
    Posts
    48 Posts
    Global Posts
    51 Global Posts
    #19  
    This is very interesting, after installing the patch I would periodicly loose Spint connection. I would have to toggle the Sprint Only and Automatic a few times and then restart the device to get signal again. This would happen a couple times per day. Very strange, once I uninstalled the patch I have had no more issues. Has anyone else seen this happen? Jason, what do you think?
  20. jeckert21's Avatar
    Posts
    48 Posts
    Global Posts
    51 Global Posts
    #20  
    Oh yes, by the way; backup worked just fine. I saw no other issues at all.
Page 1 of 2 12 LastLast

Posting Permissions