Results 1 to 10 of 10
  1.    #1  
    I'm using a Palm Pre Plus on AT&T, and I was installing a few interesting patches. I wanted to try the Scrims Multi but couldn't find an AT&T-specific version (and the normal V2 didn't work because I don't have SprintNav) so I installed the Verizon version since it didn't ask about SprintNav at all. It seemed to install fine, so I did a luna restart to see what it looked like. Turns out, it COMPLETELY destroyed my Phone app (turning the entire thing into a string of numbers and text that scroll downwards with a white background). So I tried uninstalling it but it keeps throwing up an error saying it found "unreversed patch[s] detected" in the photos, phone, and youtube apps. I tried uninstalling through WOSQI as well but it couldn't remove it either. Then I tried the WebOS Repair Utility, but because I have an AT&T Pre+ it won't recognize my correct version of WebOSDoctor so it won't even do a SCAN to see if anything is wrong!

    I'm getting desperate here, considering I kind of need the Phone app to be working. I'd really rather not do a full reset of the device, but I could live with removing all the patches (and having to reinstall them myself) but that would take a while (I have something like 80 patches right now).

    Can anyone drop some wisdom on how I can fix this?? Anything is appreciated. Thank you for your time.
  2. #2  
    Maybe you should have asked the dev? Oh wait thats me!

    First off, its not possible for this patch to do what you are describing. you obviously are conflicting w/ something else you installed. My bet is you installed a Theme that has embedded patches.

    Are you using a theme? if you are REMOVE THE THEME first. Most themes have patches embedded in them and regularly affect patches if installed after?
    2 similar patches cant occupy the same space.

    If theme removal doesnt work youll need to run EPR, that works 90% of the time. Worst case youll have to Dr.

    For future reference go to the official thread when you are having problems, You were just lucky I was scanning the new post and just happened to find this.


    BTW I have not tested this on AT&T, The verizon or o2 version SHOULD be fine but like I said I dont have access to an AT&T Pre+.
    Last edited by 2sslow; 07/27/2010 at 12:04 AM.
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  3.    #3  
    Quote Originally Posted by 2sslow View Post
    Maybe you should have asked the dev? Oh wait thats me!

    First off, its not possible for this patch to do what you are describing. you obviously are conflicting w/ something else you installed. My bet is you installed a Theme that has embedded patches.

    Are you using a theme? if you are REMOVE THE THEME first. Most themes have patches embedded in them and regularly affect patches if installed after?


    If theme removal doesnt work youll need to run EPR, that works 90% of the time. Worst case youll have to Dr.
    I didn't have any themes running. The only thing even slightly related was the glass effects for the launcher, cards, and app/device menus.

    Update on what's happened so far:
    I backed up all the patches that I wanted to keep and used the Emergency Patch Recovery. This removed all the patches, but when the phone rebooted, the phone app was still screwed up. I checked out a few other core applications that the Scrims app affected and it seems that almost all of them are glitched up! For example, the phone, music player, and web browser are glitched, and the videos app won't even open (just sits there in card view). Here are some pics:

    Phone App


    Music App


    Web Browswer


    I read that the best thing to do is after running the EPR to run the Verification program too, so I did that and it came up with several errors having to do with .css files of several apps (interestingly all the ones that are affected by the Scrims Multi....

    ------------------------------------------------------------------
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.emergency-file-verification.postinst 2>&1
    Detected stock files modified via a method other than supported patch technologies:
    File: /usr/palm/applications/com.palm.app.browser/stylesheets/browser.css
    File: /usr/palm/applications/com.palm.app.contacts/stylesheets/list.css
    File: /usr/palm/applications/com.palm.app.email/stylesheets/email.css
    File: /usr/palm/applications/com.palm.app.musicplayer/stylesheets/music-player.css
    File: /usr/palm/applications/com.palm.app.notes/stylesheets/notes-app.css
    File: /usr/palm/applications/com.palm.app.phone/stylesheets/phone.css
    File: /usr/palm/frameworks/private/metascene.videos/submission/76/javascript/assistants/browser-assistant.jsjsjs
    File: /usr/palm/frameworks/private/metascene.videos/submission/76/javascript/assistants/nowplaying-assistant.jsjsjs
    File: /usr/bin/PmWanDaemon
    Removing package org.webosinternals.emergency-file-verification from root...
    --------------------------------------------------------------------


    It doesn't like whatever changes were done to the .css files. Is there any way to replace these back to the originals?
  4. #4  
    The ONLY changes to the .css are background color, Thats it

    What firmware are you using?


    Im sorry you are having these issues!

    Like I stated earlier I have not tested this on AT&T, My only other idea short of Dr would be to EPR (totally wipe ALL patches).

    BTW the V2 versions have launcher scrims built in so the glasseffect patches will muck up the works.

    Once you get this fixed (if you still want to test this on AT&T) use the o2 version (NOT V2).


    Hope Ive been of some help?
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  5.    #5  
    Quote Originally Posted by 2sslow View Post
    Im sorry you are having these issues!

    Like I stated earlier I have not tested this on AT&T, My only other idea short of Dr would be to EPR (totally wipe ALL patches).

    BTW the V2 versions have launcher scrims built in so the glasseffect patches will muck up the works.

    Once you get this fixed (if you still want to test this on AT&T) use the o2 version (NOT V2).


    Hope Ive been of some help?
    I couldn't imagine the AT&T version being that much different than the other ones. If you've developed this patch I'm assuming you have some experience editing the .css files of the apps it affected? Is there any sort of way to recover these .css files or to install over them?

    I really didn't want to have to Dr it, but if I have no other option than I guess I will have to. One question about using the Dr: I have paid for apps on the App Catalog, will I have to pay for these again to redownload them?


    EDIT: I'm using AT&T's 1.4.2.
    And I DID use EPR, the screenshots I posted was from AFTER I removed everything.
    Last edited by JishHD; 07/27/2010 at 12:27 AM.
  6. #6  
    Quote Originally Posted by JishHD View Post
    I couldn't imagine the AT&T version being that much different than the other ones. If you've developed this patch I'm assuming you have some experience editing the .css files of the apps it affected? Is there any sort of way to recover these .css files or to install over them?

    I really didn't want to have to Dr it, but if I have no other option than I guess I will have to. One question about using the Dr: I have paid for apps on the App Catalog, will I have to pay for these again to redownload them?


    EDIT: I'm using AT&T's 1.4.2.
    1.4.2 has not been tested on any device? PreWare shouldnt have let you get this at all. How did you Install these? Or did you update to 1.4.2 w/ this installed?

    You said you backed up patches then EPRd. I would try A total EPR to wipe All patches completely. if that doesnt work you will probably have to Dr. All of your official app catalog purchases will be backed up via your Palm Profile and you will not have to repurchase them.
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  7. #7  
    I dont recommend editing the .css manually. If you wish to go this route you can open the WebosDoctor.jar w/ 7zip and extract the files and insert them manually via WOSQI.

    I DONT RECOMMEND THIS THOUGH.
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  8.    #8  
    Quote Originally Posted by 2sslow View Post
    1.4.2 has not been tested on any device? PreWare shouldnt have let you get this at all. How did you Install these? Or did you update to 1.4.2 w/ this installed?

    You said you backed up patches then EPRd. I would try A total EPR to wipe All patches completely. if that doesnt work you will probably have to Dr. All of your official app catalog purchases will be backed up via your Palm Profile and you will not have to repurchase them.
    AT&T's Pre+ comes installed with 1.4.2 (their Pixi+ is 1.4.3). I installed it via Preware right on to my phone. The backing up of the patches just added them to Preware's saved applications list (so that I can reinstall apps and patches). I actually THEN backed up Preware's app data using Save/Restore, so when I run the Dr and everything is wiped, then I can reinstall Save/Restore, and use that to restore Preware's patches list (I removed the ones that weren't compatible. This is just to save time so I don't need to go and find everything again.)

    Thanks for your help anyways!
  9. #9  
    If you don't mind my chiming in, when I've had problems in the past with patches getting stuck (this patch specifically) I run the Webos Repair Utility with Overide Capability turned on. This more or less does the same thing as the doctor except it just corrects the messed up files, compared to the doctor that replaces all the files. With the override capability turned on, all of your patches will be removed, but last time I did this it only took me about a half hour after the scan completed to get my phone back to how it was before the scan, instead of the 3 hours it took when I doctored my phone.
  10. #10  
    Quote Originally Posted by cdonehew View Post
    If you don't mind my chiming in, when I've had problems in the past with patches getting stuck (this patch specifically) I run the Webos Repair Utility with Overide Capability turned on. This more or less does the same thing as the doctor except it just corrects the messed up files, compared to the doctor that replaces all the files. With the override capability turned on, all of your patches will be removed, but last time I did this it only took me about a half hour after the scan completed to get my phone back to how it was before the scan, instead of the 3 hours it took when I doctored my phone.
    First this patch is very big, and touches 10 different files so if it "gets stuck" its because you have something interfering w/ it. I could just as easily say the glass effect patch he installed is what screwed up this patch not the other way around. Or could be which is in this case, user error. The op admitted to installing the incorrect version ( and I know its incorrect because I dont have a version for AT&T or 1.4.2) and installing the glass effect patch which modifies the same file.

    Im fairly certain your issue was user error as well due to the fact you didnt read the entire post leading me to believe you didnt read the multiple posts stating not to install a theme,any other scrim patch, or to leave this patch installed during an ota because Patches that touch multiple files are not AUPT compatible. YET!
    Quote Originally Posted by JishHD View Post
    Then I tried the WebOS Repair Utility, but because I have an AT&T Pre+ it won't recognize my correct version of WebOSDoctor so it won't even do a SCAN to see if anything is wrong!
    The op stated he doesnt have the correct dr to use the WebOsRepairUtility so that wont work for him or I would have mentioned that before.


    Sorry for the Rant!
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


Posting Permissions