Results 1 to 14 of 14
  1.    #1  
    Where does Preware store the Save Package List? Any chance that backup copies are maintained?

    I just Doctored my phone. My recovery did not go well. Now I am trying to manually reinstall all my patches. It would help if I had a list stored somewhere.

    I use both Save Packaged List, Save/Restore and Prebackup Utility. Hopefully one of those has a list from yesterday.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  2. #2  
    Open Preware and go to the bottom of the list, right under the List of Everything is the Saved Package list. Just tap on it for the options. You may need to restore Preware in Save/Restore first.
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  3.    #3  
    My Saved Package list got hosed. I have multiple backup thru Save/Restore and Pre Backup. I am looking for the source file that is loaded by Preware with the list of installed patches and applications.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  4. #4  
    its probably a hidden file right on the usb portion of the phone. you might need to unhide files to see it . of course i have not checked this yet .
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  5.    #5  
    I could not find the list. I used USB mode and Internalz to look for it. No luck. Hopefully someone can point me to the exact location of the file for the Preware saved list.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  6. #6  
    Quote Originally Posted by swieder View Post
    I could not find the list. I used USB mode and Internalz to look for it. No luck. Hopefully someone can point me to the exact location of the file for the Preware saved list.
    Man, that's a pain... hope you get the backup working.

    When you open Save/Restore and click on the "Restore" list, is anything listed? Does it even show anything you can restore?
  7. cas_esq's Avatar
    Posts
    618 Posts
    Global Posts
    656 Global Posts
    #7  
    When using Internalz you didn't see /media/internal/.webosinternals.patches.packages? I was under the impression that doctoring no longer affected the media/internal/ directory, so the packages list would remain untouched. If /media/internal/.webosinternals.patches.packages is gone, I don't know where else to look.

    Everyone is entitled to his own opinion, but not his own facts.
  8. #8  
    If you have Internalz try: media/internal/saverestore/org.webosinternals.preware/
    "Patience, use the force, think." Obi-Wan


    Ready to try Preware? Get this first: Preware Homebrew Documentation
  9. Shineon's Avatar
    Posts
    121 Posts
    Global Posts
    137 Global Posts
    #9  
    I have a serious battery drain issue and took the phone into a Sprint store to have them look at it. They couldnt fix it and are going to replace it for me tomorrow, number 4. When I got the phone back so I could use it today until I get the replacement, the Saved Package List showed all of my packages when I first went into Preware and when I updated, they were all gone. It did the update and when it was done there was nothing! There is also nothing showing under installed packages. Everything is still on the phone (about 10 patches and some apps as well) and I have opened some of the apps to make sure they are working correctly, and they are. I rebooted the phone and brought up preware again and have the same issue, no saved package list or installed packages at all.
    I do have save/restore and the backup utility.
    Any help or insight would be much appreciated.
  10. #10  
    ^ did you do a restore with save/restore?
    Palm III > Palm V > Palm Vx > (Sprint) Kyo 6035 > Handspring Treo 300
    > Handspring Treo 600 Oct.'03 > Palm Treo 700P May'06 > Treo 755P Aug.'07 > Pre(-) June'09 + TouchPad July'11 LONG LIVE webOS!!!
  11. Shineon's Avatar
    Posts
    121 Posts
    Global Posts
    137 Global Posts
    #11  
    Quote Originally Posted by ChemEngr View Post
    ^ did you do a restore with save/restore?
    I did, and i'll do a back up as well.....just thought it was pretty strange and do not want to lose anything with my new refurb
  12. kalex's Avatar
    Posts
    253 Posts
    Global Posts
    728 Global Posts
    #12  
    Here are the steps that Rod listed before. Notice step 3 it says Don't hit update.

    1) In Preware Saved Packages List, hit Update to make sure it has the current list of installed packages.
    2) In Save/Restore, save the application data for Preware, just in case.
    3) In Preware, go to the Saved Packages List, and re-install the packages. Don't hit update, or it will clear your list.
    4) If for some reason, the Saved Packages List is not there, you can restore it from Save/Restore.
  13.    #13  
    Quote Originally Posted by vza33 View Post
    If you have Internalz try: media/internal/saverestore/org.webosinternals.preware/
    I did find this file. What can I use to open an older PackageDB file? I just want to see a list of patches to remind myself what patches that I need to reinstall.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  14. Shineon's Avatar
    Posts
    121 Posts
    Global Posts
    137 Global Posts
    #14  
    Quote Originally Posted by kalex View Post
    Here are the steps that Rod listed before. Notice step 3 it says Don't hit update.

    1) In Preware Saved Packages List, hit Update to make sure it has the current list of installed packages.
    2) In Save/Restore, save the application data for Preware, just in case.
    3) In Preware, go to the Saved Packages List, and re-install the packages. Don't hit update, or it will clear your list.
    4) If for some reason, the Saved Packages List is not there, you can restore it from Save/Restore.
    Thanks kalex, unfortunately it is too late. When I initially went into Preware and saw all of my apps and patches listed, I updated and everything disappeared on me. I have also already done the save/restore. It's not a huge deal as I only had about 10 patches on the phone that can easily be downloaded again on the "new" replacement phone. I just thought it was strange that everything was showing at first and then when I updated the saved package list, it all disappeared.

Posting Permissions