Page 5 of 11 FirstFirst 12345678910 ... LastLast
Results 81 to 100 of 211
  1. #81  
    Quote Originally Posted by Pulp View Post
    To late for me
    You can also add "System Menu Initial Framework" to the list. :sigh:
    Has it been confirmed that this patch must also be removed prior to upgrading to 1.4.5?
  2.    #82  
    Quote Originally Posted by sjamie View Post
    Has it been confirmed that this patch must also be removed prior to upgrading to 1.4.5?
    The first post of this thread contains the most up to date information.

    mojo, luna-systemui and luna-sysmgr are the 3 packages this patch touches, all of which are reported to be updated in 1.4.5 OTA so it should be fine.

    There's another AUPT bug that can cause a patch to fail on removal but it is not fatal like the ones in this thread are. The other AUPT bug can be resolved by removing patches in the same category (ones that touch the same package[s]) prior to removing the "problem" patch. This workaround is for post-OTA. The patches listed in this thread's 1st post are "fatal" because there is simply no workaround to remove them after an OTA.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  3. #83  
    Quote Originally Posted by egaudet View Post

    If anyone updates with one of the problem patches installed, I believe the best solution will be to use save/restore to save your patches list. Then install EPR to wipe all patches (or webos doctor). Then use save/restore to restore the patches.
    How do I do that?

    I can't reach the "Run EPR" button in the Tweaks window, because I'm in a loop "New OS version -> update patches -> error message about MultiMod -> Done -> New OS ->...."

    I can't find EPR Emergency Patch Removal?) to download anywhere.

    [Oh, and by the way: I did not forget to remove Multimod before updating the OS, but simply didn't realise how sneaky WebOS is: When I was told that a new OS version was available, I tapped "Later"; this morning, I put it on the TouchStone with Airplane Mode On; when I came back the Pre proudly told me that it had a new OS version; "later" apparently means "when I'm not around to say No again". ]
  4.    #84  
    Quote Originally Posted by Jochen K. View Post
    How do I do that?

    I can't reach the "Run EPR" button in the Tweaks window, because I'm in a loop "New OS version -> update patches -> error message about MultiMod -> Done -> New OS ->...."

    I can't find EPR Emergency Patch Removal?) to download anywhere.

    [Oh, and by the way: I did not forget to remove Multimod before updating the OS, but simply didn't realise how sneaky WebOS is: When I was told that a new OS version was available, I tapped "Later"; this morning, I put it on the TouchStone with Airplane Mode On; when I came back the Pre proudly told me that it had a new OS version; "later" apparently means "when I'm not around to say No again". ]
    I have updated the first post with Rod's save package list instructions. EPR can be found in Preware (search for emergency). Specifically it is in the webos-internals feed.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  5. #85  
    Quote Originally Posted by egaudet View Post
    I have updated the first post with Rod's save package list instructions. EPR can be found in Preware (search for emergency). Specifically it is in the webos-internals feed.
    Ah, so its "Recovery", not "Removal"; thanks!
    I think it worked - though the re-installation of one patch failed with an error message.
    I'll have to look more closely at what was installed tonight.
    Last edited by Jochen K.; 07/12/2010 at 11:57 AM. Reason: typo
  6. #86  
    OK, so this is very important information. It first came to my attention when Dieter (I think, or Derek or Keith) mentioned it on the Palmcast.

    And yes, now I have one more reason to be glad I'm on Sprint!

    So here's my question: was this thread mentioned on the main Precentral site and I somehow missed it? If it hasn't been there, it's not too late! It should be!

    -Roland
  7. #87  
    I have an old version of 'capture with volume key' that will not remove or update. How do I get rid of it?
    Thanks,
  8. #88  
    Quote Originally Posted by egaudet View Post
    First I'd like to apologize because of my hiatus I have neglected known flaws in AUPT for too long. Although with the great development of the Save/Restore system started by rwhitby, I believe the worst case scenario will be very manageable.

    Ok, so here's the deal. Patches that touch multiple packages will not be able to remove/update after an OTA, iff the OTA doesn't update all or none of those packages. These "problem" patches will be in a half-installed half-removed state and there's nothing in AUPT logic that can get it out of this state.

    Luckily there aren't a ton of these packages but to avoid this scenario I must recommend you remove the following patches prior to OTA update while using AUPT version 4 or before.

    • GestureClick Context Menu
    • KeyToss Keyword Search
    • Enable Verizon aGPS Server for Improved GPS
    • Multi Mod
    • SMS Tone per Contact
    • SMS Tone per Contact v2
    • No Auto-Off While Charging
    • Scrim Multi
    • Scrim Multi v2
    • Scrim Multi o2
    • Scrim Multi o2 v2
    • Scrim Multi Verizon
    • Scrim Multi Verizon v2
    • Scrim System Screens


    I apologize to the patch authors in advance for the inevitable barage of questions they will receive due to my oversight.

    What to do if you have updated with a problem patch installed:

    • In Preware Saved Packages List, hit Update to make sure it has the current list of installed packages.
    • In Save/Restore, save the application data for Preware, just in case.
    • In Preware, run EPR (Emergency Patch Recovery)
    • In Preware, run EFV (Emergency File Verification) to confirm everything is removed
    • In Preware, go to the Saved Packages List, and re-install the packages. Don't hit update, or it will clear your list.
    • If for some reason, the Saved Packages List is not there, you can restore it from Save/Restore.
    Eric-

    Not sure if you have tested this one, so I wanted to ask. I know the dev of the top bar menu's (Today Menu and Mod Switcher Menu) said he thought that patch may need to be removed. I am guessing with the way it functions it probably will, but I didn't see it on your list so I figured I would ask for clarification (and to maybe help some other folks).
  9. rlopin's Avatar
    Posts
    441 Posts
    Global Posts
    443 Global Posts
    #89  
    Quote Originally Posted by sjamie View Post
    Has it been confirmed that this patch must also be removed prior to upgrading to 1.4.5?
    Quote Originally Posted by egaudet View Post
    The first post of this thread contains the most up to date information.

    mojo, luna-systemui and luna-sysmgr are the 3 packages this patch touches, all of which are reported to be updated in 1.4.5 OTA so it should be fine.

    There's another AUPT bug that can cause a patch to fail on removal but it is not fatal like the ones in this thread are. The other AUPT bug can be resolved by removing patches in the same category (ones that touch the same package[s]) prior to removing the "problem" patch. This workaround is for post-OTA. The patches listed in this thread's 1st post are "fatal" because there is simply no workaround to remove them after an OTA.
    Quote Originally Posted by OldSkoolVWLover View Post
    Eric-

    Not sure if you have tested this one, so I wanted to ask. I know the dev of the top bar menu's (Today Menu and Mod Switcher Menu) said he thought that patch may need to be removed. I am guessing with the way it functions it probably will, but I didn't see it on your list so I figured I would ask for clarification (and to maybe help some other folks).
    Seems like we have conflicting info. The dev says he thinks the patch needs to be removed, but the 1st post in this thread doesn't list his patches. Can anyone who had his patches installed confirm that after updating to 1.4.5 they still work?
    .
    .
    Phones>Ericsson->iPaq->Treo700w>>PalmPre & TouchPad<<PC<-Amiga<-C64<-Vic20<-PET<Computers
  10. #90  
    Quote Originally Posted by rlopin View Post
    Seems like we have conflicting info. The dev says he thinks the patch needs to be removed, but the 1st post in this thread doesn't list his patches. Can anyone who had his patches installed confirm that after updating to 1.4.5 they still work?
    .
    .
    When in doubt, take it out.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  11. rlopin's Avatar
    Posts
    441 Posts
    Global Posts
    443 Global Posts
    #91  
    Quote Originally Posted by rwhitby View Post
    When in doubt, take it out.

    -- Rod
    I like the both the rationale as well as the rhyming sound of that rule of thumb.

    You're a poet and didn't know it. :-)

    ..
    Phones>Ericsson->iPaq->Treo700w>>PalmPre & TouchPad<<PC<-Amiga<-C64<-Vic20<-PET<Computers
  12.    #92  
    Quote Originally Posted by rlopin View Post
    Seems like we have conflicting info. The dev says he thinks the patch needs to be removed, but the 1st post in this thread doesn't list his patches. Can anyone who had his patches installed confirm that after updating to 1.4.5 they still work?
    .
    .
    Let me explain here. The three packages that the initial framework patch touches are reported to be updated in 1.4.5. Therefore it does NOT fall under this fatal bug that this post is about. I've checked which packages each patch in the webos-patches feed touch and checked it against the list of updated packages. I've put that list in the first post and will add to it if there is one I missed. I re-checked this Initial framework patch when it was initially reported, and again it touches 3 packages (luna-systemui, luna-sysmgr and mojo) of which ALL are reported to be updated in 1.4.5.

    I understand the developer of these (great) patches has his own feed as well, and for good measure I checked the patches in the stable branch of that feed. Still the same packages being touched. Other non-fatal bugs like dependency order and the like are outside the scope of this thread and can be worked around post-OTA. Now in general, any out of feed (webos-patches feed) patches you install may or may not have this fatal bug. You can link me and ask me to check, you can ask the developer, or you can just remove them if uncertain.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  13. rlopin's Avatar
    Posts
    441 Posts
    Global Posts
    443 Global Posts
    #93  
    Thanks for the clear and detailed explanation egaudet.
    Phones>Ericsson->iPaq->Treo700w>>PalmPre & TouchPad<<PC<-Amiga<-C64<-Vic20<-PET<Computers
  14. djraw's Avatar
    Posts
    370 Posts
    Global Posts
    393 Global Posts
    #94  
    is AUPT something I need to install, or does it just work?
    IT'S NOT A DAMN BLACKBERRY!....
  15. #95  
    Being old enough to be "pre"-computer generation, and therefore wary of things technical, I was at first reluctant to homebrew in fear of losing control of my phone. This community has more than assuaged my fear.
    Willingness to "man-up," provide temporary workarounds and then reissue apps and packages, all on a voluntary basis, should embarrass the likes of MS, Apple, etc.

    Many, many thanks
  16. #96  
    Quote Originally Posted by Blacklight View Post
    Is the "Gesture tap for info and delete" also affected, or just the "context menu" patch?
    I'm also wondering...
  17. #97  
    Quote Originally Posted by schlurch View Post
    Unfortunately, not for me. But i have to admit that the patch "GestureClick Context Menu" was stuck in Preware prior to the 1.4.5 Update. Still haven't found a way to remove this from the preware list without wiping the complete phone with webOS Doctor.
    If anybody got an advice i would be happy to hear it.

    In the meantime i have to accept that "update all" won't work for me in preware.
    I have the same issue! I even doctored my phone and it's still there and wont update!
    It still shows up in WOSQI and I cant remove it that way either?
    I tried EPR first, Then tried WOSQI then tried to doctor it and nothing was able to remove the patch! can anyone help with this?
    I will try these steps and let you know how it works (or vice versa)
    Last edited by gsonspre; 07/15/2010 at 12:43 PM.
  18. #98  
    Quote Originally Posted by gsonspre View Post
    I have the same issue! I even doctored my phone and it's still there and wont update!
    It still shows up in WOSQI and I cant remove it that way either?
    I tried EPR first, Then tried WOSQI then tried to doctor it and nothing was able to remove the patch! can anyone help with this?
    I will try these steps and let you know how it works (or vice versa)
    It is simply impossible for a patch to still be installed after a correctly executed webOS Doctor.

    -- Rod
  19. #99  
    the command line patch should be added 2 the list of patches that will not work/update after 1.4.5
  20. #100  
    I modded my Sprint Pre to allow for mobile hotspot, do I need to remove the patch for that before we hit 1.4.5.1?
Page 5 of 11 FirstFirst 12345678910 ... LastLast

Posting Permissions