Results 1 to 8 of 8
  1.    #1  
    root@qemux86:/# /media/cryptofs/apps/usr/bin/patch
    /media/cryptofs/apps/usr/bin/patch: line 2: syntax error: ")" unexpected
    root@qemux86:/#


    That's about it, using org.webosinternals.patch_2.5.9-3_i686.ipk, from the repository, downloaded manually and via webos quick install.

    I was trying to install Greg's patches on an emulator, but GNU patch doesn't work on either 1.3.5, 1.4.0 or a new, unreleased beast which I cannot talk about.

    Any ideas?

  2. #2  
    WOSQI is not compatible with the emulator regarding patches at this moment.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  3. #3  
    I was never able to get GNU Patch to work either.

    Is there any way at all to get a patch to install on the emulator?
  4. #4  
    I've never tried it, but you could install Preware with WOSQI.


    If I helped you or you have downloaded one of my files,
    then least you could do is click the "Thanks" button.
  5. #5  
    Yeah, I installed Preware and installed GNU Patch and it says it installed correctly but it doesnt actually work.

    And as you said, installing them through WOSQI doesn't work either. I gave up after that, hehe.
  6.    #6  
    Quote Originally Posted by Abyssul View Post
    WOSQI is not compatible with the emulator regarding patches at this moment.
    Really? It should be, they just have to recompile the patch executable and it works :P

    Thanks anyway, I got it working.
  7. #7  
    This problem should now be fixed with the latest versions of lsdiff and patch.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  8.    #8  
    Excellent, will test later

    Thanks Rod!

Tags for this Thread

Posting Permissions