Page 196 of 207 FirstFirst ... 96146186191192193194195196197198199200201206 ... LastLast
Results 3,901 to 3,920 of 4135
Like Tree55Likes
  1. #3901  
    Some background for the advanced sync behaviors features -- from the results of testing them and trying to debug sync problems.

    A chief cause of events not being up-sync'd was the database watch activities were being lost by the activity manager. I made changes so that they should not get lost. I made them behave similarly to how the system watches for calendar alarms. They can still occasionally get lost or hang due to network errors, but they should recover after 60 mins. There's a timeout that will end the sync and restart the database watch after 60 minutes. If a sync is hung for more than 2 hours, a restart of the device will stop it. Restarting Luna does not stop it.

    Please be careful when setting the sync interval. If you have a large number of events or calendars, setting the sync interval below 20 mins may cause your battery usage to get very high. This is because it can take 10 minutes to sync a lot of calendars or events. Your device will not go to sleep and your battery will not last very long. This is especially true for Yahoo or Facebook calendars as they don't do change based syncs. They sync all events in the default 3 month period.

    I have found that since I use my Pre3 as my main point of entry for events, that I can have a longer sync interval on the Pre3. Since the database watch will fire off a sync as soon as I create the event. I don't make that many changes on google's website or on the touchpad. So I can save a little battery and still get my events to the other devices.

    I did not apply the advanced sync requirements to the initial sync after you enable a calendar account and when you do a "sync now" via the calendar app. My logic is that if you are doing one of those 2 things, then you want the sync to happen at that moment and you don't care so much about the advanced settings.

    It can take up to an hour (or day for facebook) for the settings to affect your sync after you push "set sync requirements". This is because they change the next sync after you set them. If a sync is hung, it takes 60 minutes for it to timeout and attempt to restart the sync. If you want the settings to take place immediately, you will need to restart your device -- restarting Luna will not do it.

    I'm still looking at how to best force a full sync instead of a change sync for google. I will also make the changes for all the other devices with 2.x or higher, after reports come back as stable.

    thanks for testing.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  2. #3902  
    holy cow. i just can say i'm looking forward to these patches to appear in preware.

    Irony that just now a colleague of mine (last one with webos) that always had gcal probs is switching to iP5.
    Will see which one syncs better with our groupcalendar in the future.
  3. #3903  
    modified the sync behavior patch. If you are running the local version you should update it. Submitted update to Preware as well as the updated UC from here (for 2.2.4 only):
    UberCalendar: Enhanced calendar patch
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  4. #3904  
    looking forward for preware, too!
  5. #3905  
    Seems everyone is whatsapping now and not getting the patches into the feeds
  6. #3906  
    I think they are busy with Luna CE. Not to mention their day jobs.

    It gives me more time to track down more sync bugs. I found a new one this morning, .... just have to figure out how to deal with it.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  7. #3907  
    The patches for 224 are in preware, please post the logs from lumberjack if you have any problems.

    Don't forget to enable advanced sync in Tweaks and set the sync preferences by pushing the button below them. The sync changes take effect after the next sync.
  8. #3908  
    Quote Originally Posted by frantid View Post
    It gives me more time to track down more sync bugs. I found a new one this morning, .... just have to figure out how to deal with it.
    It seems the error I found is only on the Pre3. It was caused by the wifi bug where it doesn't stay awake. My wifi stops after about 3 hours of the Pre3 being unused. (which is only at night). Sync starts up again as soon as I stick it on the touchstone -- odd. Not much I can do about this one. I guess we need a driver update or something.

    My Pre2, sleeps and syncs just fine. It doesn't get as good battery life though.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  9. #3909  
    Quote Originally Posted by frantid View Post
    It seems the error I found is only on the Pre3. It was caused by the wifi bug where it doesn't stay awake. My wifi stops after about 3 hours of the Pre3 being unused. (which is only at night).
    this bug seems to be as common as it is mysterious. range is from ppl not having wifi problems at all to ppl like me who are not able to use wifi because of intermittent connection problmes - Pre3 showing everything´s all right but it isn´t.

    I´ve tried all tricks mentionend in the appropriate thread over at the "Pre 3" forum but none of them helped. So I´ve found myself changing my data plan to unlimited and turning off wifi at all ...
  10. #3910  
    Quote Originally Posted by juggernaut View Post
    this bug seems to be as common as it is mysterious. range is from ppl not having wifi problems at all to ppl like me who are not able to use wifi because of intermittent connection problmes - Pre3 showing everything´s all right but it isn´t.

    I´ve tried all tricks mentionend in the appropriate thread over at the "Pre 3" forum but none of them helped. So I´ve found myself changing my data plan to unlimited and turning off wifi at all ...
    I guess I was just dumb and happy before. I always stick it on the touchstone in the morning, so that starts up my sync again. Weird thing is I can wake it up and use the browser, but it won't sync until it gets a charge of some sort. Or a restart. My guess is they never got a chance to tweak the drivers since everything was cancelled.

    Your problem sounds much worse than mine.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  11. #3911  
    they´re avail on preware now.

    my short betatest report:

    updated "google sync behaviours patch" to that version, restarted luna,
    updated "UC" to that version, restarted luna,
    went to tweaks and set YES,
    went to calendar, settings, taped "set sync requirements" - nothing happenend,
    remembered you saying that it is a per account setting, tapped on google acc right above, didn´t do anything there and left it with a back swipe,
    there appeared a new botton "advanced sync setting" for google acc right above the other button, tapped on that one, set everything I like.

    NICE. let´s see if it works, then
  12. #3912  
    Quote Originally Posted by juggernaut View Post
    there appeared a new botton "advanced sync setting" for google acc right above the other button, tapped on that one, set everything I like.

    NICE. let´s see if it works, then
    I should have mentioned that. The call to tweaks, takes about a sec to come back. So the settings don't appear until the preference scene has been open for a little bit.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  13. #3913  
    got the new patches on my Pre2, time to see what they do. Will there be some FAQs for the new options, like 'enable requirements' or 'use for contacts'?

    Haven't seen the new patches on my TP preware feed, though. Any plans for it?

    great job!
  14. #3914  
    Thanks, I will put something up on the preference guide.

    edited:

    The on,off in tweaks shuts all options off on all calendars. When off, syncing uses the webos standard sync every 20 minutes, 24 hrs for facebook. And the only requirement is Internet access.

    • "Enable requirements" under each account is just an on/off for that account. Off uses defaults.
    • "Use for contacts" allows you to apply the same settings to contacts. If off, contact syncing will use the defaults. So if you only want to sync all data for an account every 3 hours, set it to on. If you want calendar to 3 hours and contacts to default at 20 mins, choose off. The sync processes are separate, but where I had to patch the files I can affect both of them.
    • "Wifi only" will only sync when connected to wifi.
    • "Cell data only" will only connect through the carriers network.
    • *** having them both wifi and cell on, I configured the same as having them both off. If both are on or off, it means you want to sync when either is available.
    • "Minimum battery" is the level which is required to sync. When above it will sync, below it will not. "0" is off.
    • "Interval" is the interval that google servers are queried for changes. All changes made on the device will try to sync immediately or queue up if the requirements are not met.
    • "Charging" phone has to be charging. Usb or touchstone.
    • "On touchstone" touchstone only syncing.




    I'll add some more later.

    I haven't put the changes on anything else yet.

    Quote Originally Posted by toaste View Post
    got the new patches on my Pre2, time to see what they do. Will there be some FAQs for the new options, like 'enable requirements' or 'use for contacts'?

    Haven't seen the new patches on my TP preware feed, though. Any plans for it?

    great job!
    Attached Images Attached Images
    Last edited by frantid; 09/28/2012 at 03:04 PM.
  15. #3915  
    I should add that webOS considers all of these options as an "AND" requirement.

    Every requirement toggled on has to be met for the sync to start.


    The only exceptions are the ones I configured:

    • That if cell data and wifi are turned both on or both off, it will sync if either is available.
    • Pushing sync now in the calendar app, ignores the requirements and will try to sync if internet is available.
    • When you turn a calendar on in the accounts app it will ignore the requirements and try to sync if internet is available.
    Last edited by frantid; 09/28/2012 at 03:04 PM. Reason: added other 2 cases
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  16. #3916  
    I submitted a new version of the sync behaviors to Preware. Local copy here:
    UberCalendar: Enhanced calendar patch

    I made changes to the periodic sync that are similar to what I did to the database watch sync. The changes seem to have let my Pre3 sync the calendar after I leave it alone for more than 3 hours. It does not change any behavior on the Pre2 I have.

    Anyone notice any problems?
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  17. #3917  
    Quote Originally Posted by juggernaut View Post
    this bug seems to be as common as it is mysterious. range is from ppl not having wifi problems at all to ppl like me who are not able to use wifi because of intermittent connection problmes - Pre3 showing everything´s all right but it isn´t.

    I´ve tried all tricks mentionend in the appropriate thread over at the "Pre 3" forum but none of them helped. So I´ve found myself changing my data plan to unlimited and turning off wifi at all ...
    Quote Originally Posted by frantid View Post
    I guess I was just dumb and happy before. I always stick it on the touchstone in the morning, so that starts up my sync again. Weird thing is I can wake it up and use the browser, but it won't sync until it gets a charge of some sort. Or a restart. My guess is they never got a chance to tweak the drivers since everything was cancelled.

    Your problem sounds much worse than mine.
    I'm starting to think it is software and not so much hardware drivers. It seems while my calendar was not able to sync after those 3 hours, the email app was able to sync. I modified the calendar's sync configuration to match that of the email app's sync configuration. That seems to have allowed the calendar to sync over night. I left my Pre3 alone for about 4 hours, then modified a bunch of events on the touchpad before going to sleep, and in the morning they were all correct on the Pre3. I going to keep an eye on the logs.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  18. #3918  
    updated google sync behavior patch for 224 is in Preware.
    French Pre3, UK Pre2, US Veer, German gsm Pre, 680, garmin ique 3600 & still have my working palm pilot 1000 with the 1 Mb adapter

    Please remove UberCalendar and google sync behavior patches prior to system updates.
    patch Google calendar sync behavior for 2.x.x and TouchPad (Oauth2 and advanced sync requirements enabled)
    Preference guide for MetaView's UberCalendar patch
  19. #3919  
    Quote Originally Posted by qwiklight View Post
    Here's a whole boatload of icons I created Friday/Saturday for use in this FABULOUS UC Patch. Pick and choose which icons you use (i.e., icon-money.png could be used for tax day, rent, mortgage, tuition, car payment, etc.). Or get creative and make your own scaled icons. Just remember what you named your icon so that you can put it in your event note to be certain it will show up (ICON=money; ). I found it's vital to include the semi-colon in the naming scheme. My icons are now all 12x12 and most show in Month view fine. Not sure why some do and some don't show in week/day views (???). I thought it might have been that some of my icons were too big so the below zipped file has now been replaced with all 12x12 icons and a few new added images. Hopefully, someone knows why not all show in week/day views. If your icon isn't showing, double check to verify you typed the name correctly in the event note and include the semi-colon also go to the calendar menu and be sure enhanced view is enabled. If you forget what you named your icon, you can always use Internalz to verify the name.

    I love having the icons show in my Month view and hopefully will get them to work in week/day views as well. It's a little "thank you" to everyone here for helping me these past few months "pimp my pre". There are icons here for recreation, family, business, holidays, financial, pets, travel, seasons, etc. Have fun and enjoy and remember the thank you button!

    Attachment 49893

    Attachment 49894

    P.S. - from what I can determine, only those icons originally named in MetaView's original list of eight (birthday, car, kids, doctor, plane, holiday, vacation, party) in first post are designed to show in all views (month, day, week). The icons included in my zip will show in month but not the other views. In other words, my icon-flag.png (which I used for all holidays) only shows in month view but if renamed to icon-holiday.png (per MetaView's first post) will then show in the week and day views also. I tested this by renaming my icon-flag.png file to icon-holiday.png and renaming my event note to ICON=holiday; and now the icon shows correctly in all three views. Must be in MetaView's original code. I had two kinds of party icons; one for adult parties (icon-aparty.png) and one for children's parties (icon-kparty.png) which each have a different image. If I want the party icons to show in week and day views (as well as month), I'll need to remove my two icon versions (icon-aparty.png and icon-kparty.png), select a new image that will work for both types of parties, name it icon-party.png and then correct my naming scheme in each entry in event note to read ICON=party;. Hope this helps and makes sense to all. If you use your month view mostly, you can use any of my icons and include the name in the event code field of your calendar entry. However, if you want the icons to show in all views, you'll need to stick with the original eight names of birthday, car, kids, doctor, plane, holiday, vacation, party for that to work correctly. You can though, change each of those images to one you might like and identify with better and save it as a 12x12 pixel image). As an example, my Jack-o-lantern icon (icon-jacko.png) shows fine in month view but not in either week or day since it is not one of MetaView's original eight.

    Hi there,

    first @ Metaview: thanx for a wonderful enhancement! (still missing datebk & co on webos)

    referring to qwiklights post SOME while ago regarding the use of icons in UC I wonder if the "problem" has been solved by now, i.e. can you use more than the 8 original named icons by Metaview showing up in all calendar views?

    Sorry in case I'm beeing blind or stupid, but I couldn't find an answer in the threads.

    Personally I own a Palm Pre 1.4.5-205 (German O2) and a HP TP 32GB (3.0.5/latest UC Preware Patch) - in case there are any differences to observe.

    btw: what are the best programs/methods to create own UC icons? Any tips or ideas?

    Thanks in advance!
  20. #3920  
    Go into preferences, tap categories. You should be able to add as many icon names as you want. Put the icons in the /media/internal/.scrims/ubercalendar/ directory. The files must be named "icon-name.png" You put the "name" in the categories.

    I have no idea how to make icons. Maybe someone else can give you advice on that.

Tags for this Thread

Posting Permissions