Page 3 of 10 FirstFirst 12345678 ... LastLast
Results 41 to 60 of 199
Like Tree2Likes
  1. #41  
    I want to try this, I'm not sure which type to use, instant or delayed. I think the delayed to give it time to do it's thing or if I move the phone by mistake.

    I do use my BT headset a lot, so how would it work if using the headset?

    Or even a wired headset for that matter?

    Rob
    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Version 1.4.1.1
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  2.    #42  
    Quote Originally Posted by rlanza1054 View Post
    I want to try this, I'm not sure which type to use, instant or delayed. I think the delayed to give it time to do it's thing or if I move the phone by mistake.
    I had a hard time deciding myself.


    Quote Originally Posted by rlanza1054 View Post
    I do use my BT headset a lot, so how would it work if using the headset?
    Or even a wired headset for that matter?
    Rob
    The prox sensor isn't active on BT or wired headsets, and logic is included in the patch to limit the autoswitching to when either the front or back spreaker are active.

    .
  3. #43  
    Quote Originally Posted by frause View Post
    One thing... If I'm answering a call and put the phone up to my ear before the active-call card comes up, it won't switch from the back speaker until I do an extra screen state cycle.
    ive had this problem myself today
    Juan

    2010-2011 Champions!

  4.    #44  
    Quote Originally Posted by frause View Post
    One thing... If I'm answering a call and put the phone up to my ear before the active-call card comes up, it won't switch from the back speaker until I do an extra screen state cycle.
    ...
    Quote Originally Posted by maxima2k53 View Post
    ive had this problem myself today
    This issue was due to the prior implementation of a default audio route...In the newest version in post #55 I have changed the patch to check for the correct audio route.

    .
  5. #45  
    Quote Originally Posted by xanthinealkaloid View Post
    This issue was due to the prior implementation of a default audio route...In the newest version in post #31 I have changed the patch to check for the correct audio route.

    .
    i dont know if this is just me but the latest one uve posted is not working at all for me, and ive uninstalled it and installed it and nothing
    Juan

    2010-2011 Champions!

  6.    #46  
    Quote Originally Posted by maxima2k53 View Post
    i dont know if this is just me but the latest one uve posted is not working at all for me, and ive uninstalled it and installed it and nothing
    Which version are you having a problem with?

    .
  7. #47  
    Quote Originally Posted by xanthinealkaloid View Post
    Which version are you having a problem with?

    .
    the instant one:
    http://forums.precentral.net/webos-p...ml#post2418046

    Update: thats weird on the 3rd install it finally started working but i need to switch the mute on and off for it to work
    Juan

    2010-2011 Champions!

  8. #48  
    Quote Originally Posted by xanthinealkaloid View Post
    This issue was due to the prior implementation of a default audio route...In the newest version in post #31 I have changed the patch to check for the correct audio route.

    .
    I'm still seeing this. It might be due to another patch, though. I'll test some more when I get home from work.

    Edit: I'm using the instant variant.
  9. #49  
    Its working great and loud sound in speaker mode.
    Thanks
  10. #50  
    xanthinealkaloid,
    Are the patches in post 1 supposed to be updated so that when answering an incoming call it will switch to front speaker when the phone is initially placed to your ear? My phone is still staying in rear speaker initially until I move the phone away from my ear and place it back, then it will switch to front speaker.
    I installed the delayed one.
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  11. Trident's Avatar
    Posts
    337 Posts
    Global Posts
    343 Global Posts
    #51  
    Been using this for a few days and love it. Every so often it won't switch back from speakerphone when I put it back to my ear, but it will always work after a few attempts. Good news is that it doesn't stop me from hearing anything when I'm in the car.
    It would be nice to be able to turn the feature off from a menu so if there were other people around we could still have privacy, but I understand that it's difficult.
  12.    #52  
    Quote Originally Posted by frause View Post
    I'm still seeing this. It might be due to another patch, though. I'll test some more when I get home from work.

    Edit: I'm using the instant variant.
    I dozed off before I could finish testing a new fix I implemented…I'm pretty sure it should work because I moved the the ringerState function call from the setup to the updateCalls function.


    Quote Originally Posted by maxima2k53 View Post
    the instant one:
    http://forums.precentral.net/webos-p...ml#post2418046

    Update: thats weird on the 3rd install it finally started working but i need to switch the mute on and off for it to work
    The installation issue was probably unrelated, but the fact it's not working correctly on the first call is probably going to be fixed as I stated above.


    Quote Originally Posted by NachoB View Post
    xanthinealkaloid,
    Are the patches in post 1 supposed to be updated so that when answering an incoming call it will switch to front speaker when the phone is initially placed to your ear? My phone is still staying in rear speaker initially until I move the phone away from my ear and place it back, then it will switch to front speaker.
    I installed the delayed one.
    The patches in post #1 are the initial version I submitted for Preware without the mute switch control…Unfortunately, I wasn't aware of the issue then…It's due to the way I implemented the default audio route.

    Since the patches with the mute control will probably become the Preware versions eventually, I'm simply updating those versions with any fixes needed along the way.

    .
  13. #53  
    Quote Originally Posted by Trident View Post
    Been using this for a few days and love it. Every so often it won't switch back from speakerphone when I put it back to my ear, but it will always work after a few attempts. Good news is that it doesn't stop me from hearing anything when I'm in the car.
    It would be nice to be able to turn the feature off from a menu so if there were other people around we could still have privacy, but I understand that it's difficult.
    If you use the ringer switch version, you can just slide it to mute and disable autoswitching.
  14.    #54  
    Quote Originally Posted by Trident View Post
    Been using this for a few days and love it. Every so often it won't switch back from speakerphone when I put it back to my ear, but it will always work after a few attempts. Good news is that it doesn't stop me from hearing anything when I'm in the car.
    ...
    Hopefully, this issue will be fixed in the updates I will be posting shortly.


    Quote Originally Posted by Trident View Post
    ...It would be nice to be able to turn the feature off from a menu so if there were other people around we could still have privacy, but I understand that it's difficult.
    The goal is to be able to enable/disable the AutoSpeakerphone via the mute switch.

    .
  15.    #55  
    EDIT: Please see post# 86 for the updated patch files for both versions, as wells as basic versions.




    Patch creation is something I do in my spare time for myself and the Precentral community.
    If you find value in my work, please take a moment to click the thanks button.
    Should you be inclined, a donation link is available in my signature, and a sincere thanks to those who have.
  16. #56  
    I'm getting this error on install for the instant version:

    Code:
    ERROR: An error occured while attempting to run /tmp/scriptFile.sh
    
    /media/cryptofs/apps/usr/bin/patch:**** malformed patch at line 146: @@ -1411,6,+1522,7 @@
  17. #57  
    Quote Originally Posted by tobias funke View Post
    I'm getting this error on install for the instant version:

    Code:
    ERROR: An error occured while attempting to run /tmp/scriptFile.sh
    
    /media/cryptofs/apps/usr/bin/patch:**** malformed patch at line 146: @@ -1411,6,+1522,7 @@
    Probably a hand edit gone bad. Line 33 should read:
    Code:
    @@ -496,6 +500,112 @@

    Visor -> m515 -> Treo 650 -> HTC TyTnII -> Treo 750 -> Treo Pro -> Prē -> Prē Plus -> Prē 2

    WebOS Patches: Ringer switch icon in Top bar, Disable LightBar, Week Numbers in Calendar (ISO 8601)
  18. #58  
    are the past delayed versions a 2 or 3 second wait? Thanks Josh!
    *Patchers STILL make this phone Perfect!
    Palm Devices Currently Owned: Pre, Pre Plus, Pre 2, Pre 3, Pixi, Veer, Touchpads, and too many touchstones!
  19.    #59  
    Quote Originally Posted by frause View Post
    Probably a hand edit gone bad. Line 33 should read:
    Code:
    @@ -496,6 +500,112 @@
    Actually, it was missing a line...I must have deleted it by accident when I was using the instant version as a reference to update the delayed version.

    I've reposted both version with fresh copies.

    .
  20.    #60  
    Quote Originally Posted by stu5797 View Post
    are the past delayed versions a 2 or 3 second wait? Thanks Josh!
    Currently, the delay is set for exactly 2.25 seconds...It gives it about the same delay as the original versions before I had to switch to the setTimeout.

    .
Page 3 of 10 FirstFirst 12345678 ... LastLast

Tags for this Thread

Posting Permissions