Results 1 to 6 of 6
  1. r2ug's Avatar
    Posts
    2 Posts
       #1  
    I am currently unable to use the tweaks option under tools in WebOS Quick Install since it gives the following message:
    "It appears your device's version of WebOS has recently updated. WOSQI needs to transition patches to this new version. Would you like to do that now?"
    If I click yes, the following error shows:

    "ERRROR: An error occurred while attempting to run /tmp/ipkgScript.sh
    patching file usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    3 out of 3 hunks ignored -- see webos-patches.log for more details"

    And the webOS Update Helper says:

    "All patches are now being updated to webOS 1.4.1.1-compatible versions. If such a version does not yet exists, the patch will be removed."

    Log:
    "Error uninstalling: org.webosinternlas.patches.app-launcher-enable-add-delete-pages"

    And if I chose "NO" whenever the message "It appears your device's version of WebOS has recently updated. WOSQI needs to transition patches to this new version. Would you like to do that now?" appears then the tweaks page just closes. I tried going into Device management, which does let me, and go to the patches drop down menu, but I currently don't have any patches installed; however, there is a patch listed as "Enable Add/Delete Pages" which I've had installed in the past. I tried selecting it and hit the uninstall button but the same error comes up:

    "ERRROR: An error occurred while attempting to run /tmp/ipkgScript.sh
    patching file usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    3 out of 3 hunks ignored -- see webos-patches.log for more details"

    I'm pretty sure that patch stayed from before causing problems but how do I remove it? Or how do I fix this problem so I can use the tweaks/patches again? Help much appreciated! Thanks!
  2. #2  
    Wrong Section. But, you need to run Webos repair utility
    http://forums.precentral.net/canuck-...y-v2-01-a.html

    WebOs Repair Utility well fix the problem. make sure you check the box for the Override option in the tools tab. It wont delete anything you have on the phone, but it will delete all you patches and you'll have to reinstall them (small price to pay). If that fails, which i doubt, then you can doctor your phone.
  3. r2ug's Avatar
    Posts
    2 Posts
       #3  
    Thanks for the quick response! I did not know where to post this question. Sorry about that. After going through those errors with WOSQI, I now noticed my phone went offline and no cell phone radios are working! I shut down and restarted my phone but nothing. Any idea what's going on now? Thanks.
  4. #4  
    Run Webos Repair Utility like i said...Thats pretty much your only way out. Run Repair utility with Override to get rid of all the patches or doctor your phone to get rid of everything in it, except the USB folder.
  5. #5  
    I had the same issue....fixed it for me!
  6. #6  
    If you're planning on reinstalling all your patches it would definitely be easier if you launch Preware first, then go to saved package list and hit update. When you're done running WRU you can simply go back to the saved package list and hit install. I had to do the same thing when one patch wouldn't update or uninstall for me.

Posting Permissions