webOS Nation Forums >  Homebrew >  webOS Patches > [Patch] Add Delete Buttons (Videos)
[Patch] Add Delete Buttons (Videos)
  Reply
 
Thread Tools Display Modes
Old 04/16/2010, 01:20 AM   #1 (permalink)
Member
 
xanthinealkaloid's Avatar
 
Posts: 942
This patch adds buttons for deleting a video while viewing the video details or watching the video.


2010-04-18: Fixed the bug causing the scene to not pop correctly when viewing from camcorder...Also, corrected button placement when the share button is present and to be enabled for local videos only.




Please see post #7 for the most current patch file.


Patch creation is something I do in my spare time for myself and the Precentral community.
If you find value in my work, please take a moment to click the thanks button.
Should you be inclined, a donation link is available in my signature, and a sincere thanks to those who have.


Attached Images
File Type: png DeleteButton.png (77.9 KB, 214 views) Email Attachment
File Type: png ConfirmDelete.png (57.5 KB, 216 views) Email Attachment
File Type: png NowPlaying.png (123.6 KB, 216 views) Email Attachment
__________________
a.k.a. Josh...

Please don't forget your thanks button. --- Appreciate my efforts? -- Donate?

Various patches I've worked on:
Faster Cards|Emoticons|Shake Reload|Default Call Log|Call Log Styling|Msg Count|New Events|DM Media Vol|Megamix+MediaVol|3G icon|Gmaps fullscreen|Msg Greeting/Sig|Send Img Msg|No Ans Tstone|Dpad on Call|Vid Delete Btns|AutoSpeaker via ProxSensor

Last edited by xanthinealkaloid; 04/26/2010 at 09:11 PM.
xanthinealkaloid is offline   Reply With Quote
Old 04/16/2010, 02:59 PM   #2 (permalink)
Member
 
Partyman's Avatar
 
Posts: 95
This is yet again another awesome patch by you. Thanks.
Partyman is offline   Reply With Quote
Old 04/18/2010, 11:39 AM   #4 (permalink)
Member
 
bdubdrum's Avatar
 
Posts: 100
This is exactly what I was looking for, thank you!

One thing I've noticed, though, is that if you record a video then click the thumbnail from the camera to view the video, deleting it then gives an unresponsive white screen.

Steps to recreate bug:

1. Open Camera / Video app.
2. Record Video
3. Click thumbnail from camera screen to view video.
4. Click delete video icon
5. White screen appears and the only recourse is to swipe away camera app.

The delete function works perfectly if you're watching the selected videos directly from the video roll.

One more thing, would it be possible to move the delete icon over to the left a bit? It's very close to the upload icon in the view screen.

Thanks again for the fast patch!

bdubdrum is offline   Reply With Quote
Thanked By: xanthinealkaloid
Old 04/18/2010, 11:57 AM   #5 (permalink)
Member
 
xanthinealkaloid's Avatar
 
Posts: 942
Quote:
Originally Posted by bdubdrum View Post
...
One thing I've noticed, though, is that if you record a video then click the thumbnail from the camera to view the video, deleting it then gives an unresponsive white screen.
...
One more thing, would it be possible to move the delete icon over to the left a bit? It's very close to the upload icon in the view screen.
...
Thanks for reporting this scenario...It's happening because it's trying to pop to a scene that's not in the stack...I'll try to figure something out and post an update sometime this afternoon.

As for the button, I see what you mean, so I'll try to fix that too.

.
__________________
a.k.a. Josh...

Please don't forget your thanks button. --- Appreciate my efforts? -- Donate?

Various patches I've worked on:
Faster Cards|Emoticons|Shake Reload|Default Call Log|Call Log Styling|Msg Count|New Events|DM Media Vol|Megamix+MediaVol|3G icon|Gmaps fullscreen|Msg Greeting/Sig|Send Img Msg|No Ans Tstone|Dpad on Call|Vid Delete Btns|AutoSpeaker via ProxSensor
xanthinealkaloid is offline   Reply With Quote
Old 04/18/2010, 12:04 PM   #6 (permalink)
Member
 
bdubdrum's Avatar
 
Posts: 100
Wow, thanks for the fast response.. good luck bug hunting!
bdubdrum is offline   Reply With Quote
Old 04/18/2010, 01:36 PM   #7 (permalink)
Member
 
xanthinealkaloid's Avatar
 
Posts: 942
OK...I fixed the issue with the scene not popping correctly from the player when viewing a video from the camcorder...Also, the button has been realign for correct placement when the share button is present.

You need to uninstall the previous patch before applying the updated version.



Patch creation is something I do in my spare time for myself and the Precentral community.
If you find value in my work, please take a moment to click the thanks button.
Should you be inclined, a donation link is available in my signature, and a sincere thanks to those who have.
Attached Images
File Type: png ButtonPosition.png (32.6 KB, 120 views) Email Attachment
Attached Files
File Type: patch vid-add-delete-buttons-UPDATED.patch (4.0 KB, 26 views) Email Attachment
__________________
a.k.a. Josh...

Please don't forget your thanks button. --- Appreciate my efforts? -- Donate?

Various patches I've worked on:
Faster Cards|Emoticons|Shake Reload|Default Call Log|Call Log Styling|Msg Count|New Events|DM Media Vol|Megamix+MediaVol|3G icon|Gmaps fullscreen|Msg Greeting/Sig|Send Img Msg|No Ans Tstone|Dpad on Call|Vid Delete Btns|AutoSpeaker via ProxSensor

Last edited by xanthinealkaloid; 04/26/2010 at 08:44 PM.
xanthinealkaloid is offline   Reply With Quote
Old 04/18/2010, 02:36 PM   #8 (permalink)
Member
 
bdubdrum's Avatar
 
Posts: 100
Just tried it out and now it's perfect, great job!
bdubdrum is offline   Reply With Quote
Old 04/18/2010, 04:16 PM   #9 (permalink)
Member
 
gollyzila's Avatar
 
Posts: 1,001
Trash icon still shows up in streaming YouTube videos
gollyzila is offline   Reply With Quote
Thanked By: xanthinealkaloid
Old 04/18/2010, 06:56 PM   #10 (permalink)
Member
 
xanthinealkaloid's Avatar
 
Posts: 942
Quote:
Originally Posted by gollyzila View Post
Trash icon still shows up in streaming YouTube videos
Bummer...I didn't notice that one either...I reposted the patch file above to fix the condition, so it will only show the trash can for locally stored videos.

.
__________________
a.k.a. Josh...

Please don't forget your thanks button. --- Appreciate my efforts? -- Donate?

Various patches I've worked on:
Faster Cards|Emoticons|Shake Reload|Default Call Log|Call Log Styling|Msg Count|New Events|DM Media Vol|Megamix+MediaVol|3G icon|Gmaps fullscreen|Msg Greeting/Sig|Send Img Msg|No Ans Tstone|Dpad on Call|Vid Delete Btns|AutoSpeaker via ProxSensor
xanthinealkaloid is offline   Reply With Quote
Old 04/19/2010, 10:48 AM   #11 (permalink)
Member
 
xanthinealkaloid's Avatar
 
Posts: 942
An update has been submitted to Preware regarding the above mentioned fixes.

.
__________________
a.k.a. Josh...

Please don't forget your thanks button. --- Appreciate my efforts? -- Donate?

Various patches I've worked on:
Faster Cards|Emoticons|Shake Reload|Default Call Log|Call Log Styling|Msg Count|New Events|DM Media Vol|Megamix+MediaVol|3G icon|Gmaps fullscreen|Msg Greeting/Sig|Send Img Msg|No Ans Tstone|Dpad on Call|Vid Delete Btns|AutoSpeaker via ProxSensor
xanthinealkaloid is offline   Reply With Quote
Thanked By: bdubdrum
Old 04/19/2010, 10:49 AM   #12 (permalink)
Member
 
errade's Avatar
 
Posts: 1,608
xan, you're doing an ace job with these patches. Keep it up mate!
errade is offline   Reply With Quote
Old 03/29/2011, 11:26 AM   #13 (permalink)
Member
 
Posts: 6
Hi, when I wanted to delete this patch, all was good, but when I wanted to re-install it, that was long, very long, then I close Preware and reboot my Palm Pre but now I can't see it to install it, and now I don't have sound with my speaker with Music and Video, but I have sound with Alarm, when I receive call phone and able to heard sound wiht headphone for Music and Video. How can I re-enable sound with speaker for Music and Video?
TheOneric is offline   Reply With Quote
Old 04/06/2011, 11:25 PM   #14 (permalink)
Member
 
Posts: 36
ok, I know its offtopic but it is possible for you to make a patch for different folders in the video app, so I can have my localy stored series by season and not having to go for file hunting when I want them, I will donate, no one else seems able to do it, and several people have asked the same thing
ghostjb is offline   Reply With Quote
Old 04/15/2011, 10:41 AM   #15 (permalink)
Member
 
Posts: 58
thanks for great effect . but i don't know why HP/Palm add this icon into system ?
sunsealeo is offline   Reply With Quote
Reply

 

Tags
patch

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0