Results 1 to 18 of 18
  1.    #1  
    Share Larger Videos Via Email (Videos)
    Preware Status: Approved 4/5/10

    Increases video size limit that users can 'share via email' from the Videos app from 7MB to 25MB. Currently, videos over 7MB will force users to edit/shorten their video.


    Why 25MB?
    Because for most people, this should be fine, right? Gmail email service limit attachments to this amount so it will prevent users from sending videos over this amount that it will ultimately fail to be delivered.

    But, Preware and Precentral users aren't average users
    I agree, we know what we're doing! Therefore, the Even Larger Videos Via Email patch has a 2GB limit...just know what your email provider caps your attachment size to.

    Update: 1.4.1.x compatible version attached as well. Thanks xanthinealkaloid.


    Note, going into Email app will let you attach any filesize. This patch only increases the cap set by the Videos app.
    Attached Files Attached Files
    Last edited by opacityzero; 04/05/2010 at 10:08 AM.
  2. #2  
    could u please submit this to preware?
    thanks
  3. #3  
    Very nice...Thanks!

    I did have to change the 47 directory to 48 for 1.4.1, but it applied fine after that.

    .
  4. #4  
    Quote Originally Posted by xanthinealkaloid View Post
    Very nice...Thanks!

    I did have to change the 47 directory to 48 for 1.4.1, but it applied fine after that.

    .
    please explain and , hmm... share? im also on 1.4.1.1

    thank you
  5. #5  
    Quote Originally Posted by ericizzy1 View Post
    please explain and , hmm... share? im also on 1.4.1.1

    thank you
    If you open the patch file in a text editor, you'll see what I mean.

    .
  6. Freshyz's Avatar
    Posts
    905 Posts
    Global Posts
    926 Global Posts
    #6  
    Quote Originally Posted by xanthinealkaloid View Post
    Very nice...Thanks!

    I did have to change the 47 directory to 48 for 1.4.1, but it applied fine after that.

    .

    So every place it says '47' change that to a '48'? (there are 4 of them)

    What about the Palm 1.4 version? Do I need to change that to 1.4.1.1?

    Then save and install through QI ya?
    Everybody wants some!..
  7. #7  
    Quote Originally Posted by Freshyz View Post
    So every place it says '47' change that to a '48'? (there are 4 of them)

    What about the Palm 1.4 version? Do I need to change that to 1.4.1.1?

    Then save and install through QI ya?
    Only in the 2 line header for the context...
    Code:
    --- .orig/usr/palm/frameworks/private/metascene.videos.share/submission/48/javascript/share-master.jsjsjs
    +++ /$usr$/$palm$/$frameworks$/$private$/$metascene$.$videos$.$share$/$submission$/48/javascript/share-master.jsjsjs
  8. Freshyz's Avatar
    Posts
    905 Posts
    Global Posts
    926 Global Posts
    #8  
    WooHoo!
    My first code editing attempt and it went smoothly.
    I stuck with the Gmail limited size patch since I use that most.

    So these larger videos should be viewable on most any smart phone ya?

    Oh and just curious what that meant changing 47 to 48?
    Everybody wants some!..
  9. #9  
    done, thanks
    Last edited by ericizzy1; 04/02/2010 at 02:46 PM.
  10. add309's Avatar
    Posts
    40 Posts
    Global Posts
    100 Global Posts
    #10  
    ok well i kinda feel dumb but hopefully someone puts up better directions on how to exactly do this, it may seem there are some already however you havent made clear what to change the code with, or how to install it, or for that matter how to uninstall it if we dont want it anymore. . . please get a little more detailed
  11.    #11  
    See first post for 1.4.1.x compatible version - let me know if it works ok as I currently have 1.4.0 still (having a hard time letting go the 800MHz patch)

    Thanks again xanthinealkaloid!
  12. #12  
    Quote Originally Posted by opacityzero View Post
    See first post for 1.4.1.x compatible version - let me know if it works ok as I currently have 1.4.0 still (having a hard time letting go the 800MHz patch)

    Thanks again xanthinealkaloid!
    FWIW...The kernel mod is ok to install under 1.4.1.

    .
  13.    #13  
    Thanks xanthinealkaloid, will update.

    Btw, when submitting to preware, for a patch like this where for 1.4 it one, and for 1.4.1.x it's another, do you submit both to preware as 2 separate submissions?
    Last edited by opacityzero; 04/02/2010 at 07:36 PM.
  14. #14  
    Quote Originally Posted by opacityzero View Post
    ...
    Btw, when submitting to preware, for a patch like this where for 1.4 it one, and for 1.4.1.x it's another, do you submit both to preware as 2 separate submissions?
    Normally, you would submit the first version(1.4), then the second(1.4.1) would be submitted as an update...In which case, you'd have to wait for the first one to be add to the feed.

    Although, you may be able to submit both at the same time with the exact same name with a note to the admins, but I never really had any reason to try it.

    You may be better off simply submitting the 1.4.1 version and keeping the 1.4 version post here if anyone wants it.


    If you'd like an official answer, I would suggest jumping on the WebOS Internals IRC.
    .
  15. #15  
    Quote Originally Posted by opacityzero View Post
    See first post for 1.4.1.x compatible version - let me know if it works ok as I currently have 1.4.0 still (having a hard time letting go the 800MHz patch)

    Thanks again xanthinealkaloid!
    im on 800 patch with 1.4.1.1 , works like a charm
  16. #16  
    Dumb question time..... wich one is for 1.4.1.1?
  17.    #17  
    Quote Originally Posted by Knight77 View Post
    Dumb question time..... wich one is for 1.4.1.1?
    The patch that says 1.4.1 also works for 1.4.1.1
  18. ganthonyv's Avatar
    Posts
    44 Posts
    Global Posts
    74 Global Posts
    #18  
    Does this patch only work with videos u took with the pre video or does it work with videos I've downlaoded? I was trying to send a video I dlaoded to someone and they said they never rec'd it. Need help..I have the pre plus on verizon with the latest os update.

Posting Permissions