Page 1 of 2 12 LastLast
Results 1 to 20 of 29
  1. petegk's Avatar
    Posts
    16 Posts
    Global Posts
    17 Global Posts
       #1  
    How do I forcibly remove a patch?

    My Phone Radio Toggle patch is stuck...Preware shows it on my phone with an update available but I can't download without errors, nor will it delete. I can't even start WOSQI-->Tweaks because it says I have a patch that needs updating and errors out then closes completely. I just want to remove it and I want to avoid doctoring if possible. I tried EPR to no avail.

    Here is the ipkg error log I got from Preware:

    patching file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    2 out of 2 hunks ignored -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs.$rej$
    patching file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    6 out of 6 hunks ignored -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs.$rej$
    patching file usr/lib/luna/system/luna-systemui/app/views/devicemenu/devicemenu-scene.html
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored -- saving rejects to file usr/lib/luna/system/luna-systemui/app/views/devicemenu/devicemenu-scene.html.rej

    FYI, I am running WebOS 1.4, Preware 0.9.29 and WOSQI 3.02.

    Thanks!!!
  2. #2  
    Quote Originally Posted by petegk View Post
    How do I forcibly remove a patch?

    My Phone Radio Toggle patch is stuck...Preware shows it on my phone with an update available but I can't download without errors, nor will it delete. I can't even start WOSQI-->Tweaks because it says I have a patch that needs updating and errors out then closes completely. I just want to remove it and I want to avoid doctoring if possible. I tried EPR to no avail.

    Here is the ipkg error log I got from Preware:

    patching file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    2 out of 2 hunks ignored -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs.$rej$
    patching file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    6 out of 6 hunks ignored -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs.$rej$
    patching file usr/lib/luna/system/luna-systemui/app/views/devicemenu/devicemenu-scene.html
    Unreversed patch detected! Ignore -R? [n]
    Apply anyway? [n]
    Skipping patch.
    1 out of 1 hunk ignored -- saving rejects to file usr/lib/luna/system/luna-systemui/app/views/devicemenu/devicemenu-scene.html.rej

    FYI, I am running WebOS 1.4, Preware 0.9.29 and WOSQI 3.02.

    Thanks!!!
    Try this...delete all patches that have the phone icon in Preware except this patch...luna restart...you should then be able to delete this patch...luna restart...put this patch back on if you want it...luna restart...start adding the phone patches back w/ luna restart in between each. If you have match state to area code put it on first as it doesn't play well with others unless it's favored, lol!
    If "If's" and "But's" were candy and nuts we'd all have a Merry Christmas!


  3. #3  
    Quote Originally Posted by spudland View Post
    Try this...delete all patches that have the phone icon in Preware except this patch...luna restart...you should then be able to delete this patch...luna restart...put this patch back on if you want it...luna restart...start adding the phone patches back w/ luna restart in between each. If you have match state to area code put it on first as it doesn't play well with others unless it's favored, lol!
    It is good advice to try to remove all patches in same category first, and just a quick tip:

    luna restart is not required until the end (only serves to re-pull the files into memory so that you may visually see the effects of your patching).

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  4. petegk's Avatar
    Posts
    16 Posts
    Global Posts
    17 Global Posts
       #4  
    I tried removing all the patches in the same category (Top Bar) and then restarting, but it still did not allow me to update or remove Phone Radio Toggle.

    Do you have any other suggestions?
  5. #5  
    Quote Originally Posted by petegk View Post
    I tried removing all the patches in the same category (Top Bar) and then restarting, but it still did not allow me to update or remove Phone Radio Toggle.

    Do you have any other suggestions?
    attach webos-patches.log file

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  6. petegk's Avatar
    Posts
    16 Posts
    Global Posts
    17 Global Posts
       #6  
    I've attached txt copies of the patches log and patches list.
    Thanks!
    Attached Files Attached Files
  7. #7  
    Quote Originally Posted by petegk View Post
    I've attached txt copies of the patches log and patches list.
    Thanks!
    There is no reference to any phone radio toggle in the log.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  8. petegk's Avatar
    Posts
    16 Posts
    Global Posts
    17 Global Posts
       #8  
    Quote Originally Posted by egaudet View Post
    There is no reference to any phone radio toggle in the log.
    yeah I noticed that too. I can only tell you what is happening on my pre. Is there a way to trick preware into not seeing the patch so that I can try to reinstall it?
  9. #9  
    I am having this same problem with 2 different patches (call duration in call log and default to month view). I can't update or uninstall them. I am on 1.4.0 update.
  10. #10  
    Quote Originally Posted by stistud2k7 View Post
    I am having this same problem with 2 different patches (call duration in call log and default to month view). I can't update or uninstall them. I am on 1.4.0 update.
    I am having the same exact issue. I have reset the device via webdoctor and it still has the patches on my phone.

    Odd thing is I tried removing the patches on one computer and it wouldn't remove them but recognized them. I tried it on my home computer and webinstall doesn't see the packages. Preware still recognizes them though. I would love some help on this before I take the phone and throw it out the door.
  11. #11  
    I'm also having this issue. Anyone know of a solution? Thanks!
  12. ldj
    ldj is offline
    ldj's Avatar
    Posts
    256 Posts
    Global Posts
    264 Global Posts
    #12  
    I have the same problem with the character counter patch. Will not instal, update or uninstall; but preware insists its installed. Tried an EPR which only removed my working patches, not the problem one *sigh*
  13. #13  
    got mine to work using EPR from preware. I could not get wosqi to work until I did the epr from preware. all good now... I hope.
  14. #14  
    Hi, I have exactly the same problem. Updated to 1.4, have 73 stuck patches!! EPR hasn't worked. I tried reinstalling package manager and preware - no change.

    I have the same IPKG error stating that an 'unreversed patch' is detected. I deleted manually via Quick Install Web OS one of the directories for a patch, and that patch STILL appears in the preware list!?

    Thanks for any help in advance
  15. #15  
    I know this is a little sketchy but I had the same problem a few weeks ago. If you try to remove the patch with WOSQI 3.02, you will get the error message.

    Now, the trick is, use an older version of WOSQI, I have a copy of version 2.96 just in case this happens again. When you remove the patch, it will just ignore any error message and remove it from your list.

    Try to find yourself a copy of 2.96. I would gladly post mine, but JayCanuck doesn't allow redistribution, especially of old stuff he probably no longer directly supports.
  16. #16  
    Thanks!! Worked for me!
  17. #17  
    Quote Originally Posted by PerfectLogic View Post
    I know this is a little sketchy but I had the same problem a few weeks ago. If you try to remove the patch with WOSQI 3.02, you will get the error message.

    Now, the trick is, use an older version of WOSQI, I have a copy of version 2.96 just in case this happens again. When you remove the patch, it will just ignore any error message and remove it from your list.

    Try to find yourself a copy of 2.96. I would gladly post mine, but JayCanuck doesn't allow redistribution, especially of old stuff he probably no longer directly supports.
    Hi Perfect Logic, thanks for the reply. I tried this - thanks for your offer, managed to find a version 2.96 of WOSQI. Used this, loaded the device management page for patches, and it listed no patches!! It couldn't find any patches installed on the device. I switched back to 3.02 and when it loads the patches installer it says that it needs to update the patches to current version. It starts process, but fails in finding all these 'unreversed' patches still. Any idea why 2.96 can't even see the patches, yet 3.02 is saying they are there but wrong version and corrupt? It seems as if the patch has disappeared, but a remnant is still around fooling the system?
  18. #18  
    I rechecked my own phone with WOSQI 2.96 and apparently all the patches are listed under "Applications" in the Device Management screen. Your faulty patch should be among those.

    About your problem with 3.02, I've never encounter this before so I can't help...
  19. #19  
    I have worked out how to solve the stuck patch problem that occurs after 1.4 WebOS upgrade (thanks to perfect logic for the help here)

    1. Load QuickInstall ver 2.96 and click applications list in device management. All the stuck patches will show up. Highlight them and use uninstall function.

    2. Then use QuickInstall ver 3.02 or updated Preware to install new patches

    3. If there are any errors in the IPKG log use WebOS repair utility to scan and repair the files

    Good luck!
  20. #20  
    Where did you find the previous version of WOSQI? I've looked everywhere I can think of. Any help would be appreciated.
Page 1 of 2 12 LastLast

Posting Permissions