Results 1 to 8 of 8
  1. MotorMD's Avatar
    Posts
    32 Posts
    Global Posts
    39 Global Posts
       #1  
    I love the Open to Call Log patch, however I have run into a lil issue that I would like to put in a request for a change.

    I use the close on Hangup patch. When i use the Open to Call Log together with Close on Hangup here is what happens.

    1. i hang up the call
    2. the phone app closes
    3. the phone app reopens with the Call Log showing


    I would like to request perhaps second version of the Open to Call Log that does not revert to the Call Log at the end of a call.


    Thank you for your time.
    Keep up the fabulous work!

    --MotorDr
  2. #2  
    I'm glad you posted this issue, but it appears you may have a larger problem...

    If I'm reading your post correctly, it seems you think the Open to Call Log patch is somehow causing your Phone app to reopen.

    Please answer these 2 questions:

    1. Have you uninstalled the Open to Call Log patch to see if the behavior is still there without it?...If not, please do so and post the results.

    2. Does this behavior happen to all outgoing calls placed or only the first one after you restart?...Be sure you strictly use the dialpad when checking this.

    .
  3. MotorMD's Avatar
    Posts
    32 Posts
    Global Posts
    39 Global Posts
       #3  
    Quote Originally Posted by xanthinealkaloid View Post
    I'm glad you posted this issue, but it appears you may have a larger problem...

    If I'm reading your post correctly, it seems you think the Open to Call Log patch is somehow causing your Phone app to reopen.
    This is precisely what it appeared to do. Upon hangup the phone app disappeared then immediately reappeared with the Call log on top.

    Quote Originally Posted by xanthinealkaloid View Post
    Please answer these 2 questions:

    1. Have you uninstalled the Open to Call Log patch to see if the behavior is still there without it?...If not, please do so and post the results.

    2. Does this behavior happen to all outgoing calls placed or only the first one after you restart?...Be sure you strictly use the dialpad when checking this.

    .
    I will do the above tests and post back the results.

    Thank you for the prompt response.


    --MotorDr
  4. MotorMD's Avatar
    Posts
    32 Posts
    Global Posts
    39 Global Posts
       #4  
    Tests performed.
    Here is what I did and the responses I observed.
    Note: All calls were performed with the dialpad then I ended the calls once they were answered.

    Test1: Installed Close on Hangup Patch via Preware then Luna restarted
    Manual Call 1: on hangup, app closed. After approx 1 sec app reopened @ dail pad.
    Manual Call 2: (without closing app after call 1 I dialed again) on hangup, app closed. it did not reopen.
    Manual Call 3: I opened app, dialed. on hangup app closed. it did not reopen.

    Test 2: Installed Open to Call Log Patch via Preware then Luna restarted. Close on Hangup Patch was still installed.
    Manual Call 1: on hangup, app closed. After approx 1 sec app reopened @ Call Log.
    Manual Call 2: (without closing app after call 1 I dialed again) on hangup, app closed. it did not reopen.
    Manual Call 3: I opened app, dialed. on hangup app closed. it did not reopen.

    Test 3: Uninstalled Open to Call Log Patch via Preware then Luna restarted.
    Manual Call 1: on hangup, app closed. After approx 1 sec app reopened @ dail pad.
    Manual Call 2: (without closing app after call 1 I dialed again) on hangup, app closed. it did not reopen.
    Manual Call 3: I opened app, dialed. on hangup app closed. it did not reopen.

    It would appear that the reopen issues only happens on the first call after restart. After that it appears to work as I would like it to.

    I guess my request was unnecessary then?

    Is this somewhat "normal" that some patches will behave unexpectedly the first time after a restart?

    -MotorDr
  5. #5  
    My apologies for not getting back sooner.

    Your request may have been unnecessary, but I'm glad you reported this behavior...It isn't normal for a patch to do something only after a restart unless it's explicitly written to do so which this one isn't.

    BTW...It only seems to happen if that first call is initiated from within the Phone app otherwise it doesn't happen at all...Also, I haven't found any other adverse effects of using the patch despite this anamoly.

    I've actually seen this happen for myself without being able to determine the solution just yet...I know it's not the patch or a patch compatibilty issue because my wife's phone doesn't do this with the Close on Hangup patch installed and mine does it with only the Close on Hangup patch installed after being freshly doctored.

    I'm curious to learn more about your Pre...

    Have you done any repartitioning?
    When's the last time you doctored your phone?
    Do you do any other non-patch related hacks (possible examples: Ebag333's GPS hack, changing your home agent, or resizing your media buffer)?

    I'm somewhat surprised you and I are the only ones experiencing this problem, but perhaps we can get to the bottom of it.

    If anyone else has any feedback what could be causing this, it would be very much appreciated.

    .
  6. MotorMD's Avatar
    Posts
    32 Posts
    Global Posts
    39 Global Posts
       #6  
    No need to apologize. We all have busy lives.

    As far as modifications go:
    I haven't doctored my phone. I got it fresh as a replacement back about the beginning of the month.
    I don't have any other hacks besides patches.
    I haven't repartitioned. ( to be honest i wouldn't know how.)

    Am on Sprint running Webos 1.3.5.1
    I have about 4.3GB available on the device and have the latest Preware and WebosQI.

    An interesting dilemma to be sure.
    If there is any other information I can supply please keep asking and I'll do what I can.

    Maybe I can talk my wife or my daughter into patching their Pres and see if they get this effect as well.....hmmm
  7. #7  
    Just to update...

    I no longer have this issue after doctoring my phone with 1.4...The only difference for me was using meta-doctor to do my repartitioning of root and var.

    So, no real solution, but it's functioning correctly at this point.

  8. #8  
    i love the callanswerhangup patch but it doesnt work with 1.4.1....is there a callanswer hangup patch for this version....thx to anyone who can help

Posting Permissions