Results 1 to 12 of 12
  1.    #1  
    OK, so this one is pretty much a cut and paste job using the code from here.

    In other words, the credit goes to Palm Engineer Matt Hornyak, but 5 months later this feature still hasn't been added to the clock which is a bit odd in my opinion...Anyhow, the original discussion can be found here.

    The stock default is 10 min...With this patch, you'll have the choice of 5, 10, 15, or 20 minutes as your Clock app default.

    Accepted for Preware as "More Default Snooze Times".

    Preware Description: Adds more snooze times to the Preferences page for the Clock app. (based on code by Palm Engineer Matt Hornyak)

    Patch creation is something I do in my spare time for myself and the Precentral community...If you use it, please take a moment to click the thanks button, as it goes a long way to keeping me motivated.
    .
    Attached Images Attached Images
    Attached Files Attached Files
    Last edited by xanthinealkaloid; 03/22/2010 at 01:57 PM. Reason: patch name change...can't do less then 5 min.
  2. c_man's Avatar
    Posts
    392 Posts
    Global Posts
    393 Global Posts
    #2  
    Thank you!!

    I was one of the original requesters and I will be installing this within the next few days - looking forward to it .

    One question, you stated you tested it for 1.3.5.1.
    I am guessing it will be okay for us on 1.3.5.2 ?
  3.    #3  
    You're welcome.

    I installed it in the emulator running the most current SDK, so I don't know of any reason it shouldn't work on 1.3.5.2.
  4. #4  
    Thanks. I've been looking forward to this one.
  5. #5  
    What was the outcome with submitting it to the Preware feed?

    - Craig
  6.    #6  
    Quote Originally Posted by milominderbinder View Post
    What was the outcome with submitting it to the Preware feed?

    - Craig
    It's in the Preware feed under the Clock app as "More Default Snooze Times".
  7. c_man's Avatar
    Posts
    392 Posts
    Global Posts
    393 Global Posts
    #7  
    Hi again,
    I've tested this twice now - doesn't seem to work?
    It just completely kills any snooze for the alarm - the alarm does not sound ever again after the first time.
    I've been testing it on 3min snooze & yes, alarm preferences are enabled.

    Any ideas?
  8.    #8  
    Quote Originally Posted by c_man View Post
    Hi again,
    I've tested this twice now - doesn't seem to work?
    It just completely kills any snooze for the alarm - the alarm does not sound ever again after the first time.
    I've been testing it on 3min snooze & yes, alarm preferences are enabled.

    Any ideas?
    DUH!...I noticed at the bottom alarm.jsjsjs $is$ $states$ $that$ $the$ $service$ $can$'$t$ $handle$ $snooze$ $less$ $than$ $5$ $minutes$.

    I added the 3 minute option as a last minute thing.

    All I can do at this point is remove the 3 minute option and submit an update to Preware...I really don't have enough time to do much more than that.

    My apologies...Thanks for the feedback!

    .
  9. c_man's Avatar
    Posts
    392 Posts
    Global Posts
    393 Global Posts
    #9  
    Ok no worries - thanks for the reply.

    Can anyone else pick up this patch and add a 3min option?

    Was the default snooze 5min?? I cannot remember...
  10.    #10  
    Quote Originally Posted by c_man View Post
    Was the default snooze 5min?? I cannot remember...
    The stock default is 10 minutes.

    Quote Originally Posted by c_man View Post
    Can anyone else pick up this patch and add a 3min option?
    Also to clarify, I'm not sure any option less 5 minutes is actually possible...It would be great if someone could qualify this statement.

    .
  11. #11  
    Very nice idea this little patch but it doesn't work on my pre (european version, webos 1.4).
    Is there any fix available?
  12.    #12  
    Quote Originally Posted by tomm-jay View Post
    Very nice idea this little patch but it doesn't work on my pre (european version, webos 1.4).
    Is there any fix available?
    It's likely due to the one html file which gets patched...The only way to "fix" it would be to patch the file specific to your location.


    Replacing [LOCALE] with your language code, the file path should look something like this:
    Code:
    /usr/palm/applications/com.palm.app.clock/resources/[LOCALE]/settings/settings-scene.html

Tags for this Thread

Posting Permissions