Results 1 to 11 of 11
  1.    #1  
    OK, so I have this problem occasionally…When I do a search through the browser startpage or the global search assistant, I get a French or Spanish version of the search results page with the results in English…I'm assuming I'm probably getting some sort of localized results though.

    It would seem adding "/ncr" in the search url activates the "no country redirect"…
    i.e.
    Code:
    www.google.com/m/ncr/search?client=ms-palm-webOS&channel=iss&q=
    vs.
    Code:
    www.google.com/m/search?client=ms-palm-webOS&channel=iss&q=
    Since this happens to me only intermittently, I'm not 100% certain this will solve the problem of Google redirecting to a localized version, but I figured it was worth a shot.

    Bottomline, it doesn't seem the change hurts anything, so I hope it helps alleviate the problem.

    Of course, any feedback would be very much appreciated!



    Description: Modifies the default search engine & global search assistant to use Google's "no country redirect".

    Add'l notes:
    1. I don't use the USCL patch, so I don't know if its compatible with it.
    2. It should work fine if you have modified your global-search-assistant.jsjsjs $to$ $add$ $user$-$specific$ $searches$.
    3. The patch is really intend for those who aren't modifying their global-search-assistant.jsjsjs.
    Attached Files Attached Files
  2. #2  
    Patch works for me via WebosQI, I'm having similar problems. It appears that a cookie can correct it for a while but every so often it gets confused and chooses Spanish. I'll keep this applied for a while and see what happens.

    What I've also trying to do for the last week days is try and change the google address to my preferred local search e.g. Google instead of the .com any ideas why every time I change it the .com address overwrites it? (even with the ncr)?

    Thanks
  3. #3  
    turning data off and back on corrects the issue for me each time. This is great for those that don't want to flick the toggle each time it happens.
  4.    #4  
    Quote Originally Posted by mrloserpunk View Post
    turning data off and back on corrects the issue for me each time. This is great for those that don't want to flick the toggle each time it happens.
    Unfortunately, I tried the data toggling, but it never worked for me...Besides, I thought it was annoying that it ever happened.

    Google knows best.

    Quote Originally Posted by craigc View Post
    Patch works for me via WebosQI, I'm having similar problems. It appears that a cookie can correct it for a while but every so often it gets confused and chooses Spanish. I'll keep this applied for a while and see what happens.

    What I've also trying to do for the last week days is try and change the google address to my preferred local search e.g. Google instead of the .com any ideas why every time I change it the .com address overwrites it? (even with the ncr)?

    Thanks
    How odd...Here a version of the patch for the UK mobile Google website.

    If you open it in a text editor, you'll see the address gets changed in 2 places; the default for the browser & the default for the global search assistant.

    I really hope this helps.

    .
    Attached Files Attached Files
  5. #5  
    Thanks, I've applied your patch.

    I've messed with systemprefs.db, the default search and a few other places but not managed to get it to use .co.uk, I'll see how yours works. I'm getting UK adverts and the right amazon but that could be cookies, I'll give it some testing and let you know.

    Thanks again.
  6. #6  
    Fwiw, I recall some people speculating that this is caused when they roam near Canada.

    I'm not sure from the first post what's happening... The results are in English, but the interface is in a different language? Or is it that you're getting actual search results from a different country?

    If it's the former, you can set the language with "hl" in the query string. E.g., ?q=test&hl=en

    Also, the KeyToss Keyword Search patch would solve this problem for you. It takes the selected language of the device and automatically puts it in the query string for Google.

    KeyToss won't solve the co.uk problem because KeyToss uses google.com for every country except France, which is what the Pre does by default. Perhaps when I have time, I can add the option to change that.
  7.    #7  
    Quote Originally Posted by samkim View Post
    Fwiw, I recall some people speculating that this is caused when they roam near Canada.
    From my research, it seemed to be an IP/server related issue...It had something to do with Google getting "confused" on your location, even on desktops, based on where the ip address being acquired. (confused = mandated based Google criteria)

    Also, I can confirm mine was a roaming problem, at least that seems to be when it was happening.

    Quote Originally Posted by samkim View Post
    I'm not sure from the first post what's happening... The results are in English, but the interface is in a different language? Or is it that you're getting actual search results from a different country?

    If it's the former, you can set the language with "hl" in the query string. E.g., ?q=test&hl=en
    Just to confirm...With the boldface text in the quote being the issue, is your given solution for this situation?

    If so, you may definitely be on to something because tried the query string below with "success" which means I could easily mod the default & GSA with it.

    Code:
    www.google.com/m/search?client=ms-palm-webOS&channel=iss&hl=en&q=
    Quote Originally Posted by samkim View Post
    Also, the KeyToss Keyword Search patch would solve this problem for you. It takes the selected language of the device and automatically puts it in the query string for Google.

    KeyToss won't solve the co.uk problem because KeyToss uses google.com for every country except France, which is what the Pre does by default. Perhaps when I have time, I can add the option to change that.
    Sorry, but I wasn't really interested in the KeyToss patch.

    I do quite an extensive mod on my gsa, so it's not much to add this to it.

    .
  8. #8  
    Quote Originally Posted by xanthinealkaloid View Post
    How odd...Here a version of the patch for the UK mobile Google website.

    If you open it in a text editor, you'll see the address gets changed in 2 places; the default for the browser & the default for the global search assistant.

    I really hope this helps.

    .
    After a day of messing around, looks like the patch is being completely ignored by the pre!

    Doing a universal search for "view my headers" and visiting the site (don't forget to refresh the pre's caching is a bit hit and miss) and the referrer is http://www.google.com/m/search?client=ms-palm.......

    Doing a search from within the browser does the same.

    Starting to wonder if the default search in the systemprefs.db might be the used when it thinks the address is incorrect. Might also explain why the address doesn't start with http like the others? Any thoughts?
  9. #9  
    Quote Originally Posted by xanthinealkaloid View Post
    Just to confirm...With the boldface text in the quote being the issue, is your given solution for this situation?
    Yes.
    Sorry, but I wasn't really interested in the KeyToss patch.
    No worries. Just offering a possible solution.
  10. #10  
    Quote Originally Posted by craigc View Post
    After a day of messing around, looks like the patch is being completely ignored by the pre!

    Doing a universal search for "view my headers" and visiting the site (don't forget to refresh the pre's caching is a bit hit and miss) and the referrer is Google.......

    Doing a search from within the browser does the same.

    Starting to wonder if the default search in the systemprefs.db might be the used when it thinks the address is incorrect. Might also explain why the address doesn't start with http like the others? Any thoughts?
    I haven't looked at that patch, but I do know that there are several references to google in the webOS files, and most of them are ignored. You can change the default search engine for the device in one of the browser files. Simplest way would be to edit the KeyToss patch and replace the lines referencing Yahoo - without adding or removing any lines. Then you'll be able to switch search engines in the browser preferences.
  11. #11  
    Quote Originally Posted by samkim View Post
    I haven't looked at that patch, but I do know that there are several references to google in the webOS files, and most of them are ignored. You can change the default search engine for the device in one of the browser files. Simplest way would be to edit the KeyToss patch and replace the lines referencing Yahoo - without adding or removing any lines. Then you'll be able to switch search engines in the browser preferences.
    Thanks I think that was the start I needed, After having a play with this patch and seeing it had little effect on my Pre and started up the emulator and started looking at the keytoss patch files.

    Didn't get too far, Keytoss and it's advanced in the way in hooks in were clouding things for me. So after playing some more I found a keytoss removal script that clears the entry from the systemprefs.db. After some quick learning on the luna-send I managed to up the database with the new url and bang it works. No more spanish google. Just going to try and clear a bug or two....

Posting Permissions