Page 1 of 4 1234 LastLast
Results 1 to 20 of 62
  1.    #1  
    Only 6 of the 160 patches I had ported to 1.3.5 prior to the public release of 1.3.5 did not apply properly after the public release. I have since fixed all but 1. **BEGIN EDIT** Elryon has FIXED "Messaging SMS Tone Per Contact". **END EDIT** So ALL patches in the webOS-Patches feed apply correctly. As of this moment (11:41pm Central US, 12/30/2009) that number stands at 160! I have tested this multiple times on multiple devices and emulators. If you are having issues installing any of the patches in the feed, it is either an incompatibility of two patches or some other user error.

    Check in Index of /feeds/webos-patches/1.3.5 for the complete list of patches in the 1.3.5 feed.

    You can also view the current spreadsheet I maintain for the webOS-Patches feed. It contains all the packages and their current version number as well as certain notes that might pertain. The spreadsheet is here.

    --Begin Edit by dBsooner--
    Keep checking the above links for updates. As more patches are ported or submitted and tested, the feed will grow.
    --End Edit by dBsooner--

    The latest versions of Preware and the Package Manager service will *automatically* use the correct patch feed which corresponds to the version of webOS that you are running at the time.

    We can use this thread to report patches that are listed in that feed, but have functional problems; or patches that are not listed in that feed, but someone has been able to forward-port to webOS 1.3.5 ...

    Note that for all the patches that are licensed as MIT Open Source (there are only a few stragglers that we have not been able to confirm this for yet), *anyone* with access to the 1.3.5 Beta SDK can port the patch to webOS 1.3.5 and submit the updated patch under the same license. The original author, and the person who updated the patch, are then both listed (if desired) in the maintainer field.

    MIT Open Source patches means that the whole community can work together to get the complete set of patches ported to the next webOS version without being held up if a particular author does not have the time or desire to do so.

    -- dBsooner (Daniel), rwhitby (Rod) and emoney_33 (Eric)

    Mod Note: Here is the full list of patches ported or not.
    Last edited by dBsooner; 12/30/2009 at 11:42 PM.
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
  2. #2  
    that's awesome, I really love that one missing patch though lol

    but way to be ahead of the game, I upgraded, and had my phone right back to patched and themed in no time thanks to preware (webosQI actually screwed me for a minute, connection errors, half *** installing a theme ugh)
  3. #3  
    Don't know if this applies but..

    I followed all the steps before upgrading to 1.3.5. I did not however turn off the LED notifications before running EPR, nor did I move my icons back to only 3 pages. Once the update was complete I still had 5 launcher pages & LED notifications. After reinstalling Preware I redownloaded all previous patches except for the add/remove launcher pages patch. It's still in my pre but preware doesn't show it as downloaded. It is also fully functional. Just a heads up for anyone interested.
  4.    #4  
    Updated OP.. All 160 now apply. Thanks to Elryon, SMS Tone Per Contact has been fixed!
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
  5. #5  
    Thanks for all the FREE hard work all the developers are doing!! (So, yes, get your donation in. I did!)
    WebOS Internals:Site support - WebOS Internals
  6. #6  
    I didnt uninstall my patches and apps, so I had to doctor my phone. but now None of the patches I had or apps will download. I keep getting an ipkg error. What do I do?
  7. #7  
    I have updated the package and preware, however, when I try to install a patch it just say download/installing and the circle is moving. Nothing is happening. Left it on for awhile and nothing happens. Tried 4 different patches, the last one unthrottle download and it just doesn't work.

    Any ideas?
  8. #8  
    Quote Originally Posted by jediknight36 View Post
    I didnt uninstall my patches and apps, so I had to doctor my phone. but now None of the patches I had or apps will download. I keep getting an ipkg error. What do I do?
    If I download and install the patches using quickinstall instead of preware, they work just fine. Preware is jacked or something.
  9. #9  
    Could someone point me in the direction of the fix if you can't download apps from the app store? Thanks.
  10. rpc
    rpc is offline
    rpc's Avatar
    Posts
    4 Posts
    #10  
    I'm not sure were to post this. I had several patches on my Pre when I received the message the 1.3.5 was ready to update. I didn't have time at the moment to remove the patches so I didn't allow the update. Later today I plugged in my Pre to charge and you guessed it, I came back to see it in the update process and realized that I had been warned it would install at the next charging.

    Long and short I didn't stop the update and the phone is finished. I haven't poked around so I don't know what issues I might have. Does anyone have advice as to what to do now. Should I go to Preware and remove all the patches, some of which (4x5 icons) don't show up.

    Any ideas would be appreciated. Bad day, New Years eve to be asking questions.
  11. #11  
    you probably should doctor it
  12. #12  
    I have patch "bypassPINlock" 1.3.1-10 (which I presume is the same as patch "screen-lock-bypass-pin) from the spreadsheet of patches. My OS is now 1.3.5, so I obviously need the new version of the patch. However...PreWare won't let me unload the old version (which I must do, before installing the newer 1.3.5)
    Here's what I see in PreWare:
    IPKG Log..message…….
    The IPKG log reads: “Failed. ErrorGenericMethodException Failure during pre-remove script execution
    And: “unreversed patch detected! Ignore –R? [n]

    Apply Anyway? [n]

    Skipping patch

    1 out of 1 hunk ignored –saving rejects to file usr/palm/applications/com.palm.app.phone/ap/controllers/pin-assistant.jsjsjs.$rej$
    -------------------SO...to get this patch running now with 1.3.5.....
    Do I need to install using quickinstall, instead of PreWare??
    Last edited by otodoc; 01/06/2010 at 04:25 PM. Reason: too wordy
  13. #13  
    Many of the apps and nearly all the patches I have installed since I doctored my phone have had to go through WebOSQuick Install. PreWare, even when I installed the newest version and the newest pkg mgr, would not install them.
  14.    #14  
    Remember, you *MUST* REMOVE ALL PATCHES before (or IMMEDIATELY after) you update webOS. If you update with patches left installed, the actual "patched file" will get overwritten by the update, but Preware/WebOS Quick Install will think the patch is still installed. This is why you all are having problems with not being able to install patches.

    I have tested EVERY patch multiple times on multiple devices and emulators. I have yet to have one fail to install. Please be sure you follow the instructions. You can always look at my signature.
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
  15.    #15  
    Latest round of additions to 1.3.5:

    (Note there have been additions to 1.3.1 as well.. check that thread for the list)

    App Catalog: Hide App Vendors (Updated)
    App Launcher: Reset to First Page (Updated)
    App Launcher: Reset to Middle Page (Updated)
    Browser: Add Open URL Menu Option
    Browser: Add Shortcut Keys
    Browser: No Auto Refresh After Idle
    Camera: Sound Toggle - Green
    Camera: Sound Toggle - Grey
    Email: Additional Days for Syncing Mail
    Email: Notifications Repeat (Updated)
    Email: Replies Forwards Multi Mods (Updated)
    Email: Swap Reply2all with Move - v2
    Messaging: Add Select All and New Message (Updated)
    Messaging: Sign in as Invisible in IM
    Messaging: SMS Tone Per Contact
    PDF Viewer: Hide Header
    PDF Viewer: PDF Redux
    Phone: Disable Various Phone Sounds (Updated)
    Top Bar: Device Menu Megamix
    Top Bar: Device Menu Remix with Flashlight
    Top Bar: Flashlight in Device Menu
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
  16.    #16  
    Here is proof that ALL the patches in the 1.3.5(.1) feed(s) apply perfect to a clean 1.3.5(.1) device:

    Code:
    ************************RESULTS************************
    
    Succeed: 177
    Skipped: 0
    Failed:  0
    See the end of the log (/tmp/test-patches.sh.log) for lists of packages. They are separated by succeed, failed and skipped.
    
    **********************END OF TEST**********************
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
  17. #17  
    I doctored my phone after the update because I was having issues, and the patches DO work, but I have to go through WebOS Quick Install. Preware wont install them.
  18. #18  
    thanks,
    I removed all my patches before updating, all my patches updated except for the timestamp in messaging and the app launcher 4x4 or 5x4 icons . I'm not sure why those are the only 2 that aren't working for me with the 1.3.5.1 update using preware
  19.    #19  
    Quote Originally Posted by jediknight36 View Post
    I doctored my phone after the update because I was having issues, and the patches DO work, but I have to go through WebOS Quick Install. Preware wont install them.
    Sounds like you might be having an issue with the PKG Manager Service, GNU Patch or Diffstat. Can you install other stuff? Try removing GNU Patch and Diffstat then re-install them.

    What error is the IPKG Log giving you? Come hang out in #webos-internals on irc.freenode.net (http://webchat.freenode.net) and we can probably help you through it.

    -dB
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
  20.    #20  
    Quote Originally Posted by sergery View Post
    thanks,
    I removed all my patches before updating, all my patches updated except for the timestamp in messaging and the app launcher 4x4 or 5x4 icons . I'm not sure why those are the only 2 that aren't working for me with the 1.3.5.1 update using preware
    What error is the IPKG Log giving you? Come hang out in #webos-internals on irc.freenode.net (freenode Web IRC (qwebirc)) and we can probably help you through it.
    dBsooner
    WebOS-Internals Member and Developer
    Donations Appreciated!

    Keep up to date with webOS-Patches via Twitter: @dBsooner

    Browse Patches @ WebOS-Patches Web Portal - (Trac)
    Submit New Patches @ WebOS-Patches Web Portal
    Submit Updated Patches @ WebOS-Patches Web Portal
Page 1 of 4 1234 LastLast

Posting Permissions