Page 5 of 9 FirstFirst 123456789 LastLast
Results 81 to 100 of 165
  1. aric's Avatar
    Posts
    104 Posts
    Global Posts
    108 Global Posts
    #81  
    I also had to replace:

    /usr/palm/applications/com.palm.app.findapps/index-default.html

    then it worked (patch version 1.3.5-25)
    Last edited by aric; 02/18/2010 at 04:23 PM. Reason: typo
  2. #82  
    Quote Originally Posted by aric View Post
    I also had to replace:

    /usr/palm/applications/com.palm.app.findapps/index-default.htm

    then it worked (patch version 1.3.5-25)
    Yeah, that seems like the last file I need to replace to get this patch working.

    It's actually /usr/palm/applications/com.palm.app.findapps/index-default.html and I can confirm that after replacing this file the patch installation goes through without any errors.
    Last edited by gollyzila; 02/18/2010 at 02:43 AM.
  3. #83  
    Just a note, make sure you remove any other installed app catalog patch prior to repairing files.

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  4. #84  
    I tried following all these fixes and couldnt get them to work. I finally ran EPR and that fixed the problem, I had to reinstall my patches but I can see apps again.
  5. #85  
    Quote Originally Posted by dsevil View Post
    Are you trying to do this on a Mac?



    Same error (hunk 1 of 1 failed with appcatalog.css) as before?

    If yes, that's the same problem I've been working on the past few days. THIS TIME, the patch file downloaded from the webos-patches feed is not exactly the same as the patch file I thought I submitted. I'm going to duck the issue, put my CSS additions somewhere in the middle, generate a patch based on that, and resubmit. EDIT: submitted.

    If not, please post the error.
    Damn...I installed this beast before I found this thread...and now I have version .23, which will not uninstall -- it reports the "1 out of 1 hunk FAILED" error. Is there an easy way to fix this one?
  6. #86  
    Quote Originally Posted by scuba_steve View Post
    Damn...I installed this beast before I found this thread...and now I have version .23, which will not uninstall -- it reports the "1 out of 1 hunk FAILED" error. Is there an easy way to fix this one?
    like I just posted above, I tried about everything mentioned except doctor. It wouldnt even install the latest version of the patch. I found running EPR as the easiest thing for me.
  7. #87  
    Quote Originally Posted by HagerDeath1 View Post
    like I just posted above, I tried about everything mentioned except doctor. It wouldnt even install the latest version of the patch. I found running EPR as the easiest thing for me.
    I wasn't ignoring your response -- I was just trying to see what solutions are needed for my specific version of the installed patch -- i.e., v.23. In your post above, you did not specify what version of the patch that you were dealing with...and the author specifically mentioned the error that I am seeing now for v.23

    Either way though, thanks for the info

    cheers,
    Steve
  8. #88  
    I think it was .23 but not sure since it was weird what happened. It was showing an update in preware for it so I tried to update it a few days ago. It had an error updating and I had to reset my phone.
    After reset it wasn't showing in list of updates available so I thought it went thru after all. I found out last night it was showing that it wasnt installed but I couldnt get latest patch installed, it looked like it thought it already had the patch installed. I tried to do everything in this thread including installing latest version but no luck until EPR.

    If something similar is happening to you or anyone else, EPR is probably something to try before doctoring
  9. aweedman's Avatar
    Posts
    11 Posts
    Global Posts
    65 Global Posts
    #89  
    I'm having the same problem. The new version of the patch is still erroring out when trying to install. I can't see any apps in the app catalog. I haven't tried the removal instructions above yet but will try this weekend. I really don't want to run EPR and have to reinstall all of my patches again.

    Is there chance of getting a new version of the patch that when installing will actually install and fix all the problems?
  10. #90  
    Quote Originally Posted by gollyzila View Post
    Yeah, that seems like the last file I need to replace to get this patch working.

    It's actually /usr/palm/applications/com.palm.app.findapps/index-default.html and I can confirm that after replacing this file the patch installation goes through without any errors.
    GUYS AND GALS!!!!! If you're still getting an error after doing the recovery steps in the previous page, look at my quote and replace that file with WebOS Recovery Utility.
  11. #91  
    Using WebOS QI, I have removed the files:

    /usr/palm/applications/com.palm.app.findapps/app/controllers/hide-assistant.jsjsjs
    /usr/palm/applications/com.palm.app.findapps/app/model/hide-list.jsjsjs
    /usr/palm/applications/com.palm.app.findapps/app/views/hide/hide-scene.html

    Then I used WebOS RU, to replace the files:

    /usr/palm/applications/com.palm.app.findapps/app/controllers/app-assistant.jsjsjs
    /usr/palm/applications/com.palm.app.findapps/app/controllers/search-assistant.jsjsjs
    /usr/palm/applications/com.palm.app.findapps/app/views/search/search-appsummary.html
    /usr/palm/applications/com.palm.app.findapps/sources.json
    /usr/palm/applications/com.palm.app.findapps/stylesheets/appcatalog.css

    Now I have access to the Palm App Catalog again, and the Hide App Vendor tab is gone from the drop down in the Palm App Catalog. But the patch still shows up as installed and needing to be updated in Preware.

    So then I followed xanthinealkaloid's suggestion to remove the directory:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors

    Still it shows up in Preware so I then removed the IPKG info by removing:

    /usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors

    And so now I don't know what else I can do. "Hide App Vendors" still shows up in Preware as an installed patch but needing to be updated. Both actions, "Update" and "Remove," result in an error stating that the directories:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: No such files or directory
    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.prerm: line 35: cannot open /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: no such file

    I haven't yet tried aric's suggestion of replacing the directory:

    /usr/palm/applications/com.palm.app.findapps/index-default.html

    So that's where I'm left at the moment. This is my wife's Pre, so any help would be appreciated. I was able to somehow get the patch removed from my Pre [I did the "Update All" and then rebooted and it was removed from Preware, but I couldn't access the Palm App Catalog. After doing the first steps in this post (removing the 3 directories and replacing the 5 other ones) I was able to access the App Catalog]. But I think I am probably going to have to do an EPR since I'm having certain patches that are working and installed, not show up in neither QI nor Preware (I have tried running "Emergency Reconstruction Utility" on my Pre, with no luck).

    Anyways, any help would be appreciated; if I can't fix it then I will just run a EPR on both phones. And by the way, thanks for all the help so far!

    -Gorphee
  12. #92  
    By following dsevil's tutorial AND adding in aric's step, you shouldn't have any problems.
  13. #93  
    Quote Originally Posted by Gorphee View Post
    So then I followed xanthinealkaloid's suggestion to remove the directory:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors
    Don't do that.

    Still it shows up in Preware so I then removed the IPKG info by removing:

    /usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors
    Don't EVER touch anything in /usr/lib/ipkg... unless you like the persistent update bug.

    And so now I don't know what else I can do. "Hide App Vendors" still shows up in Preware as an installed patch but needing to be updated. Both actions, "Update" and "Remove," result in an error stating that the directories:
    WARNING: This is a unique situation, do not try this in general. I know what I am doing

    remove /media/crpyptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm

    I haven't yet tried aric's suggestion of replacing the directory:

    /usr/palm/applications/com.palm.app.findapps/index-default.html
    Yes repair this file.


    And then remove/update it from preware

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  14. #94  
    Quote Originally Posted by gollyzila View Post
    By following dsevil's tutorial AND adding in aric's step, you shouldn't have any problems.
    Most correct...I updated any previous posts to point to #63.

    My apologies for the loose ends.

    .
  15. #95  
    Quote Originally Posted by egaudet View Post
    Don't do that.



    Don't EVER touch anything in /usr/lib/ipkg... unless you like the persistent update bug.



    WARNING: This is a unique situation, do not try this in general. I know what I am doing

    remove /media/crpyptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm



    Yes repair this file.


    And then remove/update it from preware
    Well, thank you for the quick reply, but unfortunately it still won't let me remove the patch from Preware, nor update it.

    Following your suggestion, using WebOS QI, I removed:

    /media/crpyptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm

    And then using WebOS RU, I replaced:

    /usr/palm/applications/com.palm.app.findapps/index-default.html

    Any other ideas? And thanks again for the quick reply and suggestion.

    -Gorphee
  16. #96  
    Quote Originally Posted by Gorphee View Post
    Well, thank you for the quick reply, but unfortunately it still won't let me remove the patch from Preware, nor update it.

    Following your suggestion, using WebOS QI, I removed:

    /media/crpyptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm

    And then using WebOS RU, I replaced:

    /usr/palm/applications/com.palm.app.findapps/index-default.html

    Any other ideas? And thanks again for the quick reply and suggestion.

    -Gorphee
    I would need the message that you get this time for the failure. (i.e. IPKG log)

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  17. #97  
    Quote Originally Posted by egaudet View Post
    I would need the message that you get this time for the failure. (i.e. IPKG log)
    Sorry about that, it says the same thing as before:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: No such files or directory

    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.prerm: line 35: cannot open /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: no such file

    If you need any additional info, I'm more then willing to provide it. Thanks again!

    -Gorphee
  18. #98  
    Quote Originally Posted by Gorphee View Post
    Sorry about that, it says the same thing as before:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: No such files or directory

    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.prerm: line 35: cannot open /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: no such file

    If you need any additional info, I'm more then willing to provide it. Thanks again!

    -Gorphee
    Do you have a typo in the error message? That path to prerm doesn't make sense to me.

    Please verify the file does not exist: /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate
  19. #99  
    Quote Originally Posted by egaudet View Post
    Do you have a typo in the error message? That path to prerm doesn't make sense to me.

    Please verify the file does not exist: /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm
    Well I double checked my spelling, and it's exactly as a put it. And I double checked by using WebOS QI to remove:

    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm

    And after doing so, it still says the same 2 lines:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: No such files or directory

    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.prerm: line 35: cannot open /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: no such file

    What does that mean?

    -Gorphee
  20. #100  
    Quote Originally Posted by Gorphee View Post
    Well I double checked my spelling, and it's exactly as a put it. And I double checked by using WebOS QI to remove:

    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors.prerm

    And after doing so, it still says the same 2 lines:

    /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: No such files or directory

    /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.prerm: line 35: cannot open /media/cryptofs/apps/usr/palm/applications/org.webosinternals.patches.app-catalog-hide-app-vendors/app-catalog-hide-app-vendors.patch: no such file

    What does that mean?

    -Gorphee
    Get a command line terminal (novaterm, terminal app) and paste output of the following command:

    ls -F /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-catalog-hide-app*

    -Eric G

    WebOS Internals Developer.
    Follow me on Twitter for updates to my projects: | Virtual Keyboard | wIRC | SuperTux | AUPT | KeyBoss | freeTether |

    Donate

Posting Permissions