Page 4 of 6 FirstFirst 123456 LastLast
Results 61 to 80 of 115
  1. #61  
    that link is no good
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  2. #62  
    fixed
  3. #63  
    P.S. For those interested, I have re-written the Reset Scroll Position patch so that it is compatible with Wrap Pages - I've posted the new version here: http://forums.precentral.net/webos-p...ddle-page.html
  4.    #64  
    I just updated the first post with an updated version. In this version i override the internal page snapping of the scroller with my own implementation. This resolves many of the issues that i was having with events being fired late and pages being skipped.

    Thank you to IMGrant for updating the Reset Scroll Position to be compatible with this patch. I have tested with the latest version of the Reset Scroll Position patch and both work together.

    Also thank you for all who have used this patch and provided feed back.
  5. #65  
    Quote Originally Posted by Lclarkjr View Post
    I just updated the first post with an updated version. In this version i override the internal page snapping of the scroller with my own implementation. This resolves many of the issues that i was having with events being fired late and pages being skipped.

    Thank you to IMGrant for updating the Reset Scroll Position to be compatible with this patch. I have tested with the latest version of the Reset Scroll Position patch and both work together.

    Also thank you for all who have used this patch and provided feed back.
    is it updated in preware yet???
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  6. #66  
    ooops sorry just realized you just posted that ha ha my bad
    ĦṔ-Ḷṫ-Ŧḯη
    Here is a direct link to webOS Doc for all carriers
    http://www.webos-internals.org/wiki/...octor_Versions
    P.S. if i have helped you and you are thankful please hit the thanks button to the right---->
  7. #67  
    update is much better. good work
  8. #68  
    Quote Originally Posted by Lclarkjr View Post
    Thank you to IMGrant for updating the Reset Scroll Position to be compatible with this patch. I have tested with the latest version of the Reset Scroll Position patch and both work together.
    Much improved...Thanks for the update!

    It makes the launcher pages quite snappy, especially without the page transitions.

    The only downside is that the really great patches IMGrant produced to reset to the first or middle launcher pages don't seem to work with the new code.
  9. #69  
    Quote Originally Posted by xanthinealkaloid View Post
    The only downside is that the really great patches IMGrant produced to reset to the first or middle launcher pages don't seem to work with the new code.
    Lclarkjr - I think that the problem is caused by the new way the scrolling handler and moved method is implemented - it sees the snapIndex of my patch in the deactivate function as a scroll and it does another scroll of its own.

    I've tweaked the latest patch (1.3.1-??, attached) to detect when the deactivate function is called and not apply the moved function - this should resolve the problem.
    Attached Files Attached Files
  10.    #70  
    Quote Originally Posted by IMGrant View Post
    Lclarkjr - I think that the problem is caused by the new way the scrolling handler and moved method is implemented - it sees the snapIndex of my patch in the deactivate function as a scroll and it does another scroll of its own.

    I've tweaked the latest patch (1.3.1-??, attached) to detect when the deactivate function is called and not apply the moved function - this should resolve the problem.
    Thank you, I'll take a look at this tonight.
  11. #71  
    Quote Originally Posted by IMGrant View Post
    I've tweaked the latest patch (1.3.1-??, attached) to detect when the deactivate function is called and not apply the moved function - this should resolve the problem.
    Not sure if this is just me, but here's what I found...

    Wrap Pages - still works as expected

    Reset to 1st pg -
    When added, the scroll position doesn't reset, and it won't go back to the first page if the launcher is closed on the last page.

    Reset to middle pg. -
    When added, it starts at the 2nd page after reset until moved, then it will work correctly going to the middle page...Also, it resets the scroll position as expected.

    For reference, I have 7 launcher pages.

    For IMGrant & Lclarkjr, your efforts are very much appreciated...Frankly, I'm trying to learn how this stuff works for myself, but I have a very long way to go, so thanks.
  12. #72  
    Quote Originally Posted by Shadavis08 View Post
    ooops sorry just realized you just posted that ha ha my bad
    Excuse my ignorance, but if I can't use Preware then I am out of my comfort zone.

    I have downloaded the new patch, but how do I get it on my phone, or is the correct question where do I copy it onto my phone? Thanks for any help.
  13.    #73  
    Quote Originally Posted by f1nzup View Post
    Excuse my ignorance, but if I can't use Preware then I am out of my comfort zone.

    I have downloaded the new patch, but how do I get it on my phone, or is the correct question where do I copy it onto my phone? Thanks for any help.
    The updated version should be available in Preware soon. However if you still want to install it manually you can use WebOS Quick Install see this thread for information:

    http://forums.precentral.net/canuck-...l-v2-96-a.html
  14. #74  
    Alright it seems the update is making it work with the reset page patch. i have to have the reset scroll position patch installed as well though even though its stated that it incorporated into the reset page patch.
    Not a big deal.
  15.    #75  
    The release version on the first post has been updated to add support for the Reset to page patches. Thank you to IMGrant for the updates.
  16.    #76  
    Quote Originally Posted by BronTron View Post
    Alright it seems the update is making it work with the reset page patch. i have to have the reset scroll position patch installed as well though even though its stated that it incorporated into the reset page patch.
    Not a big deal.
    I found a bug in the Reset to First Page patch related to the reseting of scroll position to the top. I have reported this to IMGrant, so im sure he will have an update soon.
  17. #77  
    Quote Originally Posted by BronTron View Post
    Alright it seems the update is making it work with the reset page patch. i have to have the reset scroll position patch installed as well though even though its stated that it incorporated into the reset page patch.
    Not a big deal.
    Quote Originally Posted by Lclarkjr View Post
    I found a bug in the Reset to First Page patch related to the reseting of scroll position to the top. I have reported this to IMGrant, so im sure he will have an update soon.
    Thanks for the heads-up - I've squished that bug, re-submitted it to Preware, but in the meantime you can get a corrected version for use with WOSQI from the discussion thread: http://forums.precentral.net/webos-p...ddle-page.html

    Also, just an FYI but the Reset Scroll Position patch is still useful if you want the scroll position to reset when swiping between pages; the Reset to X Page patches don't do that, they only reset the scroll position on closing the Launcher.
  18. #78  
    Hey guys, so I got a question, I originally installed the Wrap Pages patch from preware and yesterday tried to remove it so I could install this new one from WebOS quick install and when I clicked remove it came back with an error view IPKG log and it still is listed in the installed patches list. So I still went ahead and installed the new version through quick install and it worked and I can tell I am using the new version when I scroll through pages, but my question is has anyone else experienced this and is it ok to have both on phone as everything seems to be working fine? Also I don't have the reset launcher patches installed so thats not it. Any help would be appreciated.
  19. #79  
    I just updated this patch from Preware and noticed that there are no longer any animations between pages (hopefully this makes sense what I am trying to describe). The first version of this patch kept the smooth scrolling animation between the pages and only lost this same type of smooth scrolling when wrapping pages. Now, between every page the smooth scrolling is lost.

    Is this intentional? Did it prove to difficult to accomplish and it was just abandoned? Not a huge deal. Just was curious. I do however prefer the scrolling between pages to have the smooth type scrolling. Just a personal preference though.

    EDIT: I see it was intentional so I answered my own question. However, is there a way to submit a separate patch to Preware that implements the scrolling similar to your first version of this patch?
    Last edited by bpdamas; 12/22/2009 at 09:42 AM. Reason: Actually read first post. Sorry.
  20.    #80  
    The issue is that I had to basically override the internal page snapping. With the animation enabled it causes additional issues. If enough are interested I will attempt to get it working with animations.

    Quote Originally Posted by bpdamas View Post
    I just updated this patch from Preware and noticed that there are no longer any animations between pages (hopefully this makes sense what I am trying to describe). The first version of this patch kept the smooth scrolling animation between the pages and only lost this same type of smooth scrolling when wrapping pages. Now, between every page the smooth scrolling is lost.

    Is this intentional? Did it prove to difficult to accomplish and it was just abandoned? Not a huge deal. Just was curious. I do however prefer the scrolling between pages to have the smooth type scrolling. Just a personal preference though.

    EDIT: I see it was intentional so I answered my own question. However, is there a way to submit a separate patch to Preware that implements the scrolling similar to your first version of this patch?
Page 4 of 6 FirstFirst 123456 LastLast

Tags for this Thread

Posting Permissions