Page 1 of 4 1234 LastLast
Results 1 to 20 of 64
  1.    #1  
    This is the official thread for the Phone Notification Repeat patch.


    Summary
    It will update the Phone App so that missed call notifications will repeat every two minutes until you either view the missed call or dismiss the notification.




    Installation
    The patch is available via Preware and\or WebOS Quick install. Please see the corresponding forums for patch installation instructions.

    Download

    Beta
    None

    Planned Improvement/Updates
    None

    Known Issues
    None

    Change Log
    2-17-10 v1.4.0-3
    -Updated for WebOS v1.4

    11-20-09 v1.3.1-16
    -Resolved issue when phone is asleep.

    11-15-09 v1.3.1-13
    -Updated for WebOS v1.3.1
    Attached Images Attached Images
    Last edited by Lclarkjr; 03/23/2010 at 11:07 PM.
  2. Seymour77's Avatar
    Posts
    56 Posts
    Global Posts
    58 Global Posts
    #2  
    It doesn't work cause every missed call appears a popup on the screen with the choices "call back" and "dismiss" and neither the led notification works cause this reason, sometimes only if the phone is not in standby the popup vanish and everything works (it remains only the little popup under the screen with the missed call alone), so i wonder if there's a way to delete this popup with some patch or something else.

    It's not only my problem, we italians pre owner have this issue but here i didn't find anything O_o

    Hope i made myself clear, sorry for my english if i didn't :=)
  3.    #3  
    Quote Originally Posted by Seymour77 View Post
    It doesn't work cause every missed call appears a popup on the screen with the choices "call back" and "dismiss" and neither the led notification works cause this reason, sometimes only if the phone is not in standby the popup vanish and everything works (it remains only the little popup under the screen with the missed call alone), so i wonder if there's a way to delete this popup with some patch or something else.

    It's not only my problem, we italians pre owner have this issue but here i didn't find anything O_o

    Hope i made myself clear, sorry for my english if i didn't :=)
    Hmmm, So you are correct sir. Until last night I have always tested this with the screen staying on since i have mine set to never go to sleep. Testing with it asleep indeed seems to have an issue. I will look into it.
  4. Seymour77's Avatar
    Posts
    56 Posts
    Global Posts
    58 Global Posts
    #4  
    Glad to help, i know u'll be able to fix this!
  5. #5  
    has the bug been fixed?
  6. Seymour77's Avatar
    Posts
    56 Posts
    Global Posts
    58 Global Posts
    #6  
    There was au update this morning but stil does not work in standby :|
  7. #7  
    Quote Originally Posted by Seymour77 View Post
    There was au update this morning but stil does not work in standby :|
    i know and for me this is one of the best email patches let hope it gets fixed soon
  8.    #8  
    I worked on this last night. I now know the cause of the issue and am working on a solution to night.

    For those interested the issue is that the missed call assistant is usin a window.settimeout for the one minute timeout for the initial missed call notification to close and go to just the notification bar. The problem with this is that that timeout service does not fire when the phone is asleep. So the notification bar does not get created and therefore the repeat code does not execute.
  9. #9  
    Quote Originally Posted by jrdejavux View Post
    i know and for me this is one of the best email patches let hope it gets fixed soon
    If it gets working, without a doubt this is THE SINGLE MOST IMPORTANT and useful patch *EVER* on the Pre. Period. He will need to put up a donation link...
    The power behind WebOS (and Android, and Maemo, and Google itself) is Linux!
  10.    #10  
    I just updated the first post with an updated patch that resolves the issue when the phone is asleep. Please give it a try and let me know if it works for you.

    I have also submitted it to the patches feed but may be a couple days before they get it updated.
  11. Seymour77's Avatar
    Posts
    56 Posts
    Global Posts
    58 Global Posts
    #11  
    I made a couple of tests and it seems work, i mean if the phone is in standby it always appears the popup with dismiss and call back but after a while it disappears and it appears the normal notification bar and the patch begins to work, actually when it happens also the blinking led begins to work for the same reason

    I don't know if you did this and in this way but it seems good and you have fixed two patches in one

    Let us know when it'll be on the repository and preware because now in preware i can see it without data (as aothor, version etc. etc) and avatar.

    Thanks again
  12. #12  
    Quote Originally Posted by Lclarkjr View Post
    I just updated the first post with an updated patch that resolves the issue when the phone is asleep. Please give it a try and let me know if it works for you.

    I have also submitted it to the patches feed but may be a couple days before they get it updated.
    Will test as soon as it shows up in Preware. I am not comfortable applying patches manually, since it is too easy to mess up (forget to backup, forget to revert, manage versions, etc).

    I didn't realize the patches feed was that slow. I assumed it was all automated and instant. Perhaps they are manually reviewing/test them first? If so, I suppose that makes sense from a safety aspect. Thanks
    The power behind WebOS (and Android, and Maemo, and Google itself) is Linux!
  13. GAM5's Avatar
    Posts
    46 Posts
    Global Posts
    59 Global Posts
    #13  
    Quote Originally Posted by Seymour77 View Post
    I made a couple of tests and it seems work, i mean if the phone is in standby it always appears the popup with dismiss and call back but after a while it disappears and it appears the normal notification bar and the patch begins to work, actually when it happens also the blinking led begins to work for the same reason

    I don't know if you did this and in this way but it seems good and you have fixed two patches in one

    Let us know when it'll be on the repository and preware because now in preware i can see it without data (as aothor, version etc. etc) and avatar.

    Thanks again
    Yes, it works for me as well now. As above the blink LED also works properly now as well. Thank you so much.

    When it shows up in Preware what should we do? Remove and reinstall or is that not necessary.

    Thanks again, this is the best patch!!
  14.    #14  
    You do not have to uninstall andreinstall once available in Preware however I have noticed that patches installed via quick install are not recognized under the patches area in Preware. They do seem to show up under unknown though. Bottom line is its up to you but not necessary.
  15. GAM5's Avatar
    Posts
    46 Posts
    Global Posts
    59 Global Posts
    #15  
    Great, thanks again!
  16.    #16  
    Quote Originally Posted by crxssi View Post
    Will test as soon as it shows up in Preware. I am not comfortable applying patches manually, since it is too easy to mess up (forget to backup, forget to revert, manage versions, etc).

    I didn't realize the patches feed was that slow. I assumed it was all automated and instant. Perhaps they are manually reviewing/test them first? If so, I suppose that makes sense from a safety aspect. Thanks
    It is my understanding that they do review each patch to check for malisious code.
  17. #17  
    Crxssi on 11/20/2009 on different thread:
    I retested the PHONE repeat reminder. The latest version of that is .10, and it still does not work.
    The .13 version appeared today on preware. So I installed it, restarted Luna, and tested it. Still not working. It is still doing the white notification then changes to 2 red notifications when you press the power button to wake it up, and THEN it starts to repeat notifications.

    Based on dates, I don't think this is the one you submitted most recently, they are lagging far behind on the feed. Will keep checking. I suspect you can't mention/post version numbers ahead of time because maybe the feed assigns them for you or something.
    The power behind WebOS (and Android, and Maemo, and Google itself) is Linux!
  18.    #18  
    Quote Originally Posted by crxssi View Post
    The .13 version appeared today on preware. So I installed it, restarted Luna, and tested it. Still not working. It is still doing the white notification then changes to 2 red notifications when you press the power button to wake it up, and THEN it starts to repeat notifications.

    Based on dates, I don't think this is the one you submitted most recently, they are lagging far behind on the feed. Will keep checking. I suspect you can't mention/post version numbers ahead of time because maybe the feed assigns them for you or something.
    Correct the version .13 available in Preware as of today is not the latest fixed version.

    Yes the feed assigns the version number, however is likely sequential and I should start referencing them that way.
  19. #19  
    I tested the newer version, now it works on both open and closed slider positions. Thank you so much!

    Is it possible that you can upload different version of this patch in 10 seconds, 20 second, or 1 minute interval?
  20.    #20  
    The latest version .16 is now available in Preware.
Page 1 of 4 1234 LastLast

Tags for this Thread

Posting Permissions