Page 2 of 15 FirstFirst 123456712 ... LastLast
Results 21 to 40 of 289
  1. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #21  
    I guess what I'm asking is if the op during the development of these patches had any issues removing these patches during testing. Also, if they where installed with quilt or WebOSQI.
    I've not had any issues installing or removing my changes during testing, but I used neither WebOSQI nor quilt.

    I wrote some hackish shell scripts to install and remove my changes by copying the files using "novacom put".

    I generated the patches by running diff (actually "svn diff" on my private repos) and modifying its output a bit using a little Perl program.

    Incase you're curious: the reason I didn't use WebOSQI is because it's a GUI; fast command-line scripts are how I roll. And the reason I didn't use quilt is because I'd rather have my pre do as little heavy lifting as possible.
  2. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #22  
    In other news, I've developed a fix for the "tap on .cmd" bug. Thanks to all those who've reported it!

    I'm going to work on the KeyToss compatibility issue shortly.
    Last edited by dsevil; 10/29/2009 at 10:35 PM. Reason: i can has speeling
  3. aric's Avatar
    Posts
    104 Posts
    Global Posts
    108 Global Posts
    #23  
    Quote Originally Posted by aric View Post
    I need some help. I installed the uscl.patch and the uscl-notes.patch using WebOSQuickinstall. They work fine, but I'd like to uninstall them and reinstall them now they are on the feeds in Preware (for ease of updating). The problem is I can't seem to find them anywhere using either preware (in both the patchs and unknown categories) or using WebOSQI in device management (in both applications and patch categories).
    I figured out how to manually remove them:

    sudo /var/usr/bin/patch -R -p1
    -d / < /var/usr/palm/applications/org.webosinternals.patches.uscl/uscl.patch

    For some reason when I did a ls -al on the directory I got:

    -rwxr-xr-x 1 root root 4308 Oct 29 12:40 uscl-notes.patch
    -rwxr-xr-x 1 root root 14345 Oct 29 12:40 uscl.patch

    This also occurred on anther patch that I installed with WebOSQI (extracards.patch).

    I changed all three files (chmod 644) so they were not executable. I don't know if that makes a difference or not.
  4. #24  
    it would be so awesome to just type ".sms blahblahblah" and have it open the messages app and send right away. or just send and not even open messages app but idk if that possible. but it would be way cool to just type .sms
  5. #25  
    Quote Originally Posted by mikexmayhem View Post
    it would be so awesome to just type ".sms blahblahblah" and have it open the messages app and send right away. or just send and not even open messages app but idk if that possible. but it would be way cool to just type .sms
    And just who would would you be sending the message to? Everybody in your contacts list?
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  6. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #26  
    Quote Originally Posted by 2sslow View Post
    And just who would would you be sending the message to? Everybody in your contacts list?
    Somebody didn't read the entire thread before posting; otherwise they would have seen that someone else posted the idea already, and correctly:

    ".sms contact message"

    *That* could work. But it would have to pull up a contact lookup first.
  7. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #27  
    I just fixed the issue with KeyToss and the issue with tapping on ".cmd".
    Just submitted to webos-patches.

    EDIT: and updated the attached uscl.patch in the OP.
  8. #28  
    Quote Originally Posted by 2sslow View Post
    And just who would would you be sending the message to? Everybody in your contacts list?
    rawr
  9. #29  
    Quote Originally Posted by dsevil View Post
    I just fixed the issue with KeyToss and the issue with tapping on ".cmd".
    Just submitted to webos-patches.

    EDIT: and updated the attached uscl.patch in the OP.
    This only seems to work if you install KeyToss first.

    If you try to install it after the uscl.patch it will error.
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  10. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #30  
    Quote Originally Posted by 2sslow View Post
    This only seems to work if you install KeyToss first.

    If you try to install it after the uscl.patch it will error.
    I didn't think this sort of thing was even possible. I'll look into this.
  11. #31  
    Quote Originally Posted by dsevil View Post
    I didn't think this sort of thing was even possible. I'll look into this.
    Yeah not sure whats going on but I had to remove your patches to install keytoss then reinstall your patches to get it to work.

    Might be a fluke IDK!
    Please hit the thanks button if I helped you

    If you've enjoyed my patches please feel free to donate towards further development.

    Follow the link below.


  12. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #32  
    Quote Originally Posted by 2sslow View Post
    If you try to install it [KeyToss] after the uscl.patch it will error.
    http://webonastick.com/webos/patches/uscl.patch.txt
    EDIT: fixed the URL.

    Anyone want to test this out before I submit it?

    I've run a test script that applies KeyToss after USCL and it doesn't yield any failed patches now.

    I've also added more commands: ".beer", ".ratebeer", and ".ebay".

    There's also some preparatory work going on for a minor feature I plan to implement in the future. For now that preparatory work doesn't affect anything. And I had to make the KeyToss-after-USCL fix in the midst of working on it.
    Last edited by dsevil; 11/01/2009 at 03:40 PM. Reason: Oops: fixed the URL
  13. #33  
    i have tried to install using preware and quickinstall and i keep getting an error. anyone else have trouble with this?

    edit: figured it out. i had edited the global-search-assistant.jsjsjs $to$ $try$ $to$ $get$ $the$ $sms$ $shortcut$ $hack$ $to$ $work$. $so$ $i$ $changed$ $it$ $back$ $to$ $default$ $and$ $it$ $installed$.
    Last edited by mikexmayhem; 11/01/2009 at 05:43 PM.
  14. #34  
    has anyone made any other commands besides the calc memo dictionary and thesaurus yet? i read through this thread and didnt see anything about other cmds. anyone?
  15. d.moss's Avatar
    Posts
    541 Posts
    Global Posts
    582 Global Posts
    #35  
    so would it be possible to search for music on the phone through this? maybe search in internalz for the music that way it will pull up in the streaming media player and not in the music app? if in the music app it would be so much better though. possible?
  16. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #36  
    I've received no feedback on my latest uscl.patch, so I've resubmitted it to webos-patches.
  17. jeckert21's Avatar
    Posts
    48 Posts
    Global Posts
    51 Global Posts
    #37  
    Does not work, unable to install patch update.
  18. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #38  
    Quote Originally Posted by jeckert21 View Post
    Does not work, unable to install patch update.
    Can you provide a few more details, such as what the error message(s) you received were, the contents of the ipkg log (Chances are, you were given an option to view it. ), whether or not you have keytoss installed. And what version of webOS you are running.

    Thanks.
    Last edited by dsevil; 11/05/2009 at 10:05 PM.
  19. jeckert21's Avatar
    Posts
    48 Posts
    Global Posts
    51 Global Posts
    #39  
    I had the Command Line and USCL Memos Patchesw installed. Then Command Line had an update the other day. When I pressed update the error came up. I uninstalled Keytoss, Command Line, and USCL. When Trying to reinstall it came up error (IPKG Log says Hunk #1 Suceeded at 51 (offset 15 lines) Bottom says failed ErroeGenericMethodException
    Attached Images Attached Images
  20. dsevil's Avatar
    Posts
    211 Posts
    Global Posts
    218 Global Posts
       #40  
    Quote Originally Posted by jeckert21 View Post
    I had the Command Line and USCL Memos Patchesw installed. Then Command Line had an update the other day. When I pressed update the error came up. I uninstalled Keytoss, Command Line, and USCL. When Trying to reinstall it came up error (IPKG Log says Hunk #1 Suceeded at 51 (offset 15 lines) Bottom says failed ErroeGenericMethodException
    "Reversed (or previously applied) patch detected" usually means that the patch(1) utility (the underlying utility used to install patches) detected that the patch was already installed.

    Likely scenario: you already installed the patch by means other than Preware; and because Preware did not detect that you installed the patch the way it installs patches, it allowed you to install it again.

    Less likely scenario: Preware still somehow didn't detect that the patch was already installed, but by other means. Are you running the latest version of it? (Sounds dumb but gotta ask.)

    Really unlikely scenario: disk space full.
Page 2 of 15 FirstFirst 123456712 ... LastLast

Tags for this Thread

Posting Permissions